This forum is the best way to get up and running with the Nutanix platform
Recently active
Hi allI have a cluster with vswitch active - activeI have new nodes to expand and I did theses steps below 1 - root@ahv# ./network_configuration to configure ips and vlan tag2 - Configure lacp 2.1 ssh root@192.168.5.1 "ovs-vsctl set port br0-up other_config:lacp-time=fast" 2.2 ssh ovs-vsctl set port br0-up other_config:lacp-fallback-ab=true 2.3 ssh root@192.168.5.1 "ovs-vsctl set port br0-up lacp=active" nutanix@CVM$ ssh 2.4 ssh ssh root@192.168.5.1 "ovs-vsctl set port br0-up bond_mode=balance-tcp"3 - Expand cluster The nodes were joined success in the cluster, but when I checked the vswitch configuration of theses nodes was changed to active - backupDid I do something wrong? What better way? Thank you
I ma installing remotely Nutanix AHV cluster in very isolated environment, where for everything had to request firewall rules. IPMI is in different non-routable subnet, other that AHV and CVM. Firewall team confirmed that they don’t see any blocked traffic, but Foundation fails with error like this:2023-04-07 18:25:48,759Z WARNING Failed to register internal hypervisor: <Left ("Unable to satisfy any required capabilities for '<ExportedObjectDescriptor "command##.BindInternalHypervisor-1.0.0">'") at 0x52d10f8>2023-04-07 18:25:48,759Z INFO Tartarus initialization complete2023-04-07 18:25:48,996Z DEBUG Failed to load all plugins: Unable to satisfy required capability 'OPTIONAL_SMBIOS' for <ExportedObjectDescriptor "command##.LenovoRedfish_Pyghmi-1.0.0"> Skipping command##.GenericRedfish_Pyghmi-1.0.0, entity is disabled Unable to satisfy required capability 'OPTIONAL_SMBIOS' for <ExportedObjectDescriptor "command##.YadroRedfish_Pyghmi-1.0.0"> Unable to satisfy requi
The NX G6 demo equipment is currently updated with the latest firmware. If you try to install version 5.10 to test the AOS upgrade with the latest version of the foundation, the 4. foundation version will not mount, and the 5. latest foundation version will not configure CVM after rebooting after installation and installation will fail. Is it like this originally?
We are triying to install a new Nutanix Cluster with 2 nodes Lenovo HS1021. The nodes machine type is 7D20. When we launch the installation with the Foundation, the use ends in failed and we see the following errors:WARNING Failed to register internal hypervisor: <Left ("Unable to satisfy required capability 'HYPERV_VERSION' for <ExportedObjectDescriptor "command##.BindInternalHypervisor-1.0.0">") at 0x7efbc4d82bd8>2023-03-14 17:15:27,733Z WARNING Skipping <ImagingStepPreInstall(<NodeConfig(X.X.X.X) @35d0>) @80d0> because dependencies not met2023-03-14 17:15:27,731Z WARNING Skipping <ImagingStepRAIDCheckPhoenix(<NodeConfig(X.X.X.X) @35d0>) @d150> because dependencies not met, failed tasks: [<ImagingStepInitIPMI(<NodeConfig(X.X.X.X) @35d0>) @d390>]2023-03-14 17:15:27,736Z DEBUG Setting state of <ImagingStepPhoenix(<NodeConfig(X.X.X.X.) @35d0>) @67d0> from PENDING to NR2023-03-14 17:15:27,736Z WARNING Skipping <ImagingStepPho
There are still many places where the old version is being used.Even if you try to install it with the previous version (AOS 5.10 or lower version) of the foundation on the G6 device to test the upgrade, it cannot be installed.Is it because all the firmware is up to date? It was the version that was originally installed. AOS 5.10 versions are not installed now?In foundation the log is "Device 2 :The Length of Name is not correct" The phrase continues to print. Please reply from those with experience.
Hi AllWhen I try to install AOS 6.5.2 I get the following errors. IOError: [Errno 2] No such file or directory: '/etc/nutanix/factory_config.json' 2023-03-07 13:19:54,652Z CRITICAL svm_rescue:926 No suitable SVM boot disk found. 2023-03-07 13:19:54,652Z INFO svm_rescue:114 exec_cmd: sync; sync; sync 2023-03-07 13:19:54,658Z INFO svm_rescue:114 exec_cmd: umount -R /mnt/disk 2023-03-07 13:19:54,663Z INFO svm_rescue:114 exec_cmd: umount -R /mnt/data] 2023-03-07 13:19:52,159Z INFO Imaging thread 'svm' failed with reason [None] 2023-03-07 13:19:52,164Z CRITICAL Imaging thread 'svm' failed with reason [None] 2023-03-07 13:19:52,200Z ERROR Exception in running <InstallHypervisorKVM(<NodeConfig(172.16.150.9) @b5d0>) @ee10> Traceback (most recent call last): File "foundation/imaging_step.py", line 161, in _run File "foundation/imaging_step_hypervisor.py", line 47, in run File "foundation/imaging_step.py", line 353, in wait_for_event StandardError: Received "fatal" in waiting for ev
My 3 node cluster consiting of 1065-G5 nodes is coming EOL this year. I will be replacing the hardware with a NX-3360N-G8 cluster. What is the recommended workflow for replacing the hardware? One thing to note is the current cluster is licensed with Prism Pro and the new one will be licensed with Starter as I’m not using all the features in Prism Pro.Is the replacement as easy as expanding the cluster one node at a time, migrating the workloads and then removing the old cluster? Will there be any hiccups with difference in licensing?
Hey guysI am reinstalling three Lenovo HX5521 nodes and I got stuck on the below errorFoundation IP not set. Try running the “set_foundation_ip_address” script on the desktopI'm running the foundation vm on the same subnet of the IPMI interfaces connected directly to an unmanaged switch, without VLANs or any other configuration. connectivity is perfect. I already reviewed all the settings and tried to reimage foundation using ESXi and AHV. Both result in the same error.Im running;Foundation_VM-5.2.2 AOS euphrates-5.20.3 LTS VMware-ESXi-7.0.1 or AHV-20201105.2244I've been trying to solve this problem for three days now, but so far I haven't found any clues. Any help will be greatly appreciated. Thanks! 👷🏽
Hello,We have an unsupported configuration on 2016 stretch cluster: 3 NIC teaming with LACP → should be 1 NIC Teaming with a switch independent The goal is to upgrade to server 2022, we have the manual option from TAC to upgrade to 2019 than 2022.Note based on what we have seen we have the following points:-From the doc. https://portal.nutanix.com/page/documents/details?targetId=Acropolis-Upgrade-Guide-v6_6:upg-cluster-upgrade-recommend-hyperv-r.html Upgrade to Windows Server 2022 Hyper-V from an LACP enabled Hyper-V 2019 cluster is not supported. Enabling Link Aggregation Control Protocol (LACP) for your cluster deployment is supported when upgrading hypervisor hosts from Windows Server 2016 to 2019. On the other hand in doc. https://portal.nutanix.com/page/documents/kbs/details?targetId=kA00e000000LLI8CAO the LACP is not supported on 2016 and 2022, since we have seen the following error as seen below (the ISO image was 2019 for the upgrade, not 2022 we can not upgrade to 2022 direc
Using phoenix to reimage a node after a failed satadom, after phoenix is loaded, I uploaded AHV ISO so it can proceed to install AHV/AOS. It turns out I uploaded the lcm_ahv_el7.nutanix.20201105.2267.tar.gz instead of the AHV-DVD-x86_64-el7.nutanix.20201105.2267.iso. The install is now hung at 75% Node discovery succeeded. I have tried to install the proper iso, but it immediately failed at that same progress. How can I cancel this install so I can try again?I did find this error in the foundation log. It looks like the error happens if you use the html 5 client to mount the phoenix iso, but I am using the java client.
Hello, i have nutanix 3060g8 i have error:Committed memory update intent that is stuck on 50% i tried to reboot cvm and all nodes but i still have same problem.cvm memory are 64gb i tired:ecli task.list include_completed=noTask UUID Parent Task UUID Component Sequence-id Type Statusf0ffcb92-96b1-426f-51d7-204729b269fe kGenesis 1 kCvmreconfig kRunning progress_monitor_cli --entity_id="f0ffcb92-96b1-426f-51d7-204729b269fe" --deleteany suggest ?
Hi Team,Which Firewall ports will be required for new node we are adding node in the existing cluster.There is VMware cluster with Nutanix cluster.kindly guide and suggest.
Hello eveyone,following my last post I eventually got my C node to be alive. (it was not booting nor being visible whatever I tries, always down).I can ping it with both IPv4 and IPv6 addresses, connect to it in SSH, run commands etc.Now my situation is : while I was struggling with my node down, I removed it from the cluster with Prism. I think I could bring it back after… But it does not work.As you can see here, the C node (#3) is now missing :I use the “Expand cluster” tools in Prism Element, I add the node manually, it is detectedI check the mode, validate and it starts to expand.But after a few minutes I get the error :Failure in pre expand-cluster tests. Errors: Failed to get HCI node info using discovery It seems like the cluster refuse to consider the node as “free”, or the node itself refuse to join because it thinks that it is still in the cluster.Thank you very much for any help you could provide
Whe doing an AHV update I noticed that when going into or out of Maintenance mode some of the VMs show as VM and some have their actual name - why is this?
Hello, after a firmware upgrade, one host is locked DOWN in maintenance mode :CVM: 192.168.131.132 DownI can run a command to exit maintenance mode but it is not working and it is "Removed from metadata store" :nutanix@:~$ ncli host edit id=7 enable-maintenance-mode=falseId : …Hypervisor Address : 192.168.131.122Host Status : NORMALOplog Disk Size : 394 GiB (423,054,278,649 bytes) (3.9%)Under Maintenance Mode : false (ncli_manual)Metadata store status : Node is removed from metadata store...So I tried to recover it but the script fails :nutanix@:~$ python /home/nutanix/cluster/bin/lcm/lcm_node_recovery.py 192.168.131.122Recovering node 192.168.131.122Checking if the node 192.168.131.122 is in phoenixCurrent node status host Node 192.168.131.122 out of phoenix modeBringing host None out of maintenance mode Successfully put host None out of maintenance mode Bringing CVM 192.168.131.122 out of maintenance modeTraceback (most recent call last): File "/home/nutanix/cluster/bin/lcm/lcm_node_
Hi all, I’m wondering if someone can help me out with the first install of a nutanix CE single cluster with esxiThe installation went fine but, and followed this link to make it work. https://vmik.net/2021/01/26/nutanix-ce-install-esxi-2021/I see that only have 1 disk in the storagepool. Is there a way to add a disk into the CVM? or do I have to mount it first. can someone help me out? many thanks.
My hardware - NX-6035-G4 running 5.20.3.5 LTS and is no longer under support. It is one of 8 in the cluster. We use this as a backup target for our two other production clusters using protection domainsI was attempting to replace a satadom because I got this error satadom has worn out - PE cycles above 4500 or PE cycles above 3000 and daily PE cycles above 15.I followed the instructions on this page to get things started, but after 8 hours of trying to clone the satadom disk the process timed out - put the node in maintenance mode and detached it from the Metadata Store. I took the node out of maintenance mode to add it back to the Metadata Store, but the option has not popped up in PE. Here is the output from an NCLI host list. Id : Uuid : Name : IPMI Address : Controller VM Address : Controller VM NAT Address : Controller VM NAT PORT : Hypervisor Address : Host S
Hello Ma’am and Sir,Does anybody tried installing or imaging a single node using phoenix? please i need some help/procedure for this as I can’t access the links given in this page it only shows “Not Found or Fordbidden”: Appendix: Imaging A Node (Phoenix) | Nutanix Community…...specifically in “Installing the Controller VM and Hypervisor by using Phoenix” and “Imaging Bare Metal Nodes”…..I created bootable phoenix using USB then i am now in the root@phoenix but I bet it requires some commands to push but have no idea on the commands and theres no search result in the internet regarding that
tl;dr how to perform pre-upgrade checks from the command line?Hello Guys,I have a question related to the performing manual / cli upgrade (command line). Here’s the scenario:AOS with ESXi as a hypervisor, multiple ROBO offices / Dark Site (no access to the internet), Dark Site server with LCM, very limited broadband: 16Mbit with static shaping (4Mbit) for management purposes and 12Mbit for businessIt is very difficult to upload via AOS GUI 4-5GB of upgrade and .json file. 3-4% / 10minutes and upload task informing about a ‘server issue’. I’m 99% sure that it related to the broadband shaping.Solution is simple:upload tar.gz install/upgrade bundle, ‘untar’, install ( ./install/bin/cluster -i ./install upgrade )My question is: is any magic command to start pre-upgrade tasks with is normally presented in GUI if upgrade package is available? It will be very helpfull to start pre-upgrade check in-advance the main upgrade.I tried to find the command in lab:-- uploaded the bundle in ‘normal
Hi Our setup will look very similar to the attached diagram once it’s setup (taken from here - https://portal.nutanix.com/page/documents/details?targetId=Nutanix-Security-Guide-v6_1:wc-network-segmentation-intro-wc-c.html). We won’t have the separate DVS for the VM’s though as these will be on the same DVS with everything else 😊 What I'm trying to understand is what the vmk2 kernel interface is used for and why this must be on its own port group and can’t use the same port used by the CVM. I’ve illustrated what I thought should be possible with the blue line. Within Prism where you change the setting for the Backplane network, you must select a port group for the CVM and for the host. However, when you try to select the same port group for both host and CVM it gives an error and won’t let you do it. Does anyone know why they need to be on separate port groups even though they will be on the same Backplane VLAN? I hope that made sense
Hello All, I am working with Affinity policies and I wonder if there is an Affinity “light”. What I mean by this is in Hyper-v clusters you have a “Preferred Server” this means that if the preferred server is available the vm will reside there if not it will move to stay running. Once the preferred server is back online then it will move back. Is this possible in AHV? Thanks,Scott
Is there any way to integrate Apache Cloud Stack with Nutanix AHV
I have about 9 VM that have this error (all 130 other VMS are fine). The VMS are either Server 2012 R2 or server 2016. I have tried manually mounting NGT CD from the manage guest tools on the Nutanix VM page, then I launch the console and try to install NGT. I run the mounted cd and NGT fails saying that NGT is already installed. I’ve tried uninstalling NGT and reinstalling it from the mounted CD, but it’s not installing the latest version. How can I update NGT on these 9 VMs?
Dears:I followed the LCM dark site guide to configure the IIS, the screenshot is shown is below: But when I tried to let PC to use local web server, the error showed below: It looks builds folder is not exist in the release folder. I am not sure if this is the key point. Hope anyone could help me. Thanks!
Hi Team,In the latest release notes I see:Flow Security Policies are not supported for VMs that are on advanced networking stack. An alert is raised for VMs that are part of both VPC and Flow policy, and Flow policies are not enforced for VMs on VPCs.Is there a time frame that this will be resolved? Like this VPC is not ‘really usable’. What is the work around to have some sort of micro segmentation inside VPC? Different vlan inside VPC with an 3th party firewall? Thanks and regards,Peter
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.