Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hello guys, currently we have converged infrastructure with Cisco UCS, netapp storage and virtualization with VMware , now we want to make this our DR and want to build primary DC with Nutanix HCI, so my question is can Nutanix AHV can replicate to converged DR site? Thanks....
Syslog or ‘System Logging Protocol’ is used by routers, switches, access points, servers and of course Nutanix. It is used to send events and logs to a remote syslog server that collects, organizes and filters these logs. In Nutanix, we provide different log modules for the core services that can be enabled separately and you can configure the logging level required for them as well. For example, if you wish to forward just the warning log messages for Acropolis, this would be the command: ncli rsyslog-config add-module server-name=<server_name> module-name=ACROPOLIS level=WARNING For a more comprehensive look at the various modules and log levels, check out syslog server. Bonus: Would you like to know who powered off that VM while you were sleeping? Or in general, WHO did WHAT on WHICH OBJECT, at what TIME, from WHERE, and what was the OUTCOME? You can forward these Audit logs to your syslog server as well from Prism Central. More information on this can be foun
When there is a new patch released by VMware for ESXi, you may want to check the Compatibility Matrix on the Portal, but the matrix shows only ESXi versions and update numbers, it doesn’t show every patch build number. What to do and how to understand if the patch is supported or not? Let’s break down the ESXi versions into possible options: Versions. Those are the numbered versions, for example, 6.0, 6.5, 6.7 and 7.0. All the versions need to be qualified and the qualification is a requirement. They will not be supported if they are not qualified. Check the compatibility matrix on the Nutanix portal to see if it is supported. Updates. Those are what you usually see after the “U” in the version name, for example, 6.7U1, 6.7U2. 6.7U3. They also will not be supported until they are qualified. Check the compatibility matrix on the Nutanix portal to see if the Update is supported. Patches. There are many ways that VMware calls its patches, examples are: ESXi 6.7 EP 15, ESXi 6.7 P01, ES
Hi guys. We are in the process of acquiring Nutanix products, but we need to know something crucial. We currently have more than 100 ESXi hosts, separated in 2 sites. We have a metro cluster, all the datastores are sync, this is full active active, with EMC VMAX All Flash and VPLEX. As of today (May 2020), can we do such thing with AHV and ADSF? It is supported? I’ve seen the Sync DR here: https://cloudvm.es/nutanix-ahv-synchronous-replication, where i can see you can do it VM by VM. But what about if i want to protect at datastore/container level? All of the VMs. We have more than 3000 VMs. We need to know if we can accomplish the same with Nutanix. Stretched storage and VMs on both sides, for obvious reasons (balance, availability). If one of the sites crashed, HA all the VMs automatically to the other. Is there a video or pdf showing how it works? Thank you!!
Have you always wanted to get a peek into the network traffic flowing in and out of your Nutanix infrastructure? Whether you got your first IT job for years or been a veteran for several years, you would have definitely at some point been keen to get a detailed look at your network traffic. At Nutanix, the AHV hypervisor is based on the open-source KVM module and uses the CentOS Linux distribution. And yes, it comes with the popular packet capture utility tcpdump. A few examples when you would want to use tcpdump in your Nutanix infrastructure would be: VM(s) lose network connectivity on a particular host A host has multiple network links and you wish to identify which is active VM(s) are not reachable from an external network In that particularly annoying issue, the switch vendor asks you to contact Nutanix support The good news is that tcpdump is installed by default in AHV hosts and it can be run to inspect traffic on physical NIC’s as well as VM inte
Hi, New to the forum, we recently had our Nutanix servers delivered and we are planning to do the install in the coming weeks. We haven’t decided which hypervisor to go with yet its either going to be Hyper-V or AHV. I just wanted to know peoples experiences that they have had? We currently use Hyper-V, so we are comfortable with that but all the nice features seems to be heading to AHV/Prism. I would be grateful for your thoughts and comments Thank you
Anyone have any insights to share about using the filter option in the /alerts/list API method in Prism Central? Here is that method in the documentation: https://www.nutanix.dev/reference/prism_central/v3/api/alerts/postalertslist/ It looks like there isn’t much information available about the filter option. I have found a (very) little bit of information online about FIQL, but I have no idea what field names are available for alerts in Prism Central.
I have a problem with OS and Distributed Switches on vCenter. When I migrate the vm-network from standard switch to distributed switch show the next error: Detailed information for cvm_startup_dependency_check:Node x.x.x.x: FAIL: .dvsData directory is not persistent yetRefer to KB 2050 (http://portal.nutanix.com/kb/2050) for details on cvm_startup_dependency_check################################################################################PLUGIN RESULTS################################################################################/health_checks/hypervisor_checks/cvm_startup_dependency_check [ FAIL ] I can see that when reboot the ESXi host and start the CVM I lost it network config on the CVM, and I have to assign again network adapter on the CVM. I don't know how configure on the vcenter the distributed switch to make persistent.
I hope this is an easy question. Am I allowed to increase the VCPU and memory resources on the Move VM/Docker without issues? I know hot-plug is disabled, so it’s in the reboot-world. I found that we are pegging the CPUs out when we are queueing migrations, so I want to try to get some more throughput on it to take advantage of our 25Gb infrastructure. Thanks
My migration team is doing a good job trying to push as many VM’s through Move to stage reboots after-hours. I’ve noticed that replication slows way down when we have about 15-20 VM’s waiting for cutover. I have checked the load on the Move VM and increased the amount of CPUs. Replication goes well (25Gbit network), but now we only have 2 seed streams going with 19 waiting to cutover. I have 4 other VM’s that are in the “seeding data” phase, but haven’t started their copies. Is this a bottleneck within the Move postgres database? Any ideas on how I can get more VM’s copying in parallel? Thanks,
Is there a way I can inject a NIC driver into the Phoenix.iso? We use a Broadcom 10Gb and the firmware file is not present on the Phoenix.iso so it can’t load the nic’s.
Hello community, I am facing a situation with some VMs, where the SSR-part of the Nutanis Guest Tools is causing some trouble. I have two VMs and created a Protection Domain for this to be able to play around with snap restore. One VM is working perfectly, the other VM displays: “Error executing command: Failed to query snapshot due to Nutanix Data Protection service error, error detail: Failed to fetch file information for VM with ID ****** due to hyperint error 1” This message appears as soon as I start the SSR tool or via ngtcli. Both VMs are set up the same way with IP from the same subnet. Can anyone push me in the right direction to have a look for an answer on this? Cheers Dirk
The Nutanix REST API allows administrators to create and run scripts on their Nutanix clusters. On a Nutanix cluster: API v1 and v2 runs through the Prism service. API v3 runs through Aplos services. Both of the above are services running on a CVM/PC-VM in a Nutanix cluster. Prism: Prism is the management gateway for component and administrators to configure and monitor the Nutanix cluster. This includes Ncli, the HTML5 UI, and REST API. Prism runs on every node in the cluster and uses an elected leader like all components in the cluster. All v1 and v2 API calls runs through Prism. Aplos: It’s an intentful orchestration engine + intentful API proxy. All v3 REST API calls runs through Aplos. Looking at the logs of the above 2 services can tell us a lot of things about our REST API and HTTP issues on PC-VM/CVM. The logs for these services are located on a CVM/PC-VM at: API v3 logs: ~/data/logs/aplos.out API v1 and v2 logs: ~/data/logs/prism_gateway.log HTTP defines a set of reque
Hello Team, Do we have script which we can run to get the cluster details from Prism Central. Like Total CPU and usage CPU ,Total Memory and usage memory and same for storage, and also want to schedule that report in email. Please help me with script to get the details
We are using Image configuration to upload and convert the VHDXs and so far it works except when we attempt to upload 4K sector aligned VHDXs from an old HyperV cluster, the upload completes successfully but the conversion fails. Is it possible to migrate and convert 4K sector aligned VHDXs to a Nutanix AHV cluster? Error:
Hello, I am new and I am interested in whether Nutanix acropolis supports Atlassian products Bamboo, Bitbucket, Jira? Does anyone have experience with their containers on the Nutanix platform?
I am testing Postman for API calls and one of the errors I am getting is 502 - Oops Server Error, which is related to the Apache portion. Question is, which log contains this? I’ve checked all the logs in ~/data/logs/ and can’t find that response.
Here’s my problem. Node A & B are synchronizing to the wrong host. Node C is synchronizing to the right host. This is the behavior I see on the CVMs. When I do “hostssh ntpq -pn”, the hypervisors (AHV) are reporting the correct ntp server. How do I bring nodes A & B back inline to what they should be? I tried manually correcting their ntp.conf files with the correct IP and restarted the ntpd service. No change and eventually the ntp.conf files changed to the wrong settings. Not sure how to wrestle this one to the ground.
Below are new knowledge base articles published on the week of June 14-20, 2020. KB 8507 - Cosmetic high latency spikes may be observed in Prism at time of low IOPS on a cluster KB 8932 - NCC Health Check: pc_vm_resource_resize_check KB 9423 - Beam Cost Governance for Nutanix On-Prem stops reporting cost analytics post Cluster upgrade to AOS 5.15 KB 9488 - AHV | CentOS/RHEL 6.8 may hang durin the boot when tboot package is used KB 9496 - Prism Central UI showing license expired red banner even after disabling prism pro features KB 9503 - Genesis crashing on a ESXI Node | No services are up | pyVmomi issue | ParserError: 'xml document KB 9516 - Using Nutanix objects as static web server for LCM dark sites KB 9519 - Nutanix Move | How to Configure HTTP(s) Proxy on Move KB 9534 - Hyper-V: Hyper-V 2019 fails during Foundation with "InstallerVM timeout occurred, current retry 0" KB 9538 - Prism logins fail if service account AD permissions are default KB 9545 - Copier reports inc
Hello guys, currently i deployed a new hpe hardware Hypervisor version is ESXi VERSION 6.7.0 I need a vcenter to deploy some VMs in Nutanix, so i downloaded the vcenter applicane and tried to run the setup with admin rights. I have currently no dns server, so i used the gateway. NTP server is currently not available, because the environment is completly new, so i used the Time-synchronisation: Synchronize time with the ESXi hostSynchronize time with NTP servers Its activated with http://de.pool.ntp.org/; but is only temp. The vcenter appliance setup 1 is running fine, the step 2 is very slow and need much time. After 2hours on 50% i canceled it. The error: No file found matching /etc/vmware-vpx/vc-extn-cisreg.prop cmd "/usr/bin/python /usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk" timed out after 60 seconds due to lack of progress in last 30 seconds (0 bytes read) but why? Should I try another vcen
Hi, A customer moved his Nutanix Cluster (with Hyper-V) from a DC to another, after powering the Nodes up, the IPs of all Hyper-V host and CMs released, I logged it locally to Hyper-V hosts and configure the internal IP (192.168.5.1/28) and the external IP same like before shutting the cluster down. I repeated the previous step with CVMs, I went through cd/etc/sysconfigs/ and edit network-scripts file and added the the external IP in the eth0 and the internal one (192.168.5.2/28) in eth1. Now Hyper-V FC is working fine but cannot start VMs due to the Nutanix cluster issue, whenever I tried to start cluster from any CVM, I get this message “WARNING genesis_utils.py:1211 Failed to reach a node where Genesis is up. Retrying” Is there any way to fix this issue or to repair cluster configuration without disrupting existing data? Thanks in advance
esxi 6.5 u2 vSwitch configured as 1 active uplink and 1 standby uplink on esxi nutanix. I didnt understand why the standby adapter in which scenarios. I wonder why and in what scenarios it is used. can i use both 10 GB network adaptor active-active mode in Virtual Standard Switches (VSS).
Ques- There is 5 node cluster with 200 TB raw disk data, administrator want to enable eraser coding to obtain more space. What will we the usable space after enable eraser coding Options – 100, 125, 150, 175 TB ? Please share the calculation formula ? Ques2 - Administrator want to perform DR test after 6 months, which snapshot he should use? Option – latest snapshot, oldest one
In this topic I will share how to configure an SMTP server on your Nutanix cluster. This can be done from the Prism UI. This is pretty simple and straight forward. Below is the link shared, that discusses how to configure a SMTP server- https://portal.nutanix.com/#/page/kbs/details?targetId=kA032000000TTWtCAO After the SMTP server is created, the email alerts should be tested if they are being sent from the cluster. SMTP always uses port 80 and 8443, so make sure that these firewall ports are open. You could send test emails to verify correct SMTP configuration. This can be done using the KB2773. I will attach a link to the KB below. https://portal.nutanix.com/#/page/kbs/details?targetId=kA03200000097qFCAQ Hope this piece of information is useful!
Is it possible for a single bridge can have multiple bonds? in which usecase it will be applicable? -Jai
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.