Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Below are new knowledge base articles published on the week of November 8-14, 2020.KB 9233 - Alert - A150005 - AcropolisDefaultVSwitchError KB 9406 - Alert - A150004 - AcropolisVSwitchConfigFailed KB 9544 - NCC Health Check: conntrack_connection_limit_check KB 9675 - NCC Health Check: ahv_bridge_config_check KB 10180 - VM migration failures between AHV hosts due to network MTU mismatch KB 10208 - Alert - A130160- Host Network Uplink Configuration Failed KB 10209 - A6416 - Common port group between ESXi hosts is absent KB 10222 - Alert - A111076 - OVA Upload Interrupted KB 10223 - Alert - A200402 - vNUMA VM Pinning Failure KB 10238 - Nutanix Files Unavailable due to Stale ARP entries when ARP Flooding is disabled in Cisco ACI KB 10239 - Citrix VDI and Daylight Savings Time KB 10241 - Alert ID - A500104 - Entity Sync failed for the Availability Zone KB 10242 - Alert ID - A130149 - Guest Power Operation Failed KB 10245 - Unable to upgrade Era from 2.0 to 2.0.0.1 and above KB 10249 - Alert
I set up a new cluster and I don’t know why “Uplink Configuration” shows “No Uplinks”. What can be the reason for that? (See: “PRISM/console/#page/network” » "+ Uplink Configuration" » “NIC Configuration” » Dropdown shows only one unselectable option: “No Uplinks”).
Let’s say you want to know what are the uses and differences between Prism Element, Prism Central and Prism Pro Nutanix Prism is the centralized management solution for Nutanix environments, however, Prism comes in different flavors depending on the functionality needed. Prism Element: It is a service already built into the platform for every Nutanix cluster deployed. It provides the ability to fully configure, manage, and monitor Nutanix clusters running any hypervisors, however, It only manages the cluster it is part of. Prism Central: It is an application that can be deployed in a VM or in a scale/out cluster of VMs (Prism Central Instance) that allows you to manage different clusters across separate physical locations on one screen and offers an organizational view into a distributed environment. Each Prism Central VM can manage 5,000 to 12,500 VMs, where Prism Central Instance (a three Prism Central VMs cluster) can manage up to 25,000 VMs. Prism Pro: It is a feature set
There are several ways to move a VM from one cluster to another.A. For moving a VM from Non-Nutanix cluster to Nutanix use Nutanix Move available on the PortalNutanix Move is a cross-hypervisor mobility solution to move VMs with minimal downtime.B. For Moving a VM from one Nutanix cluster to another use Asynchronous Disaster Recovery Between On Premise Data CentersSummary of stepsConfigure a Remote Site on Cluster A Create a Protection Domain on Cluster A. Add the VM to be moved to this Protection Domain. Power Off the VM Create a schedule for (N) hours temporarily and initiate a full replication. After replication is complete, restore the VM from snapshot on cluster B and power on the VM. Unprotect the VM from Protection Domain, Delete the schedule, snapshots and Protection Domain on cluster A. Un-configure the Remote Site on Cluster AConfiguring Remote Sites (Part 1) : https://www.youtube.com/watch?v=5lva3Z_HDPc&ab_channel=NutanixUniversityConfiguring Remote Sites (Part 2) : http
Hello, All.Good day!! I have an issue and need your help and advice. 1. using 10 nodes, but I want to configure 2 clusters with 5 nodes each. (Composed of RF3) 2. In a cluster consisting of 10 nodes, the removal of 5 nodes was successfully completed. 3. Then, cluster creation was done manually for 5 nodes that had been removed.cluster -s 166.103.190.123,166.103.190.124,166.103.190.125,166.103.190.126,166.103.190.127 --skip_discovery create --redundancy_factor=3 4. Errors that occur during cluster configuration work--- 166.103.190.125 (Down) to start: It seems that the part does not progress as it repeats Up and Down.Waiting on 166.103.190.124 (Up, ZeusLeader) to start: Medusa DynamicRingChanger Pithos Mantle Stargate InsightsDB InsightsDataTransfer Ergon Cerebro Chronos Curator Athena Prism CIM AlertManager Arithmos Catalog Acropolis Uhura SysStatCollector NutanixGuestTools MinervaCollector NutanixGuestTools MinervaCollector NutanixGuestTools MinervaCollector NutanixGuestTools MinervaC
Hi Team,We have three node (NX-8155 ) cluster connected to nexus switch.Vlan Tag for CVM and Host : 600Vlan Tag for Guest/Prod : 10All are in same subnet ( Host IP : 172.21.10.x/24 , CVM IP : 172.21.10.x/24 and Guest/Prod Network : 172.21.10.x/24 )We have allowed Layer-2 on Nexus, trunk port traffic and added both Vlans ( 600 and 10)Question:Can we keep all under same subnet ? If so how can I communicate inter-VLan , for the purpose of CVM to communicate NTP,DNS,Monitoring and Internet. Else Can I keep CVM, Host and Guest in same Vlan ? How this will impact broadcast domain and any issue with congestion. Else Can we have two different subnet range for (CVM, Hosts) and Guest with different Vlan (600) and (10)
I attempted several times to move a test VM over and I am running into a issue with the Mount Container process. Is there a fix for this. I suspect it to be an Firewall issue, Any help would be appreciated.Failed VM Migration: prepare target: [[Location="/hermes/go/src/tgtagent/ahvtargetprovider.go:567", Msg="Error creating target path [Container="default-container-90861820611740", Err="exit status 32", Location="/hermes/go/src/libcloud/prism/ahvmountimpl.go:146"] Container mount failed (error=0x4012)"] Target agent error (error=0x4003)]
Hi, I often get the error of: Warning : Disk space usage for /home on Controller VM... Does anyone have a definitive list of what needs to be deleted beyond the installation files? or a script that deletes the un-needed files? Surely it is something Nutanix should be building in to the system, I never have problems with VMware running out of installation space! Thanks Eric
I have tried to write [] and other 3rd level keys in my Linux machine, but I am unable when connected through “Launch Console” in Nutanix.Workaround such as shift+ctrl+u (and then some code for the wanted key) does not work either.Is this a Nutanix “thing”, and if so, is there a fix or is there a workaround?
Remote diagnostic service is an on-demand log collection from Insights which leverages Pulse workflow, which is used to diagnose a specific issue which can be related to specific service, unlike pulse which provides a high-level log collection service. The remote diagnostics allows Nutanix support to collect a set of logs for troubleshooting a specific issue and it contains: Services related logs Custom gflags Activity traces for Nutanix services Hypervisor logs and configuration System statistics NCC health check reports Workflow When Nutanix Systems Reliability Engineers needs some diagnostics data to be collected they go through the following workflow: The Remote diagnostic is enabled by default with Pulse and Remote Diagnostics can be disabled later by having the Pulse service still enabled which is required for proactive monitoring of the cluster. Only authenticated and authorized users from support, sales and customer success can use the Nutanix Remote Diagnost
Activate sysrq on Linux guest VMs Log in to the Linux Guest VM as root user and check the value of "sysrq" as below. [root@linuxvm ~]# cat /proc/sys/kernel/sysrq16Default value is 16 which stands for "enable sync command". Modify the value of "sysrq" from "16" to "1". "1" means "Enable all functions in sysrq We can set this value to be persistent or non-persistent depending on situationNon persistent [root@linuxvm ~]# echo "1" > /proc/sys/kernel/sysrqPermanent - Reboot will be required to apply the change[root@linuxvm ~]# echo "kernel.sysrq =1" >> /etc/sysctl.d/99-sysctl.confCheck “sysrq” value again[root@linuxvm ~]# cat /proc/sys/kernel/sysrq Find AHV host in which linux VM is running nutanix@cvm:~$ acli vm.get <VM name> | grep host_namehost_name: "X.X.X.X" CVM to check the UUID of Linux Guest VM from any CVM nutanix@cvm:~$ acli vm.list | grep <VM name>linuxvm 66551923-eb86-4c69-933b-ecf15ec5f59c run below command to find out the domain ID of the Linux Guest
I have a customer who’s using the tool, but once she connects the tool the values of CPU and memory displays 0% of utilization. Can you help me to address this issue?
Hi all!I’m looking for a HCL that details the exact firmware versions of specific components of a server to make sure that we are in the clear before we install or upgrade Nutanix.As far as I can tell there isn’t anyone to be found, at least not for someone who doesn’t have an account for the support portal (and I find it pretty odd to “hide” the HCL).I know there are HCL’s to be found outside of the support portal but those are extremely generic.Is there an HCL that is this detailed or is it only through trial and error we can figure out if we have the correct firmware?Thanks.
We have plan is to add e.g 10 new HPE Proliant DX380 12LFF server with the latest AOS, eg 5.17.1 into the existing cluster. Then remove 10 existing nodes and reimage and add it back. Can 5.10.5 coexisting with 5.17.1 in the same cluster? Thanks
I'd like to just confirm, is there any Nutanix web page that lists the supported browsers?The support page below that I bookmark is already deleted.https://portal.nutanix.com/#/page/docs/details?targetId=Portal-Help:sup-browsers-requirements-sp-r.htmlSo I searched similar page in Support portal, but I couldn't find.I know the browser requirements is not necessary information for many people nowadays. However that page is useful for us, so I want to refer substitute one if exist.
Below are new knowledge base articles published on the week of November 1-7, 2020.KB 8574 - Can't access Move UI - ERR_SSL_SERVER_CERT_BAD_FORMAT. KB 10169 - Alert ID - A130190 - Nutanix Guest Tools failed to initiate VM reboot after NGT install/upgrade KB 10219 - Alert - A803003 - ID Firewall lost connectivity to domain controller KB 10220 - A803005 - ID Firewall did not recover state after reconnecting to a temporarily unreachable domain controller KB 10221 - Alert - A1097 - IP Address Not Hosted KB 10243 - Alert ID – A1157 - Remote Site Network Mapping Configuration KB 10250 - Alert ID - A1123 - Metro AvailabilityNote: You may need to log in to the Support Portal to view some of these articles.
Are you still wondering about the following questions?To Which Version of AOS should I upgrade to from my current version? Will it be 1-Click Upgrade or not? What are the EOL versions for AOS, Nutanix Files or Prism Central? What is my software compatibility?Answer to above queries and many other queries is one single Link i.e. Upgrade PathsHere are some snapshots from Tools:Image 1 Image 2Image 3
Nutanix appliances support monitoring via SNMP. Only SNMP v2c and v3 versions are supported. SNMP v2c is supported starting with AOS 5.5. In addition, SNMP v2c with Nutanix does not support SNMP GET operations.The MD5 authentication is no longer supported in AOS 4.1 and later. SNMP can be set up using the Prism Web Console or from the nCLI. Setting up SNMP through nCLI Run the following command on any CVM (Controller VM) to add an SNMP user (encapsulate the keys in single and not double quotes). nutanix@cvm$ ncli snmp add-user username=SNMPUser auth-type=sha auth-key='SHAAuthKeyExample' priv-type=AES priv-key='AESPrivKeyExample' User Name : SNMPUser Auth Key : SHAAuthKeyExample Auth Type : sha Priv Key : AESPrivKeyExample Priv Type : AES Privacy protocol settings are optional. You can create the user only with the authentication protocol: nutanix@cvm$ nc
There are times when working with your environment that one of the Linux guest servers will go unresponsive. Nutanix Support may ask for crash dump files from the Linux VM to further analyze the cause.One such method is to use “sysrq”. This utility found on the Linux Guest OS allows access to several essential kernel commands and allow Nutanix Support to take a more holistic approach in trying to find a root cause.NOTE: If the VM is hung/inaccessible and "sysrq" has not already been activated, you may not be able to generate a core dump with the following method. You can configure the "sysrq" when VM is up and running and wait for the future occurrence.For more information on how to activate this feature, take a look at the KB 9066 on the Support Portal
This article provides quick links required for troubleshooting the alert – “Invalid Network Mapping Specified” for your Nutanix cluster. This alert can be generated if either the source or destination network configuration is not present in network mapping specified in the remote site, or the networks specified in the network mapping do not exist. To learn more about how to resolve this alert, check KB-10243.To learn how to configure a remote site, check this guide. For more information on Network Mapping, refer to this guide.
Hello, Regarding to this question https://next.nutanix.com/how-it-works-22/disk-fault-tollerance-8822, What will happen to VMs in a cluster with RF2 when 1 drive failed on 2 different hosts? Will be any data loss or no? Will VMs reboot?Thanks!
Hello all, i have a 3 node nutanix cluster and i was trying to deploy ACI for lab usage on nutanix AHV as a vm but while i launch the vm it wouldn’t accept my keyboard. please any idea how to solve.
If I update update firmwares or softwares via LCM, is LCM update out-of-band? Or in-band? I can’t find any information in TN-2122 (Life Cycle Manager).
SSH: We can SSH to the File Server VM using the following process Retrieve the IP address for the FSVM. Log on to the CVM. ssh nutanix@cvm_ip_address Enter the CVM password. List the FSVM IPs. nutanix@cvm$ ncli fs ls FSVM IPs appear in the following format Nvm IP Addresses: internal IP,external IP. 2. SSH onto the FSVM using the internal IP. nutanix@cvm$ ssh internal_ip_address Change password of FSVM: Log on to a file server VM with SSH. Change the nutanix password. nutanix@fsvm$ sudo passwd nutanix Respond to the prompts, providing the current and new nutanix user password. Changing password for user nutanix. Old Password: New password: Retype new password: passwd: all authentication tokens updated successfully. Portal Reference:https://portal.nutanix.com/page/documents/details?targetId=Files-v3_7:fil-file
Hello Guys, We´re currently trying to install a Big IP LTM image on Nutanix using acropolis however it´s not working... it seems we´re missing something. We´ve found a link in regards of this topic but we are receiving a message infoming we have no access to it. Does anyone know how we should proceed in order to install a F5 VE on Nutanix using acropolis? https://next.nutanix.com/archive-44/how-to-install-f5-big-ip-on-nutanix-ahv-8062# (not authorized to access) Thanks in advance!
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.