Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
I configured four Nutanix 3460-G7 nodes, and when they were installed, I tried to log in using the given link (one of the cvm), but since the new nutanix default password was changed to the IPMI serial, I had to try four times before it locked me out. and my pc was detached from the switch for some reason, which I reconnected, but now I couldn't access the prior cvm ip using the gui. Need help guys
NUTANIX documents on upgrading Microsoft OS from 2012 R2 to 2016 reference the need for both the OS ISO file and also the “metadata upgrade JSON file.” Where do I locate the JSON file? It says the Nutanix support portal but I’m not able to access it there. It also mentions the “Hyper-V ISO file” but it’s unclear what that is referencing? If it is referring to the Server 2016 ISO file there doesn’t appear to be any file like this. Upgrade using ISOs. The Prism web console supports 1-click upgrade (Upgrade Software dialog box) of Hyper-V 2016 or 2019 by using metadata upgrade JSON file. This file is available in the Nutanix Support portal Hypervisor Details page and the Microsoft Hyper-V ISO file.Anyone able to point me to where to get this file so I can perform this needed upgrade?
I have pulled some new nodes into an existing cluster that utilizes LACP/LAG on the current nodes. The default configuration on the new nodes is Active/Backup. We also have new ToR switches that are not configured in a LAG. Are these the correct steps the configure Active/Active? The new nodes are only participating in the metadata ring - not hosting any VMs:To modify networking on the new nodes:Change the node to LACP enabled (ACTIVE/ACTIVE) using vs0 in the GUI – select only that ONE node to update the config on!! Put node into Maintenance Mode Login to CVM acli host.list acli host.enter_maintenance_mode host-IP-address DO I NEED TO PUT THE CVM IN MAINT MODE AS WELL?? Make changes on ToR switch – enable the 2 ports for LAG for that node ONLY Test networking Remove from Maintenance mode acli host.exit_maintenance_mode host-ip Verify resiliency returns to OK Move onto the next nodeI would love some feedback on if this is the correct order.
Below are new knowledge base articles published on the week of February 13-19, 2022.KB 10581 - How to update email address for the Nutanix Portal access KB 12044 - NCC Health Check: fanout_secure_port_connection_pe_to_pc_check KB 12745 - Nutanix Files - Files scale out fails with "FM Files Scale Up Task Failed at: Create platform memory hot scaleup task." KB 12747 - Failed To Snapshot Entities Alert due to stale cached vm information KB 12754 - LCM: BIOS-Redfish update fails with "Failed to update BIOS. Status: 200" KB 12755 - Nutanix Move - Migration task is stuck at "In queue for Memory"Note: You may need to log in to the Support Portal to view some of these articles.
Introduced in AOS 5.18 is a feature known as the Recycle Bin, which is enabled by default and allows a 24-hour hold on VM files that were deleted and need to be recovered, unless the cluster free storage space reaches critical thresholds.This feature was introduced to simplify the recovery procedure for accidentally deleted storage entities (Virtual Machines, Volume Groups, or individual disks). You can disable and enable the recycle bin or clear its contents.To restore an entity, you MUST contact Nutanix Support.To learn more about the limitations and how to manage the recycle bin, click here.
Hi all I just want to know how nutanix AHV allocate resource(cpu or memory) to VMs? Like VMware resource share or limit, and memory overcommit?
You might have noticed that the versions of AHV hypervisor have names starting from the year, such as 2017 and 2019. For example, AHV-20170830.434 and AHV-20190916.231. The difference between them is that the versions starting with 2017 are built on CentOS 6 image, while the ones starting with 2019 are based on CentOS 7. It is very important to note that all the 2019 AHV versions are only compatible with AOS versions 5.16 and newer. It means that the current LTS AOS versions 5.10.x and 5.15.x do not support AHV 2019. The AHV 2019 is currently supported only with STS AOS versions. The cluster will not let you upgrade the AHV to 2019 version if you are below 5.16. But it is possible to manually image the node with the AHV 2019 ISO and install the earlier AOS there. Also, it is possible to upload the non-default AHV during the foundation procedure together with earlier AOS. Such configurations are unsupported. If you have already done that, you will have to go to the STS AOS to
My vCenter is still in 6.5. Which vCenter 7 version is recommended to work without issues with AOS 5.20.3 LTS ? Thank you for your advice or experience.
Below are new knowledge base articles published on the week of February 6-12, 2022.KB 12655 - AHV "firstboot" script fails with "could not find any uplinks to foundation" due to NIC auto-negotiation taking too long KB 12714 - Nutanix Files: NFS write errors due to duplicate hostnames KB 12724 - ERA - Unable to authorise an existing database server for clone operation in Era KB 12727 - Enabling RDMA fails because cpuidle states do not match. Error message "Failed to verify that states are disabled on host" KB 12730 - New To Nutanix - Educational Resources KB 12732 - Nutanix Files: How to create a TLD wtih a dedicated Volume Group KB 12737 - Nutanix Files: CVE-2021-44142 does not impact Nutanix FilesNote: You may need to log in to the Support Portal to view some of these articles.
Nutanix health check found NGT client certificates expiring , I can't solve this problem follow this method NCC Health Check: ngt_client_cert_expiry_check
I am trying to find configuration information for a Nutanix 3-node chassis, model # NX-3360-G5. The only documentation I have been able to obtain pertains to 2 or 4 node chassis. I presume the drive slots designated as node “D” are simply filled with blanking panels but would like some confirmation as such. Additionally, I would like to know the replacement model number and where available. Thank you.
There would be scenarios where in a system administrator or an engineer managing a Nutanix cluster would want to say: Perform some action like shutdown, power-on, delete, take a snapshot, clone etc ib bulk or on multiple VMs at once with some matching critearia such as say common Starting names, or common ending names, some pattern in names and all the powered-on UVMs etc. One way is to one-by-one go and perform that action from Prism for each of those VMs which is very tedious in scenarios where say we have 20 VMs etc on which we want to perform same actions say like shutting them down. What can we do ? In such scenarios we can use some basic shell scripting along with aCLI(Acropolis command line tool). So aCLI is a cmdline tool for managing hosts, networks snapshots, UVMs etc on a Nutanix cluster. Here is a document which explains how to use aCLI https://portal.nutanix.com/page/documents/details?targetId=Command-Ref-AOS-v5_17%3Aman-acli-c.html. So below are some
It’s totally available in Prism UI. But I find it impossible with API:In REST API, using PUT /virtual_disks/ “disk_capacity_in_bytes” receives 200 but not size changes. In ncli, using vdisk edit name=<> max-capacity=<> runs, yet the same no changes. Since the VM disk of this Linux VM doesn’t belong to any volume group, not an option for acli the way I see it.And if I do it via VM commands, it’s only able to create new disk or clone disk, not expand which is what I want.I really need an API for this job. Any ideas? Thanks!
Below are new knowledge base articles published on the week of January 30-February 5, 2022.KB 12077 - Alert - A130039 - UnqualifiedDisk KB 12248 - Cluster conversion validation failing because of absence of AHV installer image KB 12531 - Era - Alert "Driver exceeded the timeout value of 70 minutes for the execution of the operation" KB 12612 - Managing storage container in Prism Central fails with "Forbidden" error KB 12642 - Zero-Touch Hardware Dispatches KB 12671 - How to enable multi NIC feature for Mongodb in ERA 2.4 KB 12673 - How to enable and disable ERA services KB 12675 - Cannot modify cluster parameters via Cluster Details UI if Cluster Timezone is invalid KB 12677 - DR - Cerebro service may enter a crash loop due to retrieval of snapshots on a Cluster with AOS version 6.0 and higher from a cluster with AOS version below 6.0. KB 12681 - Maximum Node count for Nutanix clusters KB 12682 - Alert - Nutanix Cloud Clusters - AWS - Cluster Creation Failed due to shared subnets KB 12
Hi All,I’ve old hardware NX-3050 currently running AOS 5.10 + ESXi 6.7 U3I need to foundation this node to new version of AOS. But When I check into https://portal.nutanix.com/page/documents/compatibility-interoperability-matrixThere is no list for NX-3050 any more.
I am trying to import Nutanix Collector (latest available version) excel to sizer. The excel contains a large number of “PoweredOff” virtual machines. I want to make the sizing based on performance figures only for “PoweredOn” virtual machines. If I choose “CPU: performance” I get a warning message:“Data being imported contains one or more VMs that were powered ON during the collection period and reported CPU utilization. We recommend you to size both Powered ON & Powered OFF VMs.” The warning it self doesn’t make much sense. Maybe it should read“Data being imported contains one or more VMs that were powered OFF during the collection period and did not report CPU utilization. We recommend you to size both Powered ON & Powered OFF VMs.” Additionally “Upload” button is grayed out and I cannot proceed with the sizing. IMHO the “Upload” button should not be disabled.
Below are the top knowledge base articles for the month of January 2022.KB 7503 - NX Hardware [Memory] – G6, G7 platforms - DIMM Error handling and replacement policy KB 1113 - HDD or SSD disk troubleshooting KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 3827 - Alert - A130087 - Node Degraded KB 4158 - Alert - A1104 - PhysicalDiskBad KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 2473 - NCC Health Check: cvm_memory_usage_check KB 4272 - Alert - A6516 - Average CPU load on Controller VM is critically high KB 2090 - AHV host networking KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 4141 - Alert - A1046 - PowerSupplyDown KB 4519 - NCC Health Check: check_ntp KB 3786 - Alert - A1081 - CuratorScanFailure KB 6945 - How Upgrades Work at Nutanix KB 10919 - Logrotate does not rotate ikat logs KB 5228 - NCC Health Check: pcvm_disk_usage_check KB 2480 - NCC Health Check: nic_li
Below are new knowledge base articles published on the week of January 23-29, 2022.KB 11244 - NCC Health Check: stale_app_consistent_snapshot_metadata_chunks_check KB 12563 - Changes in application consistent snaphots for Nutanix workloads KB 12623 - VM Network creation on AHV indicates "VLAN identifier has to be unique within managed (or unmanaged) networks on one Virtual Switch" KB 12649 - Unable to discover nodes with Foundation java applet KB 12666 - ERA - MSSQL Database Provision Best Practices CustomisationNote: You may need to log in to the Support Portal to view some of these articles.
Hi all !I changed the format of Replication Factor 3 to 2 of my nutanix cluster, everything went well and without problems of my cluster but I have 2 doubts.I'm still seeing this error regarding extent groups and Oplogand the other doubt I have if I change my Replication Factor format from 3 to 2, my Fault Tolerance changes to 1 or is there a command to change my fault Tolerance to 2? I would greatly appreciate your help to correct errors or have more knowledge about nutanix.thanks
Good morning, Is there any way to give specific right to a role for group of vms?? Thanks in advance
NOTE: If you are running AOS 5.11.x Please upgrade to AOS 5.11.1.2 or higher before enabling the Remote Support TunnelWhat is the Remote Support TunnelThe Remote Support Tunnel allows Nutanix SREs and Engineers to access a cluster via a Secure SSH Tunnel.We can also send a public SSH key to allow access without the need for the cluster password to be exchanged. Enable the Remote Support Tunnel In Prism, go to; Settings, by clicking the gear wheel or from the Dashboard selection Select Remote Support Enable for n hour(s) (maximum of 24 hours)After 5 - 10 minutes, go back or refresh the Remote Support setting screen to see the Status. The Connection Status should be reporting “Success”. If the status is reported as Disabled, (as seen below), please review the following Knowledge Base Article for Troubleshooting options. Nutanix Remote Support Tunnel Troubleshooting Guide
Hi thereI’ve question about difference between configuring bond(port aggregiation) via manage_ovs and ovs_vsctlI wanna to change bond that is in active_backup mode to active_active balance tcpI’ve confused a little bit,what is difference between doing this with manage_ovs and ovs_vsctl
Hello,I’m trying to implement custom monitoring with Zabbix regarding the Alerts.I’ld like to put custom alert based on Nutanix alert title such as : Cluster does not have enough free space to tolerate {num_node_failure_limit} node failure(s)snmpget -v 3 -u zabbix -l authPriv -a SHA -A ‘XXXXXXXXXXXX’' -x AES -X ‘XXXXXXXXXXXX’' 172X.X.X ntxAlertTitleBut i have the following error : NUTANIX-MIB::ntxAlertTitle = No Such Object available on this agent at this OIDThis kind of things are only based on trap message ? Regards, Damien
I noticed that this web page has changed.https://www.nutanix.dev/api-reference-v3/Old version can copy the response, like this picture.I need it in this format.How can I access the old version of the web page? Or how can i copy the response in this format?Thanks.
If I want to call this api for a vm, I must add this vm into a protection domain, and take a snapshot for this protection domain. Then, I can get the vm’s disks’ snapshot file path , like this : /<storage_container_name>/.snapshot/<number>/<id>/.acropolis/vmdisk/<vm_disk_id>I can use this file path to call this api successfully.But, a protection domain maybe contain many vms, if I take a snapshot for a protection domain, all vms in it will take a snapshot, I just want to take a snapshot for one vm of them. if I take a snapshot for a vm directly, I will get the vm’s disks’ snapshot file path, like this: /<storage_container_name>/.acropolis/snapshot/<snapshot_id>/vmdisk/<vm_disk_id>.But this filepath is invalid for this api. like this question:https://next.nutanix.com/discussion-forum-14/get-error-code-400-when-use-v3-api-post-data-changed-regions-40363 I want to take a snapshot for one vm, and don’t affect other vms, and I can use this snap
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.