This forum is the best way to get up and running with the Nutanix platform
Recently active
Hello team, I hope that someone can explain to me why, looking to sizer’s recommandations about hybrid configuations, SSD/HDD ratio is not size dependent but form factor dependent. Basically if you select 2 SSD and 3.5”HDD then a minimum 1:1 ratio is possible (SSDx2 + HDDx2) but if you have have SSDx2 and 2.5” HDD then the minimum ratio is 1:2 (SSDx2 + HDDx4). Is it because 3.5” HDD SAS or SATA are usually faster than 2.5”? It’s not about size or hardware vendor, recommandations seems to changes according to the disks form factor only
Hello All, Seeking for you kind assistance, Does anyone of you tried to install or generate a SSL certificate of IPMI? This is a CVM, my Infosec detects High Risk on it. Hoping for a positive revert on this Thank you.
I have a Dell PowerEdge Server R620 with 64G of Ram and 2T of HD Space. I am wondering what version of CE is supported on this older server. I downloaded the latest one and the install errored out. Thank you,
When you replace the NIC cards in the Nutanix AHV cluster, it is possible that the new NIC card interfaces are recognised as additional interfaces and are numbered after the existing interfaces. So, for example, in the current AHV node you have 4 interfaces - eth0, eth1, eth2 and eth3 and you replace the NIC card and you see additional interfaces - eth0, eth1, eth2, eth3, eth4 and eth5. Also, if your host was connected earlier on the replaced NIC card, you will lose the host connectivity. We now have the script in AOS 5.10.10 and AOS 5.15 to get the NIC interfaces re-numbered correctly. If you are running older versions or unable to run the script for any reason, you can use the annual method. Please check the Nutanix portal page here and KB3261 for the exact script and the manual method steps.
I am trying to find out the User who took the snapshot on AHV Cluster. I did not find the same in Tasks/Events in Prism or through below Command. acli snapshot.get <SnapshotUUID>
Hi, We purchad Huawei servers end of last year (check compatibility matrix brought by Nutinix itself https://docplayer.net/136878906-Huawei-hardware-compatibility-list.html and due to Covid19, we were not able to install them until now. Currently we have 4 servers with part numbers from compatibility matrix 2288Hv5-12 and 2x10G switches for interconnection. Each server has M.2 SSD drives for OS installation configured in RAID 1, while the rest of the disks (SSD of 1.92TB) are in JBOD mode, since that there are 2 RAID cards, one for M.2 and the other for SSD drives respectively. Virtual drive has status OK. During installation process, we receive error message that says the following: “INFO Performing firmware checks for platform Huawei 2288HV5-12 WARNING Some error occurred during firmware checks. This can be due to some unsupported hardware. Please report this to foundation team.” Final error message is: Unable to find SSD in node. Please, help us resolve this issue in form o
Hi,I need an older version of Foundation and AOS. Where can I find them?I can only find the latest version to download.I need ,Nutanix Acropolis Operating System (AOS) 5.5.8Nutanix Foundation 4.3.2Nutanix AHV 20170830.185 Thank you.
Nutanix cluster works with the vDS and you can use the following guidelines and recommendations to configure the vmk and VM interfaces to be part of the vDS. Nutanix recommendations for implementation Keep the vSwitchNutanix, the vmkernel port (vmk-iscsi-pg), and the Nutanix Controller VM's virtual machine port group (svm-iscsi-pg) configuration intact. It should remain as a standard vSwitch and should not be migrated over to the vDS. Migrating the vSwitchNutanix to the vDS causes issues with upgrade, and also controller VM data path communication. Only migrate one host to a dvSwitch at a time. After migrating the host to the dvSwitch, confirm that the Controller VM can communicate with all other Controller VMs in the cluster. This ensures that the cluster services running on all Controller VMs continue to function during the migration. In general, one Controller VM can be off the network at a given time while the others continue to provide access to the datastore.
The Nutanix cluster in Vcenter must be configured according to Nutanix best practices. A quick checklist for the recommended settings review is as follows: vSphere HA Settings Enable host monitoring Enable admission control and use the percentage-based policy with a value based on the number of nodes in the cluster. Set the VM Restart Priority of all Controller VMs to Disabled. Set the Host Isolation Response of the cluster to Power Off. Set the Host Isolation Response of all Controller VMs to Disabled. Set the VM Monitoring for all Controller VMs to Disabled. Enable Datastore Heartbeating by clicking Select only from my preferred datastores and choosing the Nutanix NFS datastore. If the cluster has only one datastore, add an advanced option named das.ignoreInsufficientHbDatastore with Value of true. vSphere DRS Settings Set the Automation Level on all Controller VMs to Disabled. Leave power management disabled
Hi, I'd like to change Cluster External IP Address but CVM IP Address is NOT change. Do I have to stop the cluster ? or Do I change that online? Regards,
Hi all, the import SSL certificate form allows me to choose between key’s format. I have RSA2048, ECDSA384 along with other ECDSAs. I am pretty sure I sumbitted a ECDSA384 key with secp384r1 curve. I can safely paste my key here because it’s now revoked: -----BEGIN EC PRIVATE KEY----- MIGkAgEBBDAzjnBwsncbnlR643ngw7M8/urUzuSVNNGjB84kTxgCyplXsbSuKzyl gxiijfhY3vOgBwYFK4EEACKhZANiAAS5DDtPOWrgYA/XKxzNEM1E3TER7Ol70njH JsQC+WU8lMH4d0s9G9MfIzQ1qHB7PukydkpdwMV2MYpaKpmQyrNO75zeRr/Jle/M 76vLL7FbZP9lzvwVTnJVXttXhBctM0o= -----END EC PRIVATE KEY----- Please can anyone explain me what’s wrong? Thank you so much! francescm
Did you know you can secure your IMPI Web Interface with an SSL Certificate? Securing the IPMI Web interface is recommended to help reduce susceptibility to attacks. You can further enhance security by installing your own customized certificate or a CA-signed certificate. Nutanix recommends strong keys and signature algorithms. The IPMI module supports SHA2 and RSA 2048 bit SSL. Avoid long certificate chains or large certificates. If the IPMI module shows the default or previously-installed certificate after you install a new one, or you are unable to log in to the IPMI web interface, the chain is too long (chain length longer than one) or certificate too large. As a test, create a simple self-signed certificate and install it to ensure the IPMI is working correctly before attempting to install larger certificates. You can use openssl or keytool to generate keys, certificates, and signing requests. Similarly to any other certificate deployment, the process consists of two steps
Hello good afternoon, I have a Nodes with black screen and blinking cursor, I want to see if there is a way to reset it or to show me the normal console again. If someone can help me, I really appreciate it, I already tried to generate the Phoenix iso and boot it in ubs and connect it to the node and start but send: udhcpc sending discover Thank you for your cooperation
You are trying to expand a new node into the cluster. I am trying to expand after installing ahv,aos(not cluster settiong option) as a foundation on a new node. When do I set the existing cluster ovs settings? Or I am wondering if the setting is automatically entered upon expansion.
In Nutanix nodes, there are SSD disks and SATA disks. Can we create two separate datastores. One datastore only contains SSD disks and one datastore only contains SATA disks
The default name of the CVM is in the below format: NTNX-<Block serial number>-<Node position>-CVM This is what you see as the CVM name in the PRISM. If you want to change the CVM name in your AHV cluster, then we have a script for changing this with the following limitations. nutanix@cvm:~$ change_cvm_display_name --cvm_ip=<IP of CVM that should be renamed> --cvm_name=<new name> The script is available in AOS - 5.10.10, 5.15 and 5.16. The naming convention needs to start with “NTNX-” and end with “-CVM”, Letters, numbers and “-” are supported in the CVM name, CVM should be able to get a shutdown token to be turned off, There will be no redirection of storage traffic to other CVMs, so make sure you have no user vms running in the AHV host - put the AHV host into maintenance mode, Run the script from a different CVM than the CVM that is being re-named and make sure the SSH session is intact until the re-named CVM comes up. For more
Has anyone implemented Windows Defender ATP in a Nutanix environment? If so, I'd love to talk about your experience.
I’m about to upgrade vcenter from 6.7 u1 to 6.7 u3. I’m only upgrading the vCenter for now. My AOS version 5.10.8.1 To upgrade only vVenter is there any action to take in PRISM? Will there be any impact on PRISM? Thanks
Quick tip of the day. Did you know that you can integrate IPMI with the Active Directory? Note: The default timeout is set at 0, which results in an error message HTTP 500 - Internal Server Error. Make sure to update it to 10. Select the User and then select Add Role Group to configure the Role Group. (Be sure that it matches an existing AD group name.) When logging into the IPMI web console, use the following format to log in: username@domain. Should you find yourself with a task too big to be handled manually such as configuring the same but on a miriad of nodes there is some help available. SMCIPMITool is a utility by SuperMicro. You can create a script to go through all your nodes’ IPMI interfaces and join them to the AD. For a complete set of steps see KB-2860 How to configure IPMI Active Directory Authentication for Supermicro platforms. For commands list and use cases see SMCIPMITool User’s Guide.
Companies merge, hosts are inherited and repurposed, administrators come and go and not necessarily leave things in order after themselves. Or what if you forgot the password and the record of it is not recoverable? Where there’s a will, there’s a way. I touched the other day on how ipmitool can be accessed from a CVM CLI but would require authentication details to pass on to the IPMI. Well, the host or rather the hypervisor installed on the host does not have to do so. Hence even when ADMIN account password (or any other account with full privileges) is lost the IPMI is still accessible from the hypervisor CLI and you can still reset the password, set up new user entirely, or set a new password for a user. The process consists of several steps: Log in to the hypervisor on the host (AHV or ESXi). List user records using ipmitool. Take note of the user ID. Set the password for the user ID. The task is complete. Conveniently, commands syntax between AHV and ESXi differs only in the
Hi All I have created a MS server 2016 VM with a view to using it as a desktop , however it does not seem to have away to add anaudio / soundcard device - is there a way to add one in Nutanix? I have found a way in VMware but not Nutanix. Any ideas? Thanks Eric
Wandering if someone could point me in the right direction as I am not overally familiar with SUSE. I am replicating from ESX to AVH and have installed NGT. The guest fires in AVH but I have no GUI - it errors that there are no drivers for X. Unfortunately it is stuck in my DR segment for which I only have the Nutanix Console access to at the moment, bets I have is: Just wandering if anyone had any experience with SUSE / AHV and could point me in the right direction? If I run startx from the console I get no screens found: Any assistance appreciated.
Playing around with an old NX-2000 series server and it seems I need to make my 10GbE nics default to eth now while before on boot they seemed to be recognized in eth mode. New module: # modinfo mlx4_corefilename: /lib/modules/4.19.0+1/kernel/drivers/net/ethernet/mellanox/mlx4/mlx4_core.koversion: 4.0-0 Old module: # modinfo mlx4_corefilename: /lib/modules/4.4.0+10/updates/mlx4_core.koversion: 3.4-1.0.0 Booted to a Kubuntu 16.04 Live CD to attempt to do it with the last supported firmware for the card but the Mellanox card doesn't seem to be supported by Mellanox OEM software. MLNX_OFED_LINUX-4.7-3.2.9.0-ubuntu16.04-x86_64.tgz root@kubuntu:~# mlxfwmanager --queryQuerying Mellanox devices firmware ...Failed to identify the device - Can not create SignatureManager!Failed to identify the device - Can not create SignatureManager!Device #1:---------- Device Type: ConnectX2 Part Number: SUPERMICRO X8DTT-IBX/X8DTT-IBXF/X8DTT-HIBXF/X8DTT-HIBXF+ (Rev2.00 or later) Description: ConnectX-2 VPI; s
In Nutanix clusters running AHV hypervisors, we can use the LLDP protocol to find more details about the directly connected switches. LLDP needs to be enabled in the switches for the details to be seen in the AHV hosts. From the AHV host, [root@AHV-HOST ~]# lldpctl------------------------------------------------------------------------LLDP neighbors:------------------------------------------------------------------------Interface: eth2, via: LLDP, RID: 7478, Time: 35 days, 22:55:59 Chassis: ChassisID: mac 00:XX:XX:2d:b6:ba SysName: AHV-HOST SysDescr: Network Switch TTL: 120 MgmtIP: xx.xx.xx.xx Capability: Bridge, on Capability: Router, off Port: PortID: ifname Ethernet9 PortDescr: Nutanix-AHV-Node-A MFS: 9236 VLAN: 100, pvid: yes------------------------------------------------------------------------ You can get the following switch details: Management IP address MAC address I
Hello all, I’ve tried to install ESX 6.7.0 and AOS 5.15 onto my Nutanix but it keeps erroring out. It looks like it’s trying to mount a phoenix.iso but that file does not exist and isn’t being created during the install. Leading to Foundation to be unable to SSH to it after boot. Please assist. Thank you. Installation failed. Click here to learn how to retry the failed nodes. Node ProgressDownload Log Bundle IPMI IPHOST IPCVM IPPROGRESSLOG192.168.1.5 192.168.2.5 192.168.2.6 fatal: Waiting for installer to boot up Log Reset • Review Configuration • Version 4.5.3 Node LogRaw text log 20200513 10:59:08 DEBUG Setting state of <ImagingStepValidation(<NodeConfig(192.168.2.6) @d8d0>) @dc90> from PENDING to RUNNING20200513 10:59:08 INFO Running <ImagingStepValidation(<NodeConfig(192.168.2.6) @d8d0>) @dc90>20200513 10:59:08 DEBUG Cache MISS: key(<function common_validations at 0x03D2E8F0>_()_{'global_config': <foundation.config_manager.GlobalConfig object at
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.