This forum is the best way to get up and running with the Nutanix platform
Recently active
We have a couple of 2 node cluster with a Witness VM on a separate host but I can not seem to find any documentation on how to enable SNMP on it.Using the “ncli snmp add-user” command that works for normal CVM’s just throw me the error:“Error: Cannot connect to Prism Gateway”Any ideas?
Hi All I have something odd in my Network view in Prism - I have 3 switches ( 1 switch is a 2 switch stack) but the view shows 5 switches, 2 classified as None. The None entries have the ip addresses of one of the single recognised switches and the stack which is already identified. The other odd thing is that the Nones have ports that I would expect to see in the identified switches. Can anyone tell me how to correct this?
Cluster creation or initialization is a process of bootstrapping the cluster by configuring the unconfigured nodes, load some node information into Zeus configuration file and start the services. Let's break it down. What is an Unconfigured node? Node which are factory shipped. Node which was removed from an existing cluster. These nodes are typically Pre-installed with CVM/HypervisorNO IPv4 address is configured But IPv6 link local address configured on eth0. This will always remain on a host. Before you begin to create a cluster with your brand-new nodes,You Must Have IPv4 Address configuration IPMI IP address Hypervisor IP address CVM IP address DNS/NTP IP address (Required while creating cluster via foundation) Hypervisor and CVM should be installed. What are the methods of Cluster initialization? Foundation: One click process for cluster creation Re-Images multiple nodes Assigns IP address on each node Manual Manual Hypervisor inst
We have a very long domain name and with the current config we are using the UPN (name@company.com) name to login. This is becoming very irritating for me to enter the domain name each time I login. Can we configure a default domain for all the login users to use if the user didn’t mention any domain and of course if we don’t have local user by the same name?
I see that ERA 2.0 has a prerequisite of SQL Server SQLPS PowerShell module. Does anyone know what specific version is required? I ask because when trying to register a single node, I receive the following error:Operation Failed : Unable to import SQLPS module. Please make sure that SQLPS module is available to proceed with Dbserver VM registration.I suspect that the version of SQLPS PowerShell module that we have installed on our SQL servers is too new.
We have added Dell Switches to see the Interface information and where our AHV hosts are connected through Network Tab.But, I am able to see Interface only on One Switch for one host, not on others. I see below. Is there anything we are missing.
As companies become more security aware, third party security tools are being utilized more heavily than ever before. One such tool is a security scanner which can review open network ports within an environment and report back on certain vulnerabilities (CVEs). This includes the open ports of Nutanix specific components such as the IPMI.While it is important to keep the IPMI/BMC upgraded to the latest version so as to integrate the latest security patches, there are CVEs that will still report as failed by scanners based upon the default IPMI configuration. This is due to the virtual media port (623) and the iKVM port (5900) being opened by default.The virtual media port allows the user to open a remote session to the host console and the iKVM port allows the hosts to query information from the BMC.The specific CVEs affected by these two ports being open can be found in KB 2555. NOTE: If these features are disabled, you will be unable to query any BMC info nor able to open a remote co
Please consider the possibility of incorporating the existing IP scheme in the new infrastructure. If changing the IP address is the only option we can utilize a script to change the CVM IP address. You can use the external IP address reconfiguration script in the following scenarios: Change the IP addresses of the CVMs in the same subnet. Change the IP addresses of the CVMs to a new or different subnet.In this scenario, the external IP address reconfiguration script works successfully if the new subnet is configured with the required switches and the CVMs can communicate with each other in the new subnet. Change the IP addresses of the CVMs to a new or different subnet if you are moving the cluster to a new physical location.In this scenario, the external IP address reconfiguration script works successfully if the CVMs can still communicate with each other in the old subnet. Following is the summary of steps that you must perform to change the IP addresses on a Nutanix cluster.
We have a 15 block HPE environment built with AOS 5.15.2. we need to enable flash mode on a NVMe device (vmdk) which is presented within vSphere but cannot be seen via prism element under the VM vDisks or via ssh shell to cvm’s is this feature not currently supported? any ideas I am struggling to find much on the support portal?still unsure on this how do we pin the NVMe vmdk to the performance tier cheers
Hello,i have some questions regarding “Switch stacking”1-) Is it possible to use " 2 stacked switches " as TOR with AHV? there will be a problem if we use this configuration?2-) The best practice is to use 2 Stacked switches or 2 individual switches?We plan to use Active-Backup configuration and conect SFP to Switch1 and the other SFP to Switch2I am not a network specialist so i am not sure if both switches are stacked, and we plug 1 SFP to SW1 and the other SFP to SW2, the active passive configuration will work
The upgrade process for the VCSA from a major release to another is as follows:A new VCSA with a temp IP is created in the vSphere host/cluster by the upgrade process. The upgrade process migrates the config/data from the old VCSA to the new one. The Old VCSA is shutdown and the new VCSA is renamed/re-ip with the values of the old VCSA. New VCSA is then rebooted.At this point the new VCSA should have the old VCSA name and IP address. My question for those that have done this already is, how does the Nutanix cluster Prism element reacts to this in regards to its vcenter registration? Will all this be transparent to it or will it see the new VCSA as a new device and create a duplicate entry? I assume the migration process will copy SSH keys and certs from the old VCSA to the new one so Prism won’t bat an eye, but I just wanted to confirm.
Hello ... can anyone provide feedback on getting Network Visualization working with Cisco Nexus 9K Switches. The Nexus Series is on the Supported Switch list, but I've had a ticket open with Support for weeks and we can't get it working. https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v510:wc-network-visualizer-supported-switches-r.html LLDP is enabled globally on the 9K, and I can populate the 9K switch info into Prism just fine. The issue is I can't get any port data. Nutanix Support is saying the issue is by default the "port-id-subtype" is set "locally-assigned", and it needs to be changed to "interface-name". The 9Ks are in ACI-Mode, not NX-OS, and no one seems to know how or where the change is made. Has anyone gotten this setup to work? Here are some pics from my environment. Thanks!
A traditional Nutanix cluster requires a minimum of three nodes, but Nutanix also offers the option of a one-node or two-node cluster for ROBO implementation. Both of these have a minimum requirement for the CVM to be allocated with 6 vCPUs and 20 GB memory.Specifically for two-node, there have been several improvements in 5.10 to ensure optimal health of the cluster.Customers should upgrade to a minimum version of AOS 5.10.7 to avoid encountering any of the potential service impacting issues present in earlier releases of AOS.The table provides a summary of improvements in the document here-https://portal.nutanix.com/page/documents/kbs/details?targetId=kA00e0000009DaXCAUMore information about two node cluster can be found out -https://portal.nutanix.com/page/documents/details?targetId=Web-Console-Guide-Prism-v5_18:wc-cluster-two-node-c.htmlROBO implementation meaning - Short for remote office, branch office ROBO is a term used to refer to any off-site office that connects to the organ
Hello,have you guys ever configure a 4 SFP + Nutanix cluster with AHV? i understand that the 4 SFP + will be configured as active-passive in a same bond... but only 1 SFP should be used. There is a better way to configure network on AHV to improve and use the other SFP+??? i mean, for example, separate the traffic between user VMs and CVM (storage traffic)
I tried to create a boot UEFI with URL https://github.com/abbbi/nutanix_uefiWhat information should I put for the image ce-2019.11.22-stable? menuentry 'Nutanix Community Edition AHV (4.4.77-1.el7.nutanix.20190211.279.x86_64) 7 (Core)' --class nutanix --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.4.77-1.el7.nutanix.20190211.279.x86_64-advanced-4d8b0f1e-e014-4058-a050-c6d2ed188094' { load_video set gfxpayload=keep insmod gzio insmod part_msdos insmod ext2 if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root 4d8b0f1e-e014-4058-a050-c6d2ed188094 else search --no-floppy --fs-uuid --set=root 4d8b0f1e-e014-4058-a050-c6d2ed188094 fi linuxefi /boot/vmlinuz-4.4.77-1.el7.nutanix.20190211.279.x86_64 root=UUID=4d8b0f1e-e014-4058-a050-c6d2ed188094 ro crashkernel=128M rhgb quiet hugepages=0 intel_iommu=on,igfx_off iommu=pt elevator=noop vga=791 vfio_iommu_type1.allow_unsafe_interrupts
So you have decided to relocate your Nutanix cluster to a different data center. Here are a few things to consider and a brief overview of steps to follow for seamless transition. Caution: This information is only provided to serve as a guide to plan your move. Please engage Nutanix Support if you have any concerns or questions following this process. Before you decide to move: Consider the possibility of incorporating the existing IP address schema into the new infrastructure by reconfiguring the router and switches instead of Nutanix nodes and CVMs. If that is not possible, proceed with this guide. Before you unplug everything:Refer to these guides for the procedure.Doc 1 (CVMs) CHANGING THE CONTROLLER VM IP ADDRESSESDoc 2 (AHV hosts) CHANGING THE IP ADDRESS OF AN ACROPOLIS HOSTDoc 3 (IPMI) CHANGING AN IPMI IP ADDRESS A few things to note:1. Since the cluster is being relocated and the new network will not be able to communicate with the old network, you will need to run through so
Hello,I’ve just reimagined a block with 4 nodes (NX-1065-G4) to use in our lab using Phoenix image (created following this article https://portal.nutanix.com/page/documents/details?targetId=Field-Installation-Guide-v3-12:v31-phoenix-files-r.html#reference_bbk_vnx_p4).I’m using ESXi 7.0.0 build 15843807 and NOS 5.15.2. Hypervisor and CVMs have been correctly installed (following this https://portal.nutanix.com/page/documents/details?targetId=Field-Installation-Guide-v3-12:v31-node-install-cvm-t.html) but CVM does not have an IP configured. I’ve tried to configure CVM IP using “external_ip_reconfig” scripts but i get an error: How can i configure CVMs’ IP?Note: i’ve used Phoneix because Foundation failed several times with a “dependencies” error.Thanks, kind regards
Hi all,We recently purchased a new G7 and during this new install we converted all of our VMs to AHV using Move and we are successfully running on AOS/AHV. Working great.We now would like to convert our old 1050 with ESX/vCenter to AHV although we are hitting the DRS roadblock.We do not have a DRS license to enable this feature.We have also tried a “Trial License” and this doesn’t appear to be the best route (upgrading all kinds of vmware items just to get a “trial license enabled DRS “just to convert to AHV)My question is, now that our old cluster is decommissioned (All VMs are now on the new cluster), what would be my best approach at converting this old cluster to AHV and not having the “Convert Cluster” option hanging us up with DRS not enabled? Any input is appreciated.
Hello all,I’ve just finished the basic installation of a new 3 nodes Nutanix Cluster (NX-1065-G7 node). When i try to enter the IPMI password nothing happens. It seems the password is wrong. I have tried the default ADMIN/ADMIN password but it doesn’t worked (also admin/admin).Did the default password change with the release 5.15.x of AOS ?For information, the cluster has been created with the following parameters : AOS 5.15.2 Foundation VM 4.5.4.1 ESXi 6.7U3The “ipmitool user list” show me an “ADMIN” user with ID 2, so i think the account is correctly created. I ve tried on each of the 3 nodes and it’s still the same. So if the password set is ADMIN by default and is not working, can i safely change it with the ipmitool command ? Thx for your answers :)
Hello guys, Is it possible to add Dell PowerEdge R640 or R730 hardware to a cluster with NX hardware?
You have the option of adding a Witness to a Metro Availability configuration (see Data Protection Guidelines (Metro Availability)). A "Witness" is a special VM that monitors the Metro Availability configuration health. The Witness resides in a separate failure domain to provide an outside view that can distinguish a site failure from a network interruption between the Metro Availability sites. The goal of the Witness is to automate failovers in case of site failures or inter-site network failures. The main functions of a Witness include: Making a failover decision in the event of a site or inter-site network failure. Avoiding a split brain condition where the same storage container is active on both sites due to (for example) a WAN failure. Handling situations where a single storage or network domain fails. Metro Availability Failure Process (no Witness)In the event of either a primary site failure (the site where the Metro storage container is currently active) or the link betwee
With the new release of Objects (Objects) 2.2, now you can assign a quota policy to a user which enables Objects to set soft thresholds on the number of buckets created by the user within an object store.Release notes - https://portal.nutanix.com/page/documents/details/?targetId=Release-Notes-Objects-v2_2%3Av22-whats-new-r.htmlDocumented steps -https://portal.nutanix.com/page/documents/details?targetId=Objects-v2_2:v22-assign-quota-policy-t.htmlIf you want to know more about Objectshttps://portal.nutanix.com/page/documents/details?targetId=Objects-v2_0:Objects-v2_0ENABLING OBJECTS https://portal.nutanix.com/page/documents/details?targetId=Objects-v2_0:v20-enable-objects-t.html#ntask_t1y_mzc_4hb
Citrix Diagnostic Facility (CDF)CDF collects and traces the messages generated by various Citrix services running on the Delivery Controller. CDF helps discover and debug the root cause and related issues. Configure and Use CDFDownload the tool in a ZIP file from: http://support.citrix.com/article/CTX111961 Extract the ZIP file and run the extracted CDFControl.exe file. Go to Tools > Options and ensure that Enable real-time viewing while capturing trace is selected. This allows you to view the real time logs while the scripts run. Go to Tools → Options → Trace File Path and set the path for log collection. Check the following modules to enable plugin specific log collection. BrokerHostingManagementBrokerHostingPluginHostServiceHCLHostServiceLogHostServiceLoggingHostSnapInMachineCreationLogMachineCreationLoggingMachineCreationServiceHCLMachineCreationSnapIn Before running the script, click Start Tracing. It will start capturing the traces while PoSH script executes.Once you encounter
As the title stated, I have tried to get around this by searching some docs on Portal but couldn’t find any related to. Could someone provide me any way to identify exactly the info of the M2 drives in a G7-model standalone node?
Does anyone have issues when trying to install NGT on a system that previously had it installed? I have tried to uninstall and reinstall to no avail. And trying to install/Upgrade via prism fails.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.