This forum is the best way to get up and running with the Nutanix platform
Recently active
As per previous posters - is NGT supported on Debian 10 yet? Is there a page that lists the current supported guest operating systems?
The Objects browser is a User Interface (UI) that allows the users to directly launch the object store instance in a web browser and perform bucket and object level operations. This eliminates the steps of logging into Prism Central and launching the Objects service. The administrators use Prism Central to manage the object stores. When an administrator creates an object store, a default bucket (object browser) gets created. The static website hosting capability is already enabled on this default bucket. The Objects Browser UI is hosted on this default bucket is created The administrator can share the object store URL with the user to access the Objects Browser UI. The URL can be formed using the Objects Public IP addresshttp://objects-public-ipaddress/objectsbrowserYou can use http or https to access the web-browser Administrator workflow:The administrator needs to perform the following steps to grant access to the Objects Browser to a particular set.To grant access to Objects Brows
https://www.nutanix.dev/reference/prism_central/v3/api/vms/postvmsuuidmigratedisks/ describes an API to migrate disks as vms/{uuid}/migrate_disks. But the API is not available in AOS 6.0. I got the following response{ "message": "The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again." } The swagger definition from the cluster does not contain the endpoint either even thought the definition “migrate_disk_input” is defined. The cluster has the following information: "config": { "software_map": { "NOS": { "status": "INSTALLED", "version": "6.0", "software_type": "NOS" } }, ... "build": { "commit_id": "e13b03b321a1559f5de846520509a20f93289b8d", "full_version": "el7.3-release-fraser-6.0-stable-e13b03b321a1559f5de84652
About this taskTo track and record networking statistics for a cluster, the cluster requires information about the first-hop network switches and the switch ports being used. Switch port discovery is supported with switches that are RFC 2674 compliant. Switch port discovery involves obtaining statistics from the Q-BRIDGE-MIB on the switch and then identifying the MAC address that corresponds to the host. Such discovery is currently best-effort, so it is possible that, at times, an interface might not be discovered.Before you beginBefore you configure network switch information in the Prism web console, configure the corresponding SNMP settings on the first-hop network switch.About this taskTo configure one or more network switches for statistics collection, do the following:Procedure Click the gear icon in the main menu and then select Network Switch in the Settings page.Note: Network switch configuration is supported only for AHV clusters.The Network Switch Configuration dialog box ap
Hello,I´m new in this forum. In fact I´m new in the Nutanix world. We currently have a traditional VMWARE cluster with traditional FC SAN Storage and Catalyst 3850 switches (7 servers).We are planning to replace it with a brand new solution based on NUTANIX (with 6 nodes or so) but using VMWARE as hypervisor. The question that arise are:We need to install 2 new “top of the rack” switches for NUTANIX connections. If using Cisco (and taking into account our proposed cluster size) which one could we use ? I mean, Catalyst 9300 are ok ? Or they have to be the more expensive Nexus ? To reduce initial costs we are planning to keep the Cat 3850 to act as coreswitch and also because we need to conect other devices, but we need to ones for the new nodes. Our current VMWARE Servers have 2 x 10G connection for DATA/VEEAM BK and 2 x 1G for vSphere MGMT/vMotion. In order to cope with data traffic but also with “disk sinc” traffic, should we provide the new nodes with 4 x 10G (2 for DATA/veeam BK
hello all i am in this tight situation. as i have AOS PRO license i only can do is Async replication but i really need to make the RPO 0 so, i am thinking to leverage application level replication. for example in exchange application I want to leverage DAG replication method to be able to sync both main and DR site with RPO=0so my question if i do this configuration and take out my exchange server from any protection domain, do you think Nutanix would still give me support if the replication process have a fault after time?
I have AHV 5.11 cluster, i configured br1 with CVM eth2 interface attached and followed all the instructions via cli to configure CVM multihoming to segregate 1g and 10g network. My issues is inspite of attaching cvm eth2 interface to br1, i am not able to access cvm eth2 via br1 network but i can access it via br0.
Hi all,I’m trying to use terraform to create VMs on our Nutanix cluster and I’ve encountered issues when trying to define the project name i’m trying to assign the new VM to.I have created a variable that contains the project name and set the project_reference on the machine to point to that variable.When running terraform plan everything seems to be working as expected but when i apply the terraform, the terraform crashes with the following error:│ Error: Plugin did not respond││ with nutanix_virtual_machine.tf-build-project-test[0],│ on main.tf line 75, in resource "nutanix_virtual_machine" "tf-build-project-test":│ 75: resource "nutanix_virtual_machine" "tf-build-project-test" {││ The plugin encountered an error, and failed to respond to the plugin.(*GRPCProvider).ApplyResourceChange call. The plugin logs may contain more details.╵Stack trace from the terraform-provider-nutanix_v1.2.0.exe plugin:panic: interface conversion: interface {} is nil, not string Has anyone encountere
We have a lab setup with 3 Nutanix nodes in one cluster with model NX-1175S-G6, this Servers have a 2x10GbE ports on each and we have a network switch which is unfortunately Gigabit Ethernet switch DGS-1210-52MP (does not have any 10 GbE switch available right now) for our lab setup. and I want to bridge successfully an active-active bond and LAG,LACP will be enabled and configured on the switch . and I want to make sure the speed is negotiated and to able to work with 1 GbE. Also has a need a no more massage from ncc check “CVM is not uplinked to any 10Gbps nics on bridge/vSwitch br0”. So any expert advice will be taken seriously. Thanns in advance for your suggestions.
AHV supports GPU-accelerated computing for guest VMs. You can configure either GPU pass-through or a virtual GPU. Let us say you have an AHV host with GPU compatible hardware and looking for a simple way to install the required drivers. Nutanix recommends a specific method for installing the Nvidia GPU host driver in AHV hosts. The method involves a script which is used for installation or upgrade of all the hosts in the cluster. Go through the following document to understand the process in-depth Installing AHV GPU Drivers Have questions regarding the usage of the script? What will happen if one of the nodes doesn’t have a GPU? What will happen if the driver version is different on one node than the rest of the cluster? How can I install the driver onto the new nodes only, without affecting the currently running nodes? Can I install different versions of the driver onto different nodes of the cluster? The following knowledge base article can help you to
Hi All, I’m sorry if asking questions on group. I have new deployment with HPE DX360 via foundation portable 5.0.1 and flat switch but somehow it run into error and error message prompted during installation via foundation which im not so sure why. Im using foundation 5.01 and upload with aos 5.20. The foundation error log stuck here after sometime;StandardError: Failed to connect to Phoenix at 192.168.100.32021-06-28 06:10:50,703Z ERROR Exception in running <ImagingStepInitIPMI(<NodeConfig(192.168.100.3) @2190>) @8fb0>Traceback (most recent call last): File "foundation\imaging_step.py", line 161, in _run File "foundation\decorators.py", line 77, in wrap_method File "foundation\imaging_step_init_ipmi.py", line 273, in run File "foundation\imaging_step_init_ipmi.py", line 184, in boot_phoenixStandardError: Failed to connect to Phoenix at 192.168.100.32021-06-28 06:10:50,706Z DEBUG Setting state of <ImagingStepInitIPMI(<NodeConfig(192.168.100.3) @2190>) @8fb0>
Hi I’m new to nutanix with ESXi. I recently deployed a 4 nodes nutanix with esxi. I’ve created containers and add the nodes to the vCenter. I have not add the vCenter to the Prism. I check at prism and there’s a warning saying the hosts are not connected to vCenter. Anyone encounter this issue before?
Just a quick question about sizing SSD capacity to HDD capacity in a node (in a new homogenous cluster). When specifying drive space in a node, what is the percentage SSD to HDD per node at a minimum. Is there a best practice guide that someone can point me towards? I’m not asking about the number of HDDs vs the number of SSDs.The question is around capacity and not number or drives. e.g. I configure a node with 4TB of SSD (2x1.92TB) and 60TB of HDD (10 x 6TB) and Nutanix Sizer says this is fine. This is roughly 6.25% SSD But what should I have as a minimum SSD capacity of of a hybrid node is 6% Okay, or should it be more like 10% or 20% (or more)?
We get some questions from customer. Our customer have several Nutanix units with several models including:NX-1365-G4 NX-1365-G5 NX-8235-G4 NX-6235-G4 NX-8135-G4The question is whether HDD can be replaced with SSD? What is the procedure and what about the data on the HDD? Thanks
We are in the Process of expanding our 4 Node Cluster to 6 Nodes. The Installation of the Hosts was successful using the Foundation VM. However, the servers have Nvidia cards installed, so we need to install the driver as well. When the Cluster is expanded with the 2 extra nodes, my understanding of the command “install_host_package” is, that it will install the drivers on all hosts, that have Nvidia cards. Even those, that already have the driver. To do so it will migrate the VMs and put the Hosts into maintenance. This is not an option for us, since the reason we are expanding the cluster is that the current cluster already is overloaded. I am looking for a way to install the drivers without interfering with the up and running environment. For example, is there a way to install the drivers before expanding the cluster?
I have the latest version of Nutanix ERA installed in my lab and already have a registered Oracle server. From that server the template created without any problems and i can create new servers. But when i want to clone que existent server always fails wit: Driver execution failed. Error: 'NoneType' object is not iterable. Any ideas
Objects version upgrades by using LCM feature. You can perform LCM upgrades through Prism Central (PC). Objects is a part of the PC upgrades module in LCM. LCM upgrades the following components of Objects: Objects Manager and Objects Services.Objects ManagerObjects Manager is a containerized service running on a PC VM. The objects manager is primarily responsible for taking input from a user for deploying the object store, validating the user inputs, managing certificates, deploying the Objects Services and serves as an interface between PC and backing object store. A single Objects Manager can manage one or more object stores. In case of scale-out PC, the Objects Manager service runs on each of the PC nodes and provides high availability.During the upgrade of the Objects Manager, no disruption happens to the Objects IO. However, the user interface will not be available for a short period of time for statistics and management.Objects ServiceObjects Service provides the object store int
Era is a database as a service (DBaaS) that automates and simplifies database administration, bringing one-click simplicity and invisible operations to database provisioning and life cycle management.Era enables database administrators to perform operations such as database registration, provisioning, cloning, patching, restore and much more. It allows administrators to define standards for their database provisioning needs with end-state driven functionality that includes High Availability (HA) database deployments.Era allows multi-cluster database management. Database administration for different databases across multiple Nutanix clusters can be performed with a single Era instance. With the extension of support for Nutanix clusters, you can now use all the capabilities of Era on Nutanix clusters (both cloud and on-prem).Procedure: In the dropdown list of the main menu, select Databases. Go to Sources, select all the databases and click Remove to remove all the databases from Era. Cl
I am planning to upgrade my vcenter server appliance from 7.0 U1C to 7.0 U2b, as far as i know Nutanix only validate Esxi releases with respect to its AOS, can any one advise if i can upgrade the appliance?
What will be total usable space for the hypervisor and best practice to allocate the storage.I have three new Nutanix nodes. Physical capacity of Cluster is 79.04 TB and Free logical is 39.52 TB in RF2.
HI all, I'm preparing a change on the cluster (6 node cluster running AHV). I need to re-ip cvm's and ahv's and add them to a specific vlan (now they are not in a vlan). Before I do this in production I decided to do this on the test lab. (old baby, 4 node G5). I've followed this guide: https://next.nutanix.com/installation-configuration-23/physical-relocation-of-nutanix-clusters-38403 but got stuck step 7 after booting the cvm's. The ouput of svmips shows the old cvm ip's but they are all booted with the new ones. (and accessible via ssh on the new ip's)The output of hostips shows the old ahv ip's byt the are all booted with the new ones. (and accassible via ssh on the new ip's). I must also say that the external_ip_reconfig script hangs at a specific time and now the command “cluster start” gives an error the the cluster is still in reconfigure mode. Anyone here who has the golden tip to get the command svmips and hostips to show the correct ip's? (zk_server_config_file also had the
I have AHV cluster configured 5.5 with multi homing and now i want to add new node to existing cluster. What is the right procedure.
Hello, I am trying to deploy Nutanix CE on a Dell T7600. It is working fine when using AHV as hypervisor. But when using ESXi, i am not able to mount containers.I receive error message : There was an error while mounting the datastore for storage container 'default-container-11071639353873'In vmkernel.log i can see : 2021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)World: 12556: VC opID 738348c2 maps to vmkernel opID 7bd903772021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)NFS: 162: Command: (mount) Server: (192.168.5.2) IP: (192.168.5.2) Path: (/default-container-11071639353873) Label: (default-container-11071639353873) Options: (None)2021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)StorageApdHandler: 960: APD Handle 732ec6b0-3763e7bf Created with lock[StorageApd-0x4316fd802900]2021-06-22T14:36:46.849Z cpu17:2099496 opID=7bd90377)SunRPC: 1095: Destroying world 0x201ac22021-06-22T14:36:46.849Z cpu17:2099496 opID=7bd90377)SunRPC: 1095: Destroying world 0x201ac32021-06-22T14:
Hi I have problem after fresh install Nutanix CE.Dont have acces to CVM console and Prism from outside. SSH from hypervisor work good But from other machine have time-out error Install on Vmware ESXI 7 on Dell server Cluster works fine EDIT: use version ce-2020.09.16.isoon PC in Workstation PRO work fine but on ESXI have same problem
Hey guys,I’m getting an error regarding email alerts, this is what I can observer on the send-email.log2021-06-17 07:37:03,407Z INFO send-email:242 Not sending emails for first 1 hours of cluster creation. Cluster Age = -16009102.3605 secs 2021-06-17 07:38:03,611Z INFO send-email:242 Not sending emails for first 1 hours of cluster creation. Cluster Age = -16009042.1568 secsCluster was online for 2months already, I tried already to stop and start the cluster but that sec timer is set to around 6 months.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.