This forum is the best way to get up and running with the Nutanix platform
Recently active
I want to ask about how to give a user limited resources within the cluster. For example, user A can create VMs until he reaches 5 CPU, 4 memory, and 40 GB disk.Thanks in advance.
Hello I am looking for guidance regarding setting up a 3-node and 2 node AHV cluster on 1G switches . Our workloads are low. The official response is to use a 10G switch fabric. If I opt for 2 node, can I connect the servers back to back for distributed storage ? Can data network go over 1G ? I plan to procure 2 servers with 2x 10G for distributed storage , 2x 1G NICs for data Thanks,Ajay
As Nutanix recommended connectivity is 10G but due to some ports availability issue we initially configured Nutanix cluster with 1G but now we are planning to change our Nutanix environment uplink to 10G, any advise will there be any impact or can you share the procedure to change uplinks to 10G.
I have a situation where my production cluster is a lease with $1 buyout from a service provider who is license the cluster and the term is up this fall. We have AOS and Frame license as a service and provided by the them. In planning to take over ownership, I am needing to continue the license on this cluster and the Frame license. I am having a hard time finding instructions from any of the current Nutanix Sales team because the current hardware is still under the leasing contract and it seems like we cannot get a quote/plan to apply a new license on this cluster. We are always directed to purchase a new cluster with new licensing. We are force to look a new cluster so our team is now open to new technology outside Nutanix. The easy answer seems to elude. Does anyone have any direction contact or advise to try to get the inventory ownership transferred and get new license applied without effecting Frames on the AHV cluster? I cannot I have emails going back since last year try
I configured domain protections between my primary and secondary site.domain protections are configured by VMs which means that I have as many domain protections as VMs.After the first replications, I would like to make sure that the size of my VM on the primary site is identical on the secondary site but I find that this is not the case.I don't know if I'm doing a good interpretation.Attached is the capture of my VM on the primary site before replication and on the secondary after replication.Please help me with your explanations.
How i update the nutanix VirtualIO driver on RHEL 7.9 VM ?I have a strange situation: vm configuration is set to 16 GB ram but OS see only 11 GB ram
Is there an ETA for when NGT will add Rocky Linux support? This Reddit thread from August 2021 is the only reference I could find online suggesting that Rocky NGT support was being worked on. The NGT compatibility matrix lists Rocky as one of the OS vendors, but there are no approved OS yet. Alma Linux (the other RHEL clone project) is already listed in the compatibility matrix, so I assume the delay in adding Rocky is not a technical one. Here’s what happens if I try to install NGT on a Rocky VM:rootin nutanixngt/installer/linux via 🐍 v3.6.8 ➜ ./setup_python.sh -hPlatform type is: x86_64Unsupported distribution : rocky linuxERROR: Failed to install Nutanix Guest Tools. Check /tmp/ngt_install_log_20230707123201.txt for logs.➜ cat /tmp/ngt_install_log_20230707123201.txt[2023-07-07 12:32:03] {installer_factory.py:52} ERROR - Unsupported distribution : rocky linux
I’m trying to install NGT on CentOS 9 running on AHV and followed these instructions https://next.nutanix.com/installation-configuration-23/error-installing-ngt-on-linux-vm-41358 and I get a failure without much detail in output and logs too.$ sudo python /ngt/installer/linux/install_ngt.pyPlatform type is: x86_64Using Linux Installer for centos stream linux distribution.Setting up folders...Installing NGT Guest Agent...Setting up Nutanix Guest Tools - VM mobility drivers.Successfully set up Nutanix Guest Tools - VM mobility drivers.Installing Nutanix Guest Agent Service.Failed to install Nutanix Guest Tools.ERROR: Failed to install Nutanix Guest Tools. Check /tmp/ngt_install_log_20230627142527.txt for logs.$ sudo cat /tmp/ngt_install_log_20230627142527.txt[2023-06-27 14:25:31] {installer_factory.py:57} INFO - Using Linux Installer for centos stream linux distribution.[2023-06-27 14:25:34] {install_ngt_core.py:86} INFO - Setting up folders...[2023-06-27 14:25:34] {install_ngt_core.py:
hello, I have a Nutanix cluster with 4 nodes and AHV running in my environment, but due to another project we will configure a new cluster with 4 nodes and AHV in the same network but for another purpose, I had a question, can I use the same CVM vlan of the existing cluster for the new cluster?
Hello Team,Is it possible to transform a full-flash cluster to an hybrid one without losing data? (third party platform).Licenses should not be upgraded because SSD space would not change but the necessary SAS disks would be added to add extra cold data space
I would like to ask for some help on identifying why I receive below error prior to installing Nutanix Community Edition on a HPE Gen9 Server. We want to install Nutanix Community v2.0 for some LAB testing on a single 1U server.Steps we have taken for the install.1. I have created a bootable disk on a USB with version: phoenix-ce2.0-fraser-6.5.2-stable-fnd-5.3.4-x86_642. After boot all looks OK and we are configuring the disks as below: Attached is "Disk_config.PNG" - This is what we have as a Disk. Only C is SSD. The 16GB is the Install Media.3. I accept the EULA and scroll to the bottom4. Here is where the issue appears. We receive an ERROR Please supply 'Serial Number'. I have checked in NEXT and online but no luck..5. When I hit Enter it goes back to EULA.I was able to install the same way when I do it on ESXI, but on bare metal it looks like we are failing some king of S/N check..
I’m testing Nutanix on an old server (1065-G5 generation). The connection between Prism and vCenter is registered, but not established. I’m using AOS 5.20.4, ESX 7.0.3, NCC 4.5.0.2. The port 80 is opened and redirected to HTTPS. What could be the cause?
I’m developing Ansible playbooks to deploy Linux and WIndows servers from disk images and using cloud-init (already working) and sysprep (forthcoming, I’m not a Windows specialist)The NGT Tools are pre-installed in images.The problem is that new VMs show NGT : “Not Installed” in Prism.Is there something else to do ?Thx
Hi AllHavoc struck this morning when I tried to move my AHV cluster from old switch stack to new switch stack - the hosts, I think went into panic mode and started to restart various VMs.The background to this is: I have 2 x Dell X4012 core switches and 2 x Dell N3024 ToR switches, currently due to moving VMware environment to Nutanix only 1 x X4012 is connected to NIC 1 on each of the 3 hosts. From the X4012 there is a cross connect into the old VMware network Core blade switches (Dell 8024 x 2) which are connected to the old ToR N3048 switch stack, these are then connected to the router for VPLS and DMZ. So to move the connectivity, I thought I could add the second NICs of the hosts to the second X4012 and disconect the crossconnect and the first NICs thus using the newer switches, albeit on the opposite NICs. I planned to reconfigure and update the first X4012 and add back into the stack with a LAG to the N3024 stack and no crossconnect. I moved the NIC connections and lost all
Hello,We used compression and deduplication for a while but now it is not necessary.I disabled these functions in the storage settings but the cluster is still showing the dedup space savings with no changes. This is after a week or so of turning dedupe off.I can’t find any documentation around disabling dedupe and what is required to ‘unoptimize’ the data.I’m using AOS 5:15.5.1 LTS and this is an old NX-1050 3 node system.TIA
I just created a new cluster but there is no default virtual switch created (vs0).Is this something expected ? Ventura
Hi All,We currently have an 1 Block, 3-node cluster (NX-1065-G5) with approximately 50 VMs on it. It is approaching end of life, and we are replacing it with another 1 Block, 3-node unit (NX-1065N-G8). At end-state all of the VMs will be on the new hardware, and the old hardware will be powered down.Would we be better to…Build the new unit as a brand new cluster, and move all the VMs to it using Nutanix Move. Expand the existing cluster by adding the new hardware to it, and then remove the old hardware from the cluster. Has anyone gone through either of these processes?Thank you for your suggestions.Marlon M.
Hello thereI am new for nutanix.I want to enable foundation service in a cvm. That cvm is not in any cluster.How can i do that?
Can someone let me know how I restart the upgrade on the failed host? I cannot seem to find any restart/retry button.The host failed to go into maintenance mode and now upgrade says aborted on this one host.I have fixed the cause of maintenance mode now so it will be fine.
Dears:We have a 3 node pure NVME SSD clusters with RF 2. Now we plan to expand more 5 nodes and change the RF from 2 to 3. We have a little worried about the performance on :(1). During conversion phase from 2 copies to 3 copies.(2). For BAU usage, if RF3 performance will slower than RF2 because every write need do 3 times compared of 2 times. I got the question 1 answer from Nutanix Resiliency – Part 2 – Converting from RF2 to RF3 | CloudXC (joshodgers.com) and want to see any more experience. For question 2, any experiences could be shared? Thank you very much! P.S. We have enabled compression feature.
I have figured out that the version of the kernel is 4.19.100. I have also figured out that this version is not working with my NUC11 and the i225-V NIC. I would like to replace that kernel with the 5.15 kernel as the 5.15 kernel works with the i225-V NIC. Does anyone have a procedure on how to replace the kernel in the ISO? Any help would be greatly appreciated. Thanks,Steve
I have a used NX-3060-G5, with 4 nodesI am trying to install the new CE 2.0 on itEach node is configured with the e5-2650v4 x24x32 sticks of ramBMC version 3.94BIOS Version G4G5t8.0They all have the same 64gb statadoma 512GB SSD and a 1TB HDDI had used nodes a and b as test nodes orginally, then i tried to reinstall the new CE 2.0 on them and i keep getting failures at 2402/2430 hypervisor installation in progress with the read out to please take a look at the installer_vm_*.log inside foundation logs to debug hypervisor installation, then it restarts the install process and repeats. 2 of the nodes this installed on just fine, but they were not a reinstall of CE, they had vmware running on them previously.I have tried installing the latest supermicro bios and get the same issue, i have screenshots of the logs that i could find. Not sure if i can post them on here. Just seeing if anyone may be able to assist or point me in the right direction to find out why this keeps failing when al
Hello everyone,I have to install the first Nutanix cluster from a customer but I can't figure out how to setup the network.All customer switches (Aruba 2930, 2920) have the native vLAN (vLan1) dedicated to workstations and servers, while the management network is vLan ID 10 where the ESX, storage controllers, backup NAS and the Veeam server backing up the current infrastructure.This is the situation of all my customers, vLAN10 is completely isolated and unreachable from the native vLAN1, this was done to prevent any ransomware from affecting the backups as well.Now, Nutanix recommends configuring the CVM and hypervisor host VLAN as the native, or untagged, VLAN on the connected switch ports.I'm sure it would be nice to have all of the management in the native, adding a node would be much easier and I think the simpler things are kept the better.Furthermore, vLAN10 is propagated on many remote racks because obviously the backup NAS do not reside in the same racks as the servers, how can
In VMware, there’s the option to automatically power on VMs as the cluster is started. Is there such an option in Prism or do you have to rely on a script?
Hi, I’m new to Nutanix, coming from the vSphere world.I am working on getting our new Nutanix infrastructure set up to run Qualys scans for security. I have been looking at the following document:https://portal.nutanix.com/page/documents/kbs/details?targetId=kA07V000000LXYqSAOI am getting stuck at determining which accounts to use to set up authentication, so that Qualys can run its scans on the Hypervisors, CVMs, and Prism Central appliances. My research shows that adding new accounts via the OS to these components is not supported. Does that mean that Qualys then has to log in as root, nutanix, and admin respectively, to scan these components? Or am I looking in the wrong place for the Qualys account to be set up, to scan for vulnerabilities and compliance? I feel like I'm missing something here. Thanks!
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.