Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hello I have a cluster with 3 nodes and AOS 5.10.10 and need upgrade to 5.15 but the nodes not have access to Internet. I upload the AOS 5.15 and show me in the Prism Console the versionm but not permit run the upgrade to new version. Need to know if is possible run the upgrade directly through cli to update the cluster. Thanks for your comments
Did you know you can secure your IMPI Web Interface with an SSL Certificate? Securing the IPMI Web interface is recommended to help reduce susceptibility to attacks. You can further enhance security by installing your own customized certificate or a CA-signed certificate. Nutanix recommends strong keys and signature algorithms. The IPMI module supports SHA2 and RSA 2048 bit SSL. Avoid long certificate chains or large certificates. If the IPMI module shows the default or previously-installed certificate after you install a new one, or you are unable to log in to the IPMI web interface, the chain is too long (chain length longer than one) or certificate too large. As a test, create a simple self-signed certificate and install it to ensure the IPMI is working correctly before attempting to install larger certificates. You can use openssl or keytool to generate keys, certificates, and signing requests. Similarly to any other certificate deployment, the process consists of two steps
Hello good afternoon, I have a Nodes with black screen and blinking cursor, I want to see if there is a way to reset it or to show me the normal console again. If someone can help me, I really appreciate it, I already tried to generate the Phoenix iso and boot it in ubs and connect it to the node and start but send: udhcpc sending discover Thank you for your cooperation
Hi team, it’s a question about architecture : ROBO Site customer has two rooms (another one for the witness is possible) customers would like a node in each room hypervisor : ESXi According to the docs, there's no reason not to do it ? is this architecture supported or not, and better is there somewhere a documentation about this design ? Many thank for your help.
You may get an alert from NCC stating that the deduplication fingerprinting has been disabled, but it is enabled on a container: WARN: Fingerprinting is disabled by stargate, but configured on Storage Container(s) As we know, Stargate is the service that is managing storage on a Nutanix cluster, so Stargate has some conditions on which it will automatically disable deduplication. If the metadata usage is higher than 250Gb on a node. If the metadata usage is higher than 50% of the total metadata space on a node. The second condition is common on small size clusters, for example NX-1000 series, with single-SSD nodes if the SSD size is small. The metadata is located on the SSDs and the total metadata size on the node is equal to the capacity of: One SSD in single-SSD nodes Two SSDs in double-SSD nodes Four SSDs in all-flash nodes So, for example, if you have a node with 1 SSD which is 480Gb in size, 50% of the metadata capacity will be 240Gb (in fact it will b
How long does LVM inventory take? We have a 7 node cluster and it takes a very very long time to inventory. There are 202 tasks. It started an hour and 20 minutes ago and its only on task 63 out of 202. Is this normal? We are running LCM 2.3.1.3.18618.
You are trying to expand a new node into the cluster. I am trying to expand after installing ahv,aos(not cluster settiong option) as a foundation on a new node. When do I set the existing cluster ovs settings? Or I am wondering if the setting is automatically entered upon expansion.
Below are new knowledge base articles published on the week of July 5-11, 2020. KB 8935 - NCC Health Check: recovery_point_limit_exceeding_check KB 9479 - Deprecation of manual multihoming CVM network configuration KB 9621 - Xi Leap - After failover on Xi, floating IP is not getting assigned to the VM KB 9626 - AHV | Common VM NIC management workflows KB 9628 - AHV | Windows VM running in UEFI mode with SATA disk may fail to boot after disk expansion KB 9632 - 3rd party backup restore jobs can fail having INTERNAL ERROR: ErrorCode: 4 in AOS 5.15.1 KB 9640 - AHV | Cluster memory usage graphs may show different numbers if "HA Reservation" option is enabled Note: You may need to log in to the Support Portal to view some of there articles.
In Nutanix nodes, there are SSD disks and SATA disks. Can we create two separate datastores. One datastore only contains SSD disks and one datastore only contains SATA disks
Does anybody encountered this kind of error? when migrating ESXI to AOS. After how many hours of seeding, It show this error. However it is ready to cutover, but doesn’t want to proceed further because of this error. I already checked this VM in EsXi, it already have a VMware tools installed. Hope i can get ideas and recommendations from you guys. Thanks!
The default name of the CVM is in the below format: NTNX-<Block serial number>-<Node position>-CVM This is what you see as the CVM name in the PRISM. If you want to change the CVM name in your AHV cluster, then we have a script for changing this with the following limitations. nutanix@cvm:~$ change_cvm_display_name --cvm_ip=<IP of CVM that should be renamed> --cvm_name=<new name> The script is available in AOS - 5.10.10, 5.15 and 5.16. The naming convention needs to start with “NTNX-” and end with “-CVM”, Letters, numbers and “-” are supported in the CVM name, CVM should be able to get a shutdown token to be turned off, There will be no redirection of storage traffic to other CVMs, so make sure you have no user vms running in the AHV host - put the AHV host into maintenance mode, Run the script from a different CVM than the CVM that is being re-named and make sure the SSH session is intact until the re-named CVM comes up. For more
Prism Central is a centralized management tool that runs as a separate instance comprised of either a single VM or a set of VMs. This multi-cluster view, allows you to monitor and manage multiple clusters through a single web console. If you would like to deploy a Prism Central instance, you can either follow the 1-Click method or the manual method. Do you have a Prism Central(PC) instance deployed in your environment and are planning to upgrade it? Here is the second installation of the Upgrade Series as promised to provide you quick tips and tricks to plan and execute your upgrade activities with ease. Prism Central Guide for the latest version (as of 10th of July, 2020) can be found here. To check for the release notes or Guide, navigate to Nutanix Support Portal > Menu> Documentation > Prism and filter out the PC version from the top right section of the dropdown. Note: PC upgrades is necessarily just a reboot activity on the Prism Central Virtual Machine(s)
Has anyone implemented Windows Defender ATP in a Nutanix environment? If so, I'd love to talk about your experience.
Starting from AOS 5.10.2 and newer, if you run the ‘cluster status’ command, you may see that there is a new service running on the cluster called Xtrim. That service was not present before 5.10.2: Xtrim is the service that is going to improve the performance of the cluster. If we look a bit deeper, it improves the write performance by periodically trimming the SSDs. In Nutanix all the disks are passed-through from the host to the CVM and the CVM is managing the disks, so the Xtrim service running on CVMs is doing the trimming of the physical SSDs. So, what is trim? TRIM is a command with the help of which the operating system can tell the solid state drive (SSD) which data blocks are no longer needed and can be deleted, or are marked as free for rewriting. In other words, TRIM is a command that helps the operating system know precisely where the data that you want to move or delete is stored. That way, the solid state drive can access only the blocks holding the data. Further
Hello community, Maybe one of you can assist me for a report of cluster usage. I need a report which gives me the usage of all VMs in a cluster. But I need this information for every VM separated. In the analysis page I can only create a chart for on VM and with over 600 VM this take a long time... I need for a time span of the last 3 month the following information of the VMs IOPS (min,max, avg) RAM (min,max,avg) CPU (min,max,avg) Is it possible with the analysis page or with an cli command ?
I’m about to upgrade vcenter from 6.7 u1 to 6.7 u3. I’m only upgrading the vCenter for now. My AOS version 5.10.8.1 To upgrade only vVenter is there any action to take in PRISM? Will there be any impact on PRISM? Thanks
Quick tip of the day. Did you know that you can integrate IPMI with the Active Directory? Note: The default timeout is set at 0, which results in an error message HTTP 500 - Internal Server Error. Make sure to update it to 10. Select the User and then select Add Role Group to configure the Role Group. (Be sure that it matches an existing AD group name.) When logging into the IPMI web console, use the following format to log in: username@domain. Should you find yourself with a task too big to be handled manually such as configuring the same but on a miriad of nodes there is some help available. SMCIPMITool is a utility by SuperMicro. You can create a script to go through all your nodes’ IPMI interfaces and join them to the AD. For a complete set of steps see KB-2860 How to configure IPMI Active Directory Authentication for Supermicro platforms. For commands list and use cases see SMCIPMITool User’s Guide.
Companies merge, hosts are inherited and repurposed, administrators come and go and not necessarily leave things in order after themselves. Or what if you forgot the password and the record of it is not recoverable? Where there’s a will, there’s a way. I touched the other day on how ipmitool can be accessed from a CVM CLI but would require authentication details to pass on to the IPMI. Well, the host or rather the hypervisor installed on the host does not have to do so. Hence even when ADMIN account password (or any other account with full privileges) is lost the IPMI is still accessible from the hypervisor CLI and you can still reset the password, set up new user entirely, or set a new password for a user. The process consists of several steps: Log in to the hypervisor on the host (AHV or ESXi). List user records using ipmitool. Take note of the user ID. Set the password for the user ID. The task is complete. Conveniently, commands syntax between AHV and ESXi differs only in the
Quick tip for a hump day. Rushing in to check something quickly on the IMPI. Can’t be bothered with the Web interface. Jumping into a CVM CLI only to find out that the ipmitool isn’t working and the error isn’t helpful. Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directoryGet Device ID command failedUnable to open SDR for reading Good news is the IPMI is most likely fine. Chances are all you need to do is to use a few extra keys as part of the ipmitool command. Remember that for all calls executed from a CMV the ipmitool has to authenticate with the IPMI and the calls are traversing the network technically even if it is only a virtual switch. KB-1345 Using ipmitool on the CVM gives full command syntaxis and is rich with examples. For Dell hardware refer to KB-6007 [ipmi] Could not open device at /dev/ipmi0 on Dell hardware. If you are a proud owner of AHV host there is an extra option available for you which is to check the ipmitool service
Hi All I have created a MS server 2016 VM with a view to using it as a desktop , however it does not seem to have away to add anaudio / soundcard device - is there a way to add one in Nutanix? I have found a way in VMware but not Nutanix. Any ideas? Thanks Eric
Hi Team,I am trying to export cluster info with the below code which I got from the internet (do not remember where I got this). but the below script runs fine and able to export the data required except for Cluster name and its IP address.As per my understanding it is able to export only the content of “NTNXHost” but not the content of “NTNXClusterInfo” and “NTNXVM”$report = @()$NTNXHost = Get-NTNXHost | Select-Object name,hypervisorAddress,clusterUuid,serviceVMId,serviceVMExternalIP,ipmiAddress,serial,blockSerial,blockModel,blockModelName,cpuModel,numCpuCores,numCpuThreads,numCpuSockets,cpuFrequencyInHz,cpuCapacityInHz,memoryCapacityInBytes,hypervisorFullName,hypervisorType$report+=$NTNXHost$NTNXClusterInfo = Get-NTNXClusterInfo | Select-Object name,clusterExternalIPAddress$report+=$NTNXClusterInfo$report += "`r`n"$NTNXVM = Get-NTNXVM -SearchString "VM is a Nutanix CVM" | ft vmname,ipAddresses$report+=$NTNXVM$report | Export-Csv -Path C:\temp\ClusterInfo.csv -NoTypeInformation -UseC
Hi Expert, I would like to seek your assistance with regards to the capacity planning for Nutanix. Our prism cluster is not license so we can’t use the built in capacity planning tool. Is there any other way where i can get the historical value of CPU, memory and disk per AHV cluster? I’m a little bit new in Nutnix so I’m still curving up my skills. TIA
Wandering if someone could point me in the right direction as I am not overally familiar with SUSE. I am replicating from ESX to AVH and have installed NGT. The guest fires in AVH but I have no GUI - it errors that there are no drivers for X. Unfortunately it is stuck in my DR segment for which I only have the Nutanix Console access to at the moment, bets I have is: Just wandering if anyone had any experience with SUSE / AHV and could point me in the right direction? If I run startx from the console I get no screens found: Any assistance appreciated.
Hi I m working to automate the planned failover of protection domain. We are very familiar with powershell and so I m wondering what is the cmdlet to retrieve the status of protection domain (Enabled- in sync, disabled , pending ...) ? I searched on the documentation but i didn’t find it Thanks
Playing around with an old NX-2000 series server and it seems I need to make my 10GbE nics default to eth now while before on boot they seemed to be recognized in eth mode. New module: # modinfo mlx4_corefilename: /lib/modules/4.19.0+1/kernel/drivers/net/ethernet/mellanox/mlx4/mlx4_core.koversion: 4.0-0 Old module: # modinfo mlx4_corefilename: /lib/modules/4.4.0+10/updates/mlx4_core.koversion: 3.4-1.0.0 Booted to a Kubuntu 16.04 Live CD to attempt to do it with the last supported firmware for the card but the Mellanox card doesn't seem to be supported by Mellanox OEM software. MLNX_OFED_LINUX-4.7-3.2.9.0-ubuntu16.04-x86_64.tgz root@kubuntu:~# mlxfwmanager --queryQuerying Mellanox devices firmware ...Failed to identify the device - Can not create SignatureManager!Failed to identify the device - Can not create SignatureManager!Device #1:---------- Device Type: ConnectX2 Part Number: SUPERMICRO X8DTT-IBX/X8DTT-IBXF/X8DTT-HIBXF/X8DTT-HIBXF+ (Rev2.00 or later) Description: ConnectX-2 VPI; s
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.