Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hello,How many ssl certificate we can use in nutanix cluster. (1, 256, ...)Thank you.
Hello, i have deployed a banch of VM’s on nutanix AHV nodes and now i wanted to access those VMS with my laptop using remote desktop connection but after i have allowed the remote access on the VMs it keep showing me this error.
Dear Team,We purchased NX-1265-G6-4114-CM (3 Node) but customer refuse to take and this node register with this customer. we want to sell this node to my other customer.I want to know how we can change the customer name,basically how to change ownership one customer to another customer.really appreciate if someone help us.
Hello,I am trying to create a VM of cisco ACI so that the network team can practice on. but while installation it keep showing this error and start the installation from the begining again. i don’t know what did i do wrong please any one can help.
Below are new knowledge base articles published on the week of August 16-22, 2020.KB 9765 - Application Consistent (VSS) Snapshots fail if guest has in-guest mounted VHDX files KB 9863 - Async DR replication failure in 5.17 AOS KB 9867 - ncc default_password_check may generate "Session Audit" assertion in IPMI system event log. KB 9870 - Cannot enable Karbon Airgap with error "Failed to pass Airgap enable prechecks: Failed to get file via given server url" KB 9877 - Citrix AHV Director Plugin: PSRemotingTransportException - Access is denied KB 9885 - AHV - acpi_pad process consumes too much CPU KB 9895 - HPE: iLO Virtual NICNote: You may need to log in to the Support Portal to view some of these articles.
When hardening ESXi Security, some settings may impact operations of a Nutanix cluster. Here are some recommended settings and their possible effect on a Nutanix cluster Summary of Hardening Requirements can be implemented in /etc/ssh/sshd_config as below:HostbasedAuthentication : noPermitTunnel : noAcceptEnvGatewayPorts : noCompression : noStrictModes : yesKerberosAuthentication : noGSSAPIAuthentication : noPermitUserEnvironment : noPermitEmptyPasswords : noPermitRootLogin : noMatch Address : x.x.x.11,x.x.x.12,x.x.x.13,x.x.x..14,192.168.5.0/24PermitRootLogin : yesPasswordAuthentication : yes For more details,
Hello All, I was trying to deploy Nutanix AOS 5.15.1 and HyperV2016 on 03 Lenovo HX-2321 nodes using Foundation 4.5.4.At the first time, the deployment failed with this message : "Fatal running pre-install sanity tests" for each of the 03 nodes. Please see below all the related log messages :==================================================================2020-08-18 17:02:12,832Z DEBUG Setting state of <ImagingStepValidation(<NodeConfig(10.105.254.200) @b390>) @be70> from PENDING to RUNNING2020-08-18 17:02:12,838Z INFO Running <ImagingStepValidation(<NodeConfig(10.105.254.200) @b390>) @be70>2020-08-18 17:02:12,845Z DEBUG Cache MISS: key(<function common_validations at 0x0399D2B0>_()_{'global_config': <foundation.config_manager.GlobalConfig object at 0x0518B890>})2020-08-18 17:02:12,845Z INFO Validating parameters. This may take few minutes2020-08-18 17:02:12,845Z INFO Validating parameters. This may take few minutes2020-08-18 17:02:12,846Z INFO Val
When performing maintenance on a CVM, it is important to not treat it as a regular guest VM. This is because there are crucial services running on each CVM which need to gracefully respond when a CVM goes offline.If you need to shutdown a CVM and are running ESXi, you might otherwise think to simply go to vCenter, right-click on the CVM, and select the “Shut Down Guest OS” option. However, that procedure will not properly shut down the CVM and allow the services to gracefully respond.Instead, in using the cvm_shutdown script, it will first place a necessary HA route in the hypervisor, to redirect storage requests to another CVM, before shutting down the CVM. This will also allow the services to gracefully respond to the CVM being offline.More information and options regarding this script can be found in KB 3270
Did you know that AHV hosts can be accelerated by discrete graphics hardware (similar to how home gaming systems are accelerated)? This is especially useful for environments such as Virtual Desktop Infrastructure (VDI) deployments where it is desirable to accelerate individual desktops being shared out to large user communities.The host driver for the discrete graphics hardware can be easily installed on AHV hosts via a single command as executed from just a single CVM of a Nutanix cluster (executing the command from a single CVM will install it across all of the CVMs of the cluster – no need to touch each CVM/host individually). Information regarding this single-command procedure can be found from the INSTALLING NVIDIA GRID VIRTUAL GPU MANAGER (HOST DRIVER) section of the AHV ADMINISTRATION GUIDE.Also, just to note, the host driver can be installed on hosts running an ESX hypervisor using a different procedure. That procedure can be found via the knowledge base article Install NVIDIA
What is Fault Tolerance (FT)?FT is how the system ensures that both user VM data and cluster infrastructure data is protected from failure. What are Fault Domains?Failure scenarios can be thought of in terms of fault domains. There are four fault domains in a Nutanix cluster:Disk Node Block RackThis article focusses on Rack Awareness. Rack failure can occur in the following situations:All power supplies fail within a rack Top-of-rack (TOR) switch fails Network partition; where one of the racks becomes inaccessible from other racksWhen rack fault tolerance is enabled, the cluster has rack awareness and the guest VMs can continue to run with failure of one rack (RF2) or two racks (RF3). The redundant copies of guest VM data and metadata exist on other racks when one rack fails.Note – Rack fault tolerance has to be configured manually. Requirements and configuration of Rack Fault Tolerance can be found here.To learn more about Rack Fault tolerance on Nutanix Clusters click here.Now, Rack
NCC alert showed following issue and followed KB 2050 Detailed information for cvm_startup_dependency_check:Node 192.168.x.x:FAIL: Failed to open vmx fileRefer to KB 2050 (http://portal.nutanix.com/kb/2050) for details on cvm_startup_dependency_check Based on observation the datastore name used by node had pre-fix which caused the NCC alert to failsChanged NTNX-local-ds-17FM37420063-B (1) to NTNX-local-ds-17FM37420063-BThis helped to resolve the NCC alert message.
Is there a way with NTNX Powershell cmdlets to collect software inventory data for all registered clusters? Something like;Cluster Name AOS version Foundation version NCC version Hypervisor versionThanks!
Hello all,I have managed to configure the 3 node cluster with AHV and all of the were working at first but after 2 days one cvm has been down can’t communicate with others.i have tryied to fix it but i couldn’t.both the AHV and host ip does reply for ping but the CVM dosen’t.i have run the NCC and got the log but it only says there is a duplicate ip but when i check for duplicate ip there is no duplicate ip in the configuaration. i have attached the NCC report incase you want to see it. Any help will be greatly appretiated.
Hello, i have a running nutanix 3 node cluster in my environment all is good. the problem is when i create a VM and launch it i the OS starts with without the network adapter i have added 1 Disk and also 1 virtio and also the OS in separate disk configuration. i have the screenshot of the configuration please tell what did i do wrong.
What are the commands to shutdown and delete guest VMs?
Hello all,Is it possible to install the french version of Windows server 2016 using nutanix foundation ?I wonder this because in the iso whitelist, I only see english versions of windows server 2016 as supported versions.Thanks.
Good afternoon, all!I’m setting up a Move project to migrate some VMs from Hyper-V to AHV. In the 3.6 Move user guide, it says “You need PowerShell version 4.0 or later.” Do we need it on each source VM, on the HV hosts, on the management workstation, or all three?Thanks to all for looking! Gregg
http://runahv.com Check in with Mission Control to get the most out of Invisible Virtualization.Mission Control is a curated set of short vidoes covering a set of topics from day 0 setup and deployment, migration from other hypervisors, and advanced management. Check it out and let us know what you think. If there’s content you’re interested in, let us know in this thread.
In the process of installing the nx-8235-g7 equipment, the foundation cannot perform IPMI MAC ADDRESS DISCOVERY.When the installation was powered on, it was booted into Phoenix.iso and the IPMI IP setting was possible, so the installation was possible with the foundation. Is there any change in IPMI MAC DISCOVERY method from G7 equipment? And when the equipment is received and powered on, it boots into Phoenix.iso. Can you know what this is?And starting from g7, is the IPMI DEFAULT PASSWORD indicated by a sticker on the back of the device where the ipmi ID/PASSWORD is not ADMIN/ADMIN?
I have a Nutanix Node - Dell XC740xd with 4 Tesla T4 GPUs installed. I am Running AOS 5.15. It seems my GPU is in passthrough mode, and I would like to switch this to vGPU mode. Does anyone know how to do this? "status": "UNUSED", "assignable": true, "vendor": "NVIDIA", "name": "Tesla T4 compute", "index": 0, "max_resolution": "None", "num_vgpus_allocated": 0, "pci_address": "0000:86:00.0", "fraction": 0, "mode": "PASSTHROUGH_COMPUTE", "num_virtual_display_heads": 0, "guest_driver_version": "None", "frame_buffer_size_mib": 16384, "device_id": 7864
Dear team,can Any one please suggest below query.My CPU Model is Intel(R) Xeon(R) Silver 4114 CPU @ 2.20GHz 10 Core: How much maximum Vcpu we can consider?
We need to migrate one VM (a virtual appliance) from one AHV to another with no p connection between the two The AHV versions are different (Euphrates 5.5.8 and Euphrates 5.9). What is the best way to accomplish this.?
Below are new knowledge base articles published on the week of August 9-15, 2020.KB 9258 - Alert - A650000 - Data provider collector is in crashloop. KB 9637 - Pre-Upgrade Checks: test_if_rolling_restart_is_not_in_progress KB 9698 - Alert - Clusters on AWS - Hibernate/Resume process taking long time KB 9699 - Alert - Nutanix Clusters on AWS - Capacity not met KB 9701 - Alert - Clusters on AWS - Cluster Node Condemned Timeout KB 9703 - Alert - Clusters on AWS - Cloud Provider Connection Issues KB 9704 - Alert - Clusters on AWS - Handling AWS Health and Scheduled Events notifications KB 9723 - Clusters on AWS - Limitations of Rack Awareness feature KB 9733 - Clusters on AWS – Important Considerations when deploying Nutanix Clusters on AWS KB 9768 - Alert - Clusters on AWS - Cannot Provision Node KB 9770 - Alert - Clusters on AWS - Cluster Key Pair Deleted alert in Nutanix Clusters Console KB 9771 - Alert - Clusters on AWS - Host Agent Ping Timeout KB 9772 - Alert - Clusters on AWS - Node
Do you want to import Third Party Appliances on AHV and wondering about following questions?Is my Third-Party Appliance compatible with AHV? What is supported and un-supported? How will I migrate my Appliance to AHV?We have multiple options that can be used to deploy Third Party Appliances on AHV. Third-party application vendors provide different applications or appliances that are certified to run on AHV.Here is the full current list of such applications: Compatibility MatrixNote: Software vendors can utilize this link to request an official software validation on AHVFor more details, refer to KB 9849
Hello!We have 5 node RF3 cluster. I tried shutting down 2 of 5 node at a time. Cluster stays online, but rebuild never happens. Is it normal? Should 5 node RF3 cluster rebuild after loosing 2 nodes? Can it survive loosing 1 more node after already loosing 2 (only 2 of 5 stays online)?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.