Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
We may have a requirement to have a RPO as less as 1 minute. The NearSync feature provides you with the ability to protect your data with an RPO of as low as 1 minute.To implement the NearSync feature, Nutanix has introduced a technology called Lightweight Snapshots (LWS) to take snapshots that continuously replicates incoming data generated by workloads running on the active cluster. The LWS snapshots are created at the metadata level only. These snapshots are stored in the LWS store, which is allocated on the SSD tier. LWS store is automatically allocated when you configure NearSync for a Protection Domain.Some of the advantages of NearSync are as follows. Protection for the mission-critical applications. Securing your data with minimal data loss in case of a disaster, and providing you with more granular control during the restore process. No latency or distance requirements that are associated with fully synchronous replication feature. Allows resolution to a disaster event in
NTP i.e. Network Time Protocol is a critical component of the Nutanix cluster and is crucial in keeping up hardware, processes, services and applications running with time synchronization across one another. Inconsistencies in time synchronization could lead to undesirable consequences, not to mention the potential disastrous impact it could have on databases and real time applications through operational failures. The downside of a poor NTP scenario could be data loss, hard to detect security breaches, even leading to legal liabilities, and loss of credibility. NTP alerts are generated when you run the NCC Health checks, and are typically shown as below:Detailed information for check_ntp:Node 172.24.0.143:FAIL: The hypervisor is not synchronizing with any NTP server. This might occur if none of the configured NTP servers are available or you are currently experiencing network instability determined by the high offset/high jitter.Node 172.24.0.144:FAIL: NTP leader is not synchronizi
Witness VM in Metro Availability Configuration:A "Witness" is a special VM that monitors the Metro Availability configuration health. The Witness resides in a separate failure domain to provide an outside view that can distinguish a site failure from a network interruption between the Metro Availability sites. It can only be configured on AHV and ESXi hypervisors.The main functions of a Witness include:· Making a failover decision in the event of a site or inter-site network failure.· Avoiding a split-brain condition where the same storage container is active on both sites due to (for example) a WAN failure.· Handling situations where a single storage or network domain fails.To learn about the different scenarios you might encounter and the requirements of a witness VM, click here. Did you know?Witness VM can also be deployed if you are using a 2-node cluster! To learn more about how it works in that environment, click here.
Getting this error when I try to use putty/plink for any ACLI-related command:bash: ACLI: command not foundDoesn't seem to matter what acli “command” i run, even just running “acli” by its self gives the same error. I am able to run commands like “hostname” etc using plink/putty on the CVM. Feel like im missing something very simple here.Example command:putty $cvmIP -l $username -pw $password “acli vm.disk_get $vmname disk_addr=scsi.0”
If you want to increase data storage on your Nutanix cluster, but do not want any AHV VMs to run on that node, you can add a Never-Schedulable Node to your cluster. AOS will not run any VMs on a never-schedulable node, whether at the time of deployment of new VMs, during the migration of VMs from one host to another (in the event of a host failure), or during any other VM operations. Therefore, a never-schedulable node configuration ensures that no additional compute resources such as CPUs are consumed from the Nutanix cluster.With the release of Foundation 4.1 and higher, any G6 or G7 node can now be used as a storage-only node. You can add any number of never-schedulable nodes to your cluster!To learn more about the requirements and the procedure to add this node, click here. Also, check out KB-6819 for further instructions.
We are transferring vdisks from one Nutanix environment to another. We are going from Euphrates 5.5.8 to Euphrates 5.9. The copy seems to work but then after a while (maybe 15 minutes) the files in the new environment disappear. We’ve tried this several times with the same results. One vDisk is around 26 GB and the other is 2 TB. Has anyone seen this and what is the problem and the solution?
I have a lot of virtual machines running with latest Debian 10 distribution (version 10.2 and next 10.5).When will be available Nutanix Guest Tools for this distribution? It’s a mess to receive warnings everyday with the message of NGT not installed in these machines.
Below are new knowledge base articles published on the week of September 6-12, 2020.KB 9960 - AD user cannot manage PC and NCC upgrades after upgrading to PC 2020.8 version KB 9980 - Cluster outage may occur during an LCM upgrade when restoring block fault-tolerance KB 9981 - SSP | VM nic update task performed by SSP user may fail on Prism Central 5.17 and above versions KB 9985 - Intermittent Network Disconnects Due to MAC Learning Disabled When Using AHV Bond Mode Balance-SLB KB 9989 - LCM : Could not find any upgrading entities forgroup Group-Cluster Service-Foundation KB 9995 - Move - Guest preparation may fail when SSL is enabled on Windows VMNote: You may need to log in to the Support Portal to view some of these articles.
Do you know Support Cases can be Scheduled on Support Portal?Support Portal users that are working with Nutanix Support can elect to schedule a follow-up for a case. The instructions within the case page are designed to be self-explanatory on how to schedule. However, you may want to understand how a case is handled when scheduled prior to using the feature. Portal Scheduling Overview The scheduling feature is only presented under the following conditions: Support contract allows for 24x7 coverage Case priority is low - P3 or lower Additionally, when scheduling, the following limits apply: Can only schedule for the next business day - not today Cannot schedule on weekends or public holidays Can only schedule up to 1 week out Your Systems Reliability Engineer (SRE) is able to work with you to assist with scheduling in other circumstances. Scheduling is available both at case creation and during the life of a case by using th
While doing LifeCycle Manager (LCM) upgrades, Nutanix infrastructure customers could encounter failures on the SATADOM upgrade on a ESXi Host, with the message:"Operation failed. Reason: Lcm prechecks detected 2 issues that would cause upgrade failures.Check 'test_hypervisor_config' failed with 'Failure reason: APD/VMCP feature is enabled on cluster, Please disable, Please refer KB 6470'Check 'test_min_phoenix_version' failed with 'Failure reason: APD/VMCP feature is enabled on cluster, Please disable, Please refer KB 6470' You can try disabling the APD using the following command on the Host:# esxcfg-advcfg -s 0 /Misc/APDHandlingEnable From experience I can tell you that this does not always resolve the issue. It may be necessary, on certain occasions, to access the VMware vCenter, through possibly the vSphere Web Client, and do the following:Access the Hosts pageClick on the Host in questionClick on ManageGo to Advanced System SettingsSearch for “APD”Modify Misc.APDHandlingEnable an
There could be many reasons why an administrator would want to perform a factory reset of the IPMI/BMC module. Whatever the reason maybe, knowing the different options and its differences is important.Using ipmitool, we can perform 3 types of resets each with its own implication. Reset BMC Partial factory reset (IPMI and BMC reset but will preserve Network settings) Full factory Default reset (Potential to lose IPMI network settings)Before you execute any of these commands, note the IP_Addr, Net mask and GW IP_Addr for the IPMI. ipmitool lan printUsage note: On VMware ESXi hypervisor, place a leading "/" in front of "ipmitool", for example, "/ipmitool". The executable is located at the top-level root directory.Check out the KB-8123 for detailed instructions.
The CVMs that comprise a Nutanix cluster get their time by syncing to a single member which is known as the NTP Leader (aka Genesis Master). This node will be responsible for syncing with whatever NTP servers the customer added to Prism. When NTP is properly configured, the Leader CVM will set its own clock to the time provided by the server and then all other CVMs will sync with the Leader's time. For AHV clusters, the same list of servers used by the NTP Leader will be configured on each host to sync with independently. All other hypervisors need to have NTP configured separately using their unique management tools. By default User VMs sync their time with the local hypervisor where they are running, but users can configure their machines to sync with local or internet-based NTP servers as well. Importance of NTP: If there is a power outage and cvm’s pick up wrong time it can prevent the cluster to start It’s very difficult if you're trying to RCA any issue Commands:To check ntp s
A Cluster can be licensed following these simple stepsStep 1 is to download a Cluster Summary File(CSF)On your Prism home screen, click on the Gear Wheel (top right of the screen) --> Licensing --> Update License -->Download.The CSF will be generatedStep 2 is to generate a License Summary File(LSF)Login to your support portal account and continue with the steps belowClick on the Menu Icon ---> Licenses --> Licenses--> Manage Licenses --> Upload the CSF. Based on the product for which you are applying the license(AOS, Files, Prism Pro, Flow, Buckets etc), select the License type from the cards visible and click on Next, then download which will generate the LSF.Step 3 is uploading LSF to the Prism Access the Prism Console, under the Licensing page, Upload the LSF and click on Apply License, the licenses will be updated now. Note : Refresh(logout & re-login) the Prism for the licensing changes get applied.
Helloafter reinstalling Prism Central (PC) from v.5.16.1.3 to v5.17.1.1, using the procedure for unregistering PCUnregistering cluster from PChttps://portal.nutanix.com/page/documents/details?targetId=Prism-Central-Guide-Prism-v5_5:mul-vcenter-server-unregister-pc-t.htmlwe have some strange issues:- A PC REST API query return 2 available cluster (one for PE and one for PC, with different uuid on metadata)It is normal for API 3.1? - On Nutaniy API Explorer a simle query of vms "POST /vms/list"With small payload for "get_entities_request"{ "kind": "vm", "length": 10, "offset": 0}returns { "api_version": "3.1", "code": 500, "message_list": [ { "message": "Internal Server Error. Failed to get schema for cluster 000597eb-aa13-1c72-0000-000000029cf0", "reason": "INTERNAL_ERROR" } ], "state": "ERROR"}Where the displayed uuid is the correct PE cluster uuid.This is a lab cluster, then we have just one culster with < 50 VmsAny suggestion?Thanks
I would to ask how can I get the details of Memory and DIMM slot available
Can't I remove the interface included in the bond with ovs-vsctl For example If br0 contains interfaces eth0 to 3 in bond name br0-up, I want to clear eth0, eth1. If I can't, is there a command to update or remove interfaces like manage_ovs --bridge_name br0 --bond_name br0-up --interfaces eth2,eth4 update_uplinks command in ahv? Thank you for always helping me
I don’t see anywhere to acknowledge or remove this alert, it is no longer an issue and we resolved what was causing the issue but it keeps showing that we have a critical alert for the 28th.
Has anyone seen this error ? As checked AOS version 5.17 is compatible with HPE DX nodes.INFO Copied /home/nutanix/foundation/templates/crystal_plat_reference.json to phoenix at ip X.X.X.XERROR Command '/usr/bin/python /phoenix/minimum_reqs.py hyp_type=kvm nos_version=5.17.1' returned error code 1stdout:Loading /phoenix/features.jsonstderr:INFO /root/phoenix/hardware_pre_checks/hp_proliant/updates/hp_platform_reference.json override is not presentWARNING Firmware configuration not available for system type HPE DX380-12 G10INFO HPDX cabling validation completed successfullyTraceback (most recent call last): File "/phoenix/minimum_reqs.py", line 653, in <module> main() File "/phoenix/minimum_reqs.py", line 649, in main check_minimum_requirements(param_list, use_layout, boot_disk_controller) File "/phoenix/minimum_reqs.py", line 584, in check_minimum_requirements process_test_results(errors, warnings) File "/phoenix/minimum_reqs.py", line 603, in process_test_results
Before you begin Before you decide to change the CVM, hypervisor host, and IPMI IP addresses, consider the possibility of incorporating the existing IP address schema into the new infrastructure by reconfiguring your routers and switches instead of Nutanix nodes and CVMs. If that is not possible and you must change the IP addresses of CVMs and hypervisor hosts, proceed with the procedure described in this document. Guest VM downtime is necessary for this change, because the Nutanix cluster must be in a stopped state. Therefore, plan the guest VM downtime accordingly. Verify if your cluster is using the network segmentation feature.nutanix@cvm$ network_segment_statusNote the following if you are using the network segmentation feature. The network segmentation feature enables the backplane network for CVMs in your cluster (eth2 interface). The backplane network is always a non-routable subnet and/or VLAN that is distinct from the one which is used by the external interfaces (eth0)
There are cases where we forget the password for "nutanix" user which is used to login to Move Web GUI console. Nutanix user is a Move app user and not a user on the Move-vm. Therefore, "passwd nutanix" does not work and to reset it we need to follow the manual process mentioned in the below KB article: How to reset nutanix user password in move for Web GUI accessThe procedure mentioned in the above article is to reset the password for "nutanix" user only and not admin (cli) user. Password reset of "admin" who is a user on the move-vm would not be possible as it is the only user exposed on the move-vm. Allowing to reset the "admin" password externally would cause security violations in case of malicious actions. The only way in this case would be to re-deploy the Move appliance. The following documentation includes the step by step process of deploying a new Move VM: Move Deployment
Can anyone let me know the release date of the LCM Framework version 2.3.3 ?
We have to do a deployment of 5 HPE DX nodes with AHV as hypervisor. Is it mandatory to have the iLO ip address in the same subnet as CVM & Host ? If not then do we have to give 2 IP addresses to foundation VM ? Let me know if anything else is needed.
I'm looking for some advice.My company recently purchased a used 3460-G4. We're a professional services firm and we want to have it for our lab so we can stand up stuff like ERA, CALM, etc. and bang around on it. You know, lab stuff!We have been trying to Foundation (4.5.4.1 & 4.5.3.1) the block but I am running into a problem with Foundation failing when trying to mount the Phoenix image on the nodes. Here's how things currently stand:BIOS has been upgraded to latest recommended version on Nutanix Support site. (G4G5T6.0)BMC firmware has been upgraded to latest recommended version on Nutanix Support site. (3.64)Each node has x2 SSDs, which this system appears to recognize (I ran an ESXi installer on one of the nodes to test. The installers saw the drives)Each node has 64GB of RAM. The RAM is confirmed to be compatible according to SuperMicro's site.The Motherboard is the X10DRT-P from SuperMicro.IPMI has been set on each node and I can log into the IPMI mgmt page.At first I was wo
In our environment, eth2,3,4,5 is assigned to br0. The bonding policy uses active-backup and the current active interface is eth2.I want to leave only eth2,3 in br0 with the following command while the cluster is online.allssh manage_ovs --bridge_name br0 --bond_name br0-up --interfaces eth2,eth3 update_uplinks1. Is it possible to proceed without stopping the cluster?2. What if I need to stop the cluster?
Below are new knowledge base articles published on the week of August 30-September 5, 2020.KB 9605 - Alert - A120094 - cluster_memory_running_out_alert_insights KB 9932 - Calm: NCC checks against the incorrect IP in dataservice_connectivity_check resulting in false positive. KB 9937 - Alert ID 111066 - Failed to send alert emails KB 9940 - Nutanix SMTP and Spamhaus KB 9954 - HPEDX: IPMI IP change during Expand Cluster is not taking effect due to iLO requirement KB 9956 - Objects - MSP VMs may inadvertently get deleted under certain circumstances if MSP Controller is 1.0.5 and 1.0.7 KB 9959 - Pre-check: test_is_nos_upgrade_supported_on_esxNote: You may need to log in to the Support Portal to view some of these articles.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.