Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
I tried to create a boot UEFI with URL https://github.com/abbbi/nutanix_uefiWhat information should I put for the image ce-2019.11.22-stable? menuentry 'Nutanix Community Edition AHV (4.4.77-1.el7.nutanix.20190211.279.x86_64) 7 (Core)' --class nutanix --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.4.77-1.el7.nutanix.20190211.279.x86_64-advanced-4d8b0f1e-e014-4058-a050-c6d2ed188094' { load_video set gfxpayload=keep insmod gzio insmod part_msdos insmod ext2 if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root 4d8b0f1e-e014-4058-a050-c6d2ed188094 else search --no-floppy --fs-uuid --set=root 4d8b0f1e-e014-4058-a050-c6d2ed188094 fi linuxefi /boot/vmlinuz-4.4.77-1.el7.nutanix.20190211.279.x86_64 root=UUID=4d8b0f1e-e014-4058-a050-c6d2ed188094 ro crashkernel=128M rhgb quiet hugepages=0 intel_iommu=on,igfx_off iommu=pt elevator=noop vga=791 vfio_iommu_type1.allow_unsafe_interrupts
Nutanix infrastructure customers often suffer performance issues on their database, and call in to Nutanix Technical Support to help them resolve them. One aspect I have observed with database customers, and which impacts their performance, is the placement of the VMDKs on SCSI Controllers. Assuming that there are four VMDKs serving the database VM, they might have configured the four VMDKs as follows. This is an extract from the ESXi Host which the VM is running on:[root@esxasrk63u35:/vmfs/volumes/9f254e88-e3c751d/pqrsd00][root@esxasrk63u35:/vmfs/volumes/9f254e88-e3c751d/pqrsd00] cat pqrsd00.vmx | grep vmdk -A3scsi0:0.fileName = "pqrsd00.vmdk"sched.scsi0:0.shares = "normal"sched.scsi0:0.throughputCap = "off"scsi0:0.present = "TRUE"--scsi0:1.fileName = "pqrsd00_1.vmdk"sched.scsi0:1.shares = "normal"sched.scsi0:1.throughputCap = "off"scsi0:1.present = "TRUE"--scsi0:2.fileName = "pqrsd00_2.vmdk"sched.scsi0:2.shares = "normal"sched.scsi0:2.throughputCap = "off"scsi0:2.present = "TRUE"-
So you have decided to relocate your Nutanix cluster to a different data center. Here are a few things to consider and a brief overview of steps to follow for seamless transition. Caution: This information is only provided to serve as a guide to plan your move. Please engage Nutanix Support if you have any concerns or questions following this process. Before you decide to move: Consider the possibility of incorporating the existing IP address schema into the new infrastructure by reconfiguring the router and switches instead of Nutanix nodes and CVMs. If that is not possible, proceed with this guide. Before you unplug everything:Refer to these guides for the procedure.Doc 1 (CVMs) CHANGING THE CONTROLLER VM IP ADDRESSESDoc 2 (AHV hosts) CHANGING THE IP ADDRESS OF AN ACROPOLIS HOSTDoc 3 (IPMI) CHANGING AN IPMI IP ADDRESS A few things to note:1. Since the cluster is being relocated and the new network will not be able to communicate with the old network, you will need to run through so
If there was a gflag applied in the past on cluster and now you dont have a track on the details, the same can be found out by running this NCC check ncc health_checks system_checks gflags_diff_checkThe output will show you the list of non-default gflag currently on the system, more details here -NCC Health Check: gflags_diff_check
Very frequently we receive an alert just before an upgrade that cluster doesn't have enough space to download the binary files (). If that is happening to you, there are ways to clean the partition below the threshold (75%). Some of them include below Cleaning Old ISOs and Software Binaries ( For old AOS, NCC, Foundation versions) Checking Removing Old Logs (Log files shared for support cases if not cleared later, occupy space) Cleaned up files from the approved directories but still see high usage in /home?At this time, open a support case to identify any other underlying issues or deep cleaning on the nodes with the help of Nutanix Engineer. More details on Nutanix KB below https://portal.nutanix.com/page/documents/kbs/details?targetId=kA0600000008dpDCAQ
Nutanix has worked closely to build integrations between ServiceNOW’s SaaS offering andNutanix infrastructure with the following areas of focus:ServiceNOW CMDB integration for Nutanix hyper-converged infrastructure discovery and modeling Nutanix Alert Integration with ServiceNOW Events and Incidents and remediation via XPlay ServiceNOW Request Management and Fulfillment for Services Hosted on Nutanix via CALM plug-in For More Details: https://www.nutanix.com/blog/nutanix-integration-with-servicenow
Hello,I’ve just reimagined a block with 4 nodes (NX-1065-G4) to use in our lab using Phoenix image (created following this article https://portal.nutanix.com/page/documents/details?targetId=Field-Installation-Guide-v3-12:v31-phoenix-files-r.html#reference_bbk_vnx_p4).I’m using ESXi 7.0.0 build 15843807 and NOS 5.15.2. Hypervisor and CVMs have been correctly installed (following this https://portal.nutanix.com/page/documents/details?targetId=Field-Installation-Guide-v3-12:v31-node-install-cvm-t.html) but CVM does not have an IP configured. I’ve tried to configure CVM IP using “external_ip_reconfig” scripts but i get an error: How can i configure CVMs’ IP?Note: i’ve used Phoneix because Foundation failed several times with a “dependencies” error.Thanks, kind regards
Ever wondered about the underlying mechanism used by AHV hosts to facilitate network communications for themselves and hosted VMs across a network? This underlying mechanism is an open-source software platform called Open vSwitch which operates as a software-defined switch on each host.This software-defined switch operates very similarly to a traditional layer-2 hardware switch in that it learns and maintains MAC addresses and makes frame-forwarding decisions based upon that information. However, it also can be considered much more scalable and extendable.With AHV, each host maintains its own Open vSwitch instance and parameters are passed to these instances using an open-standard protocol called OpenFlow.You can find more information regarding the Open vSwitch platform within the AHV Administration Guide and from the associated Linux Foundation website.
Hi all,We recently purchased a new G7 and during this new install we converted all of our VMs to AHV using Move and we are successfully running on AOS/AHV. Working great.We now would like to convert our old 1050 with ESX/vCenter to AHV although we are hitting the DRS roadblock.We do not have a DRS license to enable this feature.We have also tried a “Trial License” and this doesn’t appear to be the best route (upgrading all kinds of vmware items just to get a “trial license enabled DRS “just to convert to AHV)My question is, now that our old cluster is decommissioned (All VMs are now on the new cluster), what would be my best approach at converting this old cluster to AHV and not having the “Convert Cluster” option hanging us up with DRS not enabled? Any input is appreciated.
Looking for advise, Trying to add a Hyper-V host to Move 3.5.0, but just getting the following error and nothing else, Hyper-V operation [Get Process Info] failed. Getting no other alerts/Errors.
Hello all,I’ve just finished the basic installation of a new 3 nodes Nutanix Cluster (NX-1065-G7 node). When i try to enter the IPMI password nothing happens. It seems the password is wrong. I have tried the default ADMIN/ADMIN password but it doesn’t worked (also admin/admin).Did the default password change with the release 5.15.x of AOS ?For information, the cluster has been created with the following parameters : AOS 5.15.2 Foundation VM 4.5.4.1 ESXi 6.7U3The “ipmitool user list” show me an “ADMIN” user with ID 2, so i think the account is correctly created. I ve tried on each of the 3 nodes and it’s still the same. So if the password set is ADMIN by default and is not working, can i safely change it with the ipmitool command ? Thx for your answers :)
When you on-ramp new team members they’re going to need access to all their tools. If those new teammates will be managing Nutanix systems they most likely need a login to the support portal for access to documentation, downloads, the knowledge base, and the ability to open a support case. So how do we set up access for new users? There are a few simple steps covered in the article How to Gain User Access to Nutanix Support Portal . You’ll need a block or software-only serial number and the user’s email address. The email address should be in the authorized domain for your customer account. To find the block serial number log into Prism and navigate to Hardware > Diagram. The block serial number is displayed above each block in the diagram. If there are multiple blocks, pick one and note the serial number for later. For software-only licenses, The software asset serial number is mentioned in the acknowledgement email sent upon the fulfilment of your order. Once you have the
Hello guys, Is it possible to add Dell PowerEdge R640 or R730 hardware to a cluster with NX hardware?
You have the option of adding a Witness to a Metro Availability configuration (see Data Protection Guidelines (Metro Availability)). A "Witness" is a special VM that monitors the Metro Availability configuration health. The Witness resides in a separate failure domain to provide an outside view that can distinguish a site failure from a network interruption between the Metro Availability sites. The goal of the Witness is to automate failovers in case of site failures or inter-site network failures. The main functions of a Witness include: Making a failover decision in the event of a site or inter-site network failure. Avoiding a split brain condition where the same storage container is active on both sites due to (for example) a WAN failure. Handling situations where a single storage or network domain fails. Metro Availability Failure Process (no Witness)In the event of either a primary site failure (the site where the Metro storage container is currently active) or the link betwee
Below are new knowledge base articles published on the week of September 13-19, 2020.KB 9982 - LCM: Operation failed. Reason: Multiple LAGs as uplinks in a VSwitch is not supported. KB 9987 - HPDX Platforms Cabling Guides KB 10004 - LCM inventory does not show available firmware updates for HPE nodes with iLO version 2019.03.01 KB 10008 - AHV | Uploading vhdx image may fail if the image is corrupted KB 10012 - Cloning an image and Updating disk size via Prism Element API V2 call KB 10014 - Unable to see option to edit existing disk settings for any VM in PC when logged in as Cluster/Prism Central Admin user KB 10026 - Move - Migration failed with Bad/incorrect request, AOS 5.18Note: You may need to log in to the Support Portal to view some of these articles.
With the new release of Objects (Objects) 2.2, now you can assign a quota policy to a user which enables Objects to set soft thresholds on the number of buckets created by the user within an object store.Release notes - https://portal.nutanix.com/page/documents/details/?targetId=Release-Notes-Objects-v2_2%3Av22-whats-new-r.htmlDocumented steps -https://portal.nutanix.com/page/documents/details?targetId=Objects-v2_2:v22-assign-quota-policy-t.htmlIf you want to know more about Objectshttps://portal.nutanix.com/page/documents/details?targetId=Objects-v2_0:Objects-v2_0ENABLING OBJECTS https://portal.nutanix.com/page/documents/details?targetId=Objects-v2_0:v20-enable-objects-t.html#ntask_t1y_mzc_4hb
Compression is one of the key features of the Nutanix Capacity Optimization Engine (COE) to perform data optimization. Data Storage Fabric provides both inline and offline flavors of compression to best suit the cluster’s needs and type of data. As of 5.1, offline compression is enabled by default.Inline compression will compress sequential streams of data or large I/O sizes (>64K) when written to the Extent Store (SSD + HDD). This includes data draining from OpLog as well as sequential data skipping it. There is no impact to random I/O, helps increase storage tier utilization and benefits large or sequential I/O performance by reducing data to replicate and read from disk.Offline compression will initially write the data as normal (in an un-compressed state) and then leverage the Curator framework to compress the data cluster wide. When inline compression is enabled but the I/Os are random in nature, the data will be written un-compressed in the OpLog, coalesced, and then compresse
Representational state transfer ( REST ) Application Programming Interface (API) 3.0 is based on an intentful API philosophy. According to the intentful API philosophy the machine should handle the programming instead of the user enabling the datacenter administrator able to focus on the other task There are three publicly available Nutanix APIs. Note that while you may see API v0.8 listed in the REST API Explorer in Nutanix Prism, it is strongly recommended to use v3 APIs wherever possible. v1 (Prism Element only) v2.0 (Prism Element only) v3 (Prism Central only) cURL Command AnalysisAs an extra step, let’s take the v3 API request above and look at what each part of the command is doing. If you are familiar with using cURL to make API requests, this will look very familiar. curl -X POST – Run cURL and specify that we will be making an HTTP POST request (as opposed to HTTP GET) https://[prism_central_virtual_ip]:9440/api/nutanix/v3/vms/list – Specify the complete request URL
Citrix Diagnostic Facility (CDF)CDF collects and traces the messages generated by various Citrix services running on the Delivery Controller. CDF helps discover and debug the root cause and related issues. Configure and Use CDFDownload the tool in a ZIP file from: http://support.citrix.com/article/CTX111961 Extract the ZIP file and run the extracted CDFControl.exe file. Go to Tools > Options and ensure that Enable real-time viewing while capturing trace is selected. This allows you to view the real time logs while the scripts run. Go to Tools → Options → Trace File Path and set the path for log collection. Check the following modules to enable plugin specific log collection. BrokerHostingManagementBrokerHostingPluginHostServiceHCLHostServiceLogHostServiceLoggingHostSnapInMachineCreationLogMachineCreationLoggingMachineCreationServiceHCLMachineCreationSnapIn Before running the script, click Start Tracing. It will start capturing the traces while PoSH script executes.Once you encounter
Nutanix Cluster Check (NCC) is cluster-resident software that can help diagnose cluster health and identify configurations qualified and recommended by Nutanix. Depending on the issue discovered, NCC raises an alert or automatically creates Nutanix Support cases. NCC can be run provided that the individual nodes are up, regardless of cluster state.NCC actions are grouped into plugins and modules:A Plugin is a purpose-specific or component-specific code block inside a module, commonly referred to as a check. A plugin can be a single check or one or more individual related checks. A Module is a logical group of common-purpose plugins. It can also be a logical group of common-purpose modulesNCC Output: Each NCC plugin is a test that completes independently of other plugins. Each test completes with one of these status types:PASS FAIL WARN INFO ERRNCC can be executed via:a) GUIb) CLINutanix Cluster Check (NCC) 3.10 Guide Reference LinkLogbay Tags Reference Guide for Nutanix Cluster Check (
Nutanix recommends that you use the Prism Life Cycle Manager to perform firmware updates. However, firmware must be updated manually if:The component is located in a single-node cluster, OR The component is located in a multi-node cluster, but the hypervisor the cluster is running does not support LCM firmware updates.Manual Upgrades:Manually Updating SATA DOM Firmware Manually Updating M.2 RAID Hypervisor Boot Drive Firmware Manually Updating the BMC and BIOS Manually Updating HBA Controller Firmware Manually Updating Data Drive Firmware Manually Updating NIC FirmwareFor more details: https://portal.nutanix.com/page/documents/details?targetId=Hardware-Admin-Ref-AOS-v5_18:bre-manual-firmware-update-c.html
When attempting to hit LCM via ‘Software Upgrade’ screen via a Cluster in Central, it links you to LCM on central, not on the cluster. Is this intended behavior or a bug?
As the title stated, I have tried to get around this by searching some docs on Portal but couldn’t find any related to. Could someone provide me any way to identify exactly the info of the M2 drives in a G7-model standalone node?
Does anyone have issues when trying to install NGT on a system that previously had it installed? I have tried to uninstall and reinstall to no avail. And trying to install/Upgrade via prism fails.
The Prism interface allows the investigation of the disk I/O latency. As a result, following questions are raised. Note: Nutanix recommends that maximum latency readings should not be used as a measure of cluster performance and health. Average latency is a useful measure of cluster performance and health. What should be the average latency on a production cluster? What should be the maximum latency? What point is the latency too high? How to investigate the high latency? Consider the following for latency investigations. The end-user impact for any performance investigation. If the impact is not measurable by the end-user, then any investigation of performance statistics is going to reveal normal and healthy cluster operations. VM combinations, traffic type at the time, write or read size, sequential versus non-sequential, read versus write factors on which investigations are dependent. Latency Variables in a Nutanix ClusterThe following points provide you with the information
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.