Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Below are new knowledge base articles published on the week of April 23-29, 2023.KB 14475 - Space Accounting | Nutanix Storage Usage Guide and FAQ KB 14515 - Space Accounting - Determining VM Space Usage KB 14516 - Space Accounting | Identifying Snapshots on a Nutanix Cluster KB 14525 - Space Accounting - Are the space saving settings on my containers configured correctly? KB 14600 - Space Accounting | Cluster space used by images KB 14617 - NDB - Scale Database UI for MSSQL DB Log Area "xx GB used of allocated xx GB" does not change after the size is extended KB 14639 - Prism Central - App Switcher showing no apps after upgrade to 2023.1.0.1 due to no IP address set to NTNX_LOCAL_AZ account KB 14659 - CMSP upgrade failed during PC upgrade from 2022.6.0.1 to 2022.9 KB 14665 - Migrating from ESXi to AHV Windows VMs not updating DNS records to DNS server KB 14670 - Uploading SSL certificates on PRISM could fail due to SSL certificates are password protected KB 14681 - Simultaneous VM mig
I have a used NX-3060-G5, with 4 nodesI am trying to install the new CE 2.0 on itEach node is configured with the e5-2650v4 x24x32 sticks of ramBMC version 3.94BIOS Version G4G5t8.0They all have the same 64gb statadoma 512GB SSD and a 1TB HDDI had used nodes a and b as test nodes orginally, then i tried to reinstall the new CE 2.0 on them and i keep getting failures at 2402/2430 hypervisor installation in progress with the read out to please take a look at the installer_vm_*.log inside foundation logs to debug hypervisor installation, then it restarts the install process and repeats. 2 of the nodes this installed on just fine, but they were not a reinstall of CE, they had vmware running on them previously.I have tried installing the latest supermicro bios and get the same issue, i have screenshots of the logs that i could find. Not sure if i can post them on here. Just seeing if anyone may be able to assist or point me in the right direction to find out why this keeps failing when al
Hello everyone,I have to install the first Nutanix cluster from a customer but I can't figure out how to setup the network.All customer switches (Aruba 2930, 2920) have the native vLAN (vLan1) dedicated to workstations and servers, while the management network is vLan ID 10 where the ESX, storage controllers, backup NAS and the Veeam server backing up the current infrastructure.This is the situation of all my customers, vLAN10 is completely isolated and unreachable from the native vLAN1, this was done to prevent any ransomware from affecting the backups as well.Now, Nutanix recommends configuring the CVM and hypervisor host VLAN as the native, or untagged, VLAN on the connected switch ports.I'm sure it would be nice to have all of the management in the native, adding a node would be much easier and I think the simpler things are kept the better.Furthermore, vLAN10 is propagated on many remote racks because obviously the backup NAS do not reside in the same racks as the servers, how can
In VMware, there’s the option to automatically power on VMs as the cluster is started. Is there such an option in Prism or do you have to rely on a script?
Below are new knowledge base articles published on the week of April 16-22, 2023.KB 14024 - Calm application deployment fails with "Failed getting banner" KB 14386 - Deploy button visible for Nutanix Category Apps instead of Open button post deployment KB 14572 - MS Office files fail to save to Files Server with message "Access Denied: Contact your administrator" KB 14583 - Elasticsearch failing due to missing rule for port 4199 in iptables KB 14619 - LCM BIOS upgrade to P[X]70.002 version on G6/G7 nodes fails with 'Host did not reboot in 3600 secs time' error due to CATERR events being generated on it KB 14626 - AHV upgrade fails with "Could not deserialize msgpack message" error while running salt KB 14634 - Nutanix Files - PC Files Manager unable to reach File server if PCVM and File Sever internal network are on different subnets KB 14637 - MSSQL: AG provision operation fails with error "An error occurred while creating the cluster <OU_path> An error occurred creating cluster
Hi! I have two doubts related to Collector´s vcpu and cpu calculation.1) I couldn't find the information on the vcpu/cpu ratio per VM in Collector's Excel spreadsheet? Please, how is it calculated when we perform workload upload per VM? 2) In Sizer, I performed a manual modeling from Collecto´s Excel spreadsheet information as a “Raw Input” and compared it to the automatic per VM-upload modelling.In the analyzed scenario, the customer has 440 CPU Cores distributed in 19 physical servers/hosts in the current environment (vhost table information) My calculations/modelling for a “Raw Input” is the same for the overall resources calculated by the automatic per VM upload (RAM, Datastore), except for the total o CPU cores in the cluster.The automatic per-VM upload/calculation was performed with the following settings: As result, the workload was modeled with 552 CPU cores: Please, why does the per-VM upload have 100 more CPU cores than the existing customer´s environment (552 vs 440 from t
Hi, I’m new to Nutanix, coming from the vSphere world.I am working on getting our new Nutanix infrastructure set up to run Qualys scans for security. I have been looking at the following document:https://portal.nutanix.com/page/documents/kbs/details?targetId=kA07V000000LXYqSAOI am getting stuck at determining which accounts to use to set up authentication, so that Qualys can run its scans on the Hypervisors, CVMs, and Prism Central appliances. My research shows that adding new accounts via the OS to these components is not supported. Does that mean that Qualys then has to log in as root, nutanix, and admin respectively, to scan these components? Or am I looking in the wrong place for the Qualys account to be set up, to scan for vulnerabilities and compliance? I feel like I'm missing something here. Thanks!
Hi allI have a cluster with vswitch active - activeI have new nodes to expand and I did theses steps below 1 - root@ahv# ./network_configuration to configure ips and vlan tag2 - Configure lacp 2.1 ssh root@192.168.5.1 "ovs-vsctl set port br0-up other_config:lacp-time=fast" 2.2 ssh ovs-vsctl set port br0-up other_config:lacp-fallback-ab=true 2.3 ssh root@192.168.5.1 "ovs-vsctl set port br0-up lacp=active" nutanix@CVM$ ssh 2.4 ssh ssh root@192.168.5.1 "ovs-vsctl set port br0-up bond_mode=balance-tcp"3 - Expand cluster The nodes were joined success in the cluster, but when I checked the vswitch configuration of theses nodes was changed to active - backupDid I do something wrong? What better way? Thank you
Below are new knowledge base articles published on the week of April 9-15, 2023.KB 12864 - Alert - A400117 - PolicyEngineVersionMismatch KB 13793 - NDB - scheduled daily snapshots break MSSQL differential backup chain KB 14359 - Prism Central - Redeploy errored out Infrastructure App from My Apps in Admin Center KB 14419 - Nutanix Objects Alert - kUnsynchronizedClock KB 14420 - Nutanix Objects Alert - kLowWALStorage KB 14421 - Nutanix Objects Alert - kMultipleFailedLeaderElections KB 14508 - No license eligible to convert KB 14517 - Unable to power on or migrate VMs to GPU enabled host KB 14599 - Prism Central 1-click deployment may fail when the gateway does not respond to ICMP Echo requests KB 14608 - Exporting an AHV VM using UEFI to OVA and importing to ESXi cluster causes an unbootable VM.Note: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of April 2-8, 2023.KB 13467 - No compatible products found when uploading cluster summary file KB 13903 - LCM Pre-check: "test_node_removal_status" KB 14104 - NCC Health Check: check_cvm_ssh_security KB 14121 - LCM Pre-check: "test_expand_cluster_status" KB 14277 - LCM Precheck: test_lacp_configuration KB 14304 - LCM 2.6: LCM upgrade will not fail when num_candidates > 0 KB 14407 - NDB | MSSQL AG Clone group deployment fails KB 14465 - Cluster outage can occur during multi-node removal when services go down on node which is yet to be detached KB 14522 - Slow start time of Siemens NX application on AHV due to FlexLM network query KB 14558 - Nutanix Cloud Cluster (NC2) on AWS - High space utilization during/post cluster recovery from S3 KB 14561 - License alert - Cluster is under-utilizing the Files license capacity. Usage: 0.00 TiB, Allowed license capacity: 1.0 TiB KB 14566 - NDB - OracleDB patching leaves old home and grid
Hello, I understand that if the node fails, the ha function is activated and attempts to recover. If one node fails in a Data Resilience Status Critical state due to a lack of storage space, will the cluster collapse? What happens.
I ma installing remotely Nutanix AHV cluster in very isolated environment, where for everything had to request firewall rules. IPMI is in different non-routable subnet, other that AHV and CVM. Firewall team confirmed that they don’t see any blocked traffic, but Foundation fails with error like this:2023-04-07 18:25:48,759Z WARNING Failed to register internal hypervisor: <Left ("Unable to satisfy any required capabilities for '<ExportedObjectDescriptor "command##.BindInternalHypervisor-1.0.0">'") at 0x52d10f8>2023-04-07 18:25:48,759Z INFO Tartarus initialization complete2023-04-07 18:25:48,996Z DEBUG Failed to load all plugins: Unable to satisfy required capability 'OPTIONAL_SMBIOS' for <ExportedObjectDescriptor "command##.LenovoRedfish_Pyghmi-1.0.0"> Skipping command##.GenericRedfish_Pyghmi-1.0.0, entity is disabled Unable to satisfy required capability 'OPTIONAL_SMBIOS' for <ExportedObjectDescriptor "command##.YadroRedfish_Pyghmi-1.0.0"> Unable to satisfy requi
Morning all!I have a 5 node cluster (5.20/ESXi7.0U3). its about 4-5 years old. Just got approval to upgrade and ordered a new 5 node cluster.Question: Is it best to expand current cluster and remove a node at a time, or set up net new and migrate?Looking for suggestions and experience.Thanks in advance!TJ
Can someone provide a brief explanation of Nutanix local key manager and how it handles the following in ‘???’:key access: access to the management console is restricted to authorized individuals abased on job function. changing / updating keys: encryption keys are updated from the management console, software encryption (rekey button) if necessary. revoking keys: ??? (when does revoking keys happen?) recovery keys: ??? (how do you recover if you have the key backup?) archiving keys: keys are archived (backed up) from the management console, managed keys where you download the key backup by setting up a recovery password to decrypt the backup file. activity logs: ??? (is there activity logs for keys? If yes, where is this stored and how long is the retention before the activity is overwritten?)BTW: I have this link already Native Local Key Manager (nutanix.com) but is does not have any details of the Thanks in advance.
Below are the top knowledge base articles for the month of March 2023.KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 1381 - NCC Health Check: host_nic_error_check KB 1113 - HDD or SSD disk troubleshooting KB 4409 - LCM: Life Cycle Manager Troubleshooting Guide KB 2090 - AHV host networking KB 13476 - Domain Manager Internal Service has Stopped Working (helios) KB 3786 - Alert - A1081 - CuratorScanFailure KB 2473 - NCC Health Check: cvm_memory_usage_check KB 2475 - NCC Health Check: storage_pool_space_usage_check KB 5228 - NCC Health Check: pcvm_disk_usage_check KB 8514 - NCC Health Check: fs_inconsistency_check KB 13150 - NCC Health Check: cfs_fatal_check KB 13136 - NCC Health Check: microservice_infrastructure_status_check KB 13870 - Prism Virtual IP is configured but unreachable alert and VIP be
Below are new knowledge base articles published on the week of March 26-April 1, 2023.KB 13758 - NCC health check: usb_nic_status_check KB 14480 - LCM 2.5: Intel hardware DCF firmware upgrade failure since the KCS Policy Control Mode is currently set to "RESTRICTED" KB 14488 - Error: Protection domain 'XXXX' has entities in clone. Delete the clones before deleting this protection domain KB 14502 - ASMFD may cause instability on Linux VMs running on AHV KB 14504 - After enabling CMSP on PC the protected entities under remote AZ shows error "Failed to Fetch" KB 14510 - How to extend storage on SQL database servers managed by NDB KB 14530 - Nutanix Files: "Invalid start IP address" error during deployment KB 14532 - Unable to install NGT as CDROM is not recognized in a Windows VM KB 14538 - VMware Update Manager (VUM) service crashing caused by a large amount of connections made to vCenter KB 14564 - Powering on the VM on the AHV host may fail with the "Unexpected combination of memoryBac
Hi, How can I disable ani-affinity rules ?
The NX G6 demo equipment is currently updated with the latest firmware. If you try to install version 5.10 to test the AOS upgrade with the latest version of the foundation, the 4. foundation version will not mount, and the 5. latest foundation version will not configure CVM after rebooting after installation and installation will fail. Is it like this originally?
Below are new knowledge base articles published on the week of March 19-25, 2023.KB 13943 - NCC Health Check: mantle_keys_mirroring_check KB 14416 - HW : Sporadic Link down alerts in IPMI Health event logs on a G8 hardware KB 14491 - Nutanix Object - Limitations of an Object-enabled cluster KB 14495 - Genesis service keeps crashing if a public key with a leading space character added to the cluster in PRISM Cluster Lockdown Settings KB 14496 - Era DB-Server Agent upgrade operation failed. Reason: cannot import name 'convert_bytes_to_string' KB 14503 - Data Protection - Error: Specified protection domain XXXX is protecting a Vstore which has id yyyy KB 14512 - Cluster Expansion fails if the new node was previously a Compute-Only node with network segmentation enabled KB 14514 - HPE DX380 G10 Plus: Filesystem Errors and I/O errors on a hypervisor boot volume KB 14519 - AHV and ESXi Lenovo Whitley platform hosts updated to UEFI 1.31 may restart due to NMINote: You may need to log in to th
I have a hyper-v vm that I’m looking to move to AHV. it’s a database with iscsi mounts. I know in the past move was not able to convert them. Is that still the case? If so does anyone know a way to convert these datastores? thanks.
Hello,I would like to change the password expiration for a local user I have created in the prism element.I’ve tried to change it via the command:nutanix@cvm$ sudo chage -M <MAX-DAYS> admin I’ve managed to do that to the admin user, but when I change “admin” with my local user, It says that the user does not exist in etc/passwd. Is their any way of changing the password expiration for a local user that it is not “admin”.(The user is a cluster admin).
Below are new knowledge base articles published on the week of March 12-18, 2023.KB 13746 - NCC health check: LongRunningSubtasks KB 13913 - LCM inventory fails with the error "nothing to open" on pc.2021.9.0.5 and later due to frequent registration/unregistration KB 14088 - NCC Health Check: check_host_password_expiry KB 14307 - Unable to start docker due to inode exhaustion in Objects cluster. KB 14391 - AHV upgrade or host rolling reboot tasks may fail on AHV clusters with AMD CPU during test_cluster_config pre-check KB 14433 - Objects: Bucket deletion failed with "The bucket you tried to delete is not empty. You must delete all versions in the bucket." error KB 14450 - Oracle DB in Oracle Dataguard configuration shows high latency / lag while performing NDB operation KB 14467 - Cluster will fail to upgrade through LCM if AOS version is 5.10.x or 5.5.x KB 14477 - NCC check may fail to complete due to vCenter connectivity failure KB 14479 - AHV hosts or VMs may lose network connectiv
We are triying to install a new Nutanix Cluster with 2 nodes Lenovo HS1021. The nodes machine type is 7D20. When we launch the installation with the Foundation, the use ends in failed and we see the following errors:WARNING Failed to register internal hypervisor: <Left ("Unable to satisfy required capability 'HYPERV_VERSION' for <ExportedObjectDescriptor "command##.BindInternalHypervisor-1.0.0">") at 0x7efbc4d82bd8>2023-03-14 17:15:27,733Z WARNING Skipping <ImagingStepPreInstall(<NodeConfig(X.X.X.X) @35d0>) @80d0> because dependencies not met2023-03-14 17:15:27,731Z WARNING Skipping <ImagingStepRAIDCheckPhoenix(<NodeConfig(X.X.X.X) @35d0>) @d150> because dependencies not met, failed tasks: [<ImagingStepInitIPMI(<NodeConfig(X.X.X.X) @35d0>) @d390>]2023-03-14 17:15:27,736Z DEBUG Setting state of <ImagingStepPhoenix(<NodeConfig(X.X.X.X.) @35d0>) @67d0> from PENDING to NR2023-03-14 17:15:27,736Z WARNING Skipping <ImagingStepPho
Greetings, Does the Nutanix Local Key Manager (LKM) satisfy the recommendations/requirements to safely implement the Data at Rest Encryption?The documentation at: https://portal.nutanix.com/page/documents/details?targetId=Nutanix-Security-Guide-v6_5:wc-security-data-encryption-aos-wc-c.html has the warning: "Caution: DO NOT HOST A KEY MANAGEMENT SERVER VM ON THE ENCRYPTED CLUSTER THAT IS USING IT!! Doing so could result in complete data loss if there is a problem with the VM while it is hosted in that cluster." I too share this concern, which led me to investigate External Key Managers, but I am wondering how does using the LKM alleviate this risk? Also, as stated in the Nutanix Bible as well as here: https://portal.nutanix.com/page/documents/solutions/details?targetId=TN-2026-Information-Security:TN-2026-Information-Security "Now that Nutanix supports its own native LKM, Nutanix also takes the KEK and wraps it with a 256-bit encryption key called the machine encryption key (MEK). The
There are still many places where the old version is being used.Even if you try to install it with the previous version (AOS 5.10 or lower version) of the foundation on the G6 device to test the upgrade, it cannot be installed.Is it because all the firmware is up to date? It was the version that was originally installed. AOS 5.10 versions are not installed now?In foundation the log is "Device 2 :The Length of Name is not correct" The phrase continues to print. Please reply from those with experience.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.