Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Want to know the maximum number of VLAN(802.1q) interfaces than can be created on each bridge of AHV. I cannot find any documentation or matrix about this. Thank you.
Hello, I have problem with the host reachability it goes out of cluster... When access it through the console I see the nics are up and enabled, however I can't ssh into CVM it's say not route to host eventhough it's running
I ma a dark-site NX-3060-G7 cluster. I need to know who is the manufacturer of the firmware for this machine so I can update the LCM firmware.
Hi everybody,We’re doing a slight restructure in our DC and in thus need to change the default gateway used by a Nutanix cluster (3-node cluster).I’m aware of the following guide:https://portal.nutanix.com/page/documents/details?targetId=Advanced_Admin-Acr_v4_6:ip__ip_reconfig_web_c.htmlBut isn’t it at all possible to change something as simple as just the Default Gateway without such an invasive procedure requiring downtime?The part of the article on how to do it manually is...Non-existent:https://portal.nutanix.com/page/documents/details?targetId=Advanced_Admin-Acr_v4_6:ip__cvm_ip_address_reconfigure_t.html
Recycle bin feature is available from AOS 5.18 onwards. With help from Nutanix Support, the recycle bin tool helps you to restore deleted storage entities (guest VMs and volume group vDisks) and manage the recycle bin itself.After you delete a guest VM, the configuration file and disk remain in the recycle bin for up to 24 hours. After 24 hours, these files are deleted. The files are deleted in less than 24 hours if your cluster is unable to maintain sufficient free disk space.Recycle Bin Limitations and Guidelines The recycle bin stores vDisk and configuration data for up to 24 hours. After 24 hours, these files are deleted. The files are deleted in less than 24 hours if your cluster is unable to maintain sufficient free disk space. Recycle bin is not supported on storage containers where metro availability is enabled. Recycle bin is not available for recovering protection domain snapshots. You can disable and enable the recycle bin or clear its contents. As a default, the recycle
What is better, 4x960GB SSDs per node or 2x1.9TB SSDs?We currently have 2x960GB SSDs and need to double the capacity. Cost aside, any benefits of one configuration over another?
Hi community, I have some Qlogic 10G/25G NIC cards in my cluster which as I understand are not “supported” however seem to be detected correctly to some extent. Manage_ovs show-interfaces displays the output below which leads me to belive that the driver is loaded. However, currently those ports are connected to a 10G switch and so the speed and the operational status are not correctly working. Is there a way to set these by hand? manage_ovs show_interfaces name mode link speedenp5s0f0 25000 False Noneenp5s0f1 25000 False None eth0 1000 False None eth1 1000 False None eth2 1000 False None eth3 1000 False None eth4 1000 False None eth5 1000 False None eth6 1000 False None eth7 1000 True 1000 When I add those cards to a vritual bridge I get the error message below. manage_ovs --bridge_name br1 --bond_name bond1 --interfaces 25g update_uplinks2021-03-31 18:05:50,402Z WARNING manage_ovs:437 Interface enp5s0f1 does not have link state2021-03-
Hi folks,Can I convert HC node to CO node? if yes, how?
How do I check hot and cold data by virtual machine? I'm going to migrate the virtual machines of the existing nodes to the node that I'm going to buy new ones. So, I'd like to check the hot and cold data of the virtual machines, respectively.
Below are the top knowledge base articles for the month of March 2021.KB 7503 - NX Hardware [Memory] – G6, G7 platforms - DIMM Error handling and replacement policy KB 4141 - Alert - A1046 - PowerSupplyDown KB 1540 - What to do when /home partition or /home/nutanix directory on a Controller VM is full KB 1113 - HDD/SSD Troubleshooting KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 9937 - Alert ID 111066 - Failed to send alert emails KB 4158 - Alert - A1104 - PhysicalDiskBad KB 6945 - How Upgrades Work at Nutanix KB 2090 - AHV host networking KB 2473 - NCC Health Check: cvm_memory_usage_check KB 3784 - Alert - A1030 - StargateTemporarilyDown KB 4519 - NCC Health Check: check_ntp KB 5582 - NCC Health Check: idf_db_to_db_sync_heartbeat_status_check KB 3741 - Nutanix Guest Tools Troubleshooting Guide KB 1863 - NCC Health Check: sufficient_disk_space_check KB 7386 - NCC Health Check: power_supply_check KB 6153 - NCC Health Check: default_password_check and pc_default_password_
Good morning All I have a bit of an NGT issue, the Prism Central alerts me to say some VMs need a NGT upgrade, when I go to upgrade them I see the message “NGT can only be upgraded on 0/1 VMs which have the available upgrade of NGT” Review and confirm buttons are greyed out so I cannot continue - what does the message mean and what do I do to get it to work? Many thanks Eric
We have 3 nodes with 2x960GB SSD and 4x4TB HDD.We need to expand storage (and storage only as it is going to be used to store cold data - we do not need additional processing power or RAM)Question 1: We simply added two 12TB HDDs to each node. Now each node has 2x960GB SSD, 4x4TB HDDs, 2x12TB HDDs. Everything is working fine, but we were told that this is not recommended. What is the problem with this configurationQuestion 2: Assuming the configuration in Q1 is not recommended and we want to end up with each node having one type of HDDs. We were told that we can upgrade the existing 4TB HDDs with 12TB drives. What the right procedure would be: a) Mark one 4TB drive for removal, remove it, insert 12TB drive in place of removed 4TB drive. Repeat 4 times for a node. Resulting configuration - 6x12TB HDDs per node b) Add two more 12TB drives first, then mark for removal and remove four 4TB drives (one by one). Resulting configuration - 4x12TB HDDs per node (preferred configuration by us)T
Looking at the site below, I understand that ESXi 7.0 is supported. But I'm not sure if vCenter 7.0 is supported.https://portal.nutanix.com/page/documents/compatibility-matrixIs it a problem to use vCenter 7.0 ?Also, where can I find out which vCenter versions are supported?
I am trying to move a VM from EXSI to AHV. When I try the move I get the error “VMTools is not running.” any suggestions?
Hardware failures are a part of any datacenter lifecycle. The Nutanix architecture was designed with this inevitability in mind. A cluster can tolerate one or two failures (depending on the replication factor of the cluster or container) of a variety of hardware components while still running guest VMs and responding to commands through the management console. Many of these failures also trigger an alert through that same management console in order to give the administrator a chance to respond to the situation.Nutanix provides the ability to tolerate rack failures for extended data availability, in addition to drive, node, block, and network link failure.Block fault tolerance lets a Nutanix cluster make redundant copies of data and metadata and place the copies on nodes in different blocks.A block is a rack-mountable enclosure that contains one to four Nutanix nodes. All nodes in a block share power supplies, front control panels (ears), backplane, and fans.Nutanix offers block fault
Failures are part of everything and Nutanix Clusters is not immune to it. But how we plan for failures determines the versatility of the product or a person for that matter!!Nutanix categorizes the type of failures into availability domains essentially based on type of failure. Nutanix provides the ability to tolerate rack failure for extended data availability, in addition to drive, node, block and network link failure. Node FailureA Nutanix Node comprises Physical host and a controller VM. Both these components can fail without any impact to the Nutanix cluster.CVM failureWhen a CVM fails, an alert is generated in Prism and another CVM redirects the storage path on the related host to another CVM. Read and writes will occur over the 10GbE network until the CVM comes back online.It is business as usual for the end customer with maybe a slight performance decrease.Controller VM FailurePhysical Host failureIf a node fails, all HA-protected VMs can be automatically restarted on other nod
Hello, I tried to change the Prism admin password today, but the admin account keep locked automatically. So every time I have to reset the admin account from a CVM, but it gets locked after 5 minutes.
Application monitoring provides visibility into integrated applications by collecting application metrics using Nutanix and third-party collectors, providing a single pane of glass for both application and infrastructure data, correlating application instances with virtual infrastructure and providing deep insights into applications performance metrics.Application monitoring provides visibility into the following applications Microsoft SQL server VMware vCenter Server The monitoring integrations dashboard allows you to view information about select applications, such as SQL Server or vCenter instances, running in the cluster.To access the monitoring integrations dashboard, select Operations -> Integrations from the entities menu. The monitoring integrations dashboard allows you to view the summary information about application instances and access detailed information about each instance.You can filter the list by opening the filter pane to select one or more of the filter options
Hi folks, In VMware, we need to enable EVC to be able to do vMotion between diff processors, what about AHV? what should be done or is it working smoothly?
Below are new knowledge base articles published on the week of March 21-27, 2021.KB 10516 - [ Karbon ] PE cluster is showing alerts for VGs used by the Kubernetes cluster(s) KB 10651 - NCC Health Check: metering_rest_connection_check KB 10768 - A number of VMs may be missing from the list when monitoring cluster using SNMP protocol KB 10813 - "UnicodeDecodeError" and "UnicodeEncodeError" for VM operation KB 10936 - Duplicate scheduled reports triggered after Daylight Savings Time (DST) change KB 10946 - Identifying the source IP generating TCP Reset packets in a network path KB 10953 - Using Nutanix Objects Self-Signed Certificate with Veritas Enterprise Vault KB 10954 - SMCIPMITool commands output "The node product key needs to be activated for this device" on BMC 7.10 KB 10967 - Cloning a Secure boot enabled VM on AHV with the "Custom Script" option enabled fails with "q35 machine type does not support ide bus type" error KB 10976 - Cluster instability after upgrading both primary an
HiI have 4 Nodes cluster with the detailed network belowVLAN1000 : IPMI Usage (192.168.255.x/24)VLAN20 : GuestVM & Internal Cluster Network (192.168.2.x/24)I was using eth3 and eth4 in bond br0-up in bridge br0 (vs0) And then i’m adding a new vlan (VLAN30 : 192.168.3.x/24) for separating GuestVM network from Internal ClusterI am using eth0 and eth1 in another bond (bond br1-up in bridge br1) connected to my switchport mode access VLAN30. The problem is, when i created VM using that network (vs1), my guest vm cant ping anywhere even the gateway of its subnet. But when i test my laptop that connected to the switchport mode access VLAN30, my laptop can ping the Gateway.Here i give the detail of my topology and uplinks configurationTopologyUplinks of each hostsvs1 configuration Perhaps someone can enlight me maybe i missed something here when i’m trying to configure this? Thank you.
NVIDIA GPUs primarily have two modes of operation: Compute and Graphics.Compute Mode: the GPU operates within a configuration that is optimized for high-performance computing applications.Graphics Mode: the GPU is optimized for graphics processing and can subsequently be assigned into vGPU profiles for virtual machines (vGPU profiles cannot be used while in compute mode).Various NVIDIA GPUs are provided with default configurations for either of these modes and, sometimes, it is necessary to change the mode to better suit the corresponding workload of the host.In previous models of GPUs, it has been necessary to temporarily boot an AHV host into a NVIDIA-provided Linux ISO and invoke a “gpumodeswich” command with options to apply this change. With newer models of GPU, a command can be found natively within the AHV host filesystem after the corresponding GRID driver has been installed.You can find more information regarding this command via the “Nvidia: Unable to Assign vGPUs to guests w
We have numerous clusters and each have their own hardware platform (and in a couple of cases, we’ve even mixed hardware models within the same cluster). Our current Nutanix footprint;VENDOR MODELS NODE COUNTSuper Micro NX-8155-G7 12Super Micro NX-1175S-G6 7Super Micro NX-3060-G7 6Dell XC630-10 14Super Micro NX-8035-G7 12Super Micro NX-8035-G6 36Is there a preferred or recommended solution for hardware monitoring and alerting? For instance; Dell OpenManage (DOM) or Supermicro Server Manager (SSM). I don’t readily know if either would support the others solution (like DOM supporting IPMIs or SSM supporting iDracs) Or, would Prism Central (and Prism Element) be sufficient for hardware monitoring and alerting?We currently have and are using DOM but not for the SuperMicro hardware so I’m wondering if I’m potentially missing out on a better solution or not.
Hi!I am wondering, if there is a quick way to restore from a failed ESXi upgrade.Imaging you have fired up a ONE-Klick-Upgrade of the ESXi image, and (as see with ESXi7.0U1GA) the hypervisor is not boot up again.At ESXi level i can backup config and restore config after a plane install. But what about CVM?Setting up the whole node with foundation is a nightmare, if the node is already installed in an customer environment, and can’t be discovered.The best way would be, that the foundation within a cluster could deploy a CVM to a plain ESXi and rebuild the cluster-node from the information stored in the cluster...
HI Team under Prism we’ve created a few VM’s (windows), one of VM is our File Server, current configuration is IDE disk 1TB, (60GB OS, 900GB shared folders). probably is better to create one virtual disk 60GB on OS and the second virtual disk as storage (1TB) or more.question is how to shrink current IDE disk from 1TB → 60GB, and if IDE should be change on SCSI disk, what Nutanix recommended?instruction to shrink disk IDE->SCSIthanks Dariusz
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.