Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hello Team,I hope you are doing well,I am learning more about Nutanix platform , can please share document(s) or KB(s) on how the physical disks are used in a Nutanix host? ie if the disk in slot 1 is reserved for CVM or m.2 is reserved to install the OS,I want to have my own guide that shows all models with their own disk layout according to their possible combinations -single SSD , dual or quad SSDs the rest of the slots are populated with HDDs -hybrid-or all slots are populated with SSDs ..ect.BRAdel
Below are new knowledge base articles published on the week of January 29-February 4, 2023.KB 12456 - NCC Health Check: ahv_gateway_check KB 13445 - Alert - A130377 - StaleVolumeGroup KB 13611 - Alert - A130382 - SynchronousReplicationPausedOnVM KB 13739 - Alert - A300441 - RecoveryPlanDynamicSubnetExtensionDeletionFailure KB 13773 - Alert-A130385 - SyncedVolumeGroupRunningAtSubOptimalPerformance KB 13796 - Alert - A130386 - AutoPlannedFailoverOfVolumeGroup KB 14126 - LCM Pre-check: test_ptagent_status KB 14173 - The cluster raises "A130184: Data At Rest Encryption key backup warning: Last user backup taken at MMM DD" even after performing the backup. KB 14211 - OpenShift 4.12 installation via the “openshift-install create install-config” command fails KB 14222 - Nutanix Database Service - Ubuntu/Debian DB Provisioning is failing due to static IP allocation failure KB 14224 - LCM UI is not available and inventory task stops at 0% KB 14234 - Alert - A160054 - File Server Partner Server
Below are the top knowledge base articles for the month of January 2023.KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 2473 - NCC Health Check: cvm_memory_usage_check KB 13870 - Prism Virtual IP is configured but unreachable alert and VIP becomes permanently unreachable observed on AOS 6.5.1 and later KB 4409 - LCM: Life Cycle Manager Troubleshooting Guide KB 1113 - HDD or SSD disk troubleshooting KB 2090 - AHV host networking KB 3827 - Alert - A130087 - Node Degraded KB 13150 - NCC Health Check: cfs_fatal_check KB 4519 - NCC Health Check: check_ntp KB 8514 - NCC Health Check: fs_inconsistency_check KB 5228 - NCC Health Check: pcvm_disk_usage_check KB 3786 - Alert - A1081 - CuratorScanFailure KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 4141 - Alert - A1046 -
Below are new knowledge base articles published on the week of January 22-28, 2023.KB 12548 - NCC Health Check: attached_vm_volume_different_recovery_clusters_check KB 12922 - Alert - A130369 - DistributedOplogFeatureDisabled KB 13040 - NCC Health Check: attached_vm_vg_protection_check KB 13100 - Alert - A130371/A130372/A130373/A130374/A130375 - DrNetworkSegmentationRemote KB 13513 - Alert - A160157 - FileServerVMcoreDetected KB 13889 - CRUD operations are not permitted on a stale Volume Group KB 13956 - CMSP enabled PC upgrade fails with error "Max retries done: unable to push docker image msp-registry.cmsppc.nutanix.com:5001/alpine:3.12" KB 13983 - Allow Out-of-band (OOB) snapshot for 3rd patry backups on RF1 VM KB 14177 - ESXi upgrade stuck at 14% due to vMotion taking longer than 15 minutes KB 14186 - Nutanix Files - Manual DNS verification fails even if the DNS entries are properly created KB 14195 - Acropolis service may crash with "Unexpected CAS error while trying to delete an
Below are new knowledge base articles published on the week of January 15-21, 2023.KB 10596 - Prism Central Pre-Upgrade Check: test_prism_central_cmsp_enablement_check KB 14074 - LCM Pre-check: test_empty_ilo_task_queue KB 14105 - After AOS upgrade to 6.x, users with the Prism Element Backup Admin role are unable to use AD credentials to log in to Prism Element KB 14167 - AHV upgrade is blocked in LCM 2.5.0.4 or newer if running vGPUs VMs are found KB 14185 - Power state of VMs managed by the Nutanix AHV Plugin for Citrix on AHV clusters changed to "Unknown" after upgrading AOS cluster to version AOS 6.6 or newer KB 14194 - Metrics-enabled (vhostmd) VMs fail to start on AHV 20220304.x KB 14198 - UpdateVmDbState task can often be seen on AHV clustersNote: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of January 8-14, 2023.KB 12052 - NCC Health Check: Prism Central disaster recovery PE-PC version compatibility check KB 13210 - NCC Health Check: pcvm_reboot_check KB 13272 - Pre-Upgrade Check: test_max_pe_nodes_registered_to_pc KB 13301 - Pre-Upgrade Check: test_prism_central_run_cmsp_preupgrade_check KB 13666 - Pre-Upgrade Check: test_prism_central_pcdr_compatibility_check KB 13676 - NCC Health Check: category_threshold_alert KB 13766 - Prism Central Pre-check: test_event_audit_counts_under_threshold KB 13872 - Pre-upgrade check: test_prism_central_pcdrv1_enabled_check KB 13979 - Custer creation fails on HPE DX G10 Plus nodes if there are no disks installed in a storage controller KB 14076 - In microservice infrastructure enabled Prism Centrals, /home directory space can be exhausted due to docker folders KB 14130 - LCM is running in Offline mode KB 14142 - Nutanix Kubernetes Engine - Pod to service communication does not wo
I can’t create a new scenario it says: “Install country missing”There is no option for me to input the Install CountryOnly options i have are Scenario Name and Scenario Objects.
As title, Does AOS 6.x support Fault-Tolerance on ESXi 7.x ?If positive, does it support more than 4 FVTM in an ESXi 7 host ? I had read https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.avail.doc/GUID-57929CF0-DA9B-407A-BF2E-E7B72708D825.html . Can I change parameters to support more than 4 FTVMs in an ESXi host?
Hi, One of my employees deleted 2 VMs with the name like xxxxxxxxxxxB1234 and xxxxxxxxxxxxxB1235 and at the same time xxxxxxxxxxxxxT1234 and xxxxxxxxxxxxxxxT1235 were deleted. (Logs show that he deleted them like less than a minute later) He claims that he did not touch those two. Is it possible that two VMs can be corelated somehow and deleting one triggers deletion of another one? One was bench and one was test. The only difference in name was one letter.
Hi all, I’m wondering if someone can help me out with the first install of a nutanix CE single cluster with esxiThe installation went fine but, and followed this link to make it work. https://vmik.net/2021/01/26/nutanix-ce-install-esxi-2021/I see that only have 1 disk in the storagepool. Is there a way to add a disk into the CVM? or do I have to mount it first. can someone help me out? many thanks.
My hardware - NX-6035-G4 running 5.20.3.5 LTS and is no longer under support. It is one of 8 in the cluster. We use this as a backup target for our two other production clusters using protection domainsI was attempting to replace a satadom because I got this error satadom has worn out - PE cycles above 4500 or PE cycles above 3000 and daily PE cycles above 15.I followed the instructions on this page to get things started, but after 8 hours of trying to clone the satadom disk the process timed out - put the node in maintenance mode and detached it from the Metadata Store. I took the node out of maintenance mode to add it back to the Metadata Store, but the option has not popped up in PE. Here is the output from an NCLI host list. Id : Uuid : Name : IPMI Address : Controller VM Address : Controller VM NAT Address : Controller VM NAT PORT : Hypervisor Address : Host S
Hello Ma’am and Sir,Does anybody tried installing or imaging a single node using phoenix? please i need some help/procedure for this as I can’t access the links given in this page it only shows “Not Found or Fordbidden”: Appendix: Imaging A Node (Phoenix) | Nutanix Community…...specifically in “Installing the Controller VM and Hypervisor by using Phoenix” and “Imaging Bare Metal Nodes”…..I created bootable phoenix using USB then i am now in the root@phoenix but I bet it requires some commands to push but have no idea on the commands and theres no search result in the internet regarding that
Hi. I’m trying to use Nutanix collector 4.0 to collect Hyper-V sizing information, however the following error message is displayed during the scanning phase:“Bad http response returned from the server. Code: 500. Content”I tried to use it with Remote option and locally on a cluster member and the same happens.Running the precheck script it shows these failures on the picture: The user logged in is a Domain Admin and local admin, however the script returns a failure about the user rights. Does anyone know how can I enable the “Basic auth” stated on the script output?I also tried Collector version 3.5.1 with no success.Any tips?
tl;dr how to perform pre-upgrade checks from the command line?Hello Guys,I have a question related to the performing manual / cli upgrade (command line). Here’s the scenario:AOS with ESXi as a hypervisor, multiple ROBO offices / Dark Site (no access to the internet), Dark Site server with LCM, very limited broadband: 16Mbit with static shaping (4Mbit) for management purposes and 12Mbit for businessIt is very difficult to upload via AOS GUI 4-5GB of upgrade and .json file. 3-4% / 10minutes and upload task informing about a ‘server issue’. I’m 99% sure that it related to the broadband shaping.Solution is simple:upload tar.gz install/upgrade bundle, ‘untar’, install ( ./install/bin/cluster -i ./install upgrade )My question is: is any magic command to start pre-upgrade tasks with is normally presented in GUI if upgrade package is available? It will be very helpfull to start pre-upgrade check in-advance the main upgrade.I tried to find the command in lab:-- uploaded the bundle in ‘normal
Hi Our setup will look very similar to the attached diagram once it’s setup (taken from here - https://portal.nutanix.com/page/documents/details?targetId=Nutanix-Security-Guide-v6_1:wc-network-segmentation-intro-wc-c.html). We won’t have the separate DVS for the VM’s though as these will be on the same DVS with everything else 😊 What I'm trying to understand is what the vmk2 kernel interface is used for and why this must be on its own port group and can’t use the same port used by the CVM. I’ve illustrated what I thought should be possible with the blue line. Within Prism where you change the setting for the Backplane network, you must select a port group for the CVM and for the host. However, when you try to select the same port group for both host and CVM it gives an error and won’t let you do it. Does anyone know why they need to be on separate port groups even though they will be on the same Backplane VLAN? I hope that made sense
nutanix ERROR ipv4config.py:1811 Unable to get the KVM device configuration, ret 1, stdout , stderr br0-backplane: error fetching interface information: Device not found\n Anyone know what to do with this error. I turned on remote syslogging to see why a host has been crashing and I see this as one of the errors in the logs. The host is a Dell PE R630.Not sure if KVM means the host OS, since AHV basically is KVM or an actually connecting to iDRAC for Keyboard Mouse Video.
What metrics are considered when Acropolis Dynamic Scheduling makes a migration decision on AHV related to CPU usage? Does ADS consider only CPU usage on the Host? Or does ADS take into consideration other VM or Host metrics such as CPU Ready, Co Stop, and/or Steal Time?
Below are new knowledge base articles published on the week of January 1-7, 2023.KB 14008 - NDB - Operation for Oracle DB Patch not applied on the DB but NDB UI shows successful KB 14134 - Foundation and Phoenix Fail Immediately With Error "livecd files not found" KB 14147 - Active Directory, SNMP, or SMTP configuration may be lost following BIOS firmware upgrade with LCM when using G6/G7 BMC 7.11Note: You may need to log in to the Support Portal to view some of these articles.
Below are the top knowledge base articles for the month of December 2022.KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 4409 - LCM: Life Cycle Manager Troubleshooting Guide KB 1113 - HDD or SSD disk troubleshooting KB 3827 - Alert - A130087 - Node Degraded KB 2090 - AHV host networking KB 3786 - Alert - A1081 - CuratorScanFailure KB 8514 - NCC Health Check: fs_inconsistency_check KB 2473 - NCC Health Check: cvm_memory_usage_check KB 4141 - Alert - A1046 - PowerSupplyDown KB 4519 - NCC Health Check: check_ntp KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 13150 - NCC Health Check: cfs_fatal_check KB 13870 - Prism Virtual IP is configured but unreachable alert and VIP becomes permanently unreachable observed on AOS 6.5.1 and later KB 5228 - NCC Health Check: pcvm
Below are new knowledge base articles published on the week of December 25-31, 2022.KB 13517 - Cluster fetching the old SMTP server details after it has been changed KB 14084 - Nutanix Kubernetes Engine - Node Image upgrade in clusters with K8s 1.22.9+ may wipe a proxy configurationNote: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of December 18-24, 2022.KB 13919 - Nutanix Files - Removing ICAP servers causing performance issue and access denied while trying to access smb share KB 13921 - Ultimate trial expiry alert on the Prism central KB 14012 - Error "Cannot read properties of undefined (reading 'length')" while setting Category based Affinity Policies on PC KB 14033 - Upgrading NGT through Prism Central shows the task failed but NGT shows the latest version on guest VM KB 14038 - Src and Dest incorrectly show Any/Any for all rules in Flow Virtual Networking ANC VPC policies on PC 2022.6.x KB 14064 - SSH SCP function via TeraTerm fails with the error SSH2_MSG_CHANNEL_OPEN_FAILURE KB 14071 - Hypervisor does not boot after a chassis or a node replacement with mirrored NVMe drives KB 14080 - Minimum AOS version Support for HPDX FSC Platforms KB 14091 - On IAMv2 enabled Prism Central AD or LDAP user unable to edit VM or open VNC console KB 14099 - Disks
Hello All, I am working with Affinity policies and I wonder if there is an Affinity “light”. What I mean by this is in Hyper-v clusters you have a “Preferred Server” this means that if the preferred server is available the vm will reside there if not it will move to stay running. Once the preferred server is back online then it will move back. Is this possible in AHV? Thanks,Scott
Hello guys,I’m trying to use ansible collection to manage nutanix. I tried to use examples attached to that collection, however for each playbook i got the same faied output: “Failed to convert API response to json”. Any idea what can be wrong? ansible env is up2date.
Is there any way to integrate Apache Cloud Stack with Nutanix AHV
Below are new knowledge base articles published on the week of December 11-17, 2022.KB 13976 - Windows VMs with vTPM enabled are unable to be snapshotted and give the error "Failed to capture the Recovery Point for VM 'VM_NAME'" KB 13996 - Logs and information to collect in preparation for a new support case KB 14000 - VPN connectivity is lost due to change in the subnet IP's of the Nutanix cluster KB 14019 - Prism Central - Install of NGT through Prism Central on 20+ VMs causes aplos crash and fails KB 14028 - Cost Governance (formerly Beam) may not show data before a certain date for GCP billing accounts. KB 14041 - Creating a Playbook in X-Play returns the error "Not authorized to impersonate user" KB 14045 - Inconsistent HA state on the AHV cluster KB 14054 - VMs running on AHV clusters and using a GPU type of passthrough may fail to detect GPU after an AHV upgrade KB 14057 - Unable to remove Active Directory Configuration in NDB KB 14061 - Nutanix Files - Upgrading Files from Pris
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.