Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Dear all, I have previously asked, but it was wrong forum, i have existing cluster with Dell XC630-10 4 node, and i want to expand capacity in my cluster, but my team can only buy new hardware ( dell XC640 ) cannot buy dell xc630-10 again, can i expand my cluster with different hardware? and please advice about the step to expand my cluster
# On March 4, I posted the following but I have written the wrong answer myself, and the status of that bank has become "solved". # Actually it remains unresolved. I will post it again because I want to resolve it by all means. # The problem is "CVM can only communicate with AHV". Dear All, I am trying to build Nutanix CE into the environment of Nested ESXi. I downloaded and prepared the latest version of ce - 2018.05.01 - stable.img.gz. The ESXi to build the AHV is 6.0. First of all, we started to work as a single node cluster, we plan to develop into a 3 node cluster if it works. 192.168.0.27/24 to AHV, GW: 192.168.0.254. I set up CVM 192.168.0.28/24, GW: 192.168.0.254 and started the installation. After waiting for a while, a message stating that the installation was successful is displayed and the message "Nutanix CVM IP: 192.168.0.28" is displayed. However, only AHV can communicate with this CVM, and it can not communicate with other devices on the same subnet. If you che
Dear All, I am trying to build Nutanix CE into the environment of Nested ESXi. I downloaded and prepared the latest version of ce - 2018.05.01 - stable.img.gz. The ESXi to build the AHV is 6.0. First of all, we started to work as a single node cluster, we plan to develop into a 3 node cluster if it works. 192.168.0.27/24 to AHV, GW: 192.168.0.254. I set up CVM 192.168.0.28/24, GW: 192.168.0.254 and started the installation. After waiting for a while, a message stating that the installation was successful is displayed and the message "Nutanix CVM IP: 192.168.0.28" is displayed. However, only AHV can communicate with this CVM, and it can not communicate with other devices on the same subnet. If you check the Arp Table of another Linux machine on the same subnet, the correct MAC address of CVM is registered but the MAC address of this Linux machine is not registered in the Arp Table of CVM side. Only the MAC Address of AHV is registered in the Arp Table of CVM. CVM can not communic
Would I be able to create storage containers in my cluster for the purpose of "pinning" VMs only to hosts that are assigned to the containers - restricting VMs to the hosts that belong to the container? The need is to control VM migration during Software Upgrades due to multicasting issues with the hosts.
Is it possible to mix, 3 node All Flash NX-3360-G5 &4 node Hybrid NX-1465-G5and form a AHV cluster ? NX-3360-G5 is 2*10 core CPU, 12*32GB Memory, 18*1.9TB SSD whereas NX-1465-G5 is 2*10 core CPU, 8*32GB Memory, 1*960GB SSD, 2*4TB HDD how storage tearing will work in this scenario ?
I'm trying to get a better basic understanding with regards to controllers in a VM farm's data path. We are going to be in the process of migrating some of our farm resources to another data center which may include powering down controllers in a rolling fashion. What type of service interruptions would users expect to see?
I'm trying to add a new vCenter target but I get this error :
trying to find the mobility installer?
I'm running nutanix 5.5.0.7 with esx ,when i create vmware machine,it's prompts “ This cluster is not registered to any vCenter server. You must register a management server and enable DRS before you can create a VM. ” Is vcenter installed directly on the node node ,then register this vCenter and enable DRS? Thanks in advance,
Hello again CE community! I'm running a Dell R730 with these specs: 2 Sockets 8 Cores Each Socket 256 GB RAM I'm running ESXi to run a 4-node cluster and want to parcel the CPU and Memory evenly among the 4 CVMs. Q1: Based on this, what should my CVM CPU/RAM settings be? Q2: When I allocate vCPU and RAM for VMs, how do I translate a bare-metal config spec e.g. 4x WS2016 8 CPU, 32 GB RAMto Nutanix VM specs, based on these constraints? I just need an example to shine light on how to break down the physical to esxi to nutanix CVM to VM specs. Thanks in advance, Brit
I have a problem with arp requests on the bridge for guest traffic In the drawing below the current architecture. If a request arrives from the outside, passing through the firewall, and the firewall is starting to communicate to a VM connected to a NIC to BR1-UP bond of BR1 bridge, the ARP request for the resolution of the VM address stops at the bridge BR1 and do not reach the VM, in this case the firewall and VM ARP tables remain unpopulated and the communications stop. On the other hand, if the communications depart from the VM to the Firewall (for example with a ping) the ARP request is processed by the firewall and the ARP tables of firewall and VM are correctly populated with the respective MAC ADDRs. Firewall IP and VM IP are in the same broadcast domain, no routing. I checked with Wireshark on the windows VM, with tcpdump and ovs-appctl fdb/show on the Nutanix host and when the communications start from the firewall the ARP request goes up to the physical card of the BR1
Yesterday our Nutanix CE cluster suffered a node loss (onboard NIC went offline somehow, investigating), HA failover performed correctly, but I had Zabbix monitoring cluster API 2.0 which did not state there is a problem. The only difference was that the host stopped being visible in the discovery by its proper name and remained only by IP, every other reading were "normal" and "not degraded" and even cluster state was reported "normal" during host effective downtime. WTF?! Also, WTF is with re-posting a question to another forums when asked to? Do you maybe have crosslinks allowed to ask the same question in a different subset of forums?
I tryed to run xtract but I'm facing a problem to install the VirtIO tools. Using the automatic script on xtract it's end with the error: "ExitCode: '1603'". If I try to install VirtIO manually the show this message "ended prematurely because of an error. Your system has not been modified". Creating a verbose log file, from the installation, I see some errors like this: MSI (c) (08:18) [22:06:00:591]: Package to be registered: 'Nutanix-VirtIO-1.1.3.msi' MSI (c) (08:18) [22:06:00:591]: Note: 1: 2205 2: 3: Error MSI (c) (08:18) [22:06:00:591]: Note: 1: 2262 2: AdminProperties 3: -2147287038 or Action start 22:06:00: PrepareDlg. MSI (c) (08:50) [22:06:00:623]: Note: 1: 2205 2: 3: Error MSI (c) (08:50) [22:06:00:623]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 2898 Info 2898.For WixUI_Font_Normal textstyle, the system created a 'Tahoma' font, in 0 character set, of 13 pixels height. MSI (c) (08:50) [22:06:00:623]: Note: 1: 2205 2: 3: Error MSI
Morning, i am attempting to add my other NUTANIX instances to my Prism Central instance, and for both they get the "REMOTE CONNECTION CREATION TIMED OUT" error.
I've inherited a Nutanix setup. I've noticed there is 1 Storage Pool setup and 4 Storage Containers. (see screenshot). I don't know what is the Default setup looked like so I don't know which are required. I'd like to have 1 container. Currently attached to Nutanix Host VDI_POC nutanix-peristent-pool Not attached NutanixManagementShare SelfServiceContainer All of my VMs are on the VDI_POC. Can I somehow delete the other 3 and combine them into the VDI_POC without losing data/downtime?
We have a scenario in which we are running VMware vSphere environment on existing servers and planning to deploy a DR site. Is it possible that we deploy a Nutanix AHV environment at the DR site and replicate from the existing ESXi environment at the Production site to the Nutanix DR site somehow? We are currently using Veeam backup and replication for VMware for backup. What is the possibility of such a requirement?
Hello, We have an 5.1 AOS cluster (EOL I know), we wish to upgrade to latest possible LTS (which seems to be 5.5.8). The ncc is clean but the preupgrade fails at 3°% claiming a zookeeper is not reponding on one of the CVMs. But allssh genesis status | grep zookeeper zookeeper: [3967, 3996, 3997, 4003] Connection to @1 closed. zookeeper: [3899, 3928, 3929, 24979, 25089, 25105] Connection to @2 closed. zookeeper: [3919, 3948, 3949, 7259, 7365, 7380] Connection to @3 closed. zookeeper: [3923, 3952, 3953, 7709, 8032, 8047] Connection to @4 closed. And code:ncc health_checks system_checks zkinfo_check_plugin runs normally. What could be the issue? Thank you
Hi All, I did use Nutanix CE on a standalone server before for testing and for backup recovery test. Today I was trying to install the new CE version ce-2018.05.01-Stable. The previous version I used was CE0-2017.05.22-Stable. Now the hardware is same. 1x 240 GB SSD, 2x 500 GB HDD, 3x 1TB HDD. 128 GB RAM Boot from USB. 3x 1 TB drives are in Raid0 - Storage 2x 500 GB drives are in Raid0 - ISO's 1x 240 GB drive is in Raid0 - OS - (I tried this with Raid and with out raid.) this time when it is checking the disks it says "MinimumRequirementsError: A set of disks matching the minimum requirements was not found" is there any changes to the minimum hardware requirements with new version of CE? Please help me with this. Thank you, Krishna
Hi, I'm trying to create a schedule for an existing Protection Domain like this: code:def createProtectionDomainSchedule(self,pdname): # Set the schedule for the protection domain try: policy = {"retention_policy": {"remote_retention_type": None, "remote_max_snapshots": {}, "local_retention_period": None, "local_max_snapshots": 1, "remote_retention_period": {}, "local_retention_type": None}, "start_times_in_usecs": [1549477620000000L], "rollup_schedule_uuid": None, "user_start_time_in_usecs": 1549477620000000L, "is_rollup_sched": None, "pd_name": pdname, "values": None, "suspended": False, "app_consistent": False, "end_time_in_usecs": None, "type": "DAILY", "id": "63c037e5-41e4-4630-8641-23509a5360a1gg", "every_nth": 1} protectionDomainURL = self.base_url + "/protection_domains/"+pdname+"/schedules" serverResponse = self.session.post(protectionDomainURL, policy ) print serverResponse.text return json.loads(serverResponse.text) except Ex
HI , I have Question, i want to build new cluster Nutanix using Nutniax NX3000 Series G6, Now I have existing Nutanix cluster running with server NX1000 Series G5. I want to Migrate All VM from the existing Nutanix cluster to the New Nutanix Cluster, Is it possible migrate between cluster nutanix? Can you please tell me step-step to migrate?
I have a scenario where I only have the vmUUID available to me and the NGT tools aren't currently installed on a VM so it appears to be limiting what I'm able to do with the API. Is there a way to retrieve a VMs vmID using the vmUUID?
GV Govindasamy (Nutanix Senior Solutions and Performance Engineer ) has written a series of three blog posts on data locality, I thought I would summarize and share them here. Be the first to reply with a question below. Does data locality really matter? Does data locality matter in HCI Architecture? Data locality is not just about storing new data in local node. It's also about keeping relevant useful data local when needed for low latency access. Read more. Can data locality help scale throughput? X-Ray's throughput-scalability-random-reads and throughput-scalability-sequential-reads tests help answer the following: Can IOPS or throughput rate sustain over time? As number of nodes grow in cluster, can throughput or IOPS scale with it? Read more. What if Data Locality was not a design choice in Nutanix AOS? What if data locality was not considered in Nutanix AOS architecture like a few other HCI architectures available in the market? Would AOS suffer the same as other ar
I have windows 2012 r2 VM but I forget the windows administrator password. When I'm trying to reset the password from recovery command line using below command. X:\sources d: cd windows\system32\ren utilman.exe utilman.exe.old copy windows\system32\cmd.exe utilman.exe. Usually above command will work for normal physical windows server , ESXi Guest vm's to reset the local administrator password. ** In nutanix recovery command line I am unable to view my actual OS disk. Is there any way, How can i view my guest VM os disk on recovery mode. ?
Is it possible to do RF3 with a 3 node cluster? If so any minimum requirements?
Yes. of course. The real answer lies on how these failures are handled in HCI architectures. What happens to the Data Availability during these failures? The questions arise: Does HCI architecture start protecting data as quickly as possible? How smart the architecture is to rebuild the lost data and how long it's going to take? If the rebuild takes longer, this time window is called risky period. Administrator must hope that there is no other failure occurs during this long rebuild window to ensure FTT and RF requirements. Vendors may offer another brute force method of increasing RF / FTT which increases the cost (in the absense of smart architecture). In this video, I have two disk failures simulated with soft disk pulls on Nutanix AOS. This short video can articulate how fast the AOS gets into action to protect the data from subsequent failures and how fast it completes with its truly distributed architecture by employing all available resources in the cluster w
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.