Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
AWS or Azure can be configured as a remote site for backup and restore operations, this feature is known as cloud connect. The cloud connect feature enables you to back up and restore copies of virtual machines and files to and from an on-premise cluster and a Nutanix Controller VM located on the Amazon Web Service (AWS) or Microsoft Azure cloud. The Nutanix Controller VM is created on an AWS or Azure cloud in a geographical region of your choice. It is a single-node cluster with a 30 terabyte (TB) disk attached to the node, with a usable disk capacity of 20 TB. Amazon or Azure customers are charged only for capacity that is used (not charged for the full capacity). Once configured through the web console, the remote site cluster is managed and monitored through the Data Protection dashboard like any other remote site you have created and configuredCloud configuration guide at : Cloud Connect (AWS AND AZURE)Step-By-Step Azure Remote Site Configuration for Azure Cloud Backuphttps://port
This article’s motive is to provide you the information required for troubleshooting the alert “iSCSI Configuration Failed” for your Nutanix cluster.What is iSCSI Configuration? To provide access to cluster storage, Nutanix Volumes utilizes an iSCSI data services IP address to clients for target discovery which simplifies external iSCSI configuration on clients. This iSCSI data services IP address acts as an iSCSI target discovery portal and initial connection point. This IP address is also used as a cluster-wide address by clients configured as part of Nutanix Files and other products.The iSCSI Configuration Failed alert can be generated if Nutanix Guest Tools failed to execute some iSCSI commands on the guest VM.For more troubleshooting, check KB-10118.For information on the iSCSI Configuration, check the iSCSI guide.
Cluster creation or initialization is a process of bootstrapping the cluster by configuring the unconfigured nodes, load some node information into Zeus configuration file and start the services. Let's break it down. What is an Unconfigured node? Node which are factory shipped. Node which was removed from an existing cluster. These nodes are typically Pre-installed with CVM/HypervisorNO IPv4 address is configured But IPv6 link local address configured on eth0. This will always remain on a host. Before you begin to create a cluster with your brand-new nodes,You Must Have IPv4 Address configuration IPMI IP address Hypervisor IP address CVM IP address DNS/NTP IP address (Required while creating cluster via foundation) Hypervisor and CVM should be installed. What are the methods of Cluster initialization? Foundation: One click process for cluster creation Re-Images multiple nodes Assigns IP address on each node Manual Manual Hypervisor inst
As of Nutanix Collector release version 3.0 and later, it is now possible to collect statistics for Hyper-V clusters along with AHV and ESX clusters.From the initial home screen, simply select the “Hyper-V” option from the “Run on” drop-down, then enter the IP address or fully-qualified domain name (FQDN) of a Hyper-V host, followed by the username and password of an Windows administrator from the administrator group. Thereafter, simply select the entities from which you would like to collect statistics and click the “Collect” button.Please note that any Hyper-V hosts being connected to should be running PowerShell version 5 or later. Also, as Collector currently only collects configuration data from Hyper-V clusters, the Collector performance graphs may appear as blank following a successful collection.You can find more information regarding Nutanix Collector from the Nutanix Collector User Guide.
We have a very long domain name and with the current config we are using the UPN (name@company.com) name to login. This is becoming very irritating for me to enter the domain name each time I login. Can we configure a default domain for all the login users to use if the user didn’t mention any domain and of course if we don’t have local user by the same name?
It's very simple to identify Xi leap from leapFrom the CLI of the PC, run the command "nuclei availability_zone.list" to list the Availability Zones connected to the local AZFor Xi leap availability zone name shows name as US-WEST-1Bnutanix@cvm$ nuclei availability_zone.list "Total Entities : 2""Length : 2""Offset : 0""Entities :"Name UUID State Local AZ e007dd9a-1910-4a82-a4a5-9a9c7110d0f5 COMPLETE US-WEST-1B cce71719-d160-47b0-874a-171a61f8e6ee COMPLETE For leap it should start something likePC_xxx.xx.xx.xxXi leap can be found in PC by clicking on gear icon-->Xi cloud serviceFor details please refer leap administration guideleap guide
We know you care about your infrastructure. Every time and auto support ticket is created for one of Nutanix clusters a Support Engineer contacts the person who is assigned as Support Contact for the asset. You can spread the load within your team, assign the contact based on the time zone the asset is within or use any other method you like. The choice is yours!Help us to choose the right person to work with, shorten the resolution time and avoid the avoidable – configure Support Contact for your Nutanix clusters.Log in to my.nutanix.com. Click Support Portal. Under Products, click Installed Base. Click Assets tab. Select all assets by clicking on the checkbox located at the top left of the table. Click Edit Assets. Update the details and click on the green tick box located at the bottom right of the dialogue box. Click Clusters tab. Select all clusters by clicking on the checkbox located at the top left of the table. Click Edit Clusters. Update the details and click on the green tick
ESXi 7.0 requires a minimum of 4 GB of physical RAM. Provide at least 8 GB of RAM to run virtual machines in typical production environments.4GB only for the HOSTAnd about AHV?What is the minimum memory for AHV only?, without CVMs and VMs
I see that ERA 2.0 has a prerequisite of SQL Server SQLPS PowerShell module. Does anyone know what specific version is required? I ask because when trying to register a single node, I receive the following error:Operation Failed : Unable to import SQLPS module. Please make sure that SQLPS module is available to proceed with Dbserver VM registration.I suspect that the version of SQLPS PowerShell module that we have installed on our SQL servers is too new.
Hi All, Does anyone know if it’s possible to pass variables into the ‘Custom Script’ / cloud-init section, when creating a VM in AHV via Prism Element?Ideally, I’d like to use the REST API to create (clone) a VM from a template, and pass a ‘Custom Script’ perhaps from an ADSF path, that is able to configure the guest’s Hostname / FQDN based off the VM’s name specified in the REST API call.IPAM and some basic cloud-init config is working, just trying to determine the best way to set the hostname!
We have added Dell Switches to see the Interface information and where our AHV hosts are connected through Network Tab.But, I am able to see Interface only on One Switch for one host, not on others. I see below. Is there anything we are missing.
Customers can observe cluster issues when they use more than 90 percent of the total available storage on the cluster. This article provides general guidelines on the maximum storage utilization on a cluster. The total available storage capacity on a Nutanix cluster is the sum of all the available storage space across the nodes.Customers should not try to use all the available space in the cluster. Sufficient space should always be available in the cluster in case a failure occurs. For example, when a disk fails in the cluster, the extent groups that were present on that disk have to be copied to other disks to ensure that all the data is at the configured replication factor. If the disk space is unavailable for this activity, then there is a risk of data loss if more failures occur with the data in an under-replicated state. The formula for calculating the maximum recommended usage for clusters is one of the following. Recommended maximum utilization of a cluster with containers using
In some scenarios, when you enable the remote support tunnel, it’ll tell you that it has been temporarily enabled but the status will show “disabled”.To troubleshoot, you can start by checking Basic IP connectivity to nsc01.nutanix.net or nsc02.nutanix.net. If that times out, then it is either a DNS resolution problem or a firewall issue.Check the firewall rules of your system to allow outbound connections to nsc.nutanix.com on port 80 or 8443.For more details on troubleshooting, check KB-1044
Hello Team, I’m running a small 3 node cluster, during an AHV upgrade to the latest version one of the servers failed to reboot so AOS started to rebuild trying to restore HA. After several hours rebuilding failed, looking at the logs I saw the message: “not enough space available”. If I’m not mistaken a 3 node cluster can tolerate only one node down, but lets say the two running nodes had enough space, is it possible to restore HA? It basically means that after some time rebuilding, if one of the 2 remaining nodes fails, cluster is still up in a single node mode.Just curious because it looked like AOS tried to rebuild HA despide only 2 nodes were up
Below are new knowledge base articles published on the week of October 4-10, 2020.KB 9646 - Pre-check: test_is_nos_upgrade_supported_on_esx KB 9782 - LCM pre-check : is_cvm_in_maintenance_mode KB 9876 - 1-click Hypervisor Upgrade from ESXi 6.x to ESXi 7.0 fails with "Upgrade bundle is not compatible with current VIBs installed" on Dell platforms KB 9879 - LCM Pre-check: test_nx_ipmi_health_check KB 9892 - NCC check marvell_boss_card_status_check fails on ESXi 7.0 on Dell platforms. KB 10018 - VirtIO 1.1.6 installation on Windows 7, Windows Server 2008 R2 KB 10068 - Era 2.0 FAQs KB 10070 - Calm: VM image upload fails with error "Unexpected error: the following NVRAM files cannot be imported: calm-vm-pc-x.x.x-calm-x.1-file1.nvram." KB 10073 - LCM 2.3.4 NIC Firmware Upgrade limitations KB 10094 - Move - Ability to NOT Retain static IP and set it to DHCP on destination cluster KB 10097 - Cassandra Crashing with: "None of the SVM's IPs on interfaces match the service vm external IPs in Zeus
Note - Nutanix highly recommends using Nutanix Move to migrate VMs to AHV. See the Nutanix Move documentation at the Nutanix Support portal. This KB should only be used if Nutanix Move cannot be used or for reference only. For large scale migrations of business critical systems, Nutanix Global Services organization provides resources to assist with streamlining migration scenarios. For information on available services, see: http://www.nutanix.com/services/consulting-services/.The following high-level steps are required when migrating Linux VMs from another hypervisor to AHV. Determining what VirtIO drivers are available in the Guest OS kernel and deciding which BUS ((IDE, SCSI, etc.) type to use when creating AHV disks for the VM. Determining what VirtIO drivers are built into the Guest OS initial boot image (initrd or initramfs) to allow booting the VM in AHV. Rebuilding the GuestOS initrd or initramfs with VirtIO drivers (If needed). Updating Guest OS boot configuration files
As companies become more security aware, third party security tools are being utilized more heavily than ever before. One such tool is a security scanner which can review open network ports within an environment and report back on certain vulnerabilities (CVEs). This includes the open ports of Nutanix specific components such as the IPMI.While it is important to keep the IPMI/BMC upgraded to the latest version so as to integrate the latest security patches, there are CVEs that will still report as failed by scanners based upon the default IPMI configuration. This is due to the virtual media port (623) and the iKVM port (5900) being opened by default.The virtual media port allows the user to open a remote session to the host console and the iKVM port allows the hosts to query information from the BMC.The specific CVEs affected by these two ports being open can be found in KB 2555. NOTE: If these features are disabled, you will be unable to query any BMC info nor able to open a remote co
Do you already have many security policies defined within one instance of Flow and, have another instance where you need the same set of policies but do not wish to recreate them? Or, do you wish to simply have a backup of your existing security policies just in case you should ever need to restore them sometime in the future?Flow has the native ability to export (and subsequently import) security policies that have already been defined previously. Policies are exported into a single binary file, which can then be transferred to a different instance of Flow or stored-away for backup purposes.Please also note that, when importing a previously exported binary file, any existing policies which are already defined within a given Flow instance are automatically removed in-favor of the newly imported policies.You can find more information regarding this within the Exporting and Importing Security Policies section of the Flow Microsegmentation Guide.
Synopsis: The goal of this workflow is to walk-through troubleshooting VM to VM communication issues in a Nutanix Cluster. Most customers are very vague when they state they have a networking issue. We will go through painting a complete picture of the network topology by asking the right questions and running commands on the Hypervisors. Initial Triage:Questions to Ask: What hypervisor is running on the cluster? What guestOS is running on the VMs? Are the VMs on the same node or different nodes? Are the VMs configured to use the same VLAN? What method is the customer using to test connectivity? Is there any Firewalls or ACLs that would stop this VM traffic? Information to gather: NIC teaming/bond configuration on node. Switch vendor and model from upstream switch. Interface configurations for the interfaces connecting to the nodes. If ESXi is the customer running on a Standard vSwitch or Distributed vSwitch? VLAN information for each VM. IP and Subnet Mas
Hi all.I’ve been trying to figure out how I can execute a PowerShell script inside a guest VM, both Linux and Microsoft, on AHV through the host but can’t find any solid information on the topic.There is a discussion called “Execute Script Inside AHV VM?” but that is only for initial configuration of the VM. I’m looking for a way to execute an arbitrary script on any running VM without having access to the VM through its default network configuration.It’s basically a hosting situation where customer VMs exist within their own isolated environments and I’m responsible for running various scripts for - among other things - joining new servers to AD, installing SQL Server, patching the OS, etc, etc.Looking at this post there seems to be a way to run scripts through NGT but when reading the Nutanix Bible that option seems to be limited to VM creation or cloning.Any workaround I can come up with doesn’t scale well when we reach thousands of VM’s and hundreds of customers. Is there a way to
Are you new to Era and want to learn more about it? Are you an experienced engineer working with the product looking for answers?Era is a database as a service (DBaaS) that automates and simplifies database administration, bringing one-click simplicity and invisible operations to database provisioning and life-cycle management. Nutanix has an article with over 50 questions answered about Nutanix Era 2.0. The article covers questions on the variety of topics, such as:Time Machines Profiles Provisioning and Cloning Across Multiple CLusters SAP HANA on Era Copy Data Management for Multiple Databases SQL Server Patching SQL Server Database Group PostgreSQL Patching Oracle Restore PostgreSQL RestoreSome of the questions answered are:Can a single Era management plane handle multiple Nutanix clusters?What type of networks are supported for Era Agents?Can two or more pre-2.0 Era instances be converged into one?What version of Oracle is supported for Oracle Restore?Can we clone a few databases
Please consider the possibility of incorporating the existing IP scheme in the new infrastructure. If changing the IP address is the only option we can utilize a script to change the CVM IP address. You can use the external IP address reconfiguration script in the following scenarios: Change the IP addresses of the CVMs in the same subnet. Change the IP addresses of the CVMs to a new or different subnet.In this scenario, the external IP address reconfiguration script works successfully if the new subnet is configured with the required switches and the CVMs can communicate with each other in the new subnet. Change the IP addresses of the CVMs to a new or different subnet if you are moving the cluster to a new physical location.In this scenario, the external IP address reconfiguration script works successfully if the CVMs can still communicate with each other in the old subnet. Following is the summary of steps that you must perform to change the IP addresses on a Nutanix cluster.
We have a 15 block HPE environment built with AOS 5.15.2. we need to enable flash mode on a NVMe device (vmdk) which is presented within vSphere but cannot be seen via prism element under the VM vDisks or via ssh shell to cvm’s is this feature not currently supported? any ideas I am struggling to find much on the support portal?still unsure on this how do we pin the NVMe vmdk to the performance tier cheers
If you have a storage container on the cluster and the name starts with a “#”, you may see this error while trying to upload an image:"Could not access the URL nfs://127.0.0.1/%23ISO_Images/.acropolis/image/106ac31b-6236-4534-a2ae-808c08bb912f: Failed to parse the file size" That happens because the URL cannot have the # in the name and it gets automatically replaced with %23. Therefore, this creates the inconsistency between the container name and the URL.To resolve the issue, rename the container and remove the # from the container name and retry the image upload.Take a look at KB-10117 for more information.Check this guide on storage containers.
To verify if we have replaced DIMM on correct slot and CPU we can use the following method We can look at hardware.history file which records any replacement for example DIMM,SSD,HDD,NIC being made to that node. This file remains local to each CVM After we replace DIMM we will boot the host up Power on CVM and run following command ncc hardware_info update_hardware_info This will update the hardware.history file present in ~/config directory and it will recognize any new replacement Open hardware.history using less less ~/config/hardware.history Go to last line by pressing shift+g Check out the most recent replacement it should look something like this Mon, 05 Oct 2020 15:37:01 CDT|Component changed: Memory module{locator:P1-DIMMC1} Old values: |{serial_number: 423D07AF}|(Last Detected Mon, 05 Oct 2020 10:13:25 CDT) New values: |{serial_number: 152057A5} It mentions DIMM P1-DIMMC1 was replaced and its serial number is changed from 423D07AF to 152057A5 This is a quick and
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.