Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hi, I’m trying to create a automated NGT install script for my environment: Code:curl --insecure --request POST --url https://x.x.x.x:9440/PrismGateway/services/rest/v2.0/vms/ef064f22-7ac8-4221-96dd-4cc6f2433dfb/manage_vm_guest_tools --header 'authorization: Basic xxxxx' --header 'content-type: application/json' --data '{"operation":"MOUNT","override_guest":true,"uuid":"ef064f22-7ac8-4221-96dd-4cc6f2433dfb"}' Response:{"message":"Hypervisor ahv not supported","detailed_message":null,"error_code":{"code":1101,"help_url":"http://my.nutanix.com"}} AOS: 5.15.1
Hi! After using 2 of API callshttps://www.nutanix.dev/reference/prism_element/v2/api/alerts/post-alerts-acknowledge-acknowledgealerts/https://www.nutanix.dev/reference/prism_element/v2/api/alerts/post-alerts-resolve-resolvealerts/i’ve received this response{ "num_successful_updates": 1, "num_failed_updates": 0, "alert_status_list": [ { "id": "0:0", "successful": true, "message": null } ] }I wasn’t able to understand what the “id” field in “alert_status_list” means, if someone here could clarify I would really appreciate it.
While expanding cluster out of 4 nodes able to add one and remaining three nodes failed with error “Controller VM disconnected from network”Description:Controller VM is not reachable from Controller VM in the last 3 attempts.
Below are new knowledge base articles published on the week of January 17-23, 2021.KB 10178 - [JPKB] Files ストレージネットワークに存在するクライアントからファイル共有にアクセスできません KB 10234 - acli host.enter_maintenance_mode_check on AHV is not deterministic KB 10422 - After LCM upgrade an ESXi host is showing "Installing... Please be patient..." on ESXi DCUI for a long period of time KB 10548 - "Unknown device" in Device Manage of Windows VM running in BIOS mode KB 10602 - Nutanix Files - Error message "Error creating share/export: Duplicate client entry!" when creating an NFS Share with non-default access permissions KB 10603 - Objects - Unable to deploy VMware based cluster. Failing with 'Failed to initialize vcenter client for Prism Element' KB 10612 - Alert - A1137 - Node Failure KB 10613 - RHEL 7.8 installer hangs at "Installing Boot Loader" for AHV VM on AOS 5.18.x when using Secure Boot for VM KB 10628 - LCM upgrade failure with mesage "Contorller is missing on the OS, tried PCI rescan for 3 times, it did not
Era offers the following key services for several database engines:One-Click Provisioning. Copy Data Management. Database Protection. One-Click Patching.One-Click ProvisioningEra enables you to easily provision database environments (either production or otherwise) on your Nutanix clusters. Era provisioning service includes the following components:Database engines: Custom software images that can be tailored to fit your enterprise needs. (See Oracle Database Management, Microsoft SQL Server Database Management, PostgreSQL Database Management, MySQL Database Management, MariaDB Database Management, and SAP HANA Database Management for more information) Database profiles: Customizable database profiles for software, compute, networking, and database parameters. (See Era Profiles for more information) Database recovery SLAs: Customizable recovery SLAs for continuous, daily, weekly, monthly, and quarterly Recovery Point Objectives (RPOs). (See SLA Management for more information)VM Affini
Many users are not aware that a recent change has been made to the default password setting of new Nutanix nodes. Specifically, the default password for the IPMI interface is now the serial number of the node itself (using capital letters). Please note that the node serial number is different from the block serial number. You can find more information regarding this change as per the Common BMC and IPMI Utilities and Examples Knowledge Base article.Also, if you desire to change the IPMI password, you can do so using the IPMI management utility located within the file system of the operating system running on the node. Further, you can even change the password, without having an operating system installed/running, by using the utility from a bootable DOS environment. You can find more information regarding this within the Changing the IPMI Password section of the NX Series Hardware Administration Guide.
Hi,Is there any ETA for Nutanix Guest Tools for Debian 10? Debian 11 is probably going to be released this summer, so it would be quite nice if NGT supported Debian 10. Or is there a way to “forcefully” install Nutanix Guest Tool on newer systems? Is it possible to build it ourselves to we can distribute it on our thousands of VM’s that is running?
Ever wondered how Nutanix stores the data in your environment in a distributed format? When does SSD come into picture or when is HDD actually used? Here is a brief intro in a few words of how data moves within the cluster and links to extensive libraries for more details.The disk usage stats are governed by various factors like the type of data(Frequently used or rarely used), the type of user VM(All flash or Hybrid), the type of hardware setup(All flash or Hybrid) and also the capacity optimisation techniques used in the environment.In a few words, I can summarise data I/O path in Nutanix as follows: Under normal circumstances, all the write I/Os are written to the SSDs first. Based on the type of data(metadata or actual data), frequency of the data read back (Hot/Cold data) and other such algorithms, this data is gradually drained to the Extent Stores, which are majorly located on the HDDs and partially on the SSDs as well. Nutanix Data I/O Path:This is a pictorial representation of
Hello,I am trying to read Nutanix OOB device information into ServiceNow. Is there an API that I could use to retrieve the OOB (IPMI) information from the host machine? Or Would executing SNMP commands on the IPMI help with my ask?
All Nutanix clusters that run on third-party hypervisors share the same problem – how to communicate to that hypervisor.A Controller VM performs an array of tasks, many of which are triggered by the state of the host. In addition to that, a range of health checks is running regularly to ensure the cluster's health. For ESXi, CVM collects the information via SSH. Turning off SSH service on a host results in a multitude of health errors.While recommendation exists to keep the SSH service down on the ESXi hosts and only bring it up for ad-hoc tasks, this is not the way with Nutanix. Instead, look at strengthening network security. Consider limiting access to the hosts via SSH form a limited number of network segments, that are well protected by multiple additional layers of firewalls, two-factor authentication and what not.Stay safe, stay secure.KB-2051 NCC Health Check: esx_check_servicesvSphere Administration Guide for Acropolis: Nonconfigurable ESXi Components
Security PoliciesTraditional data centers use firewalls to implement security checks at the perimeter—the points at which traffic enters and leaves the data center network. Such perimeter firewalls are effective at protecting the network from external threats. However, they offer no protection against threats that originate from within the data center and spread laterally, from one compromised machine to another.The problem is compounded by virtualized workloads changing their network configurations and hosts as they start, stop, and migrate frequently. For example, IP addresses and MAC addresses can change as applications are shut down on one host and started on another. Manual enforcement of security policies through traditional firewalls, which rely on network configurations to inspect traffic, cannot keep up with these frequent changes and are error-prone.Network-centric security policies also require the involvement of network security teams that have intimate knowledge of network
Hello,Seeking for advice, I have 3 nodes cluster having problem with node B DIMM is undetected. I’m planning to reseat my DIMM, if I will just manually move the VMs to node A and C then perform a shutdown on node B without entering maintenance mode does the VM will join back to node B?Can please also share a link to a document to refer for the procedure.
I am connecting 5 Nutanix Nodes to two Cisco Nexus 9K cores.The MGMT ports are connected to TOR FEX then 1-10 Gig Fibre to Core1 and 1-10 Gig Fibre to Core2 from each node. All 10 are VPC ports in trunk mode, switchport trunk native vlan # with spanning-tree port type edge trunk.My question is, I found a Nutanix article #000002455 for Cisco Nexus Recommended Pratices and they state you should add to the configuration spanning-tree bpduguaard enable and spanning-tree bpdufilter enable.Cisco says they dont recommend these spanning-tree settings.Who is right?
Does anyone facing Storage performance issues on Hyper converged infra for VDI environment.
Hi everyone,If you have 5 blocks with 8 nodes installed in the same rack, will you keep using RF = 2 or 3, or will you use fault tolerance domain to block instead?
Hi all,I have a small question.For the pre-installed AHV nodes with CVM, could we able to upgrade only AOS version before creating cluster? Because the AHV version already same version as our desired version, but AOS version is not same. I know the way to re-install AHV and AOS by Foundation VM, but the way takes long time. Therefore I' d like to update for only AOS if we can.In the other hands, we can upgrade AOS from Prism UI so I will able to upgrade AOS after creating a cluster. So this question is just for my reference.My environment is belowAOS : 5.15.2 (want to upgrade to 5.15.5)AHV : 20170830.434
If I want to migrate Linux (Centos,RHEL,Ubuntu/SUSE) Vms from VMware to AHV using Nutanix move then is below information enough.Below are the configuration settings to look out for when migrating a Linux VM using credentials. Ensure ssh localhost using only password authentication, ie. set “PasswordAuthentication yes” in sshd_config Ensure using sudo, user assume root privileges without entering a password Ensure read and write permission for /tmp. root access, sshd service running If this is correct then I can normally migrate the Linux VMs same as I migrated the Windows VM?
Hi,I would need some guidance on enabling Aide on AHV and CVM and strong password policy for the hardening.I found the guide on this link: Hardening Controller VMIf I enable the AIDE on AHV and CVM. Is there anything need to be done? Additional appliance to deploy?
I have a Nutanix cluster with 4 hosts and 4 blocks. Is it possible to remove two nodes from Cluster ?
Dear All,I’ve got a question?I am in the process of Moving Windows machines from a VMWare infrastructure to Nutanix.1 of my machines to a USB dongle for an application license.Could you tell me if it is possible to mount a USB dongle in nutanix like in VMWare?Thank you in advance
Hi all,I´m attempting to create one image from a disk stored inside a volume group.While I have succesfully tested image creation for standard disks using acli and api I didn´t find how to repeat the same task for disk stored inside Volume Group.As well documented here and in ther KB articles these sample commands works:ACLIacli image.create image-name container=default-container-nnnn source_url=nfs://127.0.0.1/default-container-nnnn/.acropolis/vmdisk/uuid image_type=kDiskImageAPI with curlcurl -X POST --header 'Content-Type: application/json' --header 'Accept: application/json' -d '{ "annotation": "cloned disk image", "image_type": "DISK_IMAGE", "name": "image-name", "vm_disk_clone_spec": { "disk_address": { "vmdisk_uuid": "UUID" }, "storage_container_uuid": "UUID" }}' 'https://PE-IP-ADDRESS:9440/PrismGateway/services/rest/v2.0/images/'But when I try to use the disk uuid of the disk inside a VG the commands fails both from ACLI than API.Any suggestion/workaround?Tha
Hi,A previous post by Jon from Nutanix stated that “Licenses are not tied to support agreements. Am I correct in assuming that support purchased/renewed for NX hardware covers both hardware and software support? Also is it safe to assume that the support level is not impacted by the license level on the node. For example, a node using AOS Pro license will NOT receive a higher level of support than a node using AOS Starter license if they both have production support. My understanding is that the only thing that impacts the support level is the type of support purchased, that is "Production Support vs "Mission Critical Support". Thanks,--Zip
We are considering AHV for our environment. I notice that the OEM partner product list https://www.nutanix.com/partners/oem has fixed set of disks. Most of the hardware in the list are capable to be installed with more disks. For example Fujitsu servers are capable of 12 x 3.5 + 4 x 2.5 (on the rear),Can we utilize all disk slots in a configuration like 12 x 4TB NL-SAS + 4 x 1.92TB 2.5” SSD or 4 x 1.6TB NvME ?
Below are new knowledge base articles published on the week of January 10-16, 2021.KB Number Description KB 10489 Objects - Objects browser shows No Data Found when used with FQDN KB 10547 Nutanix Files - Prerequisites for Quota Configuration for NFS KB 10555 Nutanix Frame - Request to Delete All Personal Data KB 10562 Nutanix Files - Random delay in data synchronization between Linux and Windows clients with Multiprotocol Share KB 10566 ESXi host unresponsive after upgrade to 6.7 P03 or later due to AHCI driver issue KB 10588 [Nutanix Objects] Authentication fails after re-adding directory service with a different name Note: You may need to log in to the Support Portal to view some of these articles.
Hardware TermsBMC: Baseboard management controller, the microcontroller that manages the motherboard. BIOS: Basic input/output system, the firmware that initializes the motherboard and runtime services on startup. HBA: Host Bus Adapter, a device that manages communication between storage media and other system components. SATA DOM: SATA disk on a module, the hypervisor boot drive for Nutanix platforms up to and including G5. M.2: mSATA 2, the hypervisor boot drive for Nutanix platforms G6 and later.Dell-Specific TermsiDRAC: Integrated Dell remote access controller, a software tool that lets you administer a server without needing physical access. iSM: iDRAC service module, a module that integrates iDRAC with an operating system. PTAgent: Power Tools agent, the software entity responsible for configuring the iSM. Firmware Entities: A collective term for all Dell firmware not related to iDRAC.Lenovo-Specific TermsIMM2: Integrated management module 2, a service processor that manages the
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.