Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
If you are unable to add hosts and storage to SCVMM by using the utility provided by Nutanix, you can add the hosts and storage to SCVMM by using the SCVMM user interface. Procedure: Login to the SCVMM user interface and click VMs and Services. Right-click All Hosts and select Add Hyper-V Hosts and Clusters, and click Next. Click Browse and select an existing Run as Account or create a new Run As Account by clicking Create Run As Account. Click OK and then click Next. The specify the search scope for Virtual machine host candidates screen appears. Type the failover cluster name in the Computer names text box, and click Next. Select the failover cluster that you want to add, and click Next. Select Re associate this host with this VMM environment check box, and click Next.The Confirm the settings screen appears. Click Finish Register a Nutanix SMB share as a library share in SCVMM by clicking Library and then adding the Nutanix SMB share. Right-click the Library Server
Nutanix clusters running Hyper-V have the following limitations. Certain limitations might be attributable to other software or hardware vendors: Guidelines: Hyper-V 2016 clusters and support for Windows Server 2016. VHD Set files (.vhds) are a new shared Virtual Disk model for guest clusters in Microsoft Server 2016 and are not supported. You can import existing shared .vhdx disks to Windows Server 2016 clusters. New VHDX format sharing is supported. Only fixed-size VHDX sharing is supported. Use the PowerShellAdd-VMHardDiskDrive command to attach any existing or new VHDX file in shared mode to VMs. For example: Add-VMHardDiskDrive -VMName Node1 -Path \\gogo\smbcontainer\TestDisk\Shared.vhdx -SupportPersistentReservations. Upgrading Hyper-V Hypervisor Hosts When upgrading hosts to Hyper-V 2016, 2019 and later versions, the local administrator user name and password is reset to the default administrator name Administrator and password nutanix/4u. Any previous changes to the admin
HI Team, I would like to create a Microsoft fail over cluster in Nutanix.Is that possible.If any related documents kindly share.
Below are new knowledge base articles published on the week of October 17-23, 2021.KB 10714 - NCC Health Check: oplog_index_memory_usage_check KB 11874 - NGT installation fails with "The system cannot open the file" error KB 12198 - Uhura VmGet failing for a VM with secure boot KB 12213 - Scale up the number of object Load Balancer's deployed for performance configurations KB 12216 - Klas Voyager TDC 1.0 and 2.0 does not support AHV Upgrades and AOS 6.x upgrades KB 12220 - Missing NIC details on guest VM ethtool output KB 12228 - LCM upgrade failed "Cannot complete login due to an incorrect user name or password."Note: You may need to log in to the Support Portal to view some of these articles.
For a node to join a Nutanix cluster, it must have a hypervisor and AOS combination that Nutanix supports. AOS is the operating system of the Nutanix Controller VM, which is a VM that must be running in the hypervisor to provide Nutanix-specific functionality. Find the complete list of supported hypervisor/AOS combinations at https://portal.nutanix.com/page/documents/compatibility-matrixFoundation is the official deployment software of Nutanix. Foundation allows you to configure a pre-imaged node, or image a node with a hypervisor and an AOS of your choice. Foundation also allows you to form a cluster out of nodes whose hypervisor and AOS versions are the same, with or without re-imaging. Foundation is available for download at https://portal.nutanix.com/#/page/Foundation.If you already have a running cluster and want to add nodes to it, you must use the Expand Cluster option in Prism, instead of using FoundationNetwork requirementsWhen configuring a Nutanix block a set of IP addresses
Ports and ProtocolsThe Ports and Protocols Reference allows you to determine ports requirements for multiple Nutanix products and services in a single pane. This document is divided into several sections based on the required ports for each product or service.Ports and Protocols Reference covers detailed port information (like protocol, service description, source, destination, and associated service) for the following products and services.Note: Note: The existing port information in this document is based on the latest product release. Updates to this document is made with major release of products. 1-click Upgrade AHV AOS Calm Collector Portal Collector Tool Disaster Recovery - Leap Disaster Recovery - Metro Availability (ESXi and Hyper-V) Disaster Recovery - Metro Availability with Leap (AHV) Disaster Recovery - Metro Availability with Leap (AHV) - CCLM Disaster Recovery - Protection Domain Era File Analytics Files Files Manager Karbon Platform Service
We have Lenovo HX (3752) installed with 3 nodes pre-bundled with AHV and AOS. The onsite technician configured IPMI (XCC) and we are now able to login to the XCC and also able to access the console (AHV). I wanted to do the following,Change the AHV IP address from the console (commands)? Know the AHV version and its default IPs/current IPs from the console? Connect/ssh to CVM and change the CVM IPs? Create Cluster of 3 nodes
HyperVisor - ESXi 6.7U3Mostly Windows VMsI’m sure there’s good reason for this and it's probably to do with the way SQL handles memory but when I check the memory usage from Prism or Prism Central for a VM that’s running SQL it’s not accurately reflecting what the VM is actually using. For example, from within the VM if I fire up task manager or even perfmon it will report the memory usage at say 95% whereas from Prism it reports the VM as using 25%.I need to generate a report for a collection of SQL VMs and application servers but I think for the SQL VMs I'm going to have to provide perfmon screenshots or something.Can anyone explain to me in simple terms why this is happening?
When I run the following <:~$ ncli multicluster get-cluster-state I get this output, Cluster Id : bff29593-35c0-4f5a-804f-257374c3e979 Cluster Name : Unnamed Is Multicluster : true Controller VM IP Addre... : [10.250.130.151] External or Masqueradi... : Controller VM NAT IP A... : Marked for Removal : false Remote Connection Exists : true Question is how can I change Cluster Name to something other than Unamed???
With AHV-20190916.189, Nutanix supports Directly Attached Volume Groups in a Guest VM Cluster. On AHV clusters, you can create a guest VM cluster by directly attaching a volume group to guest VMs.After you attach a volume group to guest VMs, vDisks appear as SCSI devices to the guest operating system and you do not need to set up any in-guest connections when you are creating a guest cluster. If you directly attach volume groups to guest VMs, you can seamlessly share vDisks across VMs in the guest cluster.You can directly attach a volume group to guest VMs to create the following guest clusters:1. Microsoft Failover Cluster (MSFT)2. Red Hat Enterprise Linux (RHEL) Cluster For more details, refer to following:Guest VM Cluster Configuration (AHV Only)Create Guest VM Clusters by using iSCSIAcropolis Release Notes
Hello and thank you for the advice, I administer 1 block, 3 node cluster on NX-1065-G4 hardware, power is 110v. Following is the software versions:Version 5.10.10.1 LTS - Pro LicenseNCC Version: 3.9.4.1LCM Version: 2.3.2.3.20029AHV Version: 20170830.396HA reservation is enabled Can you please describe, or link to a KB which will help me understand, how a node failure will cause VM fail-over to another node? For instance, if node 1 fails, how and when with the workload fail-over? What configuration settings do I need to consider to optimize the workflow?
Nutanix collector fails to log into Prism central. This is the error I am getting. “Failed to login. Possible reasons could be having insufficient access permissions, missing binaries or failure to execute scripts” Has anyone seen this issue?
What could cause this very error code “could not generate Firmware config” during installation on dell Power Edge R730?
I have an error at the Discover Cluster step:HTTPConnectionPool (host = 192.168.53.58, port = 5985): Max retries exceeded with url: / wsman (Caused by ConnectTimeoutError (<requests.packages.urllib3.connection.HTTPConnection object at 0x7fc18c829780>, Connection to 192.168.53.58 timed out. ( connect timeout = 90)))Everything else is ok. Port 5985 is open between VLANsDo you have an idea?
Hi there,We are currently deploying (and testing) Karbon as K8 orchestration platform for all our Nutanix platforms (worldwide). I have failed installation attempts from Prism Central.As a side note, we are using VPN Site2Site from centralised Prism Control and I can reach remote K8 VLAN from distant Nutanix deployment. The reachout tests were done with small VM belonging the the K8 VLAN testing node and via private CIDR (bidirectional tests), but utilizing the same encrypted VPN channel.This is what I’m having from karbon_core.out (PCVM):2021-10-13T21:17:12.687Z ssh.go:153: [DEBUG] [k8s_cluster=RGS-PA-K8-STAGING] On 10.20.25.130:22 executing: docker plugin inspect nutanix2021-10-13T21:17:12.825Z ssh.go:166: [WARN] [k8s_cluster=RGS-PA-K8-STAGING] Run cmd failed: Failed to run command: on host(10.20.25.130:22) cmd(docker plugin inspect nutanix) error: "Process exited with status 1", output: "Error: No such plugin: nutanix\n[]\n"2021-10-13T21:17:12.825Z sshutils.go:44: [ERROR] [k8s_clust
Below are new knowledge base articles published on the week of October 10-16, 2021.KB 11869 - NGT is failing installation on a guest OS where a Python environment already exists KB 11876 - NGT Setup Fails due to Carbonite Software modifying Drivers KB 11877 - NGT installation repeatedly failed on Windows 2016 servers with a "0x80070643 - Fatal error during installation" error KB 11931 - OVA export from Prism Central fails with 'Internal Server Error. kInternalError: Internal Error: 5 :Error accessing ovas capabilities'. KB 12130 - Windows Storage Spaces with Nutanix to improve single vdisk performance KB 12164 - ERA - Changing the ERA server IP KB 12167 - Frame - Reset Sandbox to Master Image KB 12186 - Leap | Protection/Unprotection of VM(s) in protection policy fails post PC-DR event with the error “EnumTypeWrapper' object has no attribute 'kEntityCentric'” KB 12192 - IAMv2 SAML: Unable to upload XML metadata file under IDP after enabling CMSP KB 12204 - Nutanix Clusters on AOS 6.x m
Hello team, how to open a box on the nutanix support knowing that we have 3 blocks lenovo so 3 serial number, NB: I no longer have access to the prism
Hi,Is there any limitation on mixed hardware generation in one cluster Nutanix? Example old generation like G5 want to mixed with G8. Thanks
Hey everyone - we have 2 brand new nodes that need to be added to an existing cluster. We enabled RDMA when we ran Foundation on that cluster and now need to add 2 additional nodes. Do we run the script to choose which card to enable RDMA on before we add to the cluster? Just looking for guidance on the correct way to ensure it is enabled on the new nodes as well. Thanks!
Dear communityI want to install three G5 nodes with the foundation vm 5.0.4 and it fails at the beginning with the error"Failed to connect to the following IPMIs:"Let me describe my setup and my troubleshootingNodes are X10DRT-P-G5-NI22 Set IP for the IPMI on each node and also set the ntp servers on each node Trying to image the AHV Foundation vm is version 5.04 All nodes, DNS server and the Foundation VM are in the same subnet I can ping from the foundation to the IPMI I can also send IPMI cmd to the nodes and getting results=> so used username and passwd are correct and nothing is blocking the trafficThe Foundation fails with error "Failed to connect to the following IPMIs" Following error appears very often in the logfile2021-10-13 14:40:18,125Z Thread-236 detect_node_type.check_for_nutanix:236 DEBUG: Got a pexpect.TIMEOUT exception with process.before = SMC IPMI Tool V2.22.1(Build 190920) - Super Micro Computer, Inc.Press Ctrl+D or "exit" to exitPress "?" or "help" for helpPre
Hi, I just created a new account and wanted to activate the serial number for our NX-1065S-G5.I cannot activate because I’m not authorized for the account associated with the serial number.The mail-domain from our company changed and the old admins are not here any more.What to do?
I have 5 nodes equipped with 2*3.2TB NVMe SSD and 6* 1.92TB SATA SSD. of every one. all nodes are connected with 25Gb network. all nodes upgarde from AOS 5.15 to 5.20From the nutanix bible, in the scenarion with NVMe SSD + STATA SSD, the oplog will only reside in the NVMe SSD, and not in SATA SSD.So that is mean all the random write will first write in NVMe SSD and then drain to all the NVMe SSD+ SATA SSD?all the sequential write will pass OPlog and only writhe to extent store parally in all NVMe SSD + SATA SSD? How about the read I/O path? In some test, I found that when I do some I/O operation in VM, All the device (NVMe and SATA) have I/O counters and the IOPS are roughly the same in the prism-hardware--disk page. Seems the fast speed of NVMe SSD cannot be utilized.Does you have any suggestions to prove the fast performance improve by used NVMe in the nodes.I also checked that the disk status, as the folloing: It is used SPDK.================== 172.88.61.131 =================Slot D
We have a Nutanix lab with 3 HPE PROLIANT DX360 GEN10 hosts. After we have done our tests, now we want to destroy everything and re-install everything again. What is the best way to proceed?
VStore refers to a separate mount point that is created with its own NFS namespace in a storage container. VStore Protection DomainThe namespace of a VStore is mapped to the protection domain when you protect the VStore. Such a protection domain is termed as VStore protection domain. A VStore protection domain allows you to protect the VStore. You can also unprotect the protected VStore. Files in a protected VStore are replicated to a remote site at a defined frequency. You can recover these files from the remote site in the event of a disaster. A Nearsync replication schedule of as little as 20 seconds to protect a VStore can be configured. VStore Mapping for Data Protection Nutanix recommends mapping the VStore container in the primary site to a container in the remote site. If a container containing a protected VStore in the primary site is not mapped to a specific container in the remote site, the container in the primary site is automatically mapped to the default (Self-Service) c
Below are new knowledge base articles published on the week of October 3-9, 2021.KB 11533 - Expand a cluster using ncli errors out when rack fault tolerance is configured KB 11653 - Era Postgres database crashes due to pg_wal directory full KB 12023 - Daylight Savings not accounted in Playbooks KB 12121 - Xi Frame - Cloud service is unavailable KB 12138 - IBM Power Systems: No Upgrade Path from Prism Central 5.10.0.7 or 5.11.12 | Deploy a New Prism Central 2021.3 KB 12142 - Creating a Prism Central Report for idle VMs KB 12143 - Nutanix Move | Unable to access file since it is locked KB 12147 - Frame - Disable TLS v1.0 and Enable v1.2 on SGA KB 12150 - Direct upload option is not available in Prism Element KB 12152 - FLOW: ID Based Security configuration fails with LDAPS Enabled AD Groups KB 12153 - Xi Frame - Failed to join domain. AD error code 8557 KB 12176 - Application-Consistent Recovery Point Failed because Quiescing the guest VM failed or timed outNote: You may need to log in t
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.