Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
HiI'm hoping someone has a similar setup. We have a 2 sites connected by fast links with one Nutanix cluster at each site (16 nodes in each cluster). We use Metro availability to replicate between sites. We have 1 stretched ESXi cluster hosting mainly Window servers.We have a number of VM guest failover SQL clusters (2 nodes in each cluster) which require shared storage and therefore require the use of Nutanix Volume groups. Each VM is connected to the volume group via ISCSI.We can't use Metro replication to replicate these VMS and their associated volume groups to the other site as you can't replicate volume groups with Metro availability - it's not supported.So, the only other option is to use Async replication. Here are my questions:In the manual the conditions for Async say "Do not have VMs with the same name on the primary and the secondary clusters. Otherwise, it may affect the recovery procedures"Q: If we failover the async protection domain containing the cluster node VM
Hi all, I’m trying to create additional admins accounts with LDAP authentication on Nutanix. I’ve got clusters up and running, got LDAP working, and the generic RBAC ‘VM admin/VM read only’ etc accounts (that I’m creating) are all good. But I thought Nutanix had added the ability to create a full cluster admin with AD authentication rather than creating local ones on something like prism central now? Or am I mistaken? (If someone has a way of doing this, it would be much appreciated). Kind Regards,SiW
Below are new knowledge base articles published on the week of March 13-19, 2022.KB 12102 - NCC Health Check: power_supply_issues_check KB 12508 - Nutanix Cloud Clusters (NC2) on AWS - Hibernating slowness when a CVM is unresponsive KB 12733 - Nutanix cluster nodes belonging to different vSphere clusters KB 12812 - Failed to create an application-consistent snapshot on ESXi with VssSyncStart operation failed: iDispatch error #8723 (0x80042413) KB 12843 - How to view All support cases in the Nutanix portal account KB 12867 - Karbon / CSI: Error while trying to create a pod that uses a PVC bound to Nutanix Files KB 12886 - How to change Prism Central (PC) cluster nameNote: You may need to log in to the Support Portal to view some of these articles.
I used X-Ray to do a performance testing for the Nutanix cluster. After added the target, and I do a Peak Performance Micro benchmark test. All the process has worked well. but when the performance testing is running, there is no I/O performance graph, only display the 3 graphs as cluster CPU usage,cluster network received, and cluster network transmitted. I cannot find the I/O performance information from the graph. I have meet this kind of problem many times. and the x-Ray version is 3.11.As the beginning test, the timezone is not right and I have ever adjust the time of X-Ray VM.
HiI used X-Ray 4.1.3 to do a test of VM High Availability in a cluste which includes 6 Lenovo HX nodes installed ESXi 7.0 U2, I tested several times and all are failed. The test failed in the phase of after poweroff the Host and reestablish the workload in 120 seconds. All are time out in 120 secs. I checked the VM which has already HA to another host, and the VM is already restated and the IP already obtained. So this is the timeout issue. seems if the timeout value is larger, the test will be successfully. but I cannot find the place to adjust the 120 secs value.My question is “ Is there any way to adjust the 120 sec value for the VM high Availability test”?
Hi All,I want to test block storage, file storage and object storage. How many nodes are needed for the minimum cluster size? Is there a recommended configuration?
We keep our test cluster up-to-date with the latest STS versions.Unfortunately, by doing so, I cannot upgrade from 6.0.2.5 to 6.1 as it is not supported.Upgrading from 6.0.2.4 is supported.I have two questions, one, when will I be able to upgrade to 6.1 from 6.0.2.5?Second, should I lag a version or two behind in the STS track to make sure I am not blocked from taking a major upgrade?Thanks!
Hi We have 2 sites with fast links between them with 1 Nutanix cluster on each site. All the hosts are running the ESXi 6.7 hypervisor. We use Metro availability so we have 1 ESXi cluster stretched across both sites. Currently Prism central runs on a VM in located on hosts in the primary site in a Metro availability enabled container\DS. We looking into scaling out our Prism Central installation from 1 node to 3 nodes. Ideally I was thinking we could spread the Prism Central nodes across the two sites, perhaps by having 1 node on site 1 and 2 nodes on site 2. However, the Prism Central scale out manual states the following: “All scale out Prism Central VMs must run on the same cluster. For example, running two VMs in cluster_1 and one VM in cluster_2 is not supported". Is this referring to one ESXi cluster or one Nutanix Cluster - I just want to be sure? Thanks in advance.
Looking for anyone that has been successful with installing windows 11 on Nutanix AHV?I have tried, in my VM creation i have selected UEFI and Secure Boot. What I can’t seem to get to is how to enable TPM? When VM boots there is no way to get into bios to enable TPM. So how do you do that?Thanks
Morning,We have a 5 node cluster using the Lenovo HX series hardware (ThinkAgile HX3521-G).We changed our IMPI range after the installation had completed to an out of band IP range that all our IPMI NICs sit on. I made the change in BIOS and then restarted the genesis services on each node via the node CVM.The Genesis restart appeared to be successful.However when I look at the nodes in the hardware section of Prism element the IPMI address is showing up as a a generic self assigned 169.254.x.x address.What would be the best way to address this?Im new to Nutanix so forgive me if I have missed something super obvious...thanks Graham
Below are new knowledge base articles published on the week of March 6-12, 2022.KB 12603 - How to update hosting Prism Element and Prism Central details post Re-IP procedure KB 12651 - Login to PC UI fails with "Server is not reachable" KB 12717 - VIP (Virtual IP) and Prism Gateway (PGW) may become unavailable for maximum 30 minutes when Prism leader node is rebooted or removed from the cluster with 8-core nodes KB 12790 - ESXi - nutanix_nfs_plugin - Established VAAI session with NFS server 192.168.5.2 datastore KB 12800 - Era - Log Catchup activity fails after restore operations on PostgreSQL DBs KB 12820 - Alert - A1120 - CuratorJobRunningTooLong KB 12822 - OVS process on AHV can consume a lot of CPU in certain conditions KB 12833 - Flow Microsegmentation - Service Chain Integration KB 12840 - Nutanix Files :-Share Creation failures may lead to existing volume group(s) deletionNote: You may need to log in to the Support Portal to view some of these articles.
Just in case this helps anyone else- I wasted a lot of time on this one this morning. I appreciate ovftools is a VMWare product...I was trying to convert an exported ovf vm folder to .ova as a single file for import into AHV.I was just getting a generic error- file "" could not be opened:trying to test or verify I got similar:c:\Program Files\VMware\VMware OVF Tool>ovftool --verifyOnly --machineOutput V:\Grid-lic-server\Grid-lic-server.vmxERROR+ <Errors>+ <Error>+ <Type>ovftool.io.file.open</Type>+ <LocalizedMsg>+ Failed to open file: V:\Grid-lic-server\Grid-lic-server.vmx+ </LocalizedMsg>+ <Arg>+ V:\Grid-lic-server\Grid-lic-server.vmx+ </Arg>+ </Error>+ </Errors>RESULT+ ERRORNot very illuminating.I tried setting a log output and for next to nothing useful even in verbose mode:However:When I navigated to the local directory and ran the same export / convert command where the .vmx file was located I got:C:\Program Files\VMwa
You have a nice OVF or an OVA image and you are ready to deploy that virtual appliance to AHV. There is just one more step required. Well, maybe more than one. It is not possible to import OVA and OVF files to AHV. Extraction of the files of the image as well as upload of the VMDK files is required prior to deployment.Please follow instructions provided in KB-3621 AHV: Import OVA and OVF image
We got three HPE DL380 Gen9 Server with the HP RAID-Controller H240ar Smart HBA 2-Port SAS 12G on which HBA is enabled.Accordingly to Nutanix this RAID Controller is compatible and should work:https://portal.nutanix.com/page/documents/details?targetId=HPE-Hardware-Firmware-Compatibility:mod-DL380-8-G9-r.htmlDuring the middle half of the installation via Foundation, we get the following error:StandardError: This node is expected to have exactly 1 AHCI controller. But phoenix could not find any such deviceAfter a quick search I saw this KB-Entry:https://portal.nutanix.com/page/documents/kbs/details?targetId=kA00e000000LIWmCAOI also made sure to set the SATA Controller Options again manually and rebootet the server multiple times. Also the boot order is set accordingly to the KB-Entry. But I still get this error and phoenix isn’t able to see any AHCI controller via fdisk -l.Do you have any ideas what else I could try?
hi. i was wondering if anyone here has managed to successfully transfer data between nutanix and remedy? i have a case that requires the integration. since i’m way behind my schedule, i would really appreciate any opinion, solution, point of view.
Below are new knowledge base articles published on the week of February 27-March 5, 2022.KB 10834 - Alert - A130348 - VmInPausedState KB 12394 - Exit Maintenance mode error "Client does not have maintenance authority over host" KB 12631 - Set vpxd.stats.maxQueryMetrics in vCenter to get all cluster metrics KB 12776 - NX Hardware: Node hung at DXE--BIOS PCI Bus Enumeration KB 12789 - Era - Linux operating system pre-requisites (/tmp and /dev/shm directories) KB 12793 - Foundation - Cluster create failure for new HPE DX nodes and AHV hypervisor KB 12795 - Windows VSS snapshot failed with VSS shadow copy Service error: The security ID structure is invalid KB 12809 - Support during a critical upcoming upgrade/maintenanceNote: You may need to log in to the Support Portal to view some of these articles.
Hi all!I’m trying to set up an ESXi environment in Nutanix Move but move complains that the user has insufficient access rights, despite the user being assigned the Admin role in vCenter (and on the user level, not on the group level). Insufficient privileges to perform the operation: User 'Move-User' is missing required privileges for 'vcenter.domain.obfuscated': virtualmachine.config.changetracking,virtualmachine.config.editdevice,virtualmachine.guestoperations.query,virtualmachine.provisioning.diskrandomread,virtualmachine.config.annotation,virtualmachine.config.removedisk,virtualmachine.guestoperations.execute,virtualmachine.state.createsnapshot,virtualmachine.state.removesnapshot,virtualmachine.interact.deviceconnection,global.disablemethods,virtualmachine.config.advancedconfig,virtualmachine.guestoperations.modify,virtualmachine.interact.poweroff,virtualmachine.interact.poweron,virtualmachine.config.rawdevice,virtualmachine.config.settings,global.enablemethods,global.licenses,ses
If you have ever wondered, having a 1000 User VMs in your infrastructure is making administrative jobs pretty difficult for you! You are wrong when it comes to Nutanix HCI.Nutanix makes administration simple and easy.Let’s say you have 500+ User VMs in your system and want to install NGT on those VM, will you do it manually?Will you waste countless hours manually installing NGT on each User VMs?Definitely NO!Prism Central provides you with a feature to install NGT on multiple VM simultaneously with just a few clicks and you can even enable SSR and VSS service while installing NGT.Want to know the procedure?Just give the document a readNGT Installation using Prism Central Have queries regarding NGT or some doubts?Drop a comment and let us start a discussion.
If you’ve ever encountered an alert like the referenced one below, you might have wondered, “What does this alert mean, and what do I do next?”Reference Alert:1 DIMM RAS event found for P1-DIMMA1(Serial:XXXXXXXX) by Samsung on host x.x.x.x in last 24 hours. Installed BIOS version is PB42.602The answer to the first question is easy. RAS stands for Reliability, Availability, and Serviceability and is an advanced feature that is enabled in the server’s BIOS to detect and alert failing memory region(s) proactively. The second answer is a bit more tricky, but don’t worry, we’ve got you covered with KB-11794 which goes into detail about how to diagnose and resolve a RAS event, and KB-7503 which covers DIMM error handling guidance for G6, G7, and G8 platforms.
Is it possible for PE or PC to send an email to me when a snapshot is created in the cluster?
Hello, I have installed prism central on cluster (AHV). But no cluster is registered (only prism central is deployed). Now i want to remove prism central. What is a correct way to do this? Thank you in advance. Mindaugas
I am cloning a VM using API V3, by default it was set to DHCP, I want to assign a Static IP via below code, but it is not working. i am not interested to do this Via sysprep file. "override_spec": { "memory_size_mib": 4096, "name": "{{ vm_name }}", "num_sockets": 1, "num_vcpus_per_socket": 2, "num_threads_per_core": 1, "nic_list": [ { "dns_ip_addresses_list": [ "192.168.1.10", "192.168.1.20" ], "nic_type": "NORMAL_NIC", "ip_endpoint_list": [ { "ip": "192.168.1.50", "type": "LEARNED", "prefix_length": 24, "gateway_address_list": [ "192.168.1.1" ], "ip_type": "STATIC" }, "subnet_reference": { "kind": "subnet", "name": "Client01", "uuid": "XXXXX-XXXX-XXXXX-XXXXXXX" },
Below are new knowledge base articles published on the week of February 20-26, 2022.KB 10560 - Alert - A 130351 - VolumeGroupProtectionFailed KB 10571 - Alert - A130349 - ConsistencyGroupVmConflicts KB 10572 - Alert - A130350 - ConsistencyGroupVgConflicts KB 10573 - Alert - 130352 - VolumeGroupProtectionMightFailPostRecovery KB 10754 - Alert - A130355 - VolumeGroupRecoveryPointReplicationFailed KB 11308 - Alert - A130357 - VolumeGroupProtectionFailedOnPC KB 11413 - Alert - A130358 - ConsistencyGroupWithStaleEntities KB 11744 - Alert - A130361 - PartialVolumeGroupRecoveryPoint KB 11745 - Alert - A130362 - VolumeGroupReplicationTimeExceedsRpo KB 12676 - Cloud Connect: Replicating snapshots from Cloud CVM to local On-prem cluster may fail and cerebro may enter crash loop KB 12767 - Windows VM may fail to boot with INACCESSIBLE_BOOT_DEVICE (0x7B) error if MPIO is configured KB 12773 - The Waste Electrical and Electronic Equipment Directive (WEEE) handlingNote: You may need to log in to the
Hi!We are in the process of migrating our ESXi-vms to Nutanix AHV. Does anyone know if it is a problem to migrate a Witness VM (actually used for two 2-node clusters) to AHV with Nutanix Move or would it be better to install a new one on AHV and switch the clusters over to it?
Hi Tried googling but can’t find anything to support me. Model: NUC7i5DNHE2x SSD (500+250GB SSD)1x _16_ gb Cruizer Fit USB AHV installation works and I create 1 signle node cluster., After rebooting I get SSH/Ping acces to AHV and can loginw with root. Problem:CVM does not answer to ping/wev.Tried SSH / Ping from AHV but does not get an answer: [root@NTNX-eXXXXX-A ~]# ping 10.255.1.11PING 10.255.1.11 (10.255.1.11) 56(84) bytes of data.From 10.255.1.10 icmp_seq=1 Destination Host UnreachableFrom 10.255.1.10 icmp_seq=2 Destination Host UnreachableFrom 10.255.1.10 icmp_seq=3 Destination Host Unreachable I’ve tried re-installing multiple times but same issue.Is the problem the 16Gb cruizer fit usb? It’s the bootable media.CVM gets 500gb SSD diskData gets 250Gb disk [root@NTNX-eXXXXX-A ~]# virsh list Id Name State----------------------------------------------------[root@NTNX-eXXXXX~A]# Tried the logs from other posts but not able to get any outputs. Anyone got
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.