Question

AOS 5.20.2 shown, can't upgrade to 5.20.3, says 5.20.3 already there!

  • 14 March 2022
  • 1 reply
  • 144 views

Hi,

I’m trying to update a Nutanix env, from Prism Element. Using the web, in LCM, I see version 5.20.2 being in there, but when trying to upgrade to 5.20.3, I get the following error:

Update of nutanix.nos failed on 192.168.0.2 (environment cvm) at stage 1 with error: [Failed to perform AOS upgrade with error [Preupgrade task [57c7e9a1-ebc9-495d-a848-2ead17251730] failed/aborted with message Version 5.20.3 is same as the current version 5.20.3]]

LCM is at 2.4.4.2. NCC check done previously, nothing to report. Here the LCM dashboard. 

Any ideas on how to resolve this? Thanks a lot in advance. 

BTQ: I’m working within a lab environment. 


1 reply

Userlevel 3
Badge +5

@jfm_esi In order to further investigate this behavior, kindly answer the following questions:

  1. Did you run LCM inventory before performing the AOS upgrade to 5.20.3? If yes, then did the LCM inventory complete successfully? 
  2. If LCM inventory was not run before the AOS upgrade, then can you perform LCM inventory and then check if LCM shows the AOS version to be 5.20.2 or 5.20.3 in this case.
  3. What current AOS version is shown when you log in to PE web console > Settings Dashboard > Upgrade Software > AOS? Is it showing the 5.20.2 or 5.20.3 version?

If your cluster is actually running on AOS 5.20.3 version, however, an LCM inventory was not run before the upgrade, then it means that LCM was not updated with the AOS current version details 5.20.3 and hence the LCM inventory might not be reflecting the correct current AOS version.

Reply