Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hello dear Nutanix community,A client of my company has purchased 3 HX Lenovo nodes and 2 ToR Cisco switches, each node was equipped with only 2 ports 10GbE (the LOM ones). However, with only 2 ports, I don’t know how to setup the cluster in a way that there is a redundancy. The current rack looks like this without any cabling yet: The IPMI port will go to a Management Switch, so there’s no issue there. But so far, I am confused as to how setup the cabling for the two interfaces; Should eth0 go to a port on SW1 and eth1 go to a port on SW2 for each of the 3 servers? or should both eth0 and eth1 go to the same switch? If I understood correctly the AHV Networking articles in Nutanix, eth0 and eth1 will form a logical bond (br0-up) inside the br0 bridge. And I’m guessing since we only have 2 uplinks per nodes (I’m going for the first scenario):> eth0 will go to SW1Port1 (for example), SW1Port1 will be configured as a Trunk port, for which the CVM/AHV VLAN and User VMs VLANs will be de
Below are new knowledge base articles published on the week of April 10-16, 2022.KB 12703 - NCC Health Check: file_server_vlan_mode_check KB 12904 - Nutanix Move | Cannot inventory VMs with special characters KB 12918 - Nutanix Cloud Clusters (NC2) on AWS- Access Policy-AWS security groups KB 12924 - Fujitsu Node imaging fails with error "OCP (ID 6) Device not present " KB 12977 - Prism Central: The cvm_shutdown command fails with error: "Unable to detect if VMs with RF1 disks are managed by the current CVM" KB 12980 - DELL 15G | AOS Upgrade to 5.20.3 gets stuck - CVM unable to boot KB 12991 - IAM themis POD crashing after it reaches 370+ ACPs for a specific AD user KB 12999 - Nutanix Files: "Invalid IP format" error when configuring NFS exceptions KB 13012 - Nutanix SSR | Error executing command: Failed to query snapshot due to Nutanix Data Protection service error, error detail: Current NGT version '1.x.x' does not support FLR on policy protected VMs. KB 13013 - Move - Encountered an
how do 3 node cluster guest os migrate to 2 node cluster ?
Operation failed. Reason: Update of failed on 172.16.31.106 (environment phoenix) at stage 1 with error: [Failed to update firmware. Error: Failed to upgrade 3IE3. Information: [cmd: ./mp_64 -d /dev/sdg -c 1 -u -k -r -X 3 -Y 3 -v 0 dir_name: S740305N cwd: /home/nutanix/tmp/lcm_staging/S740305N ldir: ['SYS_S.bin', 'sram.bin', 'mp_64', 'mp_32', 'JMMPTOOL.ini', 'flash.ini'] x: [True, True, True, True, True, True]], Output: [ ************************************************************ * Innodisk MPTool V3.1.0 2020/03/04 * ************************************************************ Model Name : SATADOM-SL 3IE3 V2 Serial Num : B0021805110110184 FW Version : S671115N 1. TH58TFT0DDLBA8H Flash : TH58TFT0DDLBA8H Write code ....... [libjmmp.c][write_code():#2171] erase_flash fail ch : 0 blk : 2 [1;31mFail !! [m[1;31mUpgrade Fail !! [m], Error: [], return code: [4]] Logs have been collected and are available to download on 172.16.31.103 at /home/nutanix/data/log_collector/lcm_logs__172.16.31.103
We have Red Hat Virtualization from where we are going to migrate to Nutanix AHV. Virtual machines in RHV are LVM, not disks, because we are using fibre channel. How can we migrate virtual machines from RHV to AHV?
Is it possible to enable RDMA nic manually in the CVM after manually passthrough the Mellanox network card to CVM in ESXi?It is not enable RDMA during foundation and the cluster is created.After passthrough the NICs to CVM in ESXi, I checked that the NICs are already in the lspci result but can not enable RDMA in Prism.So if it is not possible, that means if the cluster is created without RDMA enabled. there is no way to re-enable RDMA except re-foundation the cluster?
Below are new knowledge base articles published on the week of April 3-9, 2022.KB 8342 - Nutanix Files - Alert - A160085-File Server Manager upgrade Failure KB 12731 - Alert - A160148 - FileServerPartialNetworkState KB 12957 - Prims Central manual deployment error during cluster creation script <ERROR:root:Failed to execute action create. Error([Errno 2] No such file or directory> KB 12960 - Nutanix Files: Exceeding the max number of concurrent sessions 1000 KB 12970 - Enabling Prism support of obsolete encryption algorithms for older Windows OSsNote: You may need to log in to the Support Portal to view some of these articles.
HiI'm hoping someone has a similar setup. I originally posted this question a month or so ago but the answer I received isn't correct. The post has been marked as solved so I'm unable to reply hence why I'm opening a new one. I think there was a misunderstanding with my described setup in the previous post so I've tried to make it clearer here. This is tricky to explain without diagrams so I appreciate this may be difficult to provide a valid answer and I may not get a response.Our SetupWe have a 2 sites connected by fast links with one Nutanix cluster at each site (16 nodes in each Nutanix cluster). These two Nutanix clusters make up 1 stretched ESXi cluster hosting mainly Window servers. We then use Metro availability to replicate between these sites\Nutanix clusters.So in short - One ESXI cluster that's stretched across two sites and we use Nutanix Metro to synchronously replicate.On this environment we host a number of VM guest failover SQL clusters (2 nodes in each cluste
All,I ran the VM HA test failover; similar to another user, here Nutanix X-Ray VM High Availability Test timeout I got the 120 seconds timeout. So I raised a ticket. However one issue I did have is the powered off host was not powered back on again. All validation tests when I discovered the targets were good. I have included this in the support ticket for now, but wondering if anyone else has seen this? Older G5 Nutanix, 3 Node cluster, AOS 5.20.3, PC 2022.1.
I have just changed disk 0 and disk 1 which were SSD SATA 480gb and now are SSD SAS 1.92tb - Prism still identifies them as SSD-SATA - Why? or have a missed something?Also how do I know if they are in a RAID config or whether the system has just picked them up as single disks?The new drives should run like hot snot, how do I check that they are running faster than the old SATA drives - still have 2 hosts with old drives , I plan to complete the change over tomorrow. Or will I only see speed increase when all hosts are complete?
I want to Install Nutanix with VMware 6.7 on DELL XC 740XD Core, I use foundation 5.0.1 and AOS 5.20 (as recomendation on hardware compability), but we stuck at imaging process and log showed dependencies not met. any sugestion?I grab the log, 2021-06-04 06:27:46,980Z DEBUG Setting state of <ImagingStepValidation(<NodeConfig(10.14.43.12) @c990>) @cc10> from PENDING to RUNNING2021-06-04 06:27:46,985Z INFO Running <ImagingStepValidation(<NodeConfig(10.14.43.12) @c990>) @cc10>2021-06-04 06:31:25,810Z DEBUG Cache HIT: key(<function common_validations at 0x450a938>_()_{'global_config': <foundation.config_manager.GlobalConfig object at 0x7f3554120f50>})2021-06-04 06:31:25,813Z DEBUG Setting state of <ImagingStepValidation(<NodeConfig(10.14.43.12) @c990>) @cc10> from RUNNING to FINISHED2021-06-04 06:31:25,814Z INFO Completed <ImagingStepValidation(<NodeConfig(10.14.43.12) @c990>) @cc10>2021-06-04 06:31:25,824Z DEBUG Setting state of
Below are new knowledge base articles published on the week of March 27-April 2, 2022.KB 12908 - Cluster Service ['uhura'] Restarting Frequently KB 12935 - File Analytics Upgrade Fails due to port(22) block between CVM and FAVMNote: You may need to log in to the Support Portal to view some of these articles.
Sometimes you have to mount an ISO, and historically, the only methods to achieve this on G6 and G7 platforms were: 1) by using the IPMI Java console or 2) by mounting the ISO directly from a CVM (KB-4616) With BMC 7.11, we have an added option to mount the ISO directly from the HTML5 IPMI console. For more details, please check out BMC 7.11 release notes and upgrade today for this and many more new features and security enhancements!
Has anyone ever attempted a Host book disk repair and encountered this issue before? All cables and SFPs are plugged in as if it were still in production. Have not yet attempted to rebuild via foundation as these were the steps provided by Nutanix support: https://portal.nutanix.com/page/documents/details?targetId=Hypervisor-Boot-Drive-Replacement-Platform-v510-Multinode-G3G4G5:Hypervisor-Boot-Drive-Replacement-Platform-v510-Multinode-G3G4G5 Steps Taken: Downloaded and burnt phoenix.iso to USB Booted USB into Phoenix Kicked off Repair Host boot Disk and uploaded whitelisted ESXi image Encountered error I have a case open with support and have escalated and figured that while i’m waiting I could ask the community. Will provide a response here once we figure out the issue. Cheers All! (Edit: I posted this in the CE forum by accident)
Below are the top knowledge base articles for the month of March 2022.KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 3827 - Alert - A130087 - Node Degraded KB 1113 - HDD or SSD disk troubleshooting KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 2090 - AHV host networking KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 4158 - Alert - A1104 - PhysicalDiskBad KB 4519 - NCC Health Check: check_ntp KB 2473 - NCC Health Check: cvm_memory_usage_check KB 4141 - Alert - A1046 - PowerSupplyDown KB 4272 - Alert - A6516 - Average CPU load on Controller VM is critically high KB 6945 - How Upgrades Work at Nutanix KB 11663 - Unable to launch Prism Element from Prism Central due to missing "PrismUI.tar.gz" file after upgrade KB 3741 - Nutanix Guest Tools Troubleshooting Guide KB 8094 - NCC Health Check: disk_
Has anyone been able to enable bitlocker on a drive within Server 2019 or 2022? Or is there an update regarding this article? Bitlocker cannot be enabled on Windows Server 2019 in VM running on AHV (nutanix.com)
how can i change ssh port??
Hi. I’m looking for some experiences in migrating windows user vms from acropolis hypervisor to vmware esxi. I tried and followed severals KBs and articles but none were successful. After powering on windows VM on esxi, they immediately go to the famous “blue screen” and don’t recognize the disk. Articles that I followed: https://portal.nutanix.com/page/documents/kbs/details?targetId=kA032000000PMcKCAWhttps://portal.nutanix.com/page/documents/kbs/details?targetId=kA03200000098T7CAIhttps://portal.nutanix.com/page/documents/details?targetId=Prism-Central-Guide-Prism-v5_19:mul-vm-export-as-ova-pc-t.htmlhttps://next.nutanix.com/move-application-migration-19/want-to-export-a-vm-from-ahv-here-s-how-37275Has anyone has experience with this ? Can you help me ? Best regards
So - I have been trying to get some sort of automation of my Ubuntu VM creation in Prism, either by setting up a template machine that I would later modify using cloud-init custom scripts, or even better using a custom cloud-init script at creation to run through the “Ubuntu autoinstall” I have tried a few times now to install an Ubuntu server by clicking my way through the GUI and then using the resulting .yml file to try and install a VM from scratch… Using “clone” from a template I can use a custom script to change hostname and so forth, but still having some problems changing the network settings (saying they are disabled by system.cfg). I guess I will be able to figure that part out eventually, but my main goal is to be able to register a new machine in Netbox, and from the info I have entered there automatically create a cloud-init fileand use that to trigger VM creation in Nutanix… When I try to create a new VM - mounted with the Ubuntu 20.04.4 installer ISO and a 100GB disk -
Hello,I need to create several Windows Server 2019 standard, virtual machines that run in AHV (Nutanix cluster of 3 nodes nx-3170-g8, with 2x16 cores in each node) hosts that i need to buy licenses for. But i do not seem to find a calculation method for licenses).I found that i can go for per core licensing of physical cores (3*2*16 = 96 cores) which would help reduce costs since the total number of virtual cores that need to be configured is more than 200 v-cores.i would like to confirm if this approach is correct? i.e. licensing the number of the physical cores of nutanix appliances? and if anyone did it successfully?Thank you in advance,
Below are new knowledge base articles published on the week of March 20-26, 2022.KB 12846 - Prism Central VM dashboard does not load VMs list KB 12865 - Prism Element(PE) UI is not loading with error 'Unable to resolve <url>' issue KB 12893 - Intel Optane P4800X SSD upgrade concern with firmware E2010600 KB 12896 - CTRL+Enter keyboard shortcut on Frame KB 12915 - [LEAP] Planned Failover doesn't restore VM on recovery site after it gets deleted on source if Network Segmentation for Backplane is enabledNote: You may need to log in to the Support Portal to view some of these articles.
I read that we can able to export the AHV VM in OVA format via Prism central GUI if we have both AOS and Prism central supported version. I need to know is there any way to do the same via PRISM CLI. If so,please share me any link for that. Thanks. -JAI
I’m trying to uninstall VMware tools from VMs running on AHV version 20201105.2244. I am following the KB to uninstall VMware tools: Unable to Uninstall VMware Tools in Windows after Migration by Move from ESXi to AHVI mount the ISO in windows on the VM and run the ‘setup64.exe /c’ command and immediately notice EventID 1000 and 1005 in the application logs. They are application errors not being able to launch the VMware installer process. I have tried this on two separate VMs on different clusters. Has anyone else seen this before?Event ID 1000Faulting application name: setup64.exe, version: 11.0.5.17716, time stamp: 0x5e0aa12fFaulting module name: setup64.exe, version: 11.0.5.17716, time stamp: 0x5e0aa12fException code: 0xc0000096Fault offset: 0x0000000000077c3fFaulting process id: 0xb4cFaulting application start time: 0x01d81df06bb35ef0Faulting application path: E:\setup64.exeFaulting module path: E:\setup64.exeReport Id: 2dc8bb34-f3b9-40d1-859f-0f8f5b772fefFaulting package full nam
Hi,I’m trying to update a Nutanix env, from Prism Element. Using the web, in LCM, I see version 5.20.2 being in there, but when trying to upgrade to 5.20.3, I get the following error:Update of nutanix.nos failed on 192.168.0.2 (environment cvm) at stage 1 with error: [Failed to perform AOS upgrade with error [Preupgrade task [57c7e9a1-ebc9-495d-a848-2ead17251730] failed/aborted with message Version 5.20.3 is same as the current version 5.20.3]]LCM is at 2.4.4.2. NCC check done previously, nothing to report. Here the LCM dashboard. Any ideas on how to resolve this? Thanks a lot in advance. BTQ: I’m working within a lab environment.
New to Nutanix and trying to understand HA for management like in VMware. In VMware we setup vCenter HA with an active/passive/witness. Is there something similar in Nutanix?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.