Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
In certain instances, it may be necessary to change IP address of IPMI. This post explains how to achieve the outcome and where to look for help. Ther are three methods of configuring the IP address. In any case, there are only two simple steps: 1. Configure the IPMI IP addresses by using either the IPMI web interface or the hypervisor host command-line interface via one of the below: IPMI Web Interface Command Line (ipmitool - available on AHV and ESXi hypervisor hosts) BIOS For nodes from other hardware vendors, see the manufacturer instructions. 2. Log on to Controller VM on the same node in the cluster and restart Genesis service. For specific instructions, commands and examples see:NX Series Hardware Administration Guide: Changing an IPMI IP Address.KB-1486 [ESXi] How to re-configure IPMI using ipmitool - also includes instructions and examples on local user accounts management.
Dear all, Is that IPV6 need to enabled in failover cluster manager (Networks) after cluster created at Hyper -V Nutanix?
Let’s say you are installing Hyper-V and want to automate the networking configuration. We all love scripting and writing PowerShell cmdlets for different networking tasks like NIC teaming, switch configuration etc can get really complex. Do we have a cheat sheet which can help us with networking commands and workflows to configure a range of activities on PowerShell? Go through the KB to get a quick glance on the commands and workflow related to Hyper-V networking. KB-1553
Someone who can support me, was doing the idrac update (Hyper-V hypervisor) and failed, but now the node is out and can not lift the services, I try to restart it from the console and I get the error message:2019-12-11 14:04:41 INFO zookeeper_session.py:131 cvm_shutdown is attempting to connect to Zookeeper 2019-12-11 14:04:41 WARNING lcm_genesis.py:219 Failed to reach a [localhost] where LCM [LcmFramework.is_lcm_operation_in_progress] is up. Retrying... 2019-12-11 14:04:46 WARNING lcm_genesis.py:219 Failed to reach a [localhost] where LCM [LcmFramework.is_lcm_operation_in_progress] is up. Retrying... 2019-12-11 14:04:51 WARNING lcm_genesis.py:219 Failed to reach a [localhost] where LCM [LcmFramework.is_lcm_operation_in_progress] is up. Retrying... 2019-12-11 14:04:56 WARNING lcm_genesis.py:219 Failed to reach a [localhost] where LCM [LcmFramework.is_lcm_operation_in_progress] is up. Retrying... 2019-12-11 14:05:01 WARNING lcm_genesis.py:219 Failed to reach a [localhost] where LCM [Lcm
Nutanix Cluster is comprised of several critical software and hardware components. All communication happens on a IP network. CVM - Controller Virtual Machine (AOS) Hypervisor - (AHV | ESXi | Hyper-V | XEN) IPMI - (Out of band management for the hosts) Each CVM communicates with its respective Hypervisor Host on a private IP network. Hosts and CVMs must be on the same subnet. Before proceeding with any network related changes, on the CVM or Hypervisor hosts, it is recommended to perform a cluster health check. Following Nutanix KB outlines the steps to ensure your Nutanix Cluster is in a healthy and consistent state: Checklist on verifying cluster health status To change the IP Addresses, Net-Mask (subnet mask), Default gateway for your AHV hosts due to hardware re-location, network design changes, please follow the guidance from AHV Advanced Administration Guide: CHANGING THE IP ADDRESS OF AN ACROPOLIS HOST Changing IPMI Address of a Hypervisor Host CHANGING THE CONTROLLER VM IP A
Nutanix best practices dictate that regular disk drives are configured on the SCSI bus, and CD-ROM drives are configured on the IDE bus. While regular disk drives can be configured on the IDE bus, it is possible that performance degradation may be observed on the drive due to the low queue depth on IDE controller. To avoid performance impact conversion of IDE to SCSI can be performed. Prior to modifying the IDE disk, take a local snapshot of the Guest VM, in case a roll-back is needed. It is strongly recommended that the VMs are powered off before performing the conversion. Convert the disk by cloning the IDE disk and attaching it to the SCSI bus. It is recommended to remove the old IDE disk after the cloned SCSI disk is created and validated. To help you identify any non CD-ROM IDE VM disks Nutanix has included NCC check uvm_ide_disk_check into NCC software package. This check is not scheduled to run on an interval and it does not generate an alert. Further on conversion steps, pre-
We are on 5.10. I want to leverage the API(s) to remove disks from a VM, and then add new disks to a VM (using images as the sources). Which API should I use? v3 has "Update a existing VM" (sic) but I am unclear about how to (a) remove scsi:1 and scsi:2 and (b) add new disks (using images). The v2 API has "Detach disks" functionality. If I detach a disk does it get deleted? If not how do I delete it after detaching? "Attach disks" is also available in v2 but I don't see a way to use an image as the source (which I can do using ACLI). Thanks in advance for your responses.
Below are new knowledge base articles published on the week of December 8-14, 2019. KB 8306 - Pre-Upgrade Check: test_if_any_upgrade_is_runningKB 8461 - LCM Pre-check - test_oneclick_hypervisor_intentKB 8545 - NSX-T Support on Nutanix InfrastructureKB 8608 - Finding the serial ID of a bad HDD or SSDKB 8660 - [DIAL] Conversion stuck: Migrating UVMsKB 8670 - Prism Central: After upgrading to Prism Central 5.10.6 on Hyper-V, "Illegal instruction (core dumped)" message results when running NCC.KB 8673 - AHV | VM power on may fail with NoHostResources error when initiated from Prism UI or acliKB 8674 - 3rd party storage might cause issues on a Nutanix systemKB 8675 - Cannot plug out the Phoenix (or other) ISO from the IPMIKB 8690 - Alert - A160061 - FileServerShareAlmostFullKB 8694 - Alert - A400111 | EpsilonVersionMismatchKB 8701 - Dell XC-Hyper-V LCM Inventory won't recognize the installed PTAgent & iSM versionsKB 8702 - LCM Operation Failed. Reason: Failed to validate update request.
If your hypervisor is ESXi you know how vCenter manages all the Vms in the vmware data center. You can either use vCenter for Vm management or Prism to control to do most of the same. This stated long ago after AOS 5.0 was released. Most core VM management functions like creating, cloning, updating and deleting VMs, and attaching/deleting disks and NICs as well as power operations alongside console access and guest tool management But for most of the above you will need to register the prism with vCenter. There are rules and guidelines and requirements and limitations that you need to be aware of. You can find out about these and how to register/unregister prism element with vCenter by reviewing: https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v56:wc-management-multi-hypervisor-prism-c.html One thing to notice is that the network traffic between the Prims and vCenter will be much higher than usual when prism is not register with vcenter. Ask any qu
Nutanix Controller VM (CVM) is the brain of a Nutanix Cluster running the Nutanix AOS software to form a highly-resilient cluster comprised of 3 or more nodes. Nutanix CVM offers rich data services, virtual machine management and hosting services, replication services - while ensuring all data and metadata is checksummed to ensure data consistency and integrity. Nutanix CVM communicates over a IP network to all other CVMs and Hosts in the cluster. Thus, changing the CVM IP Address should be planned carefully with all the following and any environment specific points: CVM and Hypervisor Host are required to be in the same subnet (192.168.5.x) Hypervisor host can be multi-homed, but point - (i) is mandatory IPMI subnet should be reachable to and from the CVM Cluster Virtual IP Address iSCSI Data Services IP (used by Volumes, Files, Objects, Karbon, LEAP) Network Segmentation check (Backplane traffic) Remote Sites and any on-going replication Guest VM downtime (this is required for Re-IP
Shutting down and Restarting a Nutanix Cluster requires some considerations and ensuring proper steps are followed - in order to bring up your VMs & data in a healthy and consistent state. Nutanix is a Hypervisor agnostic platform, it supports AHV, Hyper-V, ESXi and XEN. This makes it all the more important to read the following Nutanix KB, which details the steps required to gracefully shutdown and restart a Nutanix cluster with any of the hypervisors. Nutanix KB : How to Shut Down a Cluster and Start it Again?
Hey Community, can someone clarify the compression and de duplication features that come with the starter edition of AOS? I can see on the Nutanix website: https://www.nutanix.com/products/software-options that starter has a check box beside inline compression and inline de duplication, but not besides compression and de duplication, Does this mean with a starter license environments can still take advantage of the storage efficiencies of de duplication and compression (on write)? Is there any solution briefs that go into detail regarding the compression and de duplication features of the starter edition. Best Regards,
And so it is settled. You are migrating to Nutanix. Maybe even from Nutanix (we are sorry to see you leave). Nonetheless you might use some help with the process. Sounds like something you’d be interested? Source and destination platforms to choose from: VMware ESXi to Nutanix AHV VMware ESXi on legacy infrastructure to VMware ESXi on Nutanix Microsoft Hyper-V to Nutanix AHV AWS EC2 to Nutanix AHV Nutanix AHV to AWS EC2 Nutanix cluster to Nutanix cluster Guide 1. Move User Guide v3.4 - It would be unfair not to mention this product. Guide 2. KB1062 - VM Migration Scenarios and Solutions Guide 3. vSphere Administration Guide for Acropolis (using vSphere HTML 5 Client) - VM Migration
Attempting to upgrade AOS from 5.1.3.2 to 5.5.9.5, but the preupgrade steps fails after 5% and the reason for failure isn’t displayed. Is there somewhere I can go to get some details about why the preupgrade keeps failing at 5%? This is what is displayed after the failure: Thank you.
VDi (Virtual Desktop Infrastructure) is one of the earliest applications that was used in hyper-convergent systems. The closer the storage to the cpu and memory the better the performance. Citrix director plugin, need to be connected to the nutanix cluster. if the connection fails with a message "Unable to connect to the host”, you can easily address it by: 1- Allow ICMP traffic and make sure port 9440 is also allowed between Citrix Director and Nutanix cluster. 2- Make sure there is no proxy server configured in the browser configuration The above is reported in the Nutanix public KB article: https://portal.nutanix.com/#/page/kbs/details?targetId=kA00e000000LKiBCAW
The Move 3.0 services are now Dockerised and all Move and Move Agent Services now run as Docker Containers. You maybe running Nutanix Move version 3 and are unable to connect it to hosts that reside on certain internal subnet you have. it may be that local docker container (Docker0) has also assigned to the same subnet. This could be addressed buy the following KB article in your Nutanix Portal: https://portal.nutanix.com/#/page/kbs/details?targetId=kA00e000000PVwkCAG Ask questions about it, if you are concerned.
Hi guys, Is there any compatibility requirement about AOS versions between 2 DR sites? I am going to upgrade one site to newer AOS version and worrying about their AOS compatibility
I want to Migration VM. Nutanix(AHV) → Another Nutanix(AHV) So. I tried to get the qcow2 file. refs https://virtualife.pro/export-an-nutanix-ahv-vm/ First I tried executed command “acli vm.list” → succeed :) The next time executed command “acli vm.get <VM name>” → nothing happend :( Why? -- Version Nutanix 5.10.5 LTS NCC 3.7.1.2 LCM 2.1.4139
We added a couple of storage nodes to a modest 3-node cluster that was running out of disk space. The alerts about running out of storage, and not having enough for redundancy, are gone. A few months in, and every time I look in Prism, under Hardware, I see that the storage nodes' "Total Disk Usage" has not gone up very much. The compute nodes' disk usage is about 5-6 times as much as the storage nodes (and the compute nodes actually have more storage onboard than the storage nodes). I understand that Nutanix tries to keep a VM's storage on the same host that provides its compute resources (and the copy is sharded and spread out among other nodes). Is that why I am seeing so little utilisation of the new storage nodes in Prism?
Hello Sirs! I just want to inquire and ask if anybody has an idea if Nutanix has a plan to automate the processes of doing a shutdown of the cluster, entering a Node to Maintenance Mode and exporting VM that resides to a nutanix cluster and integrate this basic operation to their Prism Element or Prism Central GUI just as what the other HCI vendors? currently I belive these things is done via CLI only. I know this is a easy task for a technical people and admin but I think it defies the "one click simplicity / one click operation" that is shown on presentation decks. It would be great and probably an additional edge if processes like this is automated. thanks 🙂
Hi all, Our end users want to get SMS service when Nutanix has alert. May I know the following things? 1) Do you have any script or API to send SMS by using SNMP? 2) Is it possible to share the script? 3) If there is no script for SNMP, what is the best way to send SMS to end users? Thanks in advance for your support Billy Seo
If you are running Nutanix hardware, you may be familiar with accessing the IPMI page to load ISO files and looking into hyperviosr remote console among many other functions. You can reach this page from Hardware link in Prism (click on table tab and select the hyperviosr you are concerned about, the lower left of the screen will provide you with an IP link to the ipmi page) Occasionally we need to be concerned about the hardware related messages the node provide us (Event Log) OR hardware component level health of the node. The “Server Health” tab in ipmi page can provide us with these valuable information: ==
Hi, I have updated my Nutanix (AHV) license and checking license status, i see correct license expiry date applied to my clusters. I however still get alert from “Licese Standy Mode” details below Possible Cause The license file has not been applied after cluster summary file generation. Recommendation Apply a new license. When i try to reapply license by downloading csf file, uploading csf file i get error: You’ve uploaded an older/inactive cluster summary file(CSF). To continue, download the latest CSF from Prism Element or Prism Central Help please
Let's say we need to change the MAC Address of a VM we just created due to various reasons. licensing being one of themDoes Nutanix AHV provide you with a feature to set a static MAC Address or change the MAC address of a VM? Yes, we do have a feature to change the MAC address of the VM and assign another address. As of writing this article, the feature can only be achieved through acli and have some limitations and guidelines. Please check out the Knowledgebase article regarding the steps with the latest updates. KB-3670 Want to know more about AHV Networking? Try giving this KB a readKB-2090
Hello community, does anyone have advice on destroying cluster without CVM access? As you know, JAVA applet doesn’t allow you to reinitialize system because of existing cluster config. And, I don’t have access to CVM or Prism. Thank you, Dragan
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.