Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Regardless of the reason to destroy the cluster whether it is to relocate and reuse an existing kit or switch to a different hypervisor, to build something new often means to destroy something that already exists and Nutanix has a process for it. Migrate all user VMs off the cluster. Reclaim licenses. Ensure there are no errors displayed. Stop the cluster. Destroy the cluster. Not too bad, right? Some things to keep in mind is that cluster destruction does not affect either: IPMI configuration. Which is convenient if you wish to re-use the settings in the new environment. Installed hypervisor. Nodes would have to be re-imaged should a different hypervisor be required. Migrate all workloads off the cluser prior to executing the cluster destroy. Cluster destroy clears all metadata and data on the storage. Useful links: KB-3716 Reclaiming Cluster License Acropolis Advanced Administration Guide: Destroying a Cluster Field Installation Guide
Hi, I’ve configured a Nutanix device running Prism 5.10 with SNMP - I’ve set a transport for UDP on port 161 and made sure there’s a tick in Enable for Nutanix objects. But when I try to run an SNMPWalk or SNMPGet from a device on the same subnet to start building a custom service in Solarwinds NCentral I get no response from the device. To confirm the issue isn’t on the server I’m running the query from I’ve done the same thing to another windows server and that works fine, so I’m fairly confident I’ve got the local firewall configured, I’m just not getting a response from the Nutanix device? I configured a trap on the Nutanix device and pointed that at the same server and that worked, it just doesn’t seem to be responding to incoming SNMP requests? Any suggestions as to what I may have missed would be gratefully accepted!
Let say that you have updated your IPMI IP address or moved it to another subnet, after you finish the update you are not able to log back in to the IPMI. This happens as a result of not restarting the genesis service on the local node which people tend to forget, after you make the change you must restart the services on the same node’s CVM by running “genesis restart”. If the restart is successful, output similar to the following is displayed: Stopping Genesis pids [1933, 30217, 30218, 30219, 30241] Genesis started on pids [30378, 30379, 30380, 30381, 30403] You can change the network configuration of your IPMI using one of the following methods: Configuring the Remote Console IP Address (IPMI Web Interface) Configuring the Remote Console IP Address (Command Line) Configuring the Remote Console IP Address (BIOS) For the full documentation check out this page.
Let’s say that you ran the health checks on your cluster and received a failure under the component “cvm_name_check”, what does it mean and how do you fix it? The NCC health check cvm_name_check ensures that any renamed CVMs (Controller VMs) conform to the correct naming convention to avoid issues with certain operations that depend on identifying the CVM from UVMs on the same host. The default Controller VM naming is NTNX-<block_serial>-<position-in-block>-CVM. The display name of the Controller VM must always: Start with "NTNX-"; and End with "-CVM" For more information check out: https://portal.nutanix.com/#/page/kbs/details?targetId=kA00e000000XfCMCA0 To see how to modify the hostname of the Controller VM check out: https://portal.nutanix.com/#/page/kbs/details?targetId=kA032000000TUjkCAG You followed the naming convention and the check is still showing a failure? This might be a false-positive alert depending on your AOS, contact Nutanix support for verificatio
You may have noticed when adding disks to the node or replacing disks with larger capacity ones, utilisation distribution between the disks does not occur immediately. You check on the cluster sometime later and notice that newly added disks still show minimal usage, much lower than expected. By default, the aim is to bring disks utilisation within +/-7.5% spread of the tier utilisation. There are some things to consider when expecting a certain outcome: Disk balancing is not triggered unless the tier usage is at least 35%. Only 1 GB of data is moved during a Curator scan per node. Even if the tier usage is below 35% should any disk usage across the cluster reach 70%, disk balancing takes place. Disk Balancing: Disk balancing ensures data is evenly distributed across all disks in a cluster. In disk balancing, data is moved within the same tier to balance out the disk utilization. This is different from ILM (Information Lifecycle Management), where data is moved between dif
There are a number of reasons you might want to migrate a VM manually in or out of a Nutanix AHV cluster. You could be working with a situation not supported by Move, such as stand-alone ESXi without vCenter or no network path from the old hypervisor to the Nutanix cluster. Possibly you want to save a VM's disks to portable storage media and physically transport them rather than push them across the WAN. If you're wanting to move VM data in or out of AHV, the methods have been provided in this article "Transferring Virtual Disks to an AHV Cluster". If you're just looking to migrate current, working VMs from an ESXi or Hyper-V cluster Nutanix highly recommends using Nutanix Move to migrate VMs to AHV. The manual migration methods require attention to detail and generally involve a larger time investment and more downtime to complete the move. I won't go into full detail on the steps, that's already done in the article I linked, but I will highlight that for any VM you’ll need VirtIO
Is there a way to execute a script (or PowerShell script/command) inside a newly created AHV VM which does not have an IP address yet? The VM has Nutanix Guest Tools installed. I’m looking for automating the creation of a new VM. In VMware, I use the Invoke-VMScript command. I didn’t know if Nutanix had something similar? Thanks! -TimG
Sometimes it is very boring to install the PrismCentral VM on AHV after your Cluster runs but it gets buggy. So here are some tips to solve problems there Deploy a Network in your new AHV Environment first Deploy the new VM via Prism Element Homepage Often you get an error with ssl and httpd could not start! Login via ssh to ip of your fresh deployed Prism Central Server Login via nutanix / nutanix/4u sudo -i service httpd status (mostly not started) service httpd start (ignore the ssl errors in the output) Now the new PrismCentral Website should arrive after a while under https://ip-of-prismcentral Login not possible with admin / admin or admin / nutanix/4u? Login again via ssh and nutanix / nutanix/4u to prismcentral sudo -i passwd admin set your admin password and repeat it reboot wait a while login to prismcental and admin / your password Register your cluster in prism element
When a Nutanix / vSphere cluster is deployed by Foundation the recommended drivers are installed, but after some time you may want to check if there is a newer driver recommended. From the Nutanix perspective, we have covered this with an NCC Health Check: esx_driver_compatibility_check so if you update NCC and run a health check, this check should tell you whether there is a later driver version qualified by Nutanix. To run the check from the CLI use “ncc health_checks hypervisor_checks esx_driver_compatibility_check” from any CVM in the cluster. You may see a newer driver listed for your NIC hardware and ESXi version. A newer driver may not have been qualified yet by Nutanix and in some cases could cause issues for the cluster, so generally we recommend staying with the recommended drivers as identified by NCC.
Hi, I’m new to nutanix and this is my first post :) I’ve started to create a cluster in a lab environment and it seems to work fine. I created two bridges with 2x10G and 2x1G for user VM traffic. For the next step I tried to use the network segmentation to separate management and backplane traffic. Therefore an eth2 interface is required for the CVMs. Problem is, that there’s no eth2 available, just eth0 and eth1: When I start the segmentation process I got the particular error message: Did I miss something? Thanks Benjamin
Q. Does Nutanix support inline encryption? Inline encryption is not currently supported on the Nutanix platform. However Data At Rest Encryption (DARE) of two kinds is supported: Using Self Encrypted Drives (SED) is supported Security Guide v5.16: Preparing for Data-at-Rest Encryption (SEDs) Security Guide v5.16: Configuring Data-at-Rest Encryption (SEDs) Software Only Data Encryption Security Guide: Data-at-Rest-Encryption (Software Only) Q. How do I know that the data is encrypted? More details around the encryption status and logs can be viewed via the nCLI, using REST APIs or PowerShell cmdlets. KB-7846 How to verify that data is encrypted with Nutanix data-at-rest encryption Q. Is it possible to monitor the encryption? Monitoring of the encryption state is done via our Nutanix Cluster Checks (NCC) that generate an alert on any issue detected within the cluster. Please keep in mind that enabling encryption is a cluster-scope setting. Q. What is recommended sizing of the CV
Below are new knowledge base articles published on the week of March 15-21, 2020. KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 9009 - AHV | No Intel Turbo Boost frequencies shown in the output of "cpupower frequency-info" command KB 9070 - [CSI] PVC Volumes Stuck in Pending State | Error: Secret value is not encoded using '<prism-ip>:<prism-port>:<user>:<password>' format KB 9071 - Configuring hypervisor after satadom replacement fails with phoenix 4.5.2 KB 9085 - [Objects 2.0] Error creating the object store at the deploy step. KB 9095 - Nutanix Files- FSVM expansion may file with error IP already in use KB 9102 - How to identify plugged-in SFP module hardware details KB 9103 - WARN: Could not use proxy. URL Error <urlopen error [SSL: TLSV1_ALERT_INTERNAL_ERROR] Note: You may need to log in to the Support Portal to view some of these articles.
In a Nutanix AHV cluster the image service is used to index and manage ISO and virtual disk images for cloning to new VM disks or mounting to the virtual CDROM. With the addition of Prism Central 5.5 or later, this adds a global image service to manage these files across multiple clusters. When managing images from Prism Central we sometimes will see an image show up on a cluster as "inactive". This means the metadata for the image exists but the file does not exist locally on that cluster. The article "Prism Central: Adding Images to Prism Central" gives a few options to remediate this condition when an image is needed on a certain cluster but is inactive. These methods are useful with Prism Central 5.5 and 5.10 versions. In Prism Central 5.11 we have added image placement methods to control where your images will be available. During image upload you can choose to select individual clusters where the image should reside, or you can apply a category to the image to utilize an imag
Hello, does anybody have experiences with a container OS like RancherOS on AHV? In the Compatibility Matrix of Nutanix I can see that RancherOS v1.5.5 is compatible with my AOS 5.10, but I don’t know which image of RancherOS I should use. The are some images for a specific cloud provider and some for a specific hypervisor, but no one for Nutanix, AHV or KVM. I tought then I simply have to use the rancheros.iso, but there a some contradictions that I don’t understand. The good news is that the VM is working as expected, but RancherOS everytime enables the hyperv-vm-tools on startup and the container os-hypervvmtools is restarted every few seconds. The logs of this container are also empty. Does anybody know if there is something special to consider? For example do a need to enable the qemu-guest-tools or the kernel-extras? Any information or tips are welcome. Best regards H.Budde
2 of 3 nodes are fine and working. The 3nd CVM is up and i could ping it. Restart the Cluster with “allssh genesis stop cluster_health; cluster start” does not start these Cluster Partner. After Login in Prism i saw a “Disk degraded” for these 3rd node and now these disk is missing. How to fix node Nr. 3 in a 3 Node Cluster?
What is Erasure Coding? Erasure coding increases the usable capacity on a cluster. Instead of replicating data, erasure coding uses a parity information to rebuild data in the event of a disk failure. The capacity savings of erasure coding is in addition to deduplication and compression savings. If you have configured redundancy factor 2, two data copies are maintained. For example, consider a 6-node cluster with 4 data blocks (a b c d). In this example, we start with 4 data blocks (a b c d) configured with redundancy factor 2. In the following image, the white text represents the data blocks and the green text represents the copies. Data copies before Erasure Coding Computing Parity Data copies after Computation of Parity Erasure Coding Best Practices and Requirements: A cluster must have at least four nodes populated with each storage tier (SSD/HDD) represented to enable erasure coding. Avoid strips greater than (4, 1) because capacity savings provide diminishing returns and
I am looking for other customers who have used the witness feature. We have three buildings each about 1 mile from each other. 10g fiber between them. We have two Nutanix clusters, one in each of two of the buildings. We have the ultimate licensing and are already using Metro clustering. I have the fail over set to manual. Today I setup a witness server in the third building. As far as I can tell everything is working. The real question is should I use it? Is anyone using the witness. Does it cause more problems than it solves. At least with manual I have full control when a fail over happens. So far it has been easier to fix my issues than to fail over and almost all issues are network related not nutanix.
What is Metro Availability? Nutanix provides native “stretch clustering” capabilities which allow for a compute and storage cluster to span multiple physical sites. In these deployments, the compute cluster spans two locations and has access to a shared pool of storage. The solution is currently available for ESXi only. This expands the VM HA domain from a single site to between two sites providing a near 0 RTO and a RPO of 0. In this deployment, each site has its own Nutanix cluster, however the containers are “stretched” by synchronously replicating to the remote site before acknowledging writes. The following figure shows high-level architecture of a Nutanix Metro Availability deployment: The following figure shows an example link failure: Nutanix Metro Availability also can be set up with Async-DR replication to a third site to combine the multi-site resiliency of the Metro setup with traditional space-efficient incremental snapshot backups. Metro Availability Configuration
This alert is generated when an API comes in which is authenticated as "admin". Nutanix recommends any script or third party application sending APIs to the cluster should use a service account rather than using 'admin'. You can read more about this alert from the article "Alert - ExternalClientAccessCheck" If you are seeing this alert, it is informing you that some system is authenticating as admin. To aid in investigation the IP address is provided. The intent is that any 3rd party application or script should be using a service account and not ‘admin’ as this makes command auditing much more reasonable and helps keep the admin password secure. When a third party application such as Veeam is set up to authenticate to the cluster as ‘admin’ that should generate this alert. If you log in to Prism Element as admin, access the REST API explorer, and then test an API you should see this alert because that’s your desktop sending an API as ‘admin’. Likewise if you set up a PowerShell script
We are planning our AHV migration and would like to migrate about 75% of our VM’s (~400) during their negotiated patch outage windows to minimize how many app teams get to set our schedule for us. Most of these outage windows are in the 3AM time frame. We would like to find an automated/scripted way to do the cutover so that we can set a job to run that script overnight during that window. I’ve seen some REST calls that look like they could do it. Has anyone actually done it? If so, would they mind sharing a sanitized snippet of their Powershell/REST code? Thanks in advance!
In some scenarios, you may need to move a disk from IDE to SCSI bus or vice versa. Sample scenarios include but are not limited to: VM does not boot due to missing SCSI driver. In such cases, the disk can be converted to IDE to install the missing drivers and then moved back to SCSI. A wrong disk type was used during VM creation. Application requirements dictate the particular type of the disk. You have recently migrated VMs to AHV and noticed that some of the disks appear in IDE format. After following the disks conversion process from IDE to SCSI (as described in step 2 of the uvm_ide_disk_check) the following doubts arise: Question: Once the disk gets converted, does it immediately redirect all I/O to the SCSI drive and leave the IDE disk unused? Answer: Once the conversion is completed (which is actually a cloning process from the original IDE disk), the new SCSI disk needs to be attached to the SCSI bus and then the old IDE disk could be removed. Question: What ar
What is cloud connect? Building upon the native DR / replication capabilities of DSF , the cloud connect feature enables you to back up and restore copies of virtual machines and files to and from an on-premise cluster and a Nutanix Controller VM located on the Amazon Web Service (AWS) or Microsoft Azure cloud. The following figure shows a logical representation of a “remote site” used for Cloud Connect: Cost and management Amazon or Azure customers are charged only for capacity that is used (not charged for the full capacity). Once configured through the web console, the remote site cluster is managed and monitored through the Data Protection dashboard like any other remote site you have created and configured About AWS & Azure Storage: Amazon S3 is used to store data (extents) and Amazon Elastic Block Store (EBS) is used to store metadata. When the AWS Remote feature replicates a snapshot data to AWS, the Nutanix Controller VM on AWS creates a bucket on S3 storage. The buck
NVIDIA GRID boards allow GPU virtualization, enabling multiple users to share a single graphics card. GPU virtualization not only provides the benefit of higher user densities, but also delivers native-like performance while accessing a virtual desktop. In 2016, the Pascal-based P series was released—the P100, P4, P40, and P6. The P4 and P6 are best for blade server form factors and the P100 and the P40 are suitable for the other form factors, such as rack mount. Nutanix offers the P100 and P40 in our different hardware choices. In 2018, NVIDIA introduced the Turing Tensor Core–based T4 for cloud workloads, including high-performance computing, deep learning and inference, machine learning, data analytics, and graphics. One of the common causes of being unable to allocate vGPU to guests is caused by the GPU being set to Compute Mode which results in the errors below: The vGPU option may appear greyed out and unavailable When trying to install the NVIDIA-vGPU rpm package from the CVM
You may be familiar with using Nutanix Move to migrate VMs into an AHV cluster, or you may have imported VMs to AHV manually following this method, but what if you want to take your VM out of your AHV cluster to use in a non-Nutanix ESXi cluster, or to deploy on Hyper-V or KVM? Note I said non-Nutanix ESXi cluster. If you have a Nutanix ESXi cluster and an AHV cluster it’s much easier to use Async DR migration since this kind of cross hypervisor DR migration is fully supported from Prism. If you need to export your VM from AHV to another hypervisor there is a documented procedure provided. Here we will be using the articles “AHV | How to access VM disk files on Nutanix container” and “AHV | How to migrate user VMs from AHV to Hyper-V/VMware ESXi/KVM”. The first article covers reviewing your VM configuration from ACLI to identify the VM disks which are named by their UUID, and then how to collect those files using the SFTP protocol on port 2222. The second article describes using th
Hi team, i have questions about capacity calculator let say i have config for 3 node like the picture below, so in prism will show me 17TB logical capacity correct? and i have concern in extent store RF2 and N+1 (11TB) in sizer tool, what happen if i have data 15TB which is bigger than RF2 and N+1 size (11TB)?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.