Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
The iSCSI Data Services IP address is used to provide iSCSI access to the cluster storage. It is primarily used by Nutanix Volumes, but is also leveraged by other products such as Calm, Leap, Karbon, Objects and Files. This IP address is owned by one CVM of a cluster at a time, with ownership changing among the CVMs as needed to ensure that it is always available. To note, the iSCSI Data Services IP address CVM owner does not necessarily correlate with the CVM that currently maintains Prism service leadership.To find the current CVM acting as the iSCSI Data Services IP address owner, simply obtain the IP address output from all of the CVMs (generally by using the “allssh ifconfig” command) and verify which CVM reports as having this address. To find when a ownership change has occurred, the Stargate service logs from each CVM can be filtered for entries regarding “eth0:2”.You can find more information regarding the iSCSI Data Services IP Address from the Nutanix Volumes Guide along wit
Great pleasure to say Sizer 5.0 is now liveTwo very big thingsCluster settings/cluster policy. We always allowed you to edit the model list and set thresholds for cpu/ram etc that the cluster must meet. Lot more now. Mihn cpu speed. Required networking. Also added policy. So you can state I want production, test/dev, or mission critical policy. This gives you more rigor in the sizing as enforces best practicesMultiple recommendations Sizer by default gives you the lowest cost solution. That is there but now core optimized and storage optimized too. So solution with more cores or more storage that fits in cost range you state. Good to have multiple options
I know that this question has been asked in this forum a few years back but I wanted to see if the answer changed since the newer releases of AOS. In my case, I’m running AOS version 5.15.4 LTS and found that our 7-node cluster was configured for RF3 - although most of our containers are RF2 (the exceptions being the “NutanixManagementShare: and “SelfServiceContainer” containers).Since most of our containers are only RF2 I’m not too concerned about extra overhead but was curious if AOS now supports the switchback from RF3 on the cluster.
From the AHV Best Practices document, live migration network is in host management network(br0).In the network segment enviroment, backplane is isolated in another network which maybe has high bandwidth, does the live migration has any change under this condition? or Live Migration network can do some setting like ESXi vmotion network?
Hi. I have a question while using Xi Frame.If I want to use the List active session and stop session functions among the Xi Frame functions, what privileges should the administrator at least be given to use them??For detailed functions, please check the red underlined area in the attached photo.
Hello,I'm trying to setup four nodes on Lenovo HX3321 with vm foundation, but the vm foundation is not start.We have verify the address vm foundation is correctvm foundation and IPMI same network can you help !!thanks.
Hi all,How many blocks can be added in one rack? I mean min and max numbers.Thanks in advance.
Hi Nutanix Community, We often wonder what is the real storage capacity available on a Nutanix cluster. We have a three node cluster, in RF2. In Prism Element main page, under "Storage Summary", I see : 20.87TiB free (logical) of 22.37 TiB https:// Data Resiliency is OK. (green) Which one of the following statements is correct ? I can fill my storage up to 22.37 TiB without losing the data resiliency (=I can lose a node without losing data). I can fill my storage only up to 66% of 22.37Tib (= 14.76Tib) without losing the data resiliency Thank you 🙂
I have a cluster of 6 nodes including 3 nodes 1065-G5 and 3 other nodes 1065-G6 which run a hyper-v.I wanted to update from Aos 5.10.5 to 5.17.1 through LCM but I am having issues with the processors.I therefore want to proceed node by node in maintenace mode.Can you give me the procedure for updating the aos by proceeding by this method?
after change IPMI i found warning IPMI not match I see the reference https://portal.nutanix.com/page/documents/details?targetId=Hardware-Admin-Ref-AOS-v5_17:ipc-ipmi-ip-addr-change-t.html how to step genesis restartI must stop cluster before ?i can run command genesis restart when cluster start ? Thank for support
Below are new knowledge base articles published on the week of February 14-20, 2021.KB 9314 - Nutanix-Auth-FAQ KB 9866 - NCC Health Check: ergon_checks KB 10310 - Alert A801101 - L2StretchDeletionFailure KB 10574 - Pre-Upgrade check: test_vmd_node_esxi_upgrade_versions_compatible KB 10657 - Discrepancy between Memory Capacity on Prism and Hyper-V KB 10720 - Modify snapshot expiration date and time for Xi Leap snapshots KB 10758 - PDF Report generation fails on Prism Central after upgrading to pc.2021.1 KB 10762 - Prism Central reports showing "No Data" when multiple filtering rules are applied to filter specific entities KB 10765 - AHV upgrades from 20170830.x to 20190916.x and 20201105.x on Dell clusters fail with "Failed to run 'yum remove -y DellPTAgent dcism': 1" error message. KB 10776 - NGT installation fails on Linux VM with Permission denied error KB 10787 - LCM pre-check failing with Failed while performing pre_actions err: Unable to boot cvm [xx.xx.xx.xx] into ivu. KB 10789 -
Hi,My company is going through a major organization change, and we will be driving a lot of VM automation through Ansible. Since all of us know that the Powershell support is woefully lacking in AHV, I would like to try to get more automation plugged in through Ansible. Is there an example playbook out there for upgrading/installing NGT for both Windows and Linux?I know that updating NGT via Prism Central works pretty well for Windows, but once again, it fails miserably for Linux (at least OUL). I would like to do it in an automated fashion, however, instead of 60 checkboxes at a time. I need a feature that I can upgrade hundreds of VM’s at once and schedule it.Any assistance would be appreciated!
The shutdown token is used by a Nutanix cluster to prevent more than one entity from being down or offline during the occasion of software upgrades or other cluster maintenance. The CVM that is holding the token is the only entity allowed to be down or offline. Sometimes, for various reasons, a CVM can remain holding the token even after an upgrade or maintenance has been successfully completed. This usually does not cause any issues, however, until another upgrade or maintenance is invoked on the cluster sometime in the future. Upgrades or other maintenance pre-checks will search for any unrevoked tokens and, if existing, not proceed until that token has been properly revoked. Before manually revoking the token, it is good practice to verify that there are indeed no outstanding or ongoing upgrades or maintenance activities currently occurring with the cluster. Once confirmed, manual token revocation is often accomplished by a simple restart of the Genesis service on the CVM currently
Please advise me is it support Server 2019 Hyper V on Nutanix? I unable to Find the article on Nutanix Portal with server 2019? I am planing to migrate from Server 2012 hyper v failover cluster to 2019 Server Hyper V failover Cluster? Which AOS Version is support Server 2019?
We’ve migrated a handful of test VMs from our vSphere legacy architecture to Nutanix (also running ESXi) Both on ESXi 6.5 and latest Prism/software builds, etc. When using Nutanix Move to do the migration, we’ve noticed that the migrated VM is taking on GMT for its time when the VM boots up. We are in Michigan so the VM is five hours ahead, but the local windows timezone Eastern. After logging in and/or rebooting, the time typically syncs up fine. However, this proved to be a major problem when we moved a domain controller and it caused time to be off everywhere. ncc health_checks network_checks check_ntp all comes back fine and our time sources are defined properly both in Nutanix as well as NTP oin the ESXi host. What are we missing or is this a bug?
Windows 10 VM stuck at boot and giving black screen. Tried reboot but no luck.
Hello All, I have created this great powershell script that makes VM’s in AHV. It has been a journey let me tell you, but I made it through. The one thing I would like to add to this is creating a vm with UEFI boot option. I know this needs to be done at creation and I can create it in the acli with the following: acli vm.create UEFIVM2 uefi_boot=true However; is there a way to do this with powershell? I will look at finding a way to wrap the ssh command above but it sure would be nice if it was just a parameter on the new-ntnxvirtualmachine cmdletIs there a way I can create the vm with UEFI with powershell? Thanks,Scott
I got some question from my college, He asked me when in prism. we set smtp server configuration. and also we set about alert email. Which network nutanix use to smtp protocol telecomunication. I mean if I set configuration like this.host name: smtp.gmail.comport: 993security mode: SSLuser: cat@gmail.compassword: ****from email address: nutanix@gmail.com and after I setting alert email, and after that alert is come. which network nutanix use sending email?
I have a couple of oddities going on, one is an ongoing and one was post latest PC2021. update.I was getting warnings that I was using the CVM default password so I chnaged it, it is supposed to replicate to the other CVMs but i get a health alert saying the remaining CVMs are still using the default password - any ideas why?And post PC update, i can log in using ssh but I can’t login to the web UI - I get the login screen , but after I enter username and password (not default) I get “server not available” I have run health checks and idf checks and all seem to PASS - is there a bug in the latest PC Patch? Just to note I can log into Prism Element with my name and password ok.Thanks in advance.
Nutanix recommends that you use the Prism Life Cycle Manager to perform firmware updates. However, firmware must be updated manually if: The component is located in a single-node cluster, OR The component is located in a multi-node cluster, but the hypervisor the cluster is running does not support LCM firmware updates. Shutting Down a Node in a Single-Node Cluster Shutting Down a Node in a Multinode Cluster Manually Updating M.2 RAID Hypervisor Boot Drive FirmwareManually update the firmware on HW RAID M.2 boot drives on -G7 or newer platforms in cases when LCM cannot be used. Manually Updating Data Drive FirmwareManually update the firmware for a SAS or SATA data drive or update the hypervisor boot drive firmware on any -G6 platform M.2 drive (non-RAID). Manually Updating SATA DOM FirmwareUpdate firmware for a SATA DOM. Manually Updating the BMC and BIOSManually update BMC and BIOS versions. Manually Updating HBA Controller FirmwareUpdate the firmware for an HBA card.
Hi,I have a small cluster of 4 nodes. Disk space usage for /home in all CVMs are increasing fast. After some investigation it appears that the /data/logs folder is taking majority of space, more specifically health_server.log file which is taking about 181gb now. 18133488 health_server.log.20201224-1413011144624 sysstats Does the health_server.log file keep collecting indefinitely, there must be a limit to this log file? Thanks.Beg
Hello everybody, i would like to remove a switch from the Network view in Prism Element, which also is no longer configured under Settings => Network Switch. The cluster was moved to different network a couple of months ago. So far I was unable to remove this old network swith from the Network view in Prism Element and it’s also no longer visible using ‘ncli net list-switch’ in CVM command line. There is only the existing switch configured under Settings => Network Switch. We use AOS 5.15.4 LTS currently. If I select ‘Go to Switch details’ when selecting the old visible switch in ‘Network’, I get an error => Switch with id ‘...’ was not found ! Any idea how I can remove such a switch, which is no longer available? Regards,Didi7
We are migrating workloads from VMware (vSphere 6.5) to Nutanix AHV (AOS 5.15 LTS). With regards to VM templates, any advantage in creating new templates on AHV? Any gotchas if we migrate (as per procedure, prepare and use Nutanix Move) VM templates to AHV? Anyway, we will have to migrate most workloads, but was wondering about VM templates. We’re leaning towards erring on the side of caution and creating new templates (Linux/Windows) on AHV. However, I just wanted to know if anybody experienced issues with VMs built from migrated templates on AHV and any feedback.
Hi All,How to Migrate Clusterd VM (SQL CLUSTER) from 2012 Hyper V Failover cluster to 2019 Failover Cluser?Source Infra:Hyper V2012 with Failover ClusterVM : 2012 VM (SQL Cluster, Shared Disk) Target Infra:NutanixHyper V 2019
Dear All,Can we use 1 G port for Hyper VM Traffic on Nutanix?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.