Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
I had a LCM failure while upgrading firmware on a node. The node entered maintenance mode and I was never able to get it out. I have subsequently removed the node from the cluster so that I can finish the upgrade process. I have successfully completed the firmware upgrade on the other nodes.Now I am trying to upgrade AHV. LCM is failing prechecks with the message Operation failed: Failed to find node <uuid>The <uuid> is the one of the node that is no longer in the cluster. Some how I need to get past this so I can complete the AHV upgrade. I currently have two nodes at the most recent version and one at an old version. Is there someway to bypass the precheck or to modify the LCM data about the removed node so I can press on?
Hi everyone,When create Volume Group, I’ll select the allowed source VMs to access my VG either internal VM or external client, the question is in which cases I need to configure Filesystem Whitelists? Thanks in advance.
Volumes acts as one or more targets for client Windows or Linux operating systems running on a bare metal server or as guest VMs using iSCSI initiators. Do not use Volumes to create an iSCSI datastore to Hyper-V or ESXi hosts. This configuration is not supported.The iSCSI data services IP acts as an iSCSI target discovery portal and initial connection point. The client only needs this single IP address to help load balance storage requests and provide path optimization in the cluster, preventing bottlenecks.Enable Nutanix Volume Get the client IP address that you will add to a volume group client whitelist. Create an iSCSI data services IP address for the Nutanix cluster. This address cannot be the same as the cluster virtual IP address. Provision storage on the Nutanix cluster by creating a volume group consisting of one or more vDisks. Perform an iSCSI target discovery of the Nutanix cluster from the clients. [Optional] Configure CHAP or Mutual CHAP authentication on the init
The last couple days I have received an error email indicating that snapshot replication to AWS was skipped because a newer snapshot is available. I'm looking at the replication status and I see:Id : 15008898 Protection Domain : Exchange Replication Operation : Sending Start Time : 04/09/2021 19:49:01 MDT Remote Site : *RemoteSite* Snapshot Id : 15008893 Aborted : false Paused : false Bytes Completed : 75.22 MiB (78,870,811 bytes) Complete Percent : 3.2552084E-4 Id : 14973755 Protection Domain : ERP Replication Operation : Sending Start Time : 04/08/2021 18:00:01 MDT Remote Site : *remoteSite* Snapshot Id : 14973750 Aborted : false Paused : false Bytes Completed : 1.4 GiB (1,508
Hello, I want to know each usage rate of hosts recommended by Nutanix.(For example, do not exceed 90% of the host's memory.)→ CPU, Memory, Disk Usage rateThis site is an ESXi environment.Is Nutnaix officially documented? Thank you.
Hello Community!! I'd like to discuss an ambiguous issue.There is an 3-nodes Hybrid Storage AHV cluster set to RF2. In this case, each node has 70% storage usage. Each node’s storage capacity is same.Of course, it's 70 percent overall.The data resiliency status is critical.That cluster has enough CPU and memory. The problem comes up from here.If one node goes down, will data rebuild occur?If data rebuilding occurs, the total cluster capacity will be over 95%.That would cause problems with the cluster's IO. Is there anyone who can clearly tell me how the cluster works in the event of a failure in that situation.
AHV host supports load balancing of vDisks in a volume group for Guest VMs. Load Balancing of vDisks in a volume group enables IO-intensive VMs to use the storage capabilities of multiple CVMs If you enable load balancing on a volume group, the guest VM communicates directly with each CVM hosting a vDisk. Each vDisk is served by a single CVM. Therefore, to use the storage capabilities of multiple CVMs, create more than one vDisk for a file System and use the OS-level striped volumes to spread the workload. This configuration improves and prevents storage bottlenecks. vDisk load balancing is disabled by default for volume groups that are directly attached to the VMs. You can attach a maximum of 10 load balanced volume groups per guest VM. For Linux VMs, ensure that the SCSI device timeout is 60 seconds. Procedure: SSH into the CVM as a nutanix user Do one of the following Enable vDisk load balancing if you are creating a volume group acli vg.create vg_name load_balance_vm_attachm
Hello everyone, After some research i saw that there is no opportunities to collect Total Snapshot Usage (Exclusive Usage) per Protection Domain through the API (i’m on 5.15.3 AOS).As i have lot of VMs per PD, how can i collect this info through Nutanix Cmdlets and obtain this one per PD ? Thanks.
Below are new knowledge base articles published on the week of April 4-10, 2021.KB 9952 - NCC Health Check: list_vms_with_qos_attrs KB 10350 - NCC Health Check: rdma_enabled_check KB 10482 - Getting Error Message "You’ve uploaded an invalid cluster summary file" When Licensing a Cluster KB 10668 - NCC Health Check: list_containers_being_converted_to_aes KB 10955 - Create Category in Prism returns "The name you entered is in use" even though the name does not show up in the list of categories KB 11010 - Adding Nutanix Objects as Primary or Secondary Storage with Veritas Enterprise Vault KB 11041 - Nutanix Files share not accessible after performing Nutanix Files upgrade or rebooting File Server VMs KB 11051 - Message "kvm: already loaded the other module" when booting into Phoenix KB 11054 - Expand cluster with node reimaging on AOS 5.19.1 and ESXi 7.0u1 fails KB 11057 - Cluster creation fails on HPE nodes when using generic VMWare ESXi image KB 11059 - Unable to enable HA or HA in crit
I migrated 2 linux servers from Xen Citrix successfully. In the image configuration, can I delete the disk images or if I do that the VM will no longer function.
Hi I have a question in the Nutanix enviroment.I need to change control for the ssh to CVM so that just some IPs can access to avoid some intrusion access.I checked the <Nutanix security Guide> and there are some descriptopm in TCP Wrapper Integration, But after I changed the file of /etc/hosts.allow to include just the allowed IPs and CVM management subnet. But It will be changed to default after the cluster security config schedule(by default daily.) Is it possible to change the sshd allow list to achieved this goal? there are security requreiments for the enviroment. thanks.
Now I am studying at Nutanix University. I sometimes see “hot spots” like “eliminate any hot spots” what is exactly means “hot spots”? is it performance of the node or storage degraded?
Hi,Looking to automate some reports using the Rest API. So far I can successfully pull out CPU, RAM and Physical & Logical storage cluster wide and snapshot details but am unable to calculate the values as shown on the capacity runway when viewing a cluster in PC.. specifically the storage usage figure for ‘snapshots’ and ‘system.Anyone know how these are calculated?Thanks
Hi,Can anyone tell if there is an endpoint in v2 to get stats for VMs? I don’t see it under the VM category. Thanks!
I want to gather data for the following stats metrics using the REST API v2. I understand that I need to put the metrics ID as part of the parameters, is that correct?In addition, can anyone tell me the ID for the following stats metrics?Disk Usage (%) GPU Framebuffer Usage GPU Usage GPU video decoder Usage GPU video encoder usage Memory Usage (%) Network Rx Bytes Network Tx BytesThanks!
I want to use the stats endpoints in the API v2 but the metrics are not documented, how can I get the list of metrics available for each stat endpoint?
Petter Glenstrup shows you what you can do with X-Ray, the performance benchmarking and scenario based testing tool from Nutanix.
Nutanix X-Ray is a free way to evaluate a variety of hyperconvergence scenarios. Compare configs and automate testing. X-ray your infrastructure and see if HCI is right for you.Move beyond peak-performance benchmarking to make informed decisions on hyperconverged infrastructure (HCI) evaluations. X-Ray is an automated testing framework and benchmarking solution that offers comprehensive 360° assessments of major hyperconverged infrastructure solutions.
This was a blog by Josh Odgers posted on March 5, 2021For a while now I’ve been working on building new X-ray scenarios for both internal engineering/QA and for customers to quickly/easily and repeatably test more granular functionality of Nutanix.The HCI Platform Availability, Resiliency and Integrity series covers how the test functions on both Nutanix AOS and VMware vSAN and highlights that AOS has a major advantage over vSAN as it always maintains data integrity (both Availability and Integrity) even during failures on the minimum 3 node configurations.vSAN on the other hand suffers I/O errors even with much higher I/O timeouts, larger clusters and even with 3 copies of data (FTT2).But don’t take my word for it, you can now run the tests yourself.Read the complete blog: HCI Platform Availability, Resiliency & Integrity X-Ray Scenario is now GA!
X-Ray 3.10.2 is an automated testing framework and benchmarking application for enterprise-grade data centers.X-Ray is packaged as a VM and uses realistic workloads paired with real-world test scenarios to simulate various workflows and events that typically occur during datacenter HCI life-cycles.New FeaturesData locality scenario: X-Ray 3.10.2 adds a scenario to test resiliency during unplanned system events.Resolved IssuesCurie variables not available on vSAN: Fixed an issue where scenarios did not correctly process CURIE_HCI variables on vSAN targets. IPMI discovery failing: Fixed an issue where X-Ray discovery failed when you added a target with the IPMI configuration set to None. Cannot add AWS cluster as a target: Fixed an issue where adding an AWS cluster as an X-Ray target failed with a Something went wrong error.Download the latest version of X-Ray and read the release notes. Add your comments in this forum and let us know how your are using X-Ray.
Below are new knowledge base articles published on the week of March 28-April 3, 2021.KB 8378 - NCC Health Check: Check Interface Configuration Files KB 10075 - NCC Health Check: ngt_client_cert_expiry_check KB 10743 - NCC Health Check: pulse_enablement_checks KB 10966 - Using storage_container_reference functionality with Nutanix provider for Terraform fails with error "SPEC_INCOMPATIBLE_ERROR" or "INVALID_REQUEST" KB 10980 - Hyper-V VM created in Windows Server 2008 R2 or older may fail to be migrated by Move KB 10998 - NCC ipmi_checksf fail after upgrading ESXi to version 7.0 KB 11018 - LCM-driven AHV upgrade may fail due to missing /bin/bash binary KB 11026 - Fujitsu hardware platform BIOS power setting preventing NVIDIA AHV vGPU driver loading KB 11031 - Agentless Management Service (AMS) version 11.4.0 filling up /tmp on HPE ESXi hostsNote: You may need to log in to the Support Portal to view some of these articles.
What is FLR? What’s the purpose of the /flr endpoint?
Trying to save Nutanix Bible to read as e-book offline. Can’t print page to PDF as most of grafics can’t save
Hello guys,Is it possible to extend ACI VxLAN to Nutanix AHV OVS (using Opflex agent maybe), in other words can we integrate it to ACI ?
I can ping to AHV from my pc. I can ping to CVM from AHV via address 172.x.x.x and internal address 192.x.x.x But I Can Ping To CVM From My PC.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.