Question

Trying to Upgrade AOS

  • 16 April 2021
  • 7 replies
  • 40 views

Badge +1

Trying to upgrade to a specific version by uploading the metadata and binary of 5.17.1.3. This will make the cluster the same as all the others managed by PC.

Currently, the version is 5.15.5.1 LTS.

When I attempt to upload, I get this response:

Software is not compatible with the current installed AOS version

 

This makes no sense to me in that I don’t care that it isn’t compatible. I’m replacing it with this other version. 

Is this saying that I can’t go from 5.15.5.1 LTS and that I need to upgrade to a 5.16 before I can upgrade to 5.17? Would 5.16 be compatible?

I tried finding the answer in the KB, but couldn’t find it (yet).


7 replies

Badge +1

Just tried it with 5.16.1.3 and was unsuccessful.

Not sure where to go from here.

Badge +1

A co-worker gave me this.

So there is no upgrade path to anything from 5.15.5.1?

What’s up with that?

Userlevel 2
Badge +4

Hello @DannyS 

Thank you so much for your question and so sorry for the inconvenience. 

As you are currently at the latest LTS releases there is no upgrade path available at this moment. This release was released after (or at the same time) the 5.19 STS release. If you want to upgrade from a LTS version to a STS version, the latter needs to be released later (if you check for version 5.15.3 you will see that you can upgrade to 5.19). I will check with my team to see if we have any alternative.

Userlevel 3
Badge +3

Hi @DannyS ,

5.15.1 is the latest LTS release and released at March 24th. All STS releases are released earlier (5.19.1.5 is released March 16th) hence you cannot upgrade to a STS version. You need to wait for a new release (either LTS or STS), or reinstall your cluster. Versioning can be deceiving, always check the release date to understand which version is the latest.

Badge +1

Just trying to make it the same as our other clusters which are at 5.17.1.3.

This cluster is pre-production. There are some VMs on it so I’d like to avoid rebuilding it at this time. I need this cluster to be at 5.17.1.3 for our automation to work.

Badge +1

I’m not wanting the latest LTS version. I’m trying to install an older version to be in synch with our other clusters.

Badge +1

OK, I think I found a way, but it only works if I can downgrade.

Can I downgrade to 5.15.1?

If I can, there is a path from that version to 5.17.1.3.

Reply