Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Let's say you want to shut down a CVM for maintenance, firmware upgrade or any other reason, and when you run "cvm_shutdown -P" you get this error: "StandardError: Cannot connect to genesis to check node configuration status" If you have an older version of AOS (5.5.x or 5.6.x) then the shutdown script on your CVM might need a small modification, you can contact Nutanix support and an engineer will edit the file on the spot, or you can upgrade the AOS to a newer version which has the fix. If you have a newer version and you want to shutdown a node in the cluster, make sure that you follow the correct shutdown process depending on your hypervisor, here are the instructions for each: AHV, ESXi, hyper-v or Citrix. You can also check out KB-3270 for the cvm_shutdown script.
Below are the top knowledge base articles for the month of July 2021.KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 5505 - Long Term Support (LTS) and Short Term Support (STS) Releases (Applicable only to AOS) KB 4519 - NCC Health Check: check_ntp KB 6945 - How Upgrades Work at Nutanix KB 4639 - How to place CVM and host in maintenance mode KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 3741 - Nutanix Guest Tools Troubleshooting Guide KB 8378 - NCC Health Check: Check Interface Configuration Files KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 2896 - Nutanix BMC Manual Upgrade Guide KB 3263 - How to Enable, Disable, and Verify LACP on AHV hosts KB 5228 - NCC Health Check: pcvm_disk_usage_check KB 2090 - AHV host networking KB 1438 - Shutting down Nutanix cluster running VMware vSphere for maintenance or relocation KB 6937 - Manual upgrade procedure for Host Boot devic
Below are new knowledge base articles published on the week of July 25-31, 2021.KB 10788 - NCC Health Check: pc_backup_sync_check KB 11741 - Delete user from Prism Project when the AD account is deleted KB 11774 - Imaging platforms that support UEFI boot mode only using Nutanix Foundation KB 11782 - Projects page on Prism Central 2021.5.0.1 web UI may hang on load KB 11799 - One-click CVM Memory upgrade stalls on VMware Cluster if vCenter port 443 is blockedNote: You may need to log in to the Support Portal to view some of there articles.
In addition to data compression and data deduplication — features that are expected nowadays to be present on any storage aware platform Nutanix AOS also offers Erasure Coding. For workloads with cold data present (no write within past 7 days), when enabled, EC encodes a strip of data blocks on different nodes and calculates parity. In the event of a host and/or disk failure, the parity can be leveraged to calculate any missing data blocks (decoding). In the case of DSF, the data block is an extent group and each data block must be on a different node and belong to a different vDisk. Once parity is computed, the data block copies are removed and replaced with the parity information. Workloads Recommended for Erasure Coding Write once, read many (WORM) workloads. Backups. Archives. File servers. Log servers. Email (depending on usage). Workloads Not Ideal for Erasure Coding Anything write- or overwrite-intensive. VDI. Because of data-avoidance technology like intelligent c
Hello there, I am running AHV 5.5.5 after trying to upgrade BIOS and BMC through LCM, one of my nodes failed, then its not booting up, keeps booting in pheonix, tried disabling maintenence mode for the node with no luck, and i was trying to force boot into host via "python reboot_to_host.py" but the script doesnt seem to exist. Any help ?
Hi All, Would like to check is there any docs available which related to Nutanix storage container design and best practices? Assuming i have web, apps and db vm running inside AHV. Isn’t recommended to create new dedicated storage container for each VM or VMs group based on web, apps and db instead of using default storage container? Example:Web storage container Apps storage containerDB storage container Any down side having multiple storage container? John
hello I lose the connection with a single node when I upgrade the BIOS and BMS from BIOS Update To: PB43.103BMC Update To: 7.10only IMPI can access, the host is downI have nutanix 8035 G6 can you advise to fix this issue!
Hi, Is there any best practices for nutanix with vmware on the container compression. Currently the containers is created with post-process compression. Is it better to choose inline or disabled it. My nutanix nodes are hybrid disk.
Hello i am a developer who develops through nutanix api i Want to know about api roadmap i found out by chance that urlhttps://www.nutanix.dev/2019/01/15/nutanix-api-versions-what-are-they-and-what-does-each-one-do/ when i read that page, i feel curious about api roadmap in nutanix 1. when v2.0 api is advanced, v0.8 or v1.0 is deprecated? 2. when i want to use migrate or snapshot function, i have to use v0.8 api? will some functions(like migrate) continue to be categorized in v0.8, v1.0 and v2.0? and if i get some document about v0.8 api, i want to get them i wait for your answer thank you
Most of our customers upgrade their infrastructure once every couple of months and this guide helps our customers understand how to upgrade and what to expect from the process. In older versions of AOS, upgrades were done using “one click” or “upgrade software”. With LCM available in newer versions, the upgrades are much simpler and straightforward. Here’s the documentation to understand pre-requisites of LCM and how LCM works:https://portal.nutanix.com/page/documents/details?targetId=Life-Cycle-Manager-Guide-v20:Life-Cycle-Manager-Guide-v20 The LCM works on one-node at a time and if the upgrade proceeds to the next node if the scheduled node is successful in upgrading to the target version. The LCM upgrade tasks can be monitored from “LCM” in Prism UI. There is essentially no downtime required for the user VMs during the upgrades. With regards to concerns about performance, it’s always best to schedule maintenance window for the upgrades, especially with the cluster with 1G NIC ca
Hi All, I’m sorry because couldn’t find related k/b on mixed nodes compatibility/requirements in details. Just wondering current latest platform supported for mixed nodes with different OEM hardware model in same cluster? For example: Existing we have 3 x HPE DX360 in same cluster and would like expand with different hardware model/family such as Dell XC family/NX family or HPE higher model like DX380 in same cluster? Appreciate it in advance. John.
Is anyone experiencing random RDP issues to VMs on Nutanix?I’m experiencing random authentication errors when connecting to Nutanix VMs.It’s not the RDP setup as sometimes it works.Is there an setting on Nutanix that might be causing this?
The Prism Central admin user is created automatically, but you can add more (locally defined) users as needed. To add, update, or delete a user account, do the following:Note: To add user accounts through Active Directory, see Configuring Authentication. If you enable the Prism Self Service feature, an Active Directory is assigned as part of that process (see Prism Self Service Overview).Procedure In the Settings menu available from the gear icon, select Local User Management (see Main Menu Options).The User Management dialog box appears. Figure. User Management Window Click to enlarge To add a user account, click the New User button and do the following in the displayed fields: Username: Enter a user name. First Name: Enter a first name. Last Name: Enter a last name. Email: Enter the user email address. Password: Enter a password (maximum of 255 characters).Note: A second field to verify the password is not included, so be sure to enter the password co
Below are new knowledge base articles published on the week of July 18-24, 2021.KB 10962 - Post PC-DR steps KB 11394 - Foundation of nodes fail with "Timeout (5400s) in waiting for events" due to network issue caused by the configuration of LACP on physical switch. KB 11516 - LCM: Minimum Required Versions for Dell Environment KB 11599 - Running X-Ray workloads benchmarking on a Nutanix Objects cluster KB 11709 - Duplicated Delete Run Actions may cause Calm deployments to fail and Ergon to crash with OOM errors KB 11736 - AHV vGPU Console Cursor Drift KB 11737 - 1 Click ESXi upgrade may fail if /scratch is corrupted KB 11753 - VM console is distorted for UEFI Ubuntu VMs booting into recovery mode running on AHV KB 11756 - VMs on the AHV hypervisor may restart unexpectedly during an AOS upgrade KB 11761 - Adding/Changing AD Service account leads to "validation failed, username/password contains invalid characters" message in rare cases KB 11763 - All user VMs will not be powered on auto
Hello,I have 2 questions about Storage:Can someone please explain the Deduplication option when setting up storage containers. Is this necessary or recommended? What is the purpose of a Volume Group? Currently we use the whole default storage container for creating disks and dividing out storage to servers. Recently some users have wanted to reserve a few TB for video use and storage. I created a new “video” storage container tapping into the default container for the space. So when I attach the disks to the servers, I pull from this specific container. Would creating and using a Volume Group be better? I don’t understand the purpose of it.ThanksBrent
Can you help on the Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection nic driver upgrade
Can we migrate VM from KVM to Nutanix AOS using MOVE feature?
Hi Everyone,One of the nodes of our cluster suddenly got disconnected. I was not able to ping initially, but after restarting the node and checking if maintenance mode is enabled. Connectivity was regained and all the IPs can be pinged from each other. Even so, the cluster can’t recognize the previously disconnected node even when all pings are good. Tried restarting the cluster and the local CVM but the error below appears:nutanix@NTNX-A-CVM:192.168.50.182:~$ cluster status2021-07-13 07:34:46,652Z WARNING genesis_utils.py:1304 Failed to reach a node where Genesis is up. Retrying... (Hit Ctrl-C to abortTraceback (most recent call last): File "/usr/lib64/python2.7/logging/__init__.py", line 875, in emit self.flush() File "/usr/lib64/python2.7/logging/__init__.py", line 835, in flush self.stream.flush()IOError: [Errno 28] No space left on deviceLogged from file log.py, line 1912021-07-13 07:34:47,654Z WARNING genesis_utils.py:1304 Failed to reach a node where Genesis is up. Retr
I am using MOVE 4.1 and uncovered a bug where the migrated machine network card fails to build properly. In the windows server adapter configuration GUI the NIC shows as configured for DHCP. You can edit that nic by clicking on the IPv4 and assigning an IP and all configuration items. As soon as you save and go back into the settings the IPv4 shows as being DHCP. However; when you do a command prompt ipconfig /all the static IP actually does stick and is configured and the server responds to network pings/dns. Troubleshooting attempted: Delete all registry items for the Network card GUID. Uninstalled adapters from device manager (hidden and visible). netsh winsock reset. netsh interface tcp reset. Deleted NIC and reprovisioned NIC. Rebooted after all action items tested. There is an issue with MOVE 4.1 that has to be causing this and I have a case open with NTX Engineering for resolution. I am rolling back to MOVE 3.7.
Any have integrated calm with files? Create a blueprint to create, update, mount and delete a share from nutanix files?
Any have integrated calm with files? Create a blueprint to create, update and delete a share from Nutanix files?
AOS v5.20.0.1 LTSpc.2021.5.0.1 I need to resize the PCVM from 8 to 10 vCPU and 31 G to 45G memory.Following KB 8932.First step is cluster stop.Command is in an infinite loop. Continually repeats:Waiting on REDACTED (Up, ZeusLeader) to stop: Zeus Scavenger VipMonitor Prism Should I wait this out?Should I interrupt it? If so, then what?
Hi, everyoneAOS: 5.15.6AHV: 0190916.410 / 20190916.564hardware: Lenovo HX5510After I upgrade my cluster to AOS 5.15.6, I was using LCM to upgrade my cluster’s hosts’ AHV from version 20190916.410 to 20190916.564 . Several hosts successfully upgraded, but one of my host seems to fail with the following error:Operation failed. Reason: LCM failed performing action ahv_wait_for_host in phase PreActions on ip address 10.248.51.32. Failed with error 'Host 10.248.51.12 did not complete upgrade stage one in 7200 seconds.' Logs have been collected and are available to download on 10.248.51.36 at /home/nutanix/data/log_collector/lcm_logs__10.248.51.36__2021-07-17_00-31-25.780130.tar.gzI logged on to the IMM and connect to the remote control and saw the follow error on screen:I downloaded the log bundle from mentioned above, but did not found anything useful, the ‘10.248.51.32’(the cvm on host 10.248.51.12) directory is empty, and in ‘lcm_logger.out.2021-07-17_00-31-25.780130’ I only found record
As per previous posters - is NGT supported on Debian 10 yet? Is there a page that lists the current supported guest operating systems?
Hi, Does anybody using one touch automation for setup Nutanix cluster with hypervisor ESXi. Take IP's from DHCP for ESXi and CVM Please share if you got any info. Thanks!!
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.