Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Below are new knowledge base articles published on the week of August 14-20, 2022.KB 13079 - NCC Health Check: nic_model_hypervisor_check KB 13155 - [NX-HW] - NIC Driver & FW compatibility matrix (ESXi) KB 13204 - LCM : Upgrade from <installed version> is not supported by LCM KB 13515 - Supported Upgrade paths for Intel DCF 8.0/Intel-LCM-2.0.0 for LCM-2.5 KB 13522 - Single SSD Repair fails on G8 node stating "Rescue CVM did not come up"Note: You may need to log in to the Support Portal to view some of these articles.
I have a few NX G8 nodes I want to install and configure, however the ToR Switches currently available are 1G switches (I have ordered 10G switches but they are late). I have a few questionsIn the pink circle above, the left port is Shared IPMI (10G) and the right one is its failover (as I’ve seen in NX Hardware specifications), however the speed for Failover port is not specified. Does any one know whether it’s 10G or 1G? And it is activated by default or should I go into BIOS Setup and activate the port during boot? My idea is to use this Failover port for Nutanix imaging and subsequently use it for CVM, Host and User VM traffic (temporarily). Has anyone tried this before? Any issues during Foundation imaging? I’m aware there will be performance issues when it comes to AHV/CVM services running as well as VM performance. Thanks everyone in advance!
Hello,Does anybody know where I can find the 'Nutanix AHV Best Practices', as found in the google search below, I can't for the life of me find it.Specially looking for best practices for different workloads, and that article based on the description seemed to hit the nail on the head regarding higher clock speeds for database workloads for example.i find that a lot of Google links just end up with a "Not Found or Forbidden" message.
Hi everyone, i have a question that can we schedule shutdown and restart CVMs, AHV host automatically? For example, I want to shutdown system at 9 P.M and restart it at 9 A.M. It could be scripts or anything else. Hope your helps
Hi everyone,After upgrade LCM to the latest version scavenger process scheduled every 2 minutes! It drives me crazy!/home/nutanix/bin/scavenger.py --interval_secs=120 --logtostderr=TrueSo if anyone know how to reschedule this process to 10 or 20 minutes, I’ll be very pleased.
we have three new hpe dx380 gen 10 servers for nutanix AHV installation, Can we configure LACP on the Nutanix AHV cluster with new HPE server? what is the prerequisite for LACP configuration, and what we need to do?
Below are new knowledge base articles published on the week of August 7-13, 2022.KB 13112 - NCC Health Check: user_space_process_count KB 13216 - How to switch between multiple accounts in support portal KB 13437 - Frame - App Access Issue Workaround for Mac KB 13449 - Nutanix Database Service | Provision dbserver fails with the error "Unable to sysprep the VM. Sysprep is taking > 30 mins to complete" or "Failed to get IP" KB 13465 - NDB - Log catch up fails for Oracle DBs if the maximum amount of connection is exceeded KB 13466 - NDB- during the NDB upgrade server agent upgrades can fail and cause tasks to queue in "waiting" state KB 13482 - LED operation is not working on Cisco UCS C240-M5SX and INSPUR NF5280M5-24 KB 13495 - Nutanix Disaster Recovery - Magneto service is in a crash loop due to failing license validationNote: You may need to log in to the Support Portal to view some of these articles.
Hello,On our new infra NUTANIX AHV, when I try to connect with Powershell I've this error : PS > $PrismIP = "<Prism ip>"PS > $userName = "<AccountUser>"PS > $password = ConvertTo-SecureString -String "<ComPlexE%Pass@ord>" -AsPlainText -ForcePS > Disconnect-NTNXCluster *PS > $connection = Connect-NutanixCluster -Server $PrismIP -UserName $username -Password $password -AcceptInvalidSSLCerts -ForcedConnectionConnect-NutanixCluster : The remote server returned an error: (401) Unauthorized.At line:1 char:15+ ... onnection = Connect-NutanixCluster -Server $PrismIP -UserName $ ...+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidArgument: (Nutanix.Prism.Common.NutanixCluster:NutanixCluster) [Connect-NutanixCluster], WebException + FullyQualifiedErrorId : The username or password you entered is incorrect. Please try again.,Nutanix.Prism.Common.NutanixCluster When I try a Invoke-WebRequest command
So i uploaded my new certs, everything went fine, prism then restarted, but then I get the following message when trying to connect again.refused to connect.I’ve stoped the prism service and did a cluster start, prism is showing as running but I can’t get anything other then the above message.I can’t even update the certs again incase its a cert issue as the web interface is not working and I can’t for the life of me find a way to do it via ssh.
hello @all,I tried to create a VM with a vdisk on a specified storage_container via APIv3. The JSON I entered:{ "api_version": "3.0", "metadata":{ "kind":"vm" }, "spec": { "cluster_reference": { "kind": "cluster", "uuid": "<uuid>" }, "name": "<name>", "resources": { "disk_list": [ { "storage_config": { "storage_container_reference": { "kind": "storage_container", "uuid": "<uuid>", "name": "<name>" } } }, { "data_source_reference": { "kind": "image", "uuid": "<uuid>" } }, { "disk_size_mib": 10000 } ], "memory_size_mib": 4096, "nic_list": [ { "nic_type": "NORMAL_NIC", "is_connected": true, "ip_endpoint_list": [ { "ip_type": "DHCP" } ], "subnet_reference": {
Ladies/Gents,Second time this happens. First time it did, I did not know how to fix this and did a reinstall. This time I am trying to find a way to avoid going down the full reinstall route…The issueAfter a power failure, in my area, the power may come back for like 5-60 seconds and then off again. This may happen once or twice after the power failure. In that case, what happens, is the AHV seems to mark the two NVMe drives as not available (I have one SSD, 120GB Western Digital booting AHV - so boot drive, and two Samsung EVO 1TB) and due to that, CVM and all VMs are gone.Booting off a USB stick with Linux Mint we can see the drives listed: All I can find is info that requires the CVM, what is gone in this case…So how can this be fixed? Is it a matter of booting with the Nutanix CE USB and doing a repair? Is there something that can be done on AHV (what of course I do have access to) that will 'unflag' the disks as bad (what they are not - if I do reinstall the whole thing and start
I need to stop one as I didn’t remove a large disk from it before starting.
Below are new knowledge base articles published on the week of July 31-August 6, 2022.KB 11808 - PrismCentral: Pre-check test_diskspace_available_hosting_pe KB 12811 - Alert - A130367 - StretchDisabledOnVolumeGroupWithRemoteAttachments KB 12857 - Alert - A130368 - StretchPausedOnVolumeGroupWithRemoteAttachments KB 13434 - How to change Prism Central (PC) cluster FQDN configuration KB 13451 - ESXi Hypervisor upgrade may fail on DX8000 and DX910 platforms with error on VIB Dependency KB 13455 - Nutanix Database Service - How to restore a database on Storage Spaces using CLI KB 13460 - Instructions to Uninstall MinIO binary from Nutanix Object KB 13461 - Yunling - Inspur re-branded Inmerge models KB 13464 - Configuration Steps for Okta Integration with Prism CentralNote: You may need to log in to the Support Portal to view some of these articles.
Hello, warriors of the digital ageCould you help a beginner in trouble? I took an internal snapshot yesterday to prepare for a problem moving nodes from an existing cluster to another cluster The previous one was done well, and the snapshot was about 1.8gb, but I found that even though I deleted the snapshot, I still had about 1tb of capacity leftI checked if the data was increased on another vm, but it didn't, so I think it's because of the snapshotErasing the snapshot doesn't reduce the capacity. What should I do?Where should I check first?AOS 5.20.3.5 / ESXI7.0 u2a
We are planning to migrate 2000 VMs from VMware to Nutanix, I am looking for Power shell script, which can automate the plan creation and start cutover.
Is there any specific requirement port speed on TOR Switch for Nutanix Cluster running NVME + SSD storage? Is still good running 10Gb Switch to cover NVME + SSD performance? Thanks
I would like to create a new scenario with Lenovo HW or modify one with NX HW to Lenovo but I don’t how I could that. Anyone could tell me if is it possible?
Hello Team, We are trying to migrate Fortisiem VMs ( Collectors & Supervisors ) from VMWARE to AHV using Move but facing Authentication Failed issue. We verified and we have root access to the VMs and all the rights on the 2 VMs. Also, the distribution of VMs are Redhat 4.4.7-23). Maybe it’ s a problem of Os compatibility, what do you all think.
Below are the top knowledge base articles for the month of July 2022.KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 1113 - HDD or SSD disk troubleshooting KB 3827 - Alert - A130087 - Node Degraded KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 4409 - LCM: Life Cycle Manager Troubleshooting Guide KB 8514 - NCC Health Check: fs_inconsistency_check KB 2090 - AHV host networking KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 4158 - Alert - A1104 - PhysicalDiskBad KB 2473 - NCC Health Check: cvm_memory_usage_check KB 4141 - Alert - A1046 - PowerSupplyDown KB 8094 - NCC Health Check: disk_status_check KB 3786 - Alert - A1081 - CuratorScanFailure KB 4519 - NCC Health Check: check_ntp KB 9437 - How to restore a node from LCM firmware upgrade failure using lcm_node_recovery script KB 4272 - Alert - A6516 - Averag
Hi, Can we use Aruba 25g DAC cables with Nutanix servers? Thanks,
Hello, Case 2 is not working normally in the AHV clusterIs there a solution?1. Cluster infomation > AOS : 5.20.4.5 > Cluster Network : br0(vs0) > Service Network : br1(vs1)2. HA test scenario 2-1 Case 1 : AHV01 br0 remove two cables > Result : Virtual machine move to another host 2-2 Case 2 : AHV01 br1 remove two cables > Result : Virtual machine does not move to another hostthanks
Hi, Im trying to understand how a Nutanix node works fine even if it’s connected to two switches not in stack. And i found that only one interface is enable when using the active-backup mode, but when im checking on the switches i fount that both interfaces are up. So, im asking if there is a way to check which interface is actif from AHV or CVM.
Hello,I’m trying to mount NGT to a VM through the REST API. However it does not seem to work.AOS version: 5.20.3PC version: pc.2022.4.0.1I tried these two requests:https://IP_ADDRESS:9440/PrismGateway/services/rest/v1/vms/72a3b676-906d-42b1-ad1e-ac8d63cf529b/guest_tools/mounthttps://IP_ADDRESS:9440/api/nutanix/v3/vms/72a3b676-906d-42b1-ad1e-ac8d63cf529b/guest_tools/mountHowever none of them seem to work. Do you have an idea why ?Thanks
We are planning for migrate using Nutanix move from ESXi to AHV.Does it require local admin credentials for migrations for any account with root preveliges is fine.I know the appliance will try to install VirtIO drivers and uninstall vmware tools.But can it be by passed or local admin access is required during migration.Also have another question on Domain controller and Citrix vms running on the vmware ESXi.Are there any pre-requisites to be done before migration. ThanksSriram
Hi,Does anyone replace a failure capacity SATA HDD on Nutanix NX Series with same model HDD before? Is it possible/or compatiable? The NX Series already EOL!
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.