Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Below are new knowledge base articles published on the week of May 10-16, 2026.Support Portal login required:KB-20451 - NDB: Clone from the manual snapshot failed with the error code [VSS_E_NO_SNAPSHOTS_IMPORTED] KB-20861 - NCM : Nutanix Central (NC) and Nutanix Cloud Manager (NCM) Connectivity with Prism Central (PC) is Broken After a Disaster Recovery (DR) Event KB-21141 - NDB - Oracle Software Profile Creation Fails with "Large payload received" KB-21307 - NKP: Node Provisioning fails stating all cloud-init services are not installed in Preprovisioned Cluster KB-21316 - "Unauthorized access" and "Authorization failed: User does not have access to Nutanix Data Lens." KB-21383 - NDB | AAG Registration Creates Log Drives for Non-PITR Clusters KB-21390 - NDB Oracle Database scale operation may lead to Database startup failure KB-21403 - Objects upgrade fails with "Error Op specific setup failed" KB-21442 - AHV Host - VMs Fail to Power On and Acropolis Tasks Hung Due to Unsupported SELin
Hi I’m testing the Nutanix API v3 on a AOS 7.5 cluster through the prism central API. I came across the `https://ip_address:9440/api/nutanix/v3/users` endpoint that allows us to create a new user. However, I can’t see to find a way to create a user that’s not tied to any identity provider (local user). Is there even such a thing? Or is it not supported through the API? Because I can’t see an attribute for that in the payload from the official documentation. I couldn’t find an endpoint for this functionality on other API versions, that’s why I’m using v3. Any help is much appreciated.
Hi all,I am sizing environments and really like to also add the correct licensing to the scenario and export the BOM to request this at the distribution. Unfortunately I have had it now the second time over the last months that licensing was not included correctly.This time I have a scenario with 10 VMs, 5TiB Objects and wanted NCI Edge Pro, NCM Edge Starter and 5 TiB NUS Pro with Adv. Replication. The BOM exported is listing the NCI-E Pro but in addition also Core based licensing. The 5 TiB NUS are missing also the Adv. Replication in the Excel and PDF BOM export.Anybody else with same findings or any thoughts on this?Sebastian
Below are new knowledge base articles published on the week of May 3-9, 2026.Support Portal login required:KB-20902 - NCM : Reclaiming Prism Central Resources After Migrating Intelligent Operations or Self-Service to a Nutanix Cloud Manager (NCM) Appliance KB-21005 - NCM : Handling Domain Drift in Restore Validation KB-21095 - NCM : Backup restore validation fails with "context deadline exceeded" KB-21478 - Investigation and Mitigation Guidance for CVE-2026-31431 on Nutanix Kubernetes Platform (NKP) KB-21484 - Investigation and Mitigation Guidance for CVE-2026-31431 on AHV KB-21486 - NKP - ceph-cosi-driver pod is in a CrashLoopBackOff state due to a stale cosi.sock file KB-21489 - NKP Cluster Creation Fails in Air-Gapped Environments with a Proxy that returns "403 Forbidden" to unavailable resources KB-21491 - Prism Central: Investigation and Mitigation Guidance for CVE-2026-31431 on PC KB-21492 - Alerts raised after AHV upgrade: "Virtual switch vs0 is in an inconsistent state - Reason
Hi Colleagues,Recently, I’ve don AOS & AHV version upgrade for PE cluster (8 CVMs) which is hosted PC cluster with 3 PCVMs from AOS 6.10.1.7 to 7.3.1.2. PC version is 7.3.1.1.After upgrade, there is an issue of HTTP 420 code is happening and cannot proceed with VM migration cross clusters.Does anyone have the idea or experiences with this? Thanks.
Below are the top knowledge base articles for the month of April 2026.KB-13150 - NCC Health Check: cfs_fatal_check KB-1540 - AOS Only - What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB-7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB-3827 - Alert - A130087 - Node Degraded KB-8453 - Alert - A1044 - PathOffline KB-1536 - NCC Health Check: disk_online_check KB-4944 - Unregister cluster from Prism Central and cleanup (regular and force) FAQ KB-8885 - Alert - A15039 - IPMI SEL UECC Check KB-13104 - Alert - Inconsistent Virtual Switch State Detected KB-6945 - How Upgrades Work at Nutanix KB-9437 - How to restore a node from LCM firmware upgrade failure using lcm_node_recovery script KB-8094 - NCC Health Check: disk_status_check KB-21134 - Alert "Inconsistent Virtual Switch State Detected" after AHV Upgrade to 11.0.0.1 or 11.0.0.2 KB-1558 - How to license your Nutanix Cluster - Nutanix License Manager Guide and additiona
Below are new knowledge base articles published on the week of April 26-May 2, 2026.Support Portal login required:KB-20906 - NCM : Duplicate Apps in Marketplace after NCM recovery KB-20909 - NCM : How to abort runbook executions and approval requests that are not progressing after an on-prem to NCM 2.0 migration KB-21090 - NCM : Pods experiencing CrashLoopBackOff due to unhealthy Postgres container in nc-pg pod KB-21094 - NCM : How to offboard a remote Prism Central account KB-21400 - Incorrect vmnic ordering on NX?8150?G9 ESXi hosts caused by BIOS ACPI?_SUN enumeration issue KB-21407 - Network Controller internal failure rate is excessive after network controller upgrade KB-21415 - Nutanix Files - VDI Sync Policy completes with error Replication Completed with Errors: Unable to replicate all files/folders 'as retry list is not empty'. These impacted files/folders will be replicated in the next cycle. KB-21420 - Prism Central: Role migration task stuck at 0% after upgrade KB-21434 - Ca
Can default vswitch vs0 be renamed on a new AHV 7.5 cluster? The only VMs on the cluster are the controller VMs.
I am deploying a new AHV environment with 10 clusters. Each cluster will have the same subets/vlans. If I create these from Prism Central can I check the box next each cluster in the subnet creation screen so that each cluster gets the subnet?
What happened to the Four corners test in X-Ray? What is the equivalent new test?
Below are new knowledge base articles published on the week of April 19-25, 2026.Support Portal login required:KB-20888 - NCM: Troubleshooting Receiver Rate Limit and PC Reachability Alerts KB-21051 - NCM : Upgrade Fails with Timeout Error KB-21127 - Rubrik Live Mount fails on Nutanix AHV with error ?Unable to create an external repository?. KB-21276 - Updating and Adding MetalLB Load Balancer Ranges in NKP KB-21335 - AHV Upgrade fails during LCM prechecks due to orphaned virtual machine entries in IDF KB-21349 - Prism Central: Audits list V3 API fails with internal_error 500 after upgrading to PC 7.3 KB-21366 - HPE DL Gen10 Node with MRD (mirrored bootdrive) fails to boot into phoenix while attempting to discover AHCI controller KB-21373 - Move: Network Requirements for Migrations Involving AHV VPC Networks KB-21377 - Windows Server VMs unexpectedly crash on Lenovo AMD CPU based Turin nodes KB-21382 - NC2 cluster reflects as starter licenses on the Prism Central web console despite be
We have a cluster that is not being used currently, and would like to run VMware/VSAN on it for testing some things. Is this doable? I am not worried it not supported as it is very temporary and Nutanix will be put back on it. I know ESXi is supported but you have to use CVM still to present the disk I think. So has anyone tried using Nutanix hardware (NX-1175S-G9) to run ESXi and more importantly VSAN natively? I know there are lots of variables here, especially disks being recognized, etc.
Evening,I’ve created a cluster with four nodes using the Nutanix Community Edition. Does anyone have a quick cheat sheet on updating everything. This is my second go around, and the last time, everything updated, but Prism stopped responding even after I updated. Do I need to upgrade Prism First? what’s the difference between Prism that comes after the install and Prism Central?Any suggestions on steps to updating everything before I start creating Virtual Machines would be helpful.Thanks, James
Hi Folks,I have NX-8170-G10 configured with 1x 2port 10G copper, 2x 2port 25G Fibre NICs. I need to make the following configurations.1x 2 port Copper : Active-Backup e.g. br0-up1x 2 port Fibre : Active-Active (balanced-tcp) in LACP 1 e.g. br0-up11x 2 port Fibre : Active-Active (balanced-tcp) in LACP 2 e.g. br0-up2I have the followig questions.Do I need seperate Bridge for each uplink I used the following commands on AHV for creating the uplink, but I am getting warnings on Prism Element ovs-vsctl add-bond br0 br0-up2 eth4 eth5 ovs-vsctl set port br0-up2 other_config:lacp-fallback-ab=true ovs-vsctl set port br0-up2 other_config:lacp-time=fast ovs-vsctl set port br0-up2 bond_mode=balance-tcp ovs-vsctl set port br0-up2 lacp=active and the same commands for br0-up1
Hi everyone!Recently, a client challenged me to integrate their Nutanix clusters into their existing Prometheus and Grafana stack. While I’ve found solid integrations for Nutanix Objects and Kubernetes environments, the path to extracting granular metrics from Prism Element (PE) and Prism Central (PC) seems less straightforward for standard infrastructure.I’ve been reviewing the classic community post “MONITORING Part 3/4 Metrics and Prometheus and Grafana”, but since it’s now 5 years old, I suspect APIs and available exporters have evolved significantly.I’d love to hear from the community: Is anyone currently running this setup in modern production environments? Are you relying on third-party exporters (like Cloudflare’s) or leveraging API v3/v4 directly? In your opinion, have the latest Prism Central native APIs made Prometheus redundant for infrastructure-level monitoring? Any insights, updated documentation, or "lessons learned" you could share would be invaluable in helping me
Below are new knowledge base articles published on the week of April 12-18, 2026.Support Portal login required:KB-20864 - NCM: Investigating ncm-labels-denormalization-job Failures KB-20894 - NCM : Deployment shows as "Aborting" or "Entity not Found" after an Epsilon service restart KB-20914 - NCM : Deactivate Scheduler Policies/Jobs on the Policy-VM after NCM Deployment KB-21003 - NDB | Cluster Agent Upgrade failed During Dual Boot Upgrade KB-21257 - NCM : NCM Self-Service: Troubleshooting Custom Form API Validation Errors KB-21296 - Nutanix CSI Controller CrashLoopBackOff due to Incomplete "CSI System" Role Permissions KB-21306 - Native KMS falsely detects that the PE cluster is hosting PC KB-21318 - NDB - SQL DB Log Catchup Failure message "does not have fromTimeStamp" KB-21325 - Nutanix Move: Ubuntu VM migration fails with "Drivers Installation Failed. Driver(s) virtio_scsi could not be installed for kernel" KB-21326 - NDB: Oracle Database Log Catchup Operation Fails When Pausing a
Below are new knowledge base articles published on the week of April 5-11, 2026.Support Portal login required:KB-20862 - NCM : Cost Governance On-Prem: Partial or No Data Displayed in Dashboard KB-20867 - NCM : Alert : Unable to send Email Requests KB-20895 - NCM: Deleting Nutanix Central (NC) or Nutanix Cloud Manager (NCM) results in an error if a remote Prism Central is still onboarded KB-20992 - NCM : Nutanix Central (NC) Cluster deletion failure KB-21009 - NCM : Self Service - Onboarding Task Stops Responding at 50% KB-21015 - Project Users See All Subnets Despite ACP Restrictions in Prism Central KB-21093 - NCM : Manually Rebalancing Pods on NCM Self-Service VMs After a Restart KB-21211 - ReceivedDiscardedPackets counter increases on Windows VMs using VirtIO version 1.2.4 or later KB-21219 - FAQ : Nutanix Files: Scoping the performance or access issue for Nutanix Files in Citrix VDI environment with FSLogix as Profile management solution KB-21271 - Foundation failing on XC670-16 n
Below are new knowledge base articles published on the week of March 29-April 4, 2026.Support Portal login required:KB-20863 - NCM: Resolving NCM Cost Governance On-Prem Alerts KB-20866 - NCM: Alert: SMTP server details not configured on the home PC KB-20892 - NCM: Unable to View Non-Nutanix Entities in Infrastructure Browser After Brownfield NCM Deployment KB-20893 - NCM : AIOps/Self-Service Features Remain Partially Accessible on Prism Central After NCM Deployment KB-21193 - Provisioning Oracle Database may fail with the error "Error while restoring PDB backup piece" KB-21207 - SMSP: Cluster upgrade fails on ESXi hosts during Pre-checks due to missing eth1 configuration KB-21208 - Prism Central Shows Disconnected in Prism Element due to Expired ETCD Certificates KB-21210 - Dell 17G nodes intermittently fail to boot during Foundation imaging due to an iDRAC issue KB-21214 - Perform Inventory tasks for managing PEs are stale in Prism Central. KB-21215 - Nutanix Self-Service Blueprint F
I was looking for a solution in Nutanix Playbooks to send all critical alerts to a Microsoft Teams channel or chat. I could not find a good solution online, but after about a week of testing and research, I found a way to send the alerts to Teams by using a REST API call from the playbook. To make this work in Microsoft Teams, you need to install the Workflows app and generate a webhook URL.There is good Microsoft documentation explaining how to add and use Workflows in Teams:https://support.microsoft.com/en-us/office/browse-and-add-workflows-in-microsoft-teams-4998095c-8b72-4b0e-984c-f2ad39e6ba9aI also found that some alerts contain double quotation marks in the alert text, and this caused the JSON payload to fail. Because of that, the alert name had to be cleaned before it could be sent successfully in the REST API request.Step by step: REST API Code in JSON{ "type": "message", "attachments": [ { "contentType": "application/vnd.microsoft.card.adaptive", "contentUrl"
I am installing the latest Nutanix CE from USB onto an HP DL380 G9 with 160GB Ram & 3 new 1TB SATA drives.CE Loads and runs incompletely. instsvcdrv.service: Control Process exited, status=155. Please point me to what the actual issue is. TIA.
Below are the top knowledge base articles for the month of March 2026.KB-1540 - AOS Only - What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB-1536 - NCC Health Check: disk_online_check KB-8453 - Alert - A1044 - PathOffline KB-13150 - NCC Health Check: cfs_fatal_check KB-7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB-3827 - Alert - A130087 - Node Degraded KB-4944 - Unregister cluster from Prism Central and cleanup (regular and force) FAQ KB-20558 - Unable to launch VM Console or access Prism Element via Quick Access after upgrading PC to 7.3.1.2 or 7.5 KB-9437 - How to restore a node from LCM firmware upgrade failure using lcm_node_recovery script KB-8885 - Alert - A15039 - IPMI SEL UECC Check KB-13104 - Alert - Inconsistent Virtual Switch State Detected KB-8094 - NCC Health Check: disk_status_check KB-8130 - Prism admin account locked with "Account locked due to too many failed attempts." KB-2090 - AHV host netwo
Below are new knowledge base articles published on the week of March 22-28, 2026.Support Portal login required:KB-20568 - NKP - How to find NKP UI url, user name and Password KB-20850 - NSX Endpoint Security Multiplexer (EPSEC-MUX) Interfering with One-click Host Upgrade Process KB-20951 - Nutanix Files - SMB Client error "Failed to enumerate objects in the container. Access is denied" KB-20982 - cluster_sync in restart loop causing high /home usage KB-21001 - Unable to recover and live mount VMs from one Cluster to another using Rubrik software KB-21117 - NDB | RAC Provisioning Fails with ASMLIB v3 on Nutanix Database Service KB-21158 - Nutanix Files - FSVM kernel panic caused by Out of Memory due to a large min_free_kbytes setting KB-21168 - setup_three_tier command fails in 3-tier Prism Central deployment due to vCenter connectivity issues KB-21176 - Incorrect Deployment Cluster shown for Flow Controller KB-21177 - AHV upgrades to 10.3.1.4 or later fail with the "At least X MB more
Hi everyone,Has anyone here worked with Nutanix in a PCI DSS environment? I have a few questions and would love to hear from people who have been through it.- How did you separate PCI workloads from other workloads in your Nutanix cluster?- Did you use Nutanix Flow for network segmentation? Did it work well for PCI?- How did you handle logging to meet PCI DSS requirements?- Any issues with patching AOS / AHV while staying compliant?- Did your auditor (QSA) already know Nutanix, or did you have to explain the platform to them?Any tips or lessons learned are welcome. Thank you!
Below are new knowledge base articles published on the week of March 15-21, 2026.Support Portal login required:KB-21012 - rsyslog messages reporting "parameter 'statefile' deprecated but accepted, consider removing or replacing it" KB-21063 - Nutanix Files - Smart DR Planned failover don't create SPN records on failed-over File Server for both SMB and NFS when both the protocols are enable don the File Server. KB-21096 - SAML Signing Certificates in Prism Central KB-21122 - Nutanix Move ? Failed to add AWS Provider in Move KB-21123 - NC2 - Node addition failing during Joining Cluster phase due to a host issue. KB-21125 - VLAN migration from Basic to Advanced gets stuck in Prism Central KB-21134 - Alert "Inconsistent Virtual Switch State Detected" after AHV Upgrade to 11.0.0.1 or 11.0.0.2 KB-21136 - Event ID 1035 Entries in Windows Application Log after NGT Upgrade KB-21148 - Nutanix Files - FortiSandBox ICAP configuration KB-21153 - NKP - Attempting to apply license key which results i
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.