Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hi everyone, I’m looking for your advice please for ESXi-based Nutanix clusters with hybrid storage. Question is regarding the placement of ESXi persistent scratch. With traditional architecture, the advice normally was to configure /scratch to be on a shared datastore, not a local one. The argument was that in case of a host failure, the logs will still be available from other hosts. With Nutanix, I can see the options as 1) leave the default, on vfat partition on SATADOM/M2/BOSS; 2) in a folder on local VMFS datastore where CVM is (same storage device though); 3) on a shared datastore, i.e. on DSF. What is the Community (best) practice with ESXi /scratch in Nutanix environment? Please kindly share your advice and thoughts. Thank you.
Two weeks ago I’ve upgraded our two clusters to AOS 5.15 . After that, both clusters began to receive constant warnings for root partiton space usage high(exceeded 80%) on almost all CVMs. Below is the result of ‘df -h’ on one of the CVMs: Filesystem Size Used Avail Use% Mounted on devtmpfs 18G 0 18G 0% /dev tmpfs 512M 0 512M 0% /dev/shm tmpfs 18G 1.2M 18G 1% /run tmpfs 18G 0 18G 0% /sys/fs/cgroup /dev/md1 9.8G 7.4G 1.9G 80% / /dev/loop0 240M 2.3M 221M 2% /tmp /dev/md2 40G 23G 17G 57% /home tmpfs 3.6G 0 3.6G 0% /run/user/1000 /dev/sdg1 5.5T 1.4T 4.0T 26% /home/nutanix/data/stargate-storage/disks/ 17Q0A01WFB9D /dev/sdh1
I am trying to locate the memory slots “P2-DIMMD1” and “P2-DIMMD2” in G4 but did not see any slot marked as P2-DIMMD1 or P2-DIMMD2. would you please let me know how to find these slots and replace memory. Thanks, Tairshah
Our vision at Nutanix has been and will always be: "one platform, any app, any location". This has been our goal from close to the beginning. We have openly documented Nutanix architecture in the freely available Nutanix Bible, and we are committed to open-source software, actively using and contributing code within a variety of communities. For example, here is a simplified architecture of a Nutanix environment taken from the Nutanix bible: In the documentation, you will find all the information you need regarding the Software, Hardware, performance, recommended practices, restrictions and more.
Below are new knowledge base articles published on the week of April 12-18, 2020. KB 9109 - Cannot Login to Prism with AD account KB 9168 - Custom Virtual Machine Report Creation in Prism Central KB 9223 - Nutanix Files: FileServer preupgrade check failed with cause(s) Sub task poll timed out KB 9224 - Restore the SSR snapshots using CLI KB 9232 - LCM Failure: Could not find pnics attached to the CVM interface KB 9239 - LCM upgrade failure on HPE - The node is not in production mode KB 9264 - AHV IDE bus performance implications Note: You may need to log in to the Support Portal to view some of these articles.
I am deploying nutanix at one of our customers site but unfortunately now he has 2 Switches with 1 GIG ports so is it doable to remove the 10 GIG from the bond and rely only on the 2*1G ports ? Model used (NX-1365-G6) thanks in advance
The NCC health check check_vcenter_connection verifies if the vCenter Server is registered with Prism and if a connection can be established. Nutanix cluster communicates with vCenter Server to obtain virtual machine information necessary for certain Nutanix cluster operations like Data Protection, One-Click upgrades, etc. If the vCenter Server is not registered or is not accessible, those operations may fail. The check returns a PASS if vCenter Server is registered with Prism Element and connection can be established. The check returns an INFO if vCenter is not registered with Prism The check returns a FAIL if vCenter is registered with Prism and the connection to vCenter cannot be established. This scheduled to run every 5 minutes, by default and will generate an alert after 3 consecutive failures across scheduled intervals. To take a look at the NCC check and the solution section https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA032000000TVQACA4 For instructio
To perform core VM management operations directly from Prism without switching to vCenter Server, you need to register your cluster with the vCenter Server. Nutanix cluster communicates with vCenter Server to obtain virtual machine information necessary for certain Nutanix cluster operations like Data Protection, One-Click upgrades, etc. If the vCenter Server is not registered or is not accessible, those operations may fail. The NCC health check check_vcenter_connection is also in place to verify if the vCenter Server is registered with Prism and if a connection can be established. Follow the steps to register your cluster with vCenter: Log into the Prism web console. Click the gear icon in the main menu and then select vCenter Registration in the Settings page. Click the Register link. Enter the administrator user name and password of the vCenter Server in the Admin Username and Admin Password fields. Click Register. Following are some of the important points about regi
Did you know that you can directly access the files in the Nutanix container from your local desktop? It is possible using WinSCP. This process helps in uploading or downloading files to and from Nutanix container. For example, you want to download a phoenix iso you generated on a CVM. Here are the steps to access a container: Open WinSCP. Connect to the CVM IP using SFTP protocol and port 2222. Login using the admin/prism element credentials. Enable the option to show hidden files by going to Options > Preferences > Panels and then selecting the “Show hidden files” option under the common settings. From here you can either upload or download files to the container. Note: Do not delete any data from the container via WinSCP or similar tool. Appropriate Prism or CVM command-line workflows should be leveraged to perform the cleanup if needed. To take a look at the steps in detail, take a look at https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA0
We all know that Virtual IP is used to access the Prism web console. It is also referred to as the external IP address of the cluster. Cluster virtual IP is mapped to the CVM which is the Prism service leader. Every time a new leader is elected the virtual IP is transferred to the new leader CVM, ensuring Prism Element availability. The NCC health check virtual_ip_check verifies if the cluster virtual IP is configured and reachable. It is scheduled to run every hour, by default and will generate an alert after 1 failure. To manually verify virtual IP settings in the Prism web console. Click the cluster name in the main menu of the Prism web console dashboard. In the Cluster Details pop-up window, check that a Cluster Virtual IP is configured and is correct. Check if the virtual IP configured is in the same subnet as the CVM IP. The settings can also be accessed from CLI. Have a read about this check and the scenarios where it can throw alerts https://portal.nutanix.c
Did you know that in Acropolis (AHV) you can enable high availability for the cluster to ensure that VMs can be migrated and restarted to another node in case of a failure? Best effort VM availability is enabled by default in Acropolis. Virtual Machine High Availability (VM HA) VM HA is a feature designed to ensure that critical VMs are restarted on another Acropolis Hypervisor (AHV) host within the cluster if a host fails. There are two VM high availability modes: Default - This does not require any configuration and is included by default when an Acropolis Hypervisor-based Nutanix cluster is installed. When an AHV host becomes unavailable, VMs that were running on the failed AHV host are restarted on the remaining hosts, based on the available resources. Not all of the failed VMs will restart if the remaining hosts do not have sufficient resources. Guarantee - This non-default configuration reserves space to guarantee that all failed VMs will restart on other hosts of the clu
Let’s say you need to administer your user VMs from the command line interface. The Controller VM resources are shown under the VM page In the Nutanix Prism, but you will not be able to change the resources configuration unless you connected to the Acropolis hypervisor (host) and modified the configurations using virsh. “virsh: is a command line interface tool for managing guests and the hypervisor.” Centos.org. First you can review the settings of the CVM under the VM Page on Prism. Connect to the Acropolis hypervisor (host) using the root account with password “nutanix/4u” Lists all the VMs on a host > virsh list –all Displays information about a VM > virsh dominfo VM_Name Displays information about the vCPU > virsh vcpuinfo VM_Name Sets the number of virtual processors > virsh setvcpus VM_name count Note: The count value cannot exceed the number of processors specified for the guest. You can increase the number of processors by editing the virs
Let's say that you ran the health checks on your cluster and received data_replication_check failure, what does it mean and how do you fix it? The NCC health check data_replication_check helps to ensure that the customers are not impacted by an extremely rare condition which can result in the inability to restore from snapshots. This issue is covered in Field Advisory 28. Scenario 1 - Cluster is running an old version of AOS.Scenario 2 - Cluster was recently upgraded, but has snapshots created before the AOS upgrade. For a full explanation and the solution for both scenarios check out the health check documentation at: KB-2089. To make sure that the issue is resolved you can run the dedicated health check for this component by connecting to a CVM and running: "ncc health_checks data_protection_checks protection_domain_checks data_replication_check" Note: This health check has been retired from NCC 3.9.3.
Scalability is the backbone of any industry solution, hence with ever-increasing workloads, it is natural for us to add new nodes in our existing infrastructure to make it scalable and highly efficient. Nutanix provides a feature which allows you to add new nodes to your existing cluster and increase the cluster overall capacity. A question lingering in our mind right now Do we have some guidelines regarding cluster expansion? Cluster expansion depends on the AOS version, hypervisor type (AHV, ESXi, Hyper-V, or Citrix Hypervisor), data-at-rest encryption status, and certain hardware configuration factors. The following documents provides some basic guidelines specific for cluster expansion Cluster Expansion .NEXT:Want to expand your cluster
It may be helpful to determine what commands were run previously to troubleshoot a current issue. Let’s first understand what aCLIand nCLI command utilities are. aCLI: utility to create, modify and manage VMs in AHV. nCLI: utility to manage cluster operations. The history files are hidden and are persistent across reboots. Below article explains how to retrieve commands history: https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA032000000TSsjCAG Also, take a look at how to check cluster upgrade history: https://next.nutanix.com/discussion-forum-14/checking-cluster-upgrade-history-37417
Did you know that each node of the cluster keeps records of the upgrade history of its components? Quite convenient to look at when determining the timeline of events during troubleshooting. Each of the components below has a dedicated history file: AOS Hypervisor NCC Files Hardware CVM memory In addition, there is a history of maintenance mode engagement on the cluster. The article below lists the commands necessary to retrieve a specific component’s upgrade history. https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA0600000008VYECA2 Want to know how upgrades work in Nutanix? Take a look at the following Knowledge Base to understand how upgrades work in Nutanix architecture. https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA00e000000LMgICAW
Below are new knowledge base articles published on the week of April 5-11, 2020. KB 8842 - NCC Health Check: cassandra_ssd_size_check KB 9198 - [Prism Central] Prism Central 5.16.1.2 - Docker logs for docker based services are missing KB 9209 - Zoom Security Statement KB 9211 - How to remove Ghost NICs on Windows Note: You may need to log in to the Support Portal to view some of these articles.
I have read in the ECA course some recommandation from Nutanix regarding AHV Networking specialy for LACP. If this is a best practice please Nutanix do as usual and set it by default : "ovs-vsctl set port br0-up other_config:lacp-fallback- ab=true” "ovs-vsctl set port br0-up other_config:lacp-time=fast"
You may have encountered an alert about PE-PC Connection Failure, or regarding IDF db to db sync. It’s possible that you had a visible issue with Prism Central’s management and monitoring of clusters, but also possible that you didn’t. What are these alerts for? How do we know if there’s really a problem? What can we do to fix it? I would like to answer these questions for you. Prism Element and Prism Central need two-way communication for a number of reasons. Manageability, forecasting, alert visibility, and reporting in Prism Central all depend on periodic syncing of data from PE to PC. Prism Central’s VM and infrastructure management, image creation, DR orchestration, and other enhanced features like Calm require API communication from PC to PE. PE-PC Connection Failure alerts indicate communication failure. This could be a short-lived issue and even an expected one, like when PC is rebooted during an upgrade, or it could reflect a more prolonged connection loss. Seeing the
I am using Nutanix on VSphere 6.5, and am affected by the 100% Memory usage alerts as described in KB article 000004465. I would like to create a folder in VSphere called Nutanix CVMs, which will not have the memory alerts enabled, and would like to move the CVM VMs in to this folder. Can anyone advise whether it’s safe to move a CVM VM in to another folder after is has been deployed? Part of me thinks this is a safe / normal procedure, as I’ve done it countless times with normal VMs. However, due to the complex nature of hyper-converged infrastructure and CVMs I understand I need to be very careful. Thanks for your help Jason
NCC (Nutanix Cluster Check) is a framework of scripts that can help diagnose cluster health. NCC can be run provided that the individual nodes are up, regardless of the cluster state. NCC checks could be run from the Prism web console for clusters where AOS 5.0 or above and NCC 3.0 or above are installed. Procedure: 1. Logon to the Prism web console. 2. Browse to Health page, select Actions > Run Checks 3. Select the checks that you want to run. 4. Enable/disable the sending of the report email, then click Run. 5. Browse to Tasks Page, to review the summary by clicking on the task status ‘Succeeded”. 6. Download the summary by clicking on ‘Download output’. Note: You cannot run NCC checks from the Prism web console for clusters where AOS 4.7.x or earlier and NCC 3.0 or earlier are installed. Log Collector Logs can be collected for Controller VMs, file server, hardware, alerts, hypervisor, and for the system. Procedure: 1. Logon to the Prism web console. 2. Browse to H
Logging into the cluster 5 times a day (we can’t imagine why but you’re the boss) and always re-attempt the login because you can never enter the password right? Concerned about the security of transmitting your password across the network? Looking for an extra security layer? All of these are valid reasons to enable key-based authentication for SSH sessions. Generally speaking, there are two options: Go completely passwordless Use a combination of a public key and a password How does it work? You generate a key pair (a public and a private keys) using RSA algorithm. You never share a private key with any other system or server. The public key, on the other hand, you add to the Prism. With the first login public RSA key of a server (Prism in this instance) is shared with a client (session initiator) which together with the public key of the host recorded in the prism comprises a mutual public key exchange. Since the public key on its own, without its private part, is not enou
Hi, My CVM is reporting low on disk space and trying to cleanup. I tried to follow the KB1540 and noticed the logs directory needs to be clean up. Its consuming around 8.1G the rm cmd in article dont see to apply for logs folder. Any suggestion on how to free up space under logs safely? Can i winscp and delete the logs files? Thanks CT
The new ESXi 7.0 has been released, does the latest version of nutanix 5.15 (LTS) support upgrades?
Let’s consider a scenario where you have two NX AHV clusters, A and B and there is an urgent need to move a VM from cluster A to cluster B. What are the scenarios available? Do you need to create a protection domain? Do you need to import vdisks from cluster A to cluster B? These are some questions which might be boggling your mind. The following knowledge article helps to list the different scenarios available and steps required in each scenario. AHV | How to move VM disks between two AHV Clusters To understand the concepts of data protection and disaster recovery in the Nutanix environment, the following documents might be helpful Data Protection and Disaster Recovery for AHV based VMs Data Protection and Disaster Recovery
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.