Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
I have a VM UUID 33ac3949-beba-401e-a114-6ccd48ebf237 I use POST to /vms/{uuid}/nics/ to create a NIC. The successful task returns UUID 46e8ac39-5dba-460a-afb6-f65bf1b7b43c { "uuid": "46e8ac39-5dba-460a-afb6-f65bf1b7b43c", "meta_request": { "method_name": "VmNicCreate" }, "meta_response": { "error_code": 0 }, "create_time_usecs": 1596037035354721, "start_time_usecs": 1596037035378557, "complete_time_usecs": 1596037035579435, "last_updated_time_usecs": 1596037035579435, "entity_list": [ { "entity_id": "33ac3949-beba-401e-a114-6ccd48ebf237", "entity_type": "VM", "entity_name": null } ], "operation_type": "kVmNicCreate", "message": "", "percentage_complete": 100, "progress_status": "Succeeded", "parent_task_uuid": "3b61a2df-4fe4-46aa-bd18-a9f87086f723", "cluster_uuid": "0005883b-67db-3e76-0000-000000015db3"} Notice that the entity list refers back to the VM, not to the newly created NIC. I would expect the operation to return the ‘nic_uuid’
Hello, Is it possible to provide for a group of VMs a Metro-Availability (stretched cluster) solution using ESXi (since this feature for AHV isn’t available yet) to obtain 24x7 availability and downtime+disaster avoidance capabilities for certain services) and also provide for the VMs in the stretched cluster or a subset of those VMs async replication to a 3rd site (DR site)? Understanding that the stretched containers are sync replicated at the container level, would that 3rd site async replication be based at the container or VM level? Thanks!
Hi all, I have almost 200 Virtual machine in my AHV environment . Is there anyway to summary operating system in each virtual machine, Does it have any tool like rvtool in vmware ?
I’m receiving a 401 Unauthorized error when trying to access our cluster to retrieve snapstop information. I’m passing a valid VM UUID and have used credentials from one of our local user accounts which has both cluster and admin roles assigned. I can access most other methods of the API using these credentials, but not this one. What am I doing wrong?https://{prism_element_ip}:9440/api/nutanix/v2.0/flr/{vm_uuid}/snapshots
This article's purpose is to shed some light on the rarely discussed, yet a crucial alert that you may come across on the cluster, that is, the HardwareClockFailure alert. Let us not confuse it with the system time. The system time is maintained by the OS (For example, Linux, Microsoft Windows etc.). The initial value of the system clock is typically retrieved from the real-time clock at power up or is set by the user. The hardware time is maintained by a real clock powered by a battery, which means it will persist a reboot. The alert is generated when the hardware clock time differs from the system clock time. This check is scheduled to run every 10 minutes, by default. To learn more about what causes a hardware clock to fail and how to resolve it, head over to this KB article: KB 4120 in the Nutanix Support Portal.
This is one of the questions that do not exist on AHV. It is, however, a moderately important one for ESXi environment Nutanix or not. Why it is so and what does work best for ESXi on Nutanix – this is what I intend to unfold if you care to read. Without going into nitty-gritty details but still explaining the essential differences between the formats provisioning types for VM disks define how the storage space is allocated for the VM disk. The tree options ESXi provides are: Allocate space when required. No guarantees for the space available on the datastore for the data of the disk to grow to the extent of the disk size configured. This is a Thin Provisioned disk. Location of data on physical storage is written in fragments. Accessing these fragments when reading and allocating space for new data is what may create additional latency for sensitive applications such as databases, for example. Allocate storage section for the entire VM disk file contiguously. Guarantee space availab
Hello team, We used Nutanix sizer to configure a 3 node cluster, if hybrid mode is selected the smaller suggested option for cold data is a 4 X 2Tb SAS disks set when we choose 2 x 960Gb SSD for hot data. Is it possible to get support and buy a license if we configure the node with 2 x 2Tb disks? It's a small environment and we don't need all that extra space. Every hardware component is in the supported compatibility matrix of the vendor, just not sure Nutanix can fully support a custom configuration
To enable VM management feature we can install NGT on user VM’s To use the NGT feature, you must do the following: Enable the NGT feature for a VM in the Prism Element web console. When you enable NGT for a VM, Prism Element prepares the VM so that NGT can be successfully installed and used in that VM. Mount the NGT installer (ISO disk file) in a VM. Install NGT in a user VM. Few requirements we need to take care of: The following ports must be open between the Controller VMs and guest VMs on which NGT is installed: Controller VM: 2074. TCP port 2074 must be open in the Controller VM, so that user VMs can communicate with the Controller VM. User VM: TCP port 23578 if you want to use the VSS service. For further details about NGT and its working please refer following links https://next.nutanix.com/how-it-works-22/nutanix-guest-tools-37346 https://portal.nutanix.com/page/documents/details?targetId=Web-Console-Guide-Prism-v55:m
Hello All, Seeking for you kind assistance, Does anyone of you tried to install or generate a SSL certificate of IPMI? This is a CVM, my Infosec detects High Risk on it. Hoping for a positive revert on this Thank you.
Below are new knowledge base articles published on the week of July 19-25, 2020. KB 9064 - NCC Health Check: hpe_bootdrive_raid_check KB 9261 - NCC Health Check: dimm_size_reduction_check KB 9627 - AHV | VM IP address may be intermittently shown on VM page KB 9653 - [Performance] Benchmarking storage with Microsoft Diskspd KB 9657 - LCM: LCM 2.3.2 and later does not support AOS upgrade for AOS version 5.5.x KB 9684 - Prism Central stops generating reports at random times KB 9685 - Users added to a Role on Prism Central RBAC unable to view Prism Element cluster alerts KB 9688 - X-Ray Reset Local Secret Store Passphrase KB 9694 - Upgrade stuck due to Genesis not able to start services after Cassandra service KB 9715 - LCM: Satadom upgrade fails with "Update failed with error: ['unicode' object has no attribute 'tell']" KB 9734 - AHV | NIC speed has incorrect values on Prism and ovs-ofctl for 25 Gbps / 40 Gbps cards KB 9738 - How to wget a release bundle from Portal directly t
I have a Dell PowerEdge Server R620 with 64G of Ram and 2T of HD Space. I am wondering what version of CE is supported on this older server. I downloaded the latest one and the install errored out. Thank you,
Hi! I’m trying to find a way to create automatically expiring snapshots via API. I know I can use v2 api to create normal snapshots, and with Playbooks I can create snaphots which have an expiry time. Is there a way to create recovery points (on-demand) or run playbooks via API? Thanks!
When you replace the NIC cards in the Nutanix AHV cluster, it is possible that the new NIC card interfaces are recognised as additional interfaces and are numbered after the existing interfaces. So, for example, in the current AHV node you have 4 interfaces - eth0, eth1, eth2 and eth3 and you replace the NIC card and you see additional interfaces - eth0, eth1, eth2, eth3, eth4 and eth5. Also, if your host was connected earlier on the replaced NIC card, you will lose the host connectivity. We now have the script in AOS 5.10.10 and AOS 5.15 to get the NIC interfaces re-numbered correctly. If you are running older versions or unable to run the script for any reason, you can use the annual method. Please check the Nutanix portal page here and KB3261 for the exact script and the manual method steps.
How to get SATADOM firmware Version on Nutanix AHV Hosts. We are planning to upgrade Hardware Firmware and need to upgrade SATADOM firmware before that. Also, it;s not showing under LCM. We are using AOS 5.15.1 and having latest NCC, Foundation installed.
I am trying to find out the User who took the snapshot on AHV Cluster. I did not find the same in Tasks/Events in Prism or through below Command. acli snapshot.get <SnapshotUUID>
Do you have a VM that you suspect may have been compromised or infected by malicious software (i.e. ransomware) and want to have a means to quickly remove it from your network (so as to not infect other entities)? Do you also want to be able to inspect and work on this VM from a “safe distance” using available forensic tools? Using Flow Microsegmenation, you can accomplish both of these objectives through the use of Quarantine Policies. When configuring Quarantine Policies, you can specify the “Quarantine Method” as either “Strict” or “Forensic”. The “Strict” option isolates the VM from all inbound/outbound traffic entirely. The “Forensic” option allows the limitation of inbound/outbound traffic to that which is specified from the “Add Forensic Tools” tab. For example, this could allow the infected VM to communicate only with another entity that maintains tools for further analysis of the VM. You can find more information regarding Quarantine Policies within the “QUARANTINE POLICY CO
Are you still facing DIMM Errors which cause Un-Expected Node Reboots / PSOD and Degraded Node Situations ? And your answer to above question is : YES Solution: Nutanix has further improved the ability to detect problematic DIMMs and prevent unnecessary service disruption as a result of uncorrectable memory errors (UECC).Whats are DIMM Errors ? A Memory Error is an event that leads to the logical state of one or multiple bits being read differently from how they were last writtenAll About DIMM Errors Nutanix has rolled out a Field Advisory for early detection and error handling related to memory DIMMsNutanix Field Advisory #71
I need to get the iSM and PTAgent versions from AHV clusters running on the Dell XC platform using PowerShell cmdlets. Does anyone know if this is possible? I can’t figure it out and do not think it is possible at this point.
Hi, We purchad Huawei servers end of last year (check compatibility matrix brought by Nutinix itself https://docplayer.net/136878906-Huawei-hardware-compatibility-list.html and due to Covid19, we were not able to install them until now. Currently we have 4 servers with part numbers from compatibility matrix 2288Hv5-12 and 2x10G switches for interconnection. Each server has M.2 SSD drives for OS installation configured in RAID 1, while the rest of the disks (SSD of 1.92TB) are in JBOD mode, since that there are 2 RAID cards, one for M.2 and the other for SSD drives respectively. Virtual drive has status OK. During installation process, we receive error message that says the following: “INFO Performing firmware checks for platform Huawei 2288HV5-12 WARNING Some error occurred during firmware checks. This can be due to some unsupported hardware. Please report this to foundation team.” Final error message is: Unable to find SSD in node. Please, help us resolve this issue in form o
Want to know how to change the default credentials on the cluster? On Nutanix cluster’s if you have the default credentials you will receive an INFO message (default_password_check) in NCC health check informing you the same, you can change your CVM, Hypervisor and IPMI password using the guides below, you can also use script to change it on all nodes at once. Nutanix portal document
This video demonstrate how Nutanix Calm with the help of Nutanix Move can migrate workloads from the public cloud to on-prem as day-2 operations. This custom integration uses Move APIs to automate the entire process via Calm. Let the community know how you are using Nutanix Calm and Move. Share your thoughts in the forums.
We are excited to announce the release of Nutanix Move 3.6.0 Adopting new infrastructure platforms often requires organizations to migrate existing workloads against tight timelines. Nutanix Move simplifies this process with infrastructure-level bulk VM migrations, removing the friction associated with onboarding new infrastructure, and enabling businesses to quickly leverage the full potential of Nutanix Enterprise Cloud, with near-zero VM or application service outage during migrations. Nutanix Move 3.6.0 is released and the bits are available on the portal for download. Release Notes User Guide What's New in Release 3.6.0 Added Support for Nutanix Clusters on AWS - Move now supports migration to Nutanix Clusters on AWS. Added Support for SUSE 15 VMs - Move now supports migration of SUSE 15 VMs. Added Support for UEFI with Secure Boot for Hyper-V - Move now supports UEFI with secure boot for Hyper-V. Added Support for UEFI with Secure Boot for ESXi - Move now supports UEFI wi
Want to check all the alerts on the cluster? Need to resolve them all at once?On the Nutanix web console, you can view a large number of alerts (up to 1000) AND resolve them by navigating to the alerts page from the drop-down on the home screen. But do you want to go the old school way?The Nutanix CLI is designed to display a max number of 100 alerts. You can modify it to show as many alerts as you like and choose how you want to resolve them. For details on how to count the total number of alerts and how to resolve them all in just one command, see KB 1402 in the Nutanix Support Portal.
See the new migration plan testing feature that was added with Move 3.5 in action. Have you used Move? What has been the largest migration you performed? Be the first to reply and let us know.
Authorization configuration is enabled in two clusters and directed to same Domain controller, which is a VM in one those clusters After that when I use prism API to get stats information of various VMs (I invoked it repeatedly for each VM) it is resulting in 100 % CPU usage in Domain Controller to confirm the same I changed the DC to another VM then the first DC device CPU usage got reduced and second DC device CPU usage raised to 100% API used : /PrismGateway/services/rest/v1/vms/<uuid>
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.