Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
The following document states that the CVM will be Redirected to another CVM after 30 seconds of inactivity.https://portal.nutanix.com/page/documents/details?targetId=Web-Console-Guide-Prism-v6_0:arc-failure-modes-c.html What response does the cluster request from Stargate?I want to know the details that the cluster requests to Stargate for 30 seconds.
What will be total usable space for the hypervisor and best practice to allocate the storage.I have three new Nutanix nodes. Physical capacity of Cluster is 79.04 TB and Free logical is 39.52 TB in RF2.
The following migrations are not recommended, but can be performed with some limitations. Exchange should be migrated by installing newer versions of Exchange Server in parallel with existing production environments, then move user mailboxes from the old system to the new one. Domain controllers should be migrated by preparing a new domain controller, and then migrating the Flexible Single Master Operations (FSMO) roles. Move migrates database VMs similar to any other VMs;however, the migration happens at the VM level, not the application level. Move will not perform any application-level changes, disk layout updates or best practices on the migrated VM. The above approach should be fine for smaller SQL DB servers and for servers without PCI Pass-through, pRDM disks or multi-writer disks (clustered NTFS). Also, for larger SQL DB servers, Nutanix recommends you to apply Nutanix best practices to create additional vDisks and rebalance data across those disks to take advantage o
Hello!Need help to understand problem and help. We have 4 nodes. Today saw one node have a problem with the power supply:use this command:ncc health_checks hardware_checks ipmi_checks power_supply_checkResult:1# FAIL: Power supply 1 is down on block block <name>2# FAIL: Power supply 1 is down on block block <name>My next action if physically all fine with PSU.Find in KB7386:Restore the power supply as soon as possible... If PSU info unavailable, upgrade to the latest BMC firmware, and apply factory default after BMC upgrade…If update BMC how long time to need and downtime need?Need help fix this problem, and your help, what steps do next.
HI all, I'm preparing a change on the cluster (6 node cluster running AHV). I need to re-ip cvm's and ahv's and add them to a specific vlan (now they are not in a vlan). Before I do this in production I decided to do this on the test lab. (old baby, 4 node G5). I've followed this guide: https://next.nutanix.com/installation-configuration-23/physical-relocation-of-nutanix-clusters-38403 but got stuck step 7 after booting the cvm's. The ouput of svmips shows the old cvm ip's but they are all booted with the new ones. (and accessible via ssh on the new ip's)The output of hostips shows the old ahv ip's byt the are all booted with the new ones. (and accassible via ssh on the new ip's). I must also say that the external_ip_reconfig script hangs at a specific time and now the command “cluster start” gives an error the the cluster is still in reconfigure mode. Anyone here who has the golden tip to get the command svmips and hostips to show the correct ip's? (zk_server_config_file also had the
I run a 6-node nutanix cluster, and planing to run some containers (LXC) , inside VM using ZFS pool, to leverage on easy clone, migrate, snapshot the containers mainly to transport those clones to other system (DR) I read that ZFS need to deal directly with disks hardware to be sure about what is or what is not actually written to disks. Is ZFS suaitable or not, being run on top of nutanix platform, concerning the data corruption risk or losing pool, because it can’t deal directly with disk hardware? Hardware is supermicro bundled with nutanix-enterprise.
I have AHV cluster configured 5.5 with multi homing and now i want to add new node to existing cluster. What is the right procedure.
Hello, I am trying to deploy Nutanix CE on a Dell T7600. It is working fine when using AHV as hypervisor. But when using ESXi, i am not able to mount containers.I receive error message : There was an error while mounting the datastore for storage container 'default-container-11071639353873'In vmkernel.log i can see : 2021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)World: 12556: VC opID 738348c2 maps to vmkernel opID 7bd903772021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)NFS: 162: Command: (mount) Server: (192.168.5.2) IP: (192.168.5.2) Path: (/default-container-11071639353873) Label: (default-container-11071639353873) Options: (None)2021-06-22T14:36:46.848Z cpu17:2099496 opID=7bd90377)StorageApdHandler: 960: APD Handle 732ec6b0-3763e7bf Created with lock[StorageApd-0x4316fd802900]2021-06-22T14:36:46.849Z cpu17:2099496 opID=7bd90377)SunRPC: 1095: Destroying world 0x201ac22021-06-22T14:36:46.849Z cpu17:2099496 opID=7bd90377)SunRPC: 1095: Destroying world 0x201ac32021-06-22T14:
Hi I have problem after fresh install Nutanix CE.Dont have acces to CVM console and Prism from outside. SSH from hypervisor work good But from other machine have time-out error Install on Vmware ESXI 7 on Dell server Cluster works fine EDIT: use version ce-2020.09.16.isoon PC in Workstation PRO work fine but on ESXI have same problem
Below are new knowledge base articles published on the week of June 13-19, 2021.KB 10440 - Alert - A150009 - AcropolisSpanSessionStateError KB 10804 - Alert - A200405 - RF1VMAutoPowerOnFailure KB 11460 - VSS Snapshot fails for windows VM with error "hr = 0x80070005, Access is denied" KB 11466 - Objects - Objects Deployment post CMSP enablement with IAM service is not healthy KB 11473 - Critical : Cluster Service: Mercury is down on the Controller VM KB 11475 - Prism virtual IP inaccessible and unreachable Prism login during Prism leadership change or Prism leader restart or node removal or when the node is down where the Prism leader is located KB 11485 - Duplicate instances exist for one or more of the entities in the Recovery Plan KB 11486 - Hyper-V | Windows VMs may crash unexpectedly with bugcheck code 0x109 shortly after live migration KB 11489 - Linux User Virtual Machine unable to boot, initramfs not found KB 11490 - VM live migrations fail with "libvirtError: operation failed:
Hey guys,I’m getting an error regarding email alerts, this is what I can observer on the send-email.log2021-06-17 07:37:03,407Z INFO send-email:242 Not sending emails for first 1 hours of cluster creation. Cluster Age = -16009102.3605 secs 2021-06-17 07:38:03,611Z INFO send-email:242 Not sending emails for first 1 hours of cluster creation. Cluster Age = -16009042.1568 secsCluster was online for 2months already, I tried already to stop and start the cluster but that sec timer is set to around 6 months.
We recently performed a cluster shutdown with hardware power off of an AHV cluster running AOS 5.15.5.1.We powered on all the nodes, and waited 10 minutes for the AHV hypervisor to boot and the CVMs to boot and get ready.Even after 30 minutes the CVMs did not recognise the confirmed correct password for the “nutanix” userID during ssh login attempt to any CVM.Fortunately one SSH key had previously been registered into Prism Element, which allowed SSH via this key. The cluster was NOT configured to be locked down.The key owner successfully connected to a CVM via SSH and performed sudo passwd set of the “nutanix” userID to a confirmed password.Despite setting this password, the same CVM still refused to accept the “nutanix” userID and confirmed correct password during SSH password login. I am suspecting that with the cluster service stopped, but with one SSH key present, that the CVMs operate as if lockdown were enabled.Can someone please confirm for this?This prevented the password hol
Below are new knowledge base articles published on the week of June 6-12, 2021.KB 11185 - Xi Frame - Microsoft 365 Apps Enterprise (Office 365 ProPlus) in non-persistent Frame account and Enterprise Profiles KB 11448 - AHV host crashes whenever NVIDIA Control Panel settings are changed inside guest OS VMs KB 11453 - Dell PTAgent versions 2.3.6 and 2.4.0 do not start after a host reboot on AHV KB 11455 - Nutanix Files: "System error 1312 has occurred", when mapping a drive using credentials. KB 11471 - Hyper-V: Unable to add VM to Protection DomainNote: You may need to log in to the Support Portal to view some of these articles.
My customer ask me about how to config vm power on sequence when start cluster Example Domain Controllers power on firstExchange Server power on secondApplication Server power on thirdMy customer have only PE.Thank you for answer the questions.
Do you think is there any way i can migrate data from standalone server to the AHV?
Nutanix, AHV, MS Server 2016 installed with IIS, Media Wiki.Out of the blue, the server performs very slow. The MediaWiki site takes forever to load ( at times a Server 500 error appears when going to the MediaWiki site from a desktop). Opening the console shows the Server logon window but very slow. Everything is very slow. Once logged on, it takes almost 20 min for the server management window to open.Currently, vCPU=6, Cores per CPU=4, RAM 16CPU Usage around 10% and Memory usage around 17%Only server that acts like that. Ran DISM /Online /Cleanup-Image /ScanHealth and so on and everything is ok/ no problems. Rebooted all hosts.Not sure what caused this all of a sudden ….
I want to transfer Prism Alerts, Events logs to another log collection server. A log collection server is a solution called innerbus. How can I send it?
Below are new knowledge base articles published on the week of May 30-June 5, 2021.KB 10959 - Unable to deploy Azure Cloud Connect from Prism UI KB 11329 - Linux VM performance troubleshooting scenario - ksofirqd process utilizes 100% of a vCPU in Linux VM due to a high number of iptables rules. KB 11368 - Objects Service Manager (aoss_service_manager) service on PC crashes due to expired certificate KB 11372 - LCM HBA upgrade to PH16.00.10 fails with "kLcmUpdateOperation for release.smc.gen11.hba.hba_LSISAS3008_2U4N_2U2N.Skylake.update on X.X.X.X with ret: -1, out" KB 11383 - Network Segmentation: "Interface eth2 is not present on cvm" Error Seen When Enabling Backplane Network KB 11398 - "Invalid network selected" message returned when editing network configuration of a Nutanix Files cluster KB 11404 - Expand Cluster may fail when running on an unqualified ESXi build KB 11438 - LCM upgrade for disk firmware fails if there is a USB device in the node KB 11444 - Enabling Cloud ConnectN
Is AOS single node cluster upgrade an disruptive action?Thanks!
Hi,I have three identical nodes (basic Lenovo servers) but one performs really slowly compared to the others. The disks aren’t the same across all three though. I wonder if anyone has any ideas which difference might be causing the performance issues: Firstly the HDDs are 4TB in the two ‘good’ nodes and 2TB in the ‘slower’ one. I wouldn’t expect that to cause performance issues, just overall capacity will be limited? To be fair the 2TB is a WD ‘green’ and the 4TBs are WD ‘red’ drives. Secondly the ‘slower’ host has a Samsung Pro 840 256GB SSD which Prism reports as often having a higher latency than the HDDs! See the image below Are they known for being poor in this kind of environment? I’m not really stressing them. Any good logs to see performance issues? I can see the HDD activity light is permanently on on the slower host. Cheers,Steve
Beside the “classical” Monitoring with snmp or agent based version now we are talking about Metrics and the Monitorng of LiveData with the OpenSource Project Prometheus. The Virtualization is made with the powerfull Tool of Grafana.The access to the Data will be made with so called “Node-Exporter” which could we found under GitHUB. One is present for Nutanix! My Testcase in the homelab is build with the following items:NutanixCluster <- Prometheus <- Grafana192.168.10.80 192.168.10.123 192.168.10.100Nutanix CE Ubuntu 18.04 LTS Ubuntu 18.04 LTSPrometheus 2.2.1 Grafana 7.0.4GO 1.10RequirementsCreate NEW User in Nutanix Prism Central with VIEWER Rights2. Installation of Prometheus on Ubuntu 18.04 LTS with running GO!Good Sourcse will be available here or here.3. Installation ofvon Grafana 7.x on a second Ubuntun 18.04 LTSGood Source are found here. Start of Connection to NutanixWe download the GO Binary for the Nutanix Exporter to the Prometheus VM in the folder of GO/BINWe will tes
I am getting this error when adding my AWS environment to Nutanix Move toolAWS Authorization Error. RequestCanceled: request context canceled caused by: context deadline My move tool version is 4.0.0
Hello, all. We’re running vCenter 7 with AOS 5.15.x, and I’m learning about how VMware has now decoupled the DRS/HA cluster availability from vCenter appliance and moved that into a three VM cluster (the vCLS VMs).In the interest of trying to update our graceful startup/shutdown documentation and code snippets/scripts, I’m trying to figure out how to handle these vCLS VMs. They reside on the Nutanix shared storage, so I obviously would like to shut them down before gracefully shutting down the Nutanix CVMs/ADSF cluster as well as ensure the CVMs are up and cluster is good before allowing them to power back on using that storage. Evidently, these vCLS VMs are very aggressive about powering back on or recreating themselves once deleted, so I’m a little unsure what to expect.So with regard to powering back on the ESX hosts, I assume when I take them back out of maintenance mode the CVMs will be powered back on (or maybe I have to do that manually?), and after waiting a few minutes, I woul
While it is not as a straightforward process as we would like for it to be there is an option to add a NIC to your Move VM. Login to Prism Element Add New NIC to the Nutanix-Move appliance and select the network Launch the console of Nutanix Move appliance. Switch to root user Use vi editor or any other editor of your choice to open the file /etc/network/interfaces Add the second interface eth1 configuration in the format below based on DHCP/Static IP addressing. Restart the networking service.Please Note: If you are using Move 3.0.3 or above you can skip Step-7 and Step-8. That'll be taken care automatically. There will be an existing script named "start-xtract" under "/opt/xtract/bin". Overwrite that script with the one provided in the KB (see link below). Change the permissions for the script. Stop iptables and restart move services. Verify the new eth1 interface configuration using "ifconfig eth1". See KB7399 - Procedure to add a second NIC interface on Move v3.0.2 for detailed ins
Hello all..is there a list with model number somewhere of the Nutanix supported NICs? I am looking for the cheapest 1Gb dual NICs Nutanix supported that I can get from Amazon or ebay or the cheapest 10Gb..I was reading that supermicro Nic is supported but I don’t see model number so I was wandering if the Supermicro AOC-SG-12 is supported since that card cost about $35..my understanding is the CE and commercial support the same NICs now. My use case is CE for homelab. thanks
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.