Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
I received this answer a few days ago[Just plug your VM on a VLAN where there is a router connected to the internet. Then either use DHCP if there is some, or configure an IP address and set your router as gateway. That’s it.]but Is there anyone who can explain in more detail?I am currently configuring guestvm with windows10The network settings are like this The port of the node where the GUEST VM is installed is directly connected to the Internet-enabled LANOr should I change the settings inside Windows vm? It is composed of dhcp
Below are new knowledge base articles published on the week of June 5-11, 2022.KB 13167 - NCC health checks running repeatedly after AOS upgrade KB 13180 - Health Server crashing by ValueError for a garbled UTF-8 character KB 13197 - Nutanix Cloud Clusters - NC2 on AWS - "Elastic Block Store was added in drive bay Unknown on Controller VM XXXX. Action Required: Disk is not qualified by Nutanix. Visit Prism hardware page for further actions." KB 13208 - LCM inventory triggers the Alarm Lost network connectivity on virtual switch "vSwitchiDRACvusb" KB 13231 - Zenoss Monitoring of Nutanix Environment KB 13233 - CVM Configure page shows an error when the CVMs are at 64Gb memoryNote: You may need to log in to the Support Portal to view some of these articles.
Hello everyone, So I’m running into a couple of issues that have been preventing me from getting a CE install onto bare metal.The first (and my work around for it) is that downloading the ISO from the pinned Download thread simply fails when using Opera under Linux. A new tab pops up, looks like it’s going to download and then simply nothing else further happens. This does not seem to be a problem with Firefox. So I am able to copy the link from the thread in Opera, then paste the ISO URL into Firefox and successfully download it. The second, and show-stopper, issue is when attempting to boot off of the ISO. Here’s my environment:C6400 with two C6420 nodes.Node 1 currently is running ESXI while I am testing other hypervisors.Node 3 is the target.Nodes 2 and 4 are unpopulated.1 and 3 have identical hardware; 2x Xeon Gold 6130, 128GB RAM, 2x 250GB NVME drives internal, 2x 250GB SSD drives on the front bay. All passed through direct with a SATA controller, no RAID. The ISO is able to be m
We are thinking about going with an HCI and I was looking at my list of requirements. One is that we can use our existing Fiber channel attached Tape Library. Is this a possibility with nutanix? I am seeing conflicting reports of FC not being supported, or it only being supported if I am using VMware as a hypervisor (pass through to the machine)Can anyone shed some light on this? My end game is to use our existing Veeam infrastructure(in a vm hopefully, currently stand alone), connected to fiber channel to backup our environment to tape.
Hi everyonePlease help me with this case:1- I have two nutanix blocks, each 3 nodes, I have only one core switch and I want to manage and see all nodes in the same cluster, I don`t have prism center.2-I want to install ESXI on all the nodes, if the configuration goes right!, when I want to manage VMs (create, delete, .. i.e.,) should this be done through the prism or from the esxi?Appreciating any help from you guys.
Hello Everyone, I am woking on a Java project at the moment and feel that StringBuffer would help a lot in performing this particular task, where I am 'building' a string representation of a Matrix:/** * Returns a String representation of the Matrix using the getIJ getter * function. You should use MaF.dF to format the double numbers to a * sensible number of decimal places and place the numbers in columns. * * @return A String representation of the Matrix */public String toString() { //String stringBuilder = new String StringBuffer beep = new StringBuffer; for(i=0; i<m-1; i++){ for(j=0; j<n-1; j++){ } // You need to fill in this method}I've tried it in a Java program by itself and it seemed okay, but then I tried some sample Java program from online java compiler and it didn't compile. Is StringBuffer built into Java, or would it require importing a package? I am not allowed to import any packages for this project. Can anyone know, where am I wrong?
Hello fellow Nutanix fans,We have a three-node cluster in a DR location. This DR cluster has less capacity than the primary site which has resulted in us exceeding the resilient capacity of the DR cluster.To remedy this situation, we decided to replace four 8TB HDDs with four 12TB HDDs in each node. Today we removed one drive from a node in Prism UI and waited approximately four hours before the system reported it was safe to remove the drive. During this time, Prism reported that data was lowering on the drive. The cluster showed about 700MB/s of throughput during this rebuild, which seems pretty really good for a cluster of this size. We removed the 8TB HDD and inserted the 12TB HDD. The rebuild did not initiate until we ran NCC. By default, NCC runs every 24 hours so, eventually the rebuild would have started but, we wanted to see it get started.We watched the rebuild run for a while after it got underway. The system is writing around 80MB/s to the replacement drive. At this rate (2
I have the commands for setting up a user and access level, but I’m not having any luck when configuring the SNMPv3 portion. I need to setup the following and would like to use IPMITOOL rather than manually logging into the IPMI: Has anyone been able to do this?
I am trying to have Nutanix portal sit behind a NGINX reverse proxy. I have it sort of working. If I try and go to nutanixpc.domain.com, it will redirect to nutanixpc.domain.com:9440/console. I tried adding a redirect but it doesn’t seem to be working. If I type the path https://nutanixpc.domain.com/console, then it works. server { listen 443 ssl http2; server_name nutanixpc.domain.com; ssl_certificate /etc/letsencrypt/live/domain.com/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/domain.com/privkey.pem; ssl_trusted_certificate /etc/letsencrypt/live/domain.com/chain.pem; include snippets/ssl.conf; include snippets/letsencrypt.conf; location = / { return 301 https://nutanixpc.domain.com/console; } location / { proxy_pass https://pcconsole.domain.com:9440; proxy_intercept_errors on; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_
Hey Guys, first time working with VMware installed on Nutanix. I am getting ready to install 7.0.2u, but I need some clarification first.I am unable to find the correct Customized Dell Binaries for 7.0.2u from VMware. Even reached out to support and they are no help. Every other version I can get the binaries for. Anyway I am just wondering is it required for me to use the 1 click upgrade in Nutanix to update my ESXi hosts or can I use update manager in vCenter?
is there any possible way to configure SPAN port on AHV Cluster?
I have 3 Node Cluster , One of the node is completely down. we replaced the SSD hard disks sda&sdb. These servers are located in remote Data center. i cant use physical foundation deployment. so used the below method; 1. Created ISO from Other Working CVM 2.Logged into IPMI console, Mounted ISO on the Virtual media 3. But here the foundation is got stuck , more than 10 hours any other best methods can we do the foundation ?
Hi,We used LCM to upgrade our cluster to AOS 5.20.4 and AHV-20201105.2286 on Lenovo HX7820 hardware.This combination is supported according to the Compatibility and Interoperability Matrix.However, on the Nutanix portal there now is a ‘Critical’ discovery:Cluster <removed> (UUID: <re-mo-ve-d>) is running AOS 5.20.4 and AHV-20201105.2286. This configuration may degrade functionality of new features and cause issues during cluster maintenance operations such as upgrades or cluster expansions.Install a qualified combination of AOS and AHV immediately to avoid issues that could arise from running an running an unsupported configuration.AHV-20201105.2267 is the recommended version(s) for AOS 5.20.4.If I check the C&IM, the AHV-20201105.2267 / AOS 5.20.4 combination is not supported. Does anybody know how to get this discovery resolved?
Below are the top knowledge base articles for the month of May 2022.KB 7503 - NX Hardware [Memory] - DIMM Error handling and replacement policy KB 8885 - Alert - A15039 - IPMI SEL UECC Check KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 11663 - Unable to launch Prism Element from Prism Central due to missing "PrismUI.tar.gz" file after upgrade KB 1113 - HDD or SSD disk troubleshooting KB 2090 - AHV host networking KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 3827 - Alert - A130087 - Node Degraded KB 8094 - NCC Health Check: disk_status_check KB 4519 - NCC Health Check: check_ntp KB 8514 - NCC Health Check: fs_inconsistency_check KB 4158 - Alert - A1104 - PhysicalDiskBad KB 6153 - NCC Health Check: default_password_check and pc_default_password_check KB 2473 - NCC Health Check: cvm_memory_usage_check KB 3786 - Alert - A1081 - CuratorScanFailure KB 4141 - Alert - A1046 - PowerSupplyDown KB 2463 - NCC He
Below are new knowledge base articles published on the week of May 22-28, 2022.KB 12211 - Alert - A200803 - AZNameUpdateFailed KB 12219 - Disconnecting Availability Zone fails KB 12428 - Alert - A110026 - Nutanix Cloud Clusters (NC2) - CloudAPIEndpointUnreachable KB 12445 - NCC Health Check: ahv_duplicate_secondary_ip_check KB 12699 - How to map a block to Rack after chassis or node replacement or after relocation KB 12711 - Missing link to reset the Nutanix Support Portal password KB 12782 - NCC Health Check: pmem_health_check KB 12783 - NCC Health Check: pmem_size_check KB 13014 - File copy throughput differs based on Windows version KB 13068 - Microseg update task failures every 1-2 minutes on a cluster where microseg has been disabled using acli KB 13070 - VM may experience network issues due to Flow rules left over from a previous VM that used the same Tap port KB 13157 - LVM partition "home" disappeared from a new RHEL 9.0 guest VM with SCSI disk running on AHV KB 13161 - CVM and
The expansion of cluster fails with an error log.Could anyone tell me how to solve it? <Detail>When I try to add a node to a cluster in the prism element, it fails with the error log below. Failure in pre expand-cluster tests. Errors: Failed to start foundation service to do network validation SSD tier on nodes [u'xxx.xxx.xxx.xx'] is not sized to accomodate expected metadata growth on cluster. Refer KB-8842 for more details. <Environment>As shown in the diagram below, the Nutanix nodes are created as one of the virtual machines on the ESXi.used version : ce-2020.09.16.iso <What I have tried>・Improving the spec of SSDs in a virtual machine for the additional Nutanix node SSD1 : 32GB → 64GB SSD2 : 200GB → 400GB SSD3 : 500GB → 1TB ・Confirming the result of KB-8842-->The result of issuing commands are attached as "kb-8842.log" in the bottom of this page. <Re-production procedure>1) Creating Nutanix nodes as one of the virtual machines on ESXi2) Composing a
I know this can be done with the NX hardware using the IPMITOOL utility pre-installed, but we’re starting to use HPE hardware and I wondered if anyone knew how to change the iLo administrator login password via cmdlet? We’ve scripted this for NX line and looking to do the same with HPE’s as a part of our deployment scripting.
I want to connect the guest VM to the Internet, what should I consider?
I have provisioned a SQL database with 200 GB. ERA will mount the disks and distribute the files on different point points. I have Enabled auto extend on database level. what will happened if the mount points got full. Will it auto extend or do we need to extend by our self.
I have some clusters where LCM propose some upgrade to STS version, but I want to stick to LTS. is there a way to disable some version so LCM display only “Enabled version”.BTW, there is a filter for disabled updates, so I guess there might be a way to disable some updates.
Below are new knowledge base articles published on the week of May 15-21, 2022.KB 12020 - NCC Health Check: pc_backup_limit_check KB 12212 - Expand cluster pre-check - test2_1_foundation_network_validation KB 12715 - Understanding Your Hardware & FE Entitlements KB 13115 - Expand cluster or hypervisor bootdisk repair fails at imaging phase if clusters is running Foundation 5.2 KB 13133 - vCenter Enhanced Linked Mode (EHM) with Nutanix KB 13134 - Veeam proxy deployment failed with message "Backup REST error: HTTP StatusCode:'BadRequest', Description:'"Unable to connect to AHV cluster" KB 13139 - Era - Enable or disable ERA private build flag KB 13140 - Era - How to disable or enable UDP fragmentation on Oracle RAC KB 13143 - Nutanix Files: Windows Previous Version (WPV) hanging when trying to recover SSR snapshots KB 13144 - Frame - Publish of Sandbox fails due to Sysprep failure KB 13151 - LCM HPE firmware upgrade failing due to baseline version not matching with HPE OneView SPP ve
Hi,New Nutanix user here so please forgive me my ignorance. I created a new VM in Prism Element and then (using this guide) used the Convert to Template function in Prism Central. So far so good. However, the converted VM still shows up under VMs in Element/Central. Can I now delete this VM? (We’re running just one cluster.) info:AHV version Nutanix 20201105.2267Prism central: pc.2022.4 Kind regards,Thomas
Please your support, I have two nutanix servers each is 3 node cluster, how I can connect them so they appear as a single cluster, should I connect them via a physical switch? Second question is I have vSphere license which I want to install on the clusters, how should I do that?
Anybody has the correct guidance or URL from where i can download the ESXi 6.7 u3 customized image file for Nutanix NX-WDT series node to build the AOS 3 node cluster
We are attempting to install the latest version of vmware tools across multiple clusters (12.0.0). Currently it requires a restart of the host if upgrading to 12 via lifecycle man and a baseline. However, if i do it manually via esxcli software vib update or install, it does not require an update. When i try to push this out to one of our test clusters via a cvm and the command: hostssh ‘esxcli software vib update -d /vmfs/volumes/tehdatastore/Tools12/Tools12.zip’, it completes properly but times out and moves to the next host before the output stating it completed successfully etc, giving an error stating it timed out instead (to be clear, it does actually run against all the hosts properly). Is there any way of adding a no timeout switch to the hostssh command (or perhaps just a larger timeout)? Upgrade was verified using hostssh ‘esxcli software vib list | grep tools'. Also within vcenter it now shows updates available to the vm’s etc. So this does work, it just looks bad whe
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.