Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Hi All I have been asked by my dev team for Windows NLB to be enabled, I have had problems with this in a VMware environment, are there any gotchas, alternatives or tips to get this to work? Many thanks E.
Trying to migrate two Windows VMs with Move 3.2 from ESXi to AHV. in the VM Preparation section after adding the credentials "migration rediness" is Pending and the error message shows "2 VMs are not ready for migration." What would cause the VMs not to be ready for migration? the VMs have in production for several months.
Hi, I`m very new to Nutanix and have a question. Does anyone know if there is a way to list all current snapshots via a script? I`d like to find out if there are any lingering snapshots that should be removed. Thanks for any advice you might have.
Hi All I've rather large number of non-managed and managed networks to create on multiple clusters and really am not willing to be creating them manually. I've created PowerShell script to create non managed networks, that was pretty easy. However, I'm finding it a bit more challenging to create managed networks using PowerShell commandlets. I understand that the command should look something like New-NTNXNetwork -Name "vLAN_Name" -VlanId "vLAN_ID" -ipconfig "IpConfigDTO" I can not find any samples of IpConfigDTO format. I understand that IPv4 default gateway address and subnet in CIDR notation should be provided as values but I can't work it out how. Any assistance would be much appreciated. Cheers
Our CVMs are locked down tight, I have no intention of allowing any internet access to PE, all support actions must be done through a webex session where our admin grants control to the support tech. but I have PC set up for NAT so it can communicate outside our private network. my question is, will pulse work strictly through PC or does PE need to be set up for it? Everything i see documented is about PE talking to insights.nutanix.com.
Looking for a simple script to Power on a shutdown Nutanix VM. Perhaps there is already a thread on this but I couldn't locate it if so. Thanks!!
I am a huge VS Code user, all I do is run my scripts/codes for local/remote/cloud products within VS Code. So I am now trying to get it so I can compile and run Nutanix Cmdlets within VS Code. I am trying to find the neatest, safest and most maintainable way possible without putting at risk the core of PowerShell. I've only found one post where someone has mentioned doing this and it was by installing the Nutanix Cmdlets and copying the contents of the module's folder into "C:\Windows\System32\WindowsPowerShell\v1.0\Modules". Maybe possible but there are over 200 items that would need copying into the root of this folder, seems messy to me. Can a sub folder called Nutanix be created for the contents to be copied too? Is there a better way to achieving what I feel be a great tool for all? Advice/support much appreciated 🤓
Hi, I'm relatively new to Nutanix, so I'm still learning the concepts and terms. But I was wondering if it was possible to develop a Powershell script, for the purpose of getting the last logon of Windows 7 workstations running as VM's in our environment. The script would run from a central location on our network, so it would have to access AHV and then somehow be able to grab the last logon time in the guest OS by the user who "owns" the workstation. We determine who owns the virtual workstation, by determining the sole user listed in the Remote Desktop group. We can do this, in VMWware for Windows 10 workstations; but I've been told that it's a little more tricky to develop such a script for Windows 7 running on Nutanix. Any help or guidance would be greatly appreciated, so that I could get a starting point. Thanks.
IF an admin resolves an alert but doesn't fix the condition, does the alert retrigger? and if yes, how long before it does? Thanks in advance.
Hello, I keep getting the following message when I run a health check Running : health_checks system_checks default_password_check [==================================================] 100% /health_checks/system_checks/default_password_check [ INFO ] -------------------------------------------------------------------------------+ Detailed information for default_password_check: Node 1.2.3.4 INFO: One or more hosts are using the default password Refer to KB 6153 (http://portal.nutanix.com/kb/6153) for details on default_password_check or Recheck with: ncc health_checks system_checks default_password_check +-----------------------+ | State | Count | +-----------------------+ | Info | 1 | | Total Plugins | 1 | +-----------------------+ Plugin output written to /home/nutanix/data/logs/ncc-output-latest.log When I check the node with the IP listed I cannot find any user account with the default password set. Admin is not default neither is the Nutanix user. I canno
Hello, We just received some alerts from our PRISM about the disk firmware. Following the alerts we have to upgrade them. Info : SATA DOM on host XXXXXX has old firmware version: SATADOM-SL 3IE3 firmware version is S560301N. Need to upgrade to the latest firmware version. We know that the upgrade do an upgrade one disk at a time but i've some doubts about the process to use before to click to upgrade. https://portal.nutanix.com/#/page/docs/details?targetId=Web_Console_Guide-Prism_v4_7:wc_cluster_firmware_upgrade_wc_t.html My question is, should we move our VM from the host before to upgrade the disks? should we add our hypervisor in maintenance mode in order to upgrade the disks? Or the disk firmware update has no impact on VM hosted ? Thanks in advance all!!!
Hi everyone, The X-Ray new UI just got released last month. The redesign of the tool mainly focused on improving the user experience and better aligning with user’s business needs. Yini talks about the effort behind the scene and explore why we redesigned X-Ray, explain how we approached the redesign, and look at the features and benefits that this redesign enabled. Check out the article 👉 Redesign a data heavy application Be the first to reply and share your thoughts!
Hello, I need to understand if Nutanix deduplication works weel for optimize capacity if I have two identical VM (for example two Windows VM with DFSR. Thanks Manuel
Has anyone installed the Virtio 1.1.4 drivers on Windows servers. If so where they SQL server and if so did it help or hinder?? Just beginning our AHV installation and want to know if anyone has seen or recorded the results/improvements in performance. Thanks
Hello, I am trying to use nutanix xtract to move a windows server 2016 machine to nutanix. I have a local admin and disabled UAC and rebooted the computer. When i put in the local admin account and it trys to verify it tells me UAC is enabled. I have checked and rechecked. Logged in with different accounts to ensure UAC is disabled and rebooted multiple times. What am I doing wrong? Thank you
I am trying to connect Zenoss to Nutanix Prism cluster and have provided the monitoring guys a user name and pw along with cluster IP. They are getting errors trying to connect, the error is in title of this post.. unauthorized for Nutanix REST API. check username and password So I then provided the monitoring guys the nutanix account and pw and it still spits out the same error. Please advise. I have to be missing something here.
Hi Does anyone here who have migrated VM from ESXI To AHV using Nutanix Xtract tool? THe ESXI does not have a Vcenter .. Ive read that A Vcenter is require to migrate a Esxi VM to AHV..
Hello; When i try to migrate a Vm from Esxi to AHV with Move, the operation is being failed sometimes. Migration Status steps go well until last step "install device drivers". The error is this: "Failed to execute guest command: 'msiexec.exe /i C:\Users\ADMINI~1\AppData\Local\Temp\vmware174\Nutanix-VirtIO-latest-stable.msi /quiet' ExitCode: '1603'." My AOS version is 5.10.5. The OS is windows server 2016. I logged in with Built-in Administrator account and i installed VirtIO 1.1.4 manually. I can migrate some Server 2016 Vms but there is a problem about some Vms.
Hi; I have an ubuntu server on vmware and i want to migrate it to AHV with Move. when i type "uname -a" output is: Linux TKMAPP1 4.2.0-42-generic #49~14.04.1-Ubuntu SMP Wed Jun 29 20:22:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux when i type "grep -i virtio /boot/config-`uname -r`" output is: CONFIG_NET_9P_VIRTIO=m CONFIG_VIRTIO_BLK=y CONFIG_SCSI_VIRTIO=m CONFIG_VIRTIO_NET=y CONFIG_CAIF_VIRTIO=m CONFIG_VIRTIO_CONSOLE=y CONFIG_HW_RANDOM_VIRTIO=m CONFIG_DRM_VIRTIO_GPU=m CONFIG_VIRTIO=y # Virtio drivers CONFIG_VIRTIO_PCI=y CONFIG_VIRTIO_PCI_LEGACY=y CONFIG_VIRTIO_BALLOON=y CONFIG_VIRTIO_INPUT=m CONFIG_VIRTIO_MMIO=y CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES=y As i see VirtIO drivers are installed. And then when i start to migrate on Move an error pop up is appears: SCSI VirtIO device driver not found. Please download and install the appropriate device driver before retrying the migration. What can i do for this issue ?
I'm new to Nutanix, and have a basic question pertaining to keeping drivers and firmware in the server up to date with LCM. We have Dell XC640 servers running VMware ESXi. Am I too assume the LCM is going to provide all the drivers and firmware required for the stack? Documentation states that Dell provides the payload, LCM installs it. I want to validate after updating the hosts with LCM if that's all that I need to do. Does this also update the VMware Ethernet driver? It seems to good to be true that LCM would actually do that as well. Looking for some guidance on this so that I have a solid game plan that I can document moving forward.
Hello! This is my environment: LENOVO Converged HX3710 Appliance - Type 8689 (4 Nodes) AOS 5.10.5 Foundation VM 4.4 ESXi 6.5 U2 I am trying to install nutanix AOS 5.10.5 on this LENOVO HX server without any success so far. The installation process fails once again with the following message: ------------------------------------------------------------------------------------------------------------ 20190623 14:29:56 ERROR Error occured during virtual media mount: Session no longer connected 20190623 14:50:05 ERROR Exception on executing cmd: ['test', '-f', '/usr/bin/layout_finder.py'] Traceback (most recent call last): File "foundation/foundation_tools.py", line 218, in ssh File "foundation/foundation_tools.py", line 194, in get_ssh_client File "/home/nutanix/foundation/bin/../lib/py/paramiko-1.18.4-py2.7.egg/paramiko/client.py", line 323, in connect raise NoValidConnectionsError(errors) NoValidConnectionsError: [Errno None] Unable to connect to port 22 on 10.8.25.109 2019062
I have re-install NUtanix Cluster NX1350 with AHV new version. But when I try to foundation, I found a problem after mount virtual media step log as a below: code:20190725 16:29:51 INFO Validating parameters. This may take few minutes20190725 16:29:54 INFO Running ) @a3b0>20190725 16:29:54 INFO Validating parameters. This may take few minutes20190725 16:31:32 ERROR Node with ip 172.17.1.206 is not in cvm or is not reachable20190725 16:31:53 ERROR Node with ip 172.17.1.206 is not in phoenix or is not reachable20190725 16:32:56 ERROR Node with ip 172.17.1.206 is not in cvm or is not reachable20190725 16:33:17 ERROR Node with ip 172.17.1.206 is not in phoenix or is not reachable20190725 16:33:17 INFO Completed ) @a3b0>20190725 16:33:17 INFO Running ) @acd0>20190725 16:33:17 INFO Node IP: CVM(172.17.1.206) HOST(172.17.1.203) IPMI(172.17.1.200)20190725 16:33:17 INFO NOS Version is: 5.10.3.220190725 16:33:17 INFO Completed ) @acd0>20190725 16:33:17 INFO Running ) @ab10>2019072
Hello, Just wondering if there is anything special about running CVM commands via ansible or other non-interactive session tools? The ansible ping module works just fine but when I start using Nutanix specific commands i get errors telling me that "no such file exists." The commands i'm running are "cluster status" and "ncli rsyslog-config get-status" These obviously work in a regular interactive session but not with ansible. Am i missing a path variable declaration or something? Are the commands only available via interactive sessions(if that is even a thing)? Thanks Update: a coworker who is better at linux than I am said that the profile probably isn't loaded the same so I need to fully source all the commands. So right now I'm doing my best to find them and running them that way. So far so good. /home/nutanix/cluster/bin/cluster status
code:Hi All !I made a new install of nutanix on 3 host vmware esxi, when I started it for a while, it does thisfatal: Mounting installer media20190725 23:19:17 WARNING Skipping ImagingStepRAIDCheckPhoenix because dependencies not met, failed tasks: ImagingStepInitIPMI20190725 23:19:17 DEBUG Setting state of ImagingStepPreInstall from PENDING to NR20190725 23:19:17 WARNING Skipping ImagingStepPreInstall because dependencies not metand can't run anymore, can you help me?
is it possible to install nutanix MOVE on bare metal server ?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.