Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Below are the top knowledge base articles for the month of May 2021.KB 7503 - NX Hardware [Memory] – G6, G7 platforms - DIMM Error handling and replacement policy KB 1540 - [AOS Only] What to do when /home partition or /home/nutanix directory on a Controller VM (CVM) is full KB 4141 - Alert - A1046 - PowerSupplyDown KB 1113 - HDD or SSD disk troubleshooting KB 4409 - LCM: (Life Cycle Manager) Troubleshooting Guide KB 4158 - Alert - A1104 - PhysicalDiskBad KB 6945 - How Upgrades Work at Nutanix KB 2090 - AHV host networking KB 2473 - NCC Health Check: cvm_memory_usage_check KB 4519 - NCC Health Check: check_ntp KB 1863 - NCC Health Check: sufficient_disk_space_check KB 3827 - Alert - A130087 - Node Degraded KB 7554 - Critical : Cluster Service: Aplos is down on the Controller VM KB 5228 - NCC Health Check: pcvm_disk_usage_check KB 4872 - LCM: How to cancel an ongoing LCM update operation using the "Stop Update" feature KB 5505 - Long Term Support (LTS) and Short Term Support (STS) Relea
Hi All,We have scheduled to perform a Nutanix Cluster upgrade.Existing Setup:3xDell XC730 XD-12 running on AHV 20170830.453 / AOS(5.15.3). This cluster is hosting around 50 VMs.Upgrade to:4* NX 8235 -G7-4215R -CMIs it possible to add the 4*NX to existing cluster and then remove 3xDell XC servers. We are trying to achieve minimum downtime here without major outage.Per Nutanix documentation https://portal.nutanix.com/page/documents/details/?targetId=Hardware-Admin-Ref-AOS-v5_17%3Ahar-product-mixing-restrictions-r.html , it seems mixing hardware isn't feasible. Could you please confirm if there is any work around possible?Regards,
Below are new knowledge base articles published on the week of May 23-29, 2021.KB 11317 - License Feature Violations or Expired Licenses on Xi-Beam KB 11327 - Calm Blueprint output window block can only be minimized by clicking on the minimize button KB 11339 - X-Ray fails to run the Throughput Scalability test KB 11350 - Recieving "name in body should be at most 40 chars long" when creating a Karbon Cluster KB 11354 - Hit logs from Flow-enabled AHV cluster not forwarded to remote syslog due to regex issue KB 11363 - Lazan service restarts with "GenesisClientError: kRetry: Failed to check if upgrade is in progress, please retry" KB 11367 - Calm: App/VM deployment fails with ERROR - "The resource '<value>' is in use." KB 11395 - Windows VM running VirtIO 1.1.6 may crash with code IRQL_NOT_LESS_OR_EQUALNote: You may need to log in to the Support Portal to view some of these articles.
This is a continuation of the post that I wrote here: https://next.nutanix.com/topic/show?tid=33950&fid=31 Part of this was resolved however we are still running into an issue with some of our VMs in which they get stuck in this state: { "status": { "description": "2016 Template-4/17/19", "state": "ERROR", "execution_context": { "task_uuids": [ "8d0c2110-461b-4252-a223-11016ff8714b" ] }, "message_list": [ { "message": "Edit conflict: please retry change. Entity CAS version mismatch.", "reason": "CONCURRENT_REQUESTS_NOT_ALLOWED" } ]} The only way to clear it is to power the VM down and update the VM within the GUI. However, upon trying to subsequently update the VM by API it results int the same error. Please advise.
Hi All, I am a beginner to Nutanix, just wanted to AHV / AOS! how its function.
The release-api.nutanix.com is not reachable from my prism central and my prism element .I have valid name servers configured in both PC and PE .I got it verified from network team that the traffic is passing by firewall .Can anyone let me know what exact things do i need to check in my name servers so that this URL will be connected from PC and PE ?
Hello Community, I have some doubts about running Nutanix on VMWare with ESXi with Cisco ACI fabric. To start, we have already married ourselves to a Cisco ACI network fabric (two sites connected with 12x10Gbit fiber (120Gbit)). We are using an IPN / Spine / Leaf topology, with APIC clusters in each site. In each DC there will be 24 Nutanix Nodes. All of my question have to do with the best practices of integrating these technologies. 1) Is it necessary to use VMware NSX to reap the benefits of Cisco ACI? 2) Can we just use a simple VMware installation (without NSX) and allow Nutanix full access to the ACI fabric? 3) Whats the best practices related to these three technologies coexisting together? I have found documents on Nutanix/ACI and Nutanix/VMWare, but I cant find anything on using all three together in terms of hierarchy and how to stitch it all together. Any guidance from those who have experience would be greatly appreciated. Thanks, Michael
The reason we deploy SQL Always-on as an enterprise is to have multi-site resiliency for our SQL clusters for operational and business continuity reasons. The issue is that ERA will not register SQL always-on clusters if they are spread between two sites/clusters. From an “API First” solution I would expect differently! I can not introduce risk and pull back DR planning because of the lack of support from ERA. How is the NTX community solving this issue?
Im trying to create a playbook that on X alert posts to teams channel…. is this possible? I have tried a few methods but not having much joy. Method: POST URL: https://outlook.office.com/webhook/blahblahblahlongstring user: blank Pass: blank Request body: I have tried setting json and tried using the built in parameters Alert: Source Entity Name Alert: Alert Name Alert: Creation Time Alert: Severity request headers: blank or Content-Type: application/json so am i just missing something about the syntax? Or is the rest api call for nutanix api’s only? Thanks in advance.
Is it possible for purposes of DR in a cloud solution to move just the VMWare environment?Can you replicate your Production Nutanix VMware environment to a cloud based solution? Say IBM cloud? They say you can but i guess i am having a hard time seeing how that will work? I am really new to the whole cloud solution arena and my company wants to move our DR\Datacenter to cloud? We have business reasons for using IBM cloud but they do not have a nutanix cloud infrastructure but tell us we can bring our VMWare environment.
Below are new knowledge base articles published on the week of May 16-22, 2021.KB 11189 - How to secure the bootloader with a user-defined password KB 11190 - RHEL STIG requirement for actions when audit storage is full KB 11191 - How to configure CVM to use nutanix user on AHV instead of root KB 11192 - How Envoy handles downstream service failures KB 11193 - New users are added to AHV: "nutanix" and "admin" KB 11252 - SSL Certificates and the Secure Gateway Appliance for Frame KB 11312 - AOS upgrade notification shows 5.20.x as Short Term Support (STS) release instead of Long Term Support (LTS) release KB 11321 - Calm VM image upload to vCenter7 fails with error "Unable to retrieve manifest or certificate file." KB 11333 - Adding Nutanix Objects as Secondary Storage with Veritas Enterprise Vault KB 11334 - AHV/ESXi Standalone Foundation deployment failure on HPE DX AMD platforms with Mellanox NIC CX4 or CX5 KB 11346 - Nutanix Files - Inode usage high on FSVM KB 11364 - CVE-2020-13946
AOS 5.20 delivers performance enhancements that build on the breakthroughs in AOS 5.19 and expands on built-in key management capabilities for keeping data encrypted and secure. AOS 5.20 also increases the portability of VMs running on the built-in hypervisor AHV, streamlines advanced management capabilities, and more. A complete list can be found in the Release Notes. Nutanix Insights:Available with all new AOS releases is Nutanix Insights. Most enterprise IT solutions rely on a reactive approach to system maintenance and issue resolution. For example, when a technical issue arises, vendor support teams typically capture detailed system data from the customer and recreate the issue in a separate environment—only then can the actual debugging begin. This approach consumes unnecessary time and resources and ultimately delays resolution. Nutanix simplifies and streamlines this process through two important support services: Nutanix Pulse and Nutanix Remote Diagnostics. When enabled, Puls
On cvm, the cs and cluster start commands are output to the next screen.Hypervisor : ESXI 6.7U3AOS : 5.15.4What's the problem?
I just updated a cluster’s AOS and am now getting the warning:AHV version 20190916.360 is currently installed on host, while minimum compatible AHV version is 20190916.410But I cannot AHV without updating also AOS to 5.19.2 which would change my plan to STS (currently installed 5.15.5.1 LTS)So I have to ignore the warning and waiting for a compatible AOS LTS version, or should I change to 5.19.2 STS?
I have a server that no longer needs one of its 2TB disk. I know how to remove the disk from the VM but, how do I remove that VMDK from the Nutanix Storage container? Is there a way to browse it and then delete it? 2TB is a lot of space that I would like to reclaim.
Which node type does not deploy a Nutanix Controller VM. A bit confused with documentations available some say “Compute only” and other say “All Flash”One more question A vDisk is read by multiple VMs. The cluster creates immutable copies of the vDisk. What are these vDisk copies called.
We noticed that recently in our test cluster all operations take very long to complete. This seems to be due to long lasting “cerberus” tasks being executed with a type “uncharge”. Does anyone know what “cerberus” is doing or how I could speed it up? Whenever we kill the cerberus tasks manually all other queued ‘non cerberus’ tasks start to execute.
Below are new knowledge base articles published on the week of May 9-15, 2021.KB 10162 - NCC Health Check: disk_power_check KB 10204 - NCC Health Check: esx_product_locker_setting_check KB 10414 - NCC Health Check: ahv_file_integrity_check KB 10420 - NCC Health Check: stale_recovery_points_check KB 10461 - NCC Health Check: aide_check KB 10524 - NCC Health Check: marker_files_check KB 10532 - NCC Health Check: recovery_plan_consistency_group_checks KB 10735 - NCC Health Check: rsyslog_forwarding_check KB 10811 - NCC Health Check: remote_log_forwarding_check KB 10864 - Alert - A130347 - ExternalDatasourceStorageMigrationSuspendedAlert KB 11141 - Secure Boot Causes Device Re-enumeration in Windows Guest VMs on AHV KB 11212 - Nutanix Move fails to prepare Windows Server 2008 R2 VM for migration from Azure KB 11266 - Cassandra fails to be active after one metadata SSD goes bad in a multi SSD node KB 11273 - Hyper-V 2019 upgrade - SKU option is missing in Upgrade Software page KB 11323 - Nu
HCI runs on ESXi hosts, and VMs are protected with Async Protection Domain. I wonder, how to find which host a recovered VM will be registered with? I guess, it’s a certain service “leader”? Also, can I change it?
Not sure why but there appears to be an absence of documentation pertaining to required ports that might need to be opened in a firewall to access the CVMs. Perhaps Nutanix thinks that organizations aren't going to firewall off the cluster to protect access from malicious users. If I'm wrong why don't I see a list of ports that are needed to access the CVMs rather than KB articles showing what outgoing ports are needed in a perimeter firewall? In order to properly protect a cluster the CVMs should sit behind a firewall, which in my architecture this will be the case before we go live with anything. In order for admins to access the CVMs through a firewall TCP 22 is needed for SSH, and 80 and 9440 are needed for accessing the web console. Is this is? or are there more ports that would need to be opened up for the various types of admin interactions? how about running cli tools against the cluster? how about downloading support files? and I'm sure I'm missing mor
I was trying to get AlienVault (OSSIM) to run on Nutanix, but I have hit a road block. I was able to get the install dialog to run after setting the boot to legacy bios. However, after install, It fails to boot.My questions, do any of you use any open source SIMS solution that works in Nutanix?I could accept a SIMS solution at a cost. However, after going through sales with LogRythim and splunk, I was frustrated because both of them incure log ingestion fees. We may have a good budget, but we are limited with our operational cost.Thanks for any assistance you can provide.
I have setup Nutanix CE in a lab environment but I cannot get to the Prism page when browsing to the CVM IP address. I'm getting the message: Prism services have not started yet. Please try again later. Although I have run cluster status and the Prism service is up and running: It is a single node setup on VMWare. I can ping the CVM IP and SSH onto the CVM. Any assistance would be gratefully received! Thanks.
I’m asking about the version of VMFS datastore for ESXi hypervisor on Nutanix cluster. I’m trying to create new VM with a disk larger than 2 TB with no luck of success, after some google searches seems this issue could be due to VMFS3.
Why need volume_group_uuid when i create a new Volume Group???how to get the volume_group_uuid?
Hello Nutanix community. I have problem with upgrading my AHV version. I attached error screenshot. How can i solve this problem without any power off, reboot or other actions? Because it production environment. Thanks
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.