Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
Let’s say that you need to use Phoenix on a node, how do you know which ISO is best for you? the minimal or a bundle of Phoenix & AOS? How do you create the bundle? The short answer for both questions is, it depends. What is Phoenix? Phoenix is an ISO-based installer that you can use to perform installation tasks on bare-metal hardware one node at a time. Tasks that performed by Phoenix: Configuring Hypervisor settings, virtual switches and more (no need for AOS in this case) Installing the Controller VM which runs the AOS. Installing the Hypervisor on a new or replacement node. Repairing the CVM. If you don’t have access to the CVM and you want to check the data drives’ health, you will be able to see the drives from the Phoenix shell. How do you obtain the correct Phoenix? Looking at the scenarios above, we can see that for each case you might need a different approach and ISO, but all scenarios require the minimal Phoenix ISO. You can download the minimal Phoenix ISO from
Below are the top knowledge base articles for the month of January 2020. KB 4116 - Alert - A1187, A1188 - ECCErrorsLast1Day, ECCErrorsLast10Days KB 4141 - Alert - A1046 - PowerSupplyDown KB 7503 - G6, G7 platforms with BIOS 41.002 and higher - DIMM Error handling and replacement policy KB 1540 - What to do when /home partition or /home/nutanix directory is full KB 4541 - Alert - A101055 - MetadataDiskMountedCheck KB 1113 - HDD/SSD Troubleshooting KB 4158 - Alert - A1104 - PhysicalDiskBad KB 4409 - LCM: (LifeCycle Manager) Troubleshooting Guide KB 2090 - AHV | Host and Guest Networking KB 4188 - Alert - A1050, A1008 - IPMIError KB 1507 - Alert IPMI IP address on Controller VM {CVM-IP} was updated to ... without following the Nutanix IP Reconfiguration procedure, can be misleading KB 4519 - NCC Health Check: check_ntp KB 4494 - NCC Health Check: metadata_mounted_check KB 4705 - Alert - ExternalClientAccessCheck KB 2473 - NCC Health Check: cvm_memory_usage_check KB 8514 - NCC Health Check
Below are new knowledge base articles published on the week of January 26-February 1, 2020. KB 8861 - Calm - Can't edit/delete task library when the associated project gets deleted KB 8891 - Lenovo XCC/IMM upgrade via LCM : "Failure in executing cmd:ifconfig usb0 169.254.95.120" KB 8896 - Multiple disks marked offline on node running PH16 firmware Note: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of January 5-11, 2019. KB 8725 - AHV | Cluster expansion or host boot disk replacement may fail on AOS 5.16 KB 8727 - AHV | LCM does not offer new AHV versions after upgrading AOS to 5.16 on cluster with GPU cards KB 8732 - AHV | 1-Click hypervisor upgrade may fail on mixed cluster running AOS 5.16 KB 8790 - ESXi - Supporting 6.0 series on G7 KB 8792 - NCC checks: same_hypervisor_version_check, duplicate_cvm_ip_check, same_timezone_check giving ERR KB 8793 - Firmware update for DX+DL mix cluster KB 8796 - AHV | Windows installation fails with "No signed device drivers were found" error KB 8799 - Syslog setup for Prism fails with port error KB 8806 - AHV | Windows Server OS may crash when hot-adding vCPU KB 8815 - [Karbon] Deployment fails on etcd volume creation Note: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of January 12-18, 2019. KB 8801 - How to change between TTY (virtual terminal) on Linux guest VMs when using a console launched from Prism Element KB 8804 - Xi Beam Issue KB 8811 - AHV | ISO image file with uppercase extension "ISO", detected as "DISK" during image creation KB 8814 - AHV | How to create VM templates KB 8832 - AHV | Generic troubleshooting scenarios KB 8835 - AHV | How to add or remove NICs from bridges KB 8838 - AHV | How to upgrade using LCM Dark site bundle KB 8841 - Nutanix Files - UID and GID differences for Multiprotocol shares KB 8847 - How to Change Background of Production Instances Note: You may need to log in to the Support Portal to view some of these articles.
Below are new knowledge base articles published on the week of January 19-25, 2019. KB 8805 - AHV | How to change hypervisor identity KB 8848 - Listing VMs via CLI for importing into Excel KB 8853 - ESXi ixgben technical details and known issues KB 8858 - AHV | Hypervisor 1-Click upgrade troubleshooting scenarios Note: You may need to log in to the Support Portal to view some of the articles.
Below are new knowledge base articles published on the week of December 29, 2019-January 4, 2020. KB 8463 - HDD/SSD failure can cause CVM reboot KB 8464 - LCM - Why VMs are detected as non-migratable during update operation ? KB 8778 - AHV | Bitlocker cannot be enabled on Windows Server 2019 in VM running on AHV KB 8779 - Check the Foundation version installed via CLI Note: You may need to log in to the Support Portal to view some of these articles.
I'm will be configuring Network Segmentation on my Nutanix Cluster as per these instructions. https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v510:wc-network-segment-on-existing-cluster-wc-t.html The VLAN that I put my backplane traffic on, does it matter or not if I have a Gateway for that VLAN? I would use 172.16.10.0 as the Subnet IP and 255.255.255.0 as the Netmask. I am planning on having a Gateway of 172.16.10.1 on the firewall. Currently, the default configuration without network segmentation, the management and backplane traffic on eth0 has a gateway so as far as I can tell, everything should still work if I have a gateway for backplane traffic. Could someone please confirm that it doesn’t matter if I have a gateway on the backplane VLAN or not?
Dear All Is there any limitation for Nutanix to hold more than 64TB storage in a single node ? Pls send me the refference link
We are thinking of adding two compute only nodes to our cluster for Oracle. What are the hardware requirements for running CO nodes? Does the cluster the CO’s are joined to have to be all flash or do you have to “pin” the VM’s running on the CO to All Flash in the HC storage. We currently have 4 HC nodes running a mix of SSD and HDD.
Security and encryption are backbone of an IT infrastructure. Many organisation have made it a compliance to encrypt data and keep the data on-prem. Nutanix also provides industry standard security features. One of them being :DATA-AT-REST ENCRYPTION Nutanix provides an option to secure data while it is at rest using either self-encrypted drives or software-only encryption and key-based access management (cluster's native or external KMS for software-only encryption). Want to more about D-A-R-E and it’s features? Go through the following guide D-A-R-E guide During various compliance auditing and administrator task, we need to verify if D-A-R-E is enabled and successfully working or we need to configure D-A-R-E How can we safely accomplish that? We have different methods using which you can verify that D-A-R-E is enabled or not . You can use these methods to automate the process of verification or configuration. Go through the following KB to know about the various methods with comm
Hi, I am having a Hyper-V cluster managed by a SCVMM with Kerberos enabled. I already did: Join the cluster and hosts to domain Create the MSFC and join to domain Add hosts and Nutanix container share to SCVMM Enable Kerberos and configure Delegation But, from each host, I currently cannot: Access to Nutanix container via SMB path (\\VIP\container). When I type the SMB path into file explorer, it requires me to login. I tried to use the AD account used to enable Kerberos on Prism as well as AD admin account but could not make it Create the VM (I could create the VM by using SCVMM instead). “Failed to create the virtual hard disk” error window appears every time I try to create Is this the normal behavior of the whole system? As I am quite new to Hyper-V, I am getting lost in finding the solution to solve it
Confused regarding crash-consistent snapshot and application-consistent snapshot? Crash-Consistent SnapshotVM snapshots are by default crash-consistent, which means that the vDisks captured are consistent with a single point in time. The snapshot represents the on-disk data as if the VM crashed or the power cord was pulled from the server—it doesn’t include anything that was in memory when the snapshot was taken. Today, most applications can recover well from crash-consistent snapshots. Application-Consistent SnapshotApplication-consistent snapshots capture the same data as crash-consistent snapshots, with the addition of all data in memory and all transactions in process. Because of their extra content, application-consistent snapshots are the most involved and take the longest to perform.While most organizations find crash-consistent snapshots to be sufficient, Nutanix also supports application-consistent snapshots. The Nutanix application-consistent snapshot uses Nutanix Volume Shad
Is it necessary to have 2 vlans when deploying nutanix or can I deploy nutanix with one vlan?
Dear Sir/ Madam, I am working on a further Nutanix project and I have installed 8 x NX8155 servers. Each server has 6 x 10g TwinX cables and 2 x CAT6 copper connections. I am again trying to find any suitable cable manager due to the amount of physical cabling for each device. Can someone please advise if there are any cable managers that Nutanix is aware of or via a third party as I am struggling to locate any. Thanks in advance. Simon.
I am trying to add Hyper-V host to Move to migrate the VMs. But after adding the host, VM inventory are not loading(Shows 0 VMs) . When i try to refresh i get below error: Failed to get inventory for source ' '. [ApiName="Get VM", HypervisorErr="[Cmd="Get-VM | Select-Object -ExpandProperty DVDDrives | Select ControllerType, ControllerNumber, ControllerLocation, Path, SupportPersistentReservations, VMName, VMId | ConvertTo-Json -Compress | Out-File -FilePath C:\Users\xtract\AppData\Local\Temp\executeCmd385362813\Ouput.json", ErrorMsg="exit status 1", Location="/root/workspace/xtract_vm_qcow2_builder_prod/go/src/hypervisor/hyperv/hyperv_agent/utils.go:96", Stderr="#< CLIXML <Objs Version="1.1.0.1" xmlns="http://schemas.microsoft.com/powershell/2004/04"><Obj S="progress" RefId="0"><TN RefId="0"><T>System.Management.Automation.PSCustomObject</T><T>System.Object</T></TN><MS><I64 N="SourceId">1</I64><PR N="Record">
The cluster is up and running and we are getting error “Disk 'root' space usage high on host” Can /home/install/phx_iso be deleted?
Hi, I am new here and this is my firts experience with Nutanix. I need to deploy 3 nodes, and I’ m going to use the native Hypervisor from Nutanix (AHV). I saw a video explainning that, to do it, it’s necessary to download and use the Foundation Tools to configure the cluster and than, gathering access to PRISM. Unfortunally, I can’t download Foundation, due to the Nutanix blocks were registered by our customer (message: ...The email XXXXXXX is not authorized for the account associated with the serial number YYYYYYY) and we don’t know who did it. We are trying to identify who registered the blocks but, meanwhile, Is there another way to deploy it without the Foundation tool, or is there a way to unregister the blocks and register again but to different user account? Thanks in advance,
Hello all, Hope you’re all doing great. Kindly if you can guide me where to start with Nutanix as I don’t know anything and willing to know everything related .. so I am a VMware guy who is willing to understand the NU platform and I hope I am writing the right post in the right place Thanks in Advance, Cheers.
hi all Im trying to install 4 node nutanix but I got this issue Do you have any idea what is the issue? this error is the same in this 4 nodes code:20190902 16:16:19 INFO Setting cdrom as boot device for next boot20190902 16:16:35 INFO Next boot device is set to optical20190902 16:16:35 INFO Power status is off20190902 16:16:35 INFO Powering up node20190902 16:16:58 INFO Exiting SMCIPMITool20190902 16:16:58 ERROR Exception in ) @bcb0>Traceback (most recent call last): File "foundation\decorators.py", line 77, in wrap_method File "foundation\imaging_step_init_ipmi.py", line 309, in run File "foundation\imaging_step_init_ipmi.py", line 156, in boot_phoenix File "site-packages\bmc_utils\boot_media.py", line 47, in wrapped File "site-packages\bmc_utils\remote_boot_rmh.py", line 193, in boot File "site-packages\bmc_utils\remote_boot_rmh.py", line 240, in boot_from_iso File "site-packages\pyghmi\ipmi\command.py", line 314, in set_powerIpmiException: timeout20190902 16:16:58 ERR
I completed an AOS upgrade from 5.5.2.2 to 5.10.8 on two different clusters. On one cluster I have the health page showing a warning symbol (no data) and the message: “An error has occurred. Show me why” When I role over “Show me why” I see the message “java.lang.NullPointerException”. I have a ticket open with Nutanix but haven’t received any solutions that have worked yet. Appreciate help if someone knows how to resolve.
When i try to connect to IPMI by clicking on the link in Prism Central i get an error stating the site can not be reached because it timed out. It seems to be related to the firewall maybe. Any information where to start? thank you
Hi, We have a NX-3060-G4 with 3 VMware hosts on that is currently connected to our Cisco core switch cluster using 10GB twinax cables. A long story short, I need to remove these and connect the NTX to a single 1GB Cisco switch (WS-C3850-12S-S). My question is: can I connect a 1GB SFP link between the NTX and new core switch using the 10GB NTX ethernet port? If so, will the NTX detect that the cable connected can only run at 1GB? Thanks in advance.
In some scenarios, we might have a need to find the disks associated with a virtual machine hosted on a Nutanix AHV Cluster. Nutanix offers a distributed storage fabric, which forms a large storage pool across “N” number of nodes. we then create containers for different types of workloads or we can easily use a single container as well.Virtual Machines are created via Prism Management and all vDisks associated with the VMs are hosted on the distributed storage pool. On a Nutanix AOS Cluster, Acropolis service runs across the cluster to manage virtual machine operations and configurations. As both Data & MetaData is distributed across the cluster, we can use the “Acropolis” service on almost any CVM to retrieve virtual machine information running on any node.In order to interact with the Acropolis service, Nutanix offers “acli”. a powerful set of commands for virtual machine operations across your Nutanix cluster.acli offers tab-completion once inside the acli shell or we can execu
Impact : If hostd service is not running, AOS upgrade will fail. Cause : VMware hostd service may not be running. Resolution : Check hostd status and restart it manually. Node Id : ZM164S021332 Block Id : 16SM13330093 Block Type : NX-1065S Cluster Id : 57606 Cluster Uuid : 00053fb4-2744-267d-0000-00000000e106 Cluster Name : NTX-DETACOOP01 Cluster Version : el7.3-release-euphrates-5.5.3.1-stable-266039dc19600d27bdc4b7134d02d1c7d267cea6 Cluster Ips : 192.168.39.13 192.168.39.14 192.168.39.15 Timestamp : Thu Aug 16 7:29:06 -03 2018
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.