Get guidance, share wins, and ensure smooth Nutanix deployments.
Recently active
While getting some stats for a vm the behavior seems to be different depending on the stat.Is there any documentation for specific stats? Sample Call:metrics: controller_avg_read_io_size_kbytes,controller_avg_io_latency_usecsstartTimeInUsecs: 1631290740000000intervalInSecs: 3600Output (see below):stat controller_avg_io_latency_usecs - give the expected output of a value for each interval since the input start timebut for stat controller_avg_read_io_size_kbytes - A single value is returned. What is the meaning of single value? Is it just the read at that point in time? Or is any calculation done behind the scenes? { "statsSpecificResponses": [ { "successful": true, "message": null, "startTimeInUsecs": 1632404100000000, "intervalInSecs": 3600, "metric": "controller_avg_read_io_size_kbytes", "values": [ 127 ] }, { "successful": true, "message": null, "startTimeInUsecs": 1631290740000000, "intervalInSecs": 3600, "
Hello, I have a 3 node cluster with RF 2 configured. When All the nodes are up and running I can see Total Cluster resources as below on the Prism Element.CPU - 388 Ghz RAM - 4.5 TB ( 1.5 TB Per Node) Storage - 32.9 TB Let’s say If 1 node fails, Will my Available Storage size reduce? Please Help me. Also, I don’t understand one thing, I have Total 42 SSD of 1.92 TB = 80.64 TB, But in reality with RF2 why am I getting only 32.9 TB (without any data efficiency options enabled). I should Ideally get 40 TB of usable space. I checked on the storage sizer portal and it said I should get 63 TB. Please guide guys, what am I missing.
Connect-NTNXCluster -Server prismserver -UserName (Get-StoredCredential -Target NTNX).UserName -Password (Get-StoredCredential -Target NTNX).Password -ForcedConnection | Format-Table -Property name,version | Out-Null$imagecreatespec = New-NTNXObject -Name ImageImportSpecDTO$containerID = (Get-NTNXContainer -SearchString "StorageContainer").Id$imagecreatespec.containerId = $containerID.Substring($containerID.IndexOf(":")+2)$diskId = (Get-NTNXVMDisk -Vmid (Get-ntnxvm -SearchString $VMName).vmId -BusType scsi).vmDiskUuid$imagecreatespec.url = "nfs://127.0.0.1/StorageContainer/.acropolis/vmdisk/$diskId"$date = (Get-Date -Format yyyyMMdd)New-NTNXImage -Name "$OperatingSystem-$date-$ImageType" -Annotation $ImageAnnotation -ImageType DISK_IMAGE -ImageImportSpec $imagecreatespecI have been using the above script while I was on AOS 5.15.1.1 and the cloning of a disk took no more than 10 seconds. After upgrading to 5.20.1.1 this process now takes 10mins. Any reason this would have changed betwee
While trying to get the list of vms using the rest api v2 against a Hyper-V configurationThe api return the following error message "Exception while retrieving entities : Hypervisor hyperv not supported" https://www.nutanix.dev/reference/prism_element/v2/api/vms/get-vms-getvmsThere is no mention of api v2 not supporting this, is it meant to be supported? If not how can we get the list of vms from it? Do we need to revert back to V1 api? This one returns the vm list but looking at the v1 v2 documentation the recommendation is to migrate to v2, so would just like some clarification.Also if we need to go back to V1 for hyper-v will any of the endpoints for in api V2 that require a VM_uuid work for a vm hyper-v or not? Since those uuid were returned by the V1 apiFor example:https://www.nutanix.dev/reference/prism_element/v2/api/flr/get-flr-vm-uuid-attached-disks-getattachedflrsnapshotofvmhttps://www.nutanix.dev/reference/prism_element/v2/api/flr/get-flr-vm-uuid-snapshots-getflrsnapshotsof
Foundation 4.6.2 Stuck with this error,Please help. SSD Model:SSDSC2KB960G801
I am new and watching all videos. I try to set up nutanix like proxmox with:3 x Dell R710 Hosts (nutanix installed on usb internal drive)1 x Dell R720 Freenas 20TB storage connected with direct Fiber With proxmox fiber channel setup was a nightmare, so can I use Fiber Channel here with Nutanix? My goal is if one of a host dies I have other VMs be ready | transferred into another host so like in VMWARE (pricy license). Let me know if I can achieve same with Nutanix and direct me towards hardware (Fiber Channel or 10GB ISCSI) whatever is easier and works well.
Hello,I am new to ovs and AHV configurations in general and have a networking question. I have been reading through the documentation on networking and still am not clear on a question or two.Situation: I am mapping out steps to create a DMZ zone for my server environment. My firewall will be configured with a DMZ port and vlan tagged, public IP will NAT to server in DMZ zone, and ACLs will control what traffic can get threw. This will be routed through vlan tagged ports via lay 3 switch to my Nutanix cluster. The server mentioned above will be on my Nutanix cluster and will need to communicate with with 1-4 other Nutanix VMs in the same DMZ/vlan.Questions: If I create a "network" in Prism with vlan tagging and apply it to all DMZ servers in question, will this keep my DMZ traffic separated from all trusted traffic?If not, do I need to configure a new bridge to keep this network traffic separate from my other networks? My concern is because all traffic is being routed to the same trun
How do i enable and update CMSP? i perform LCM inventory, however, it doesn’t detect the MSP and update it. Appreciate if someone can help on this?
Difference between Cluster and I/O latency? Is that same or different?
Digital transformation demands that IT services become more agile, shorten application deployment time and increase scalability. Designed to run any application, Nutanix software converges storage and computation, eliminating the complexity of separate standalone storage solutions. Nutanix Supports VMware vSphere, Microsoft Hyper-V and Nutanix AHV, allowing you to choose the right hypervisor for your needs. Using the advanced storage functionality of Nutanix Volumes, your workloads get all the foundational Nutanix benefits, such as backup and recovery, disaster recovery, snapshots, clones and high performance. Running Oracle on Nutanix offers several advantages. Simplicity You can deploy your database in minutes with Nutanix Era, which means a shorter time to production. Era also simplifies management with a single management pane and one-click life-cycle management (LCM) that includes database patching. With Era, you don’t have to worry about SAN management tasks such as mul
Hello All, When attempting to run any test we receive one error: Prism Error 500 - This happens when it attempts to communicate with node 2 of our Nutanix cluster (we have 3 nodes) or when Deleting images (Kclusterapierror) I’ve checked all the configuration and can pass the validation, so I am unsure what could be the cause of the error. Any advice would be appreciated.
Please provide study notes in PDF format.
Below are new knowledge base articles published on the week of September 12-18, 2021.KB 11887 - Nutanix Files - Slow free space reclamation with SSR or CFT snapshots KB 11934 - Performance benchmarking with CrystalDiskMark on Nutanix KB 12026 - VM power change state fails with error message "unable to map backing store for guest RAM: Cannot allocate memory" on PPC platforms KB 12035 - Foundation - SMCIPMITool times out when DNS entries are unreachable KB 12039 - Prism Central Report CSV ZIP file directory appears as empty KB 12049 - On IBM PowerPC clusters, Prism login screen shows "Server is not reachable" after entering credentials KB 12060 - Add Nutanix Cluster to Rubrik KB 12064 - Scheduled and OOB snapshots for a PD are not createdNote: You may need to log in to the Support Portal to view some of these articles.
Although Prism is user friendly, it will be nice to know some commands that are useful for cluster management. Cluster status The cluster status or “cs | grep -v UP” command gives the status(up or down ) of all the CVMs and their services. Running this command is helpful when there are alerts in the prism about services being down on certain CVMs. Metadata ring The command “nodetool -h0 ring” shows if all the CVMs are a part of the metadata ring. Being in a metadata ring is essential for the CVM to be an active part of the cluster and handle its designated responsibilities. It is essential to run this command after every hardware replacement to make sure the node is back sharing responsibilities of the cluster. Health check Most of the problems in the cluster are easily diagnosed by the health check command “ncc health_checks run_all” At the end of every WARN/INFO/ERR/FAIL plug in we see a KB to further troubleshoot the issue. This check is essential to make sure if the cluster he
Good Day to All!I would like to understand how the resources (CPU, Memory) get allocated while creating Database specific compute profiling through ERA. Does the “DB compute profile” allocate the resources directly from AHV cluster or from ERA VM?
Foundation Central Foundation Central Overview Limitations Foundation Central OverviewFoundation Central can create clusters from factory-imaged nodes and reimage existing nodes that are already registered with Foundation Central, remotely from Prism Central. This provides benefit such as creating cluster on remote sites such as ROBO, without arranging for a deployment personnel visit.LimitationsFoundation Central has the following limitations: Foundation Central supports creation of one node cluster without imaging on factory shipped nodes with AOS and any hypervisor installed. Foundation Central supports creation of one node cluster with imaging only on nodes that are shipped out of factory with DiscoveryOS installed.Note: If you want to create a one or two-node cluster, ensure that the nodes you select support the creation of a one or two-node cluster. Imaging logs of the remote node are not available on Prism Central. These logs are only accessible within the nodes. It does
vDisk migration allows you to change the container of a vDisk. You can migrate vDisks across storage containers while they are attached to the guest VMs without the need to shutdown or delete VMs (live migration). You can either migrate all vDisks attached to a VM or migrate specific vdisks to another container. In a Nutanix solution, you group vDisks into storage containers and attach vDisks to guest VMs. AOS applies storage policies such as replication factor, encryption, compression, deduplication and erasure coding at the storage container level. If you apply a storage policy to a storage container. AOS enables that policy on all the vdisks of the container. If you want to change the policies of the vDisks, create another container with a different policy and move the vDisk to that container. With live migration of vDisks across containers, you can migrate vdisk across containers even if those vdisks are attached to a live VM. Thus, live migration of vDisks across storage container
Hi Allhttps://portal.nutanix.com/page/documents/details?targetId=AHV-Admin-Guide-v5_19:ahv-cluster-nw-vs-about-ahv-c.htmlFollow the link,after the AHV was upgraded to 5.19 or lateer, the br0 of OVS was replaced with vs0,If br1 or br2 can coexist or need to be manually migraded,does anyone have some experience .Thank you
You can configure a VM to boot over the network in a Preboot Execution Environment (PXE). booting over the network is called PXE booting and does not require the use of installation media. When starting up, a PXE-enabled VM communicates with a DHCP server to obtain information about the boot file it requires. Configuring PXE boot for an AHV VM involves performing the following steps: Configuring the VM to boot over the network. Configuring the PXE environment. The procedure for configuring a VM to boot over the network is the same for managed and unmanaged networks. A VM that is configured to use PXE boots over the network on subsequent restarts until the boot order of the VM is changed. To configure a PXE environment for a VM on a managed network on an AHV host, do the following: Log on to the Prism web console, click the gear icon, and then click Network configuration in the menu. The Network dialog box is displayed. On the Virtual Networks tab, click the pencil icon shown for
I have been trying to chase down and eliminate this error for a while now. The cvm leader only wants to use itself as the time source - when I run this command (allssh ntpq -pn) it shows remote refid st t when poll reach delay offset jitter==============================================================================x.x.x.x y.y.y.y 2 u 603 1024 377 0.337 55090.5 419.722x.x.x.x 184.105.182.16 3 u 200 1024 4 0.358 75064.8 0.000*127.127.1.0 .LOCL. 10 l 587 1024 377 0.000 0.000 0.000 (The asterisk indicates that it is using itself as a time source, is that correct?) I can run ntpdate successfully to the configured ntp servers and the cvm can connect to them. (I can even run ntpdate to an external time server that is not configured for that matter) How do I get the cvm leader to use the configured ntp servers as the source (and not use itself)?
Collector 3.5.1, Windows version. The customer has collected the data from a 2-node Hyper-V cluster and I can open the excel and browse through it - it looks right to me, I see all the VMs etc. When I try and import into sizer, I get “Some unknown error occurred”. Any ideas? There’s nothing particularly strange or unusual in the data that I can think of. In the meantime I will probably try and manually add the equivalent workload. Thanks, Allan.
Hi All, After installing NGT in a win server 2019 image, NCC reported that: Client certificates for VM *** with uuid ***-**-**-**-*** are expiring in -18883 days and need to be regenerated.Upon Certificate expiry, the CVM-Guest VM communication will be broken.(i have removed uuid and vm name from texts for quick reading) And after i follow the instructions in KB3868 i run this command from a CVM "ncli ngt list" i found that some of the VMs have a communication problem:VM Id : xxxxxxxx::xxxxxx VM Name : yyyyyyyy NGT Enabled : true Tools ISO Mounted : true Vss Snapshot : true File Level Restore : false Communication Link Active : falseThen checking inside on the Win server 2019 VM i can seee that the NGT python processes are running but the are errors on C:\Program Files\Nutanix\logs\guest_agent_service.INFO ERROR C:\Program Files\Nutanix\python\bin\guest_agent_service.py:497 kNotAuthor
Hi,I followed this guide:Installing Nutanix Community Edition (CE) on vSphere 7 - Derek Seaman's IT BlogTo test a install of AHV/Prism CE and the AHV host installs fine but the CVM can not get to the outside world or ping ip’s.I can ssh to the CVM from the host on the correct IP and do the one_node_cluster create command but it just fails with `Failed to reach a node where Genesis is up` if I do `genesis start` it gets past that but just hangs after it starts up some services during the create.I tried not checking the one_node_cluster option in the install and doing it manually afterwards, but I get the same results.Happy to provide any info. The gateway etc look fine in the `/etc/sysconfig/network-scripts/ifcfg-eth0` file
Below are new knowledge base articles published on the week of September 5-11, 2021.KB 10355 - NCC Health Check: nvme_raid_check KB 11923 - False positive anomaly events on PC KB 11998 - Enabling LCM auto-inventory feature via CLI fails via admin user KB 12009 - NCLI command "ncli pd ls-snaps" displays zero size for snapshots when Application Consistent Snapshot is enabled KB 12019 - Prism Central - Storage Container Runway may incorrectly report containers with 0 usage as running out of space in 0 days KB 12024 - NCC 4.2: False Positive Alert :GPU in the slot [PCI Slot) was removed/missingNote: You may need to log in to the Support Portal to view some of these articles.
We are running an image from HPE Aruba for a Mobility Master that crashes daily. The error is an IRQ interrupt:User: [14730.377720] irq 27: nobody cared (try booting with the "irqpoll" option) [14730.378230] handlers: [14730.378461] [<ffffffff813be5d0>] vring_interrupt [14730.378717] Disbling IRQ #27I’ve been directed by the community that there is a KVM fix for this by changing the machine type to Q35. I can see in the acli documentation there are settings for machine type but I can’t seem to find a list of acceptable settings that I could use there. I was hoping to perhaps create a VM through the acli with this already set or perhaps update a VM (is this bad?)Perhaps it would look something like this:acli vm.update machine_type="pc-q35"
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.