Question

ESXi 6.7u3 Patch - 1-click upgrade - Not compatible with current VIBs

  • 10 May 2020
  • 6 replies
  • 1232 views

I ugraded my ESXi hosts using 1-click upgrade to VMware-VMvisor-Installer-6.7.0.update03-15160138.x86_64-DellEMC_Customized-A04 with no issues. Trying to apply patch ESXi670-202004002.zip using 1-click upgrade and get the following error:

Upgrade bundle is not compatible with current VIBs installed in hypervisor. [DependencyError] VIB QLC_bootbank_qedi_2.10.19.0-1OEM.670.0.0.8169922 requires qedentv_ver = X.11.15.0, but the requirement cannot be satisfied within the ImageProfile.

I am able to successfully patch using esxcli and update manager. 

I updated the image profile to DellEMC-ESXi-6.7U3-15160138-A04 on the hosts thinking that may resolve the issue but this did not work.

Anyone have any suggestions to get 1-click upgrade to function with 6.7u3? 


6 replies

I get the same message on a lenovo cluster.

Even “esxcli software sources profile list -d <path>” birngs an error..

Badge

I have the same problem with 6.7.0-14320388 and prism 5.15 LTS. 

 

“Upgrade bundle is not compatible with current VIBs installed in hypervisor. [DependencyError] VIB QLC_bootbank_scsi-qedil_1.2.13.0-1OEM.600.0.0.2494585 requires qedentv_ver = X.9.31.0, but the requirement cannot be satisfied within the ImageProfile. VIB QLC_bootbank_qedrntv_3.9.31.1-1OEM.670.0.0.8169922 requires qedentv_ver = X.9.31.0, but the requirement cannot be satisfied within the ImageProfile.”

Userlevel 2
Badge +1

@BGR2020 @JESUS19 @kloppo, It seems like you are hitting this error. Feel free to check out KB-4878 for further details: https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA00e000000XeNdCAK

@BGR2020 @JESUS19 @kloppo, It seems like you are hitting this error. Feel free to check out KB-4878 for further details: https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA00e000000XeNdCAK

Hi Nashma,

thanks for your reply. It looks similar but unfortunetelly it is not exactly the same. In my case there are some QLogic VIBs affected, support sent me back to my hardware vendor to fix the issue. Unfortunatelly the last qualified lenovo product patch build is from 11/2019.

I’m still in touch with lenovo to get the cluster on an actual release as a security patch gap from half a year is not possible.

If you got any other idea please let me know :)

thanks a lot!

Same here with pre-upgrade check for ESXi670-202004002.zip

VMware ESXi, 6.7.0, 14320388 (Lenovo ISO)

5.15 LTS

VIB QLC_bootbank_qedf_1.3.35.0-1OEM.600.0.0.2768847 requires qedentv_ver = X.11.6.0, but the requirement cannot be satisfied within the ImageProfile.

 

Badge

@BGR2020 @JESUS19 @kloppo, It seems like you are hitting this error. Feel free to check out KB-4878 for further details: https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA00e000000XeNdCAK


Thank you, I resolved the issue on follow this Article https://portal.nutanix.com/page/documents/kbs/details/?targetId=kA00e000000XeNdCAK

Reply