Question

vSphere and Nutanix upgrade

  • 4 January 2019
  • 4 replies
  • 2210 views

Badge
purchased 7/15/2016
setup/install 10/24/2016 (by Nutanix tech)
office move 4/1/2017 (late april, power outage in San Francisco financial district, was on bus on way to work when power went out, never got to shutdown Nutanix cluster properly, next morning powered up cluster and ran fine. Awesome! no issues since then)

hardware:
2 NX-8235-G5
1 NX-8135-G5
NOS: 4.7.2
NCC: 2.3.0
BIOS: 20160516
BMC: 03.28

hypervisor:
VMware vCenter Server 5.5 Update 2e
(vSphere on Windows Server 2008 R2)


I need to upgrade vSphere from 5.5 U2e to whatever latest version of 6.5 and also Nutanix NOS 4.7.2 to 5.5.8
Do I:
1 - upgrade VMware to 6.5 then upgrade Nutanix to 5.5.8
or
2 - upgrade Nutanix to 5.5.8 then upgrade VMware to 6.5
or
3 - upgrade VMware to compatible intermediate version and then upgrade Nutanix to compatible intermediate version. upgrade VMware to 6.5 and then upgrade Nutanix to 5.5.8
or
4 - upgrade Nutanix to compatible intermediate version and then upgrade VMware to compatible intermediate version. then upgrade Nutanix to 5.5.8 and then upgrade VMware to 6.5

note: at time of Nutanix setup 10/24/2016, I was a part-time contractor. as of 4/1/2018, I'm only contracted for 40 hours of remote-only work, but work onsite when needed for special projects.

4 replies

Userlevel 4
Badge +5

Hello @mars_seven  

This post might help you to plan your upgrade sequence effortlessly. 

https://next.nutanix.com/prism-infrastructure-management-26/all-things-considered-upgrade-sequence-and-preaparation-guidelines-33524#post44161

Userlevel 3
Badge +3

@mars_seven  I agree that the link provided above is a must read for you, especially if you have Prism central in your environmnet. Make sure you read it before you do anything so it gives you some idea as what is involved in the process.

 

I say upgrade your ncc first and run health checks to see what it complains about. The info you get form ncc might actually be very helpful in taking a path to your target.

 

But I also checked the info you provided and your targets against our compatibility matrix page:

https://portal.nutanix.com/#/page/compatibilitymatrix

and upgrade path page:

https://portal.nutanix.com/#/page/upgradePaths

It seems both your target AOS 5.8 and your present AOS 4.7.2 are compatible with “ESXi 6.0 U1B”  so I would say that would be an intermediate step for hypervisor upgrade, but to do so you need to upgrade your vSphere to a release compatible with that release of ESXi, which usually a vcenter release higher or the same level.  In upgrading the vsphere, you may or may not have to upgrade the OS it runs on to a higher level, you need to check this with vmware documentation.

 

Once the hyperviosr upgrade is done, you can go directly from AOS 4.7.2 to 5.5.8 based on info in the upgrade path link in the above.

After that you can actually upgrade your vsphere to ESXi 6.5 U2 as a target, i you still want so.

 

In the above I assumed you are not having Prism Central, if you do, you need to upgrade that to a version compatible with your target AOS first. Check the upgrade path for PC in the above link I provided.

After each upgrade step be it AOS or Hyperviosr, you must run ncc to make sure all is OK and address all reported issues before you move on.

 

As for your BIOS and BMC, the later releases of NCC would tell you if you need to upgrade them as well before you move on to the next component upgrade.

 

Hope the above is not too confusing, let me kow if you have any questions or concerns about it.

 

 

 

 

Badge

Original posting was January 4, 2019. Frustrated no response. Ended up opening support ticket February 4, 2019. Able to upgrade to AOS 5.5.0.6 by February 19, 2019 (some issues such as zoopkeeper). Wasn’t able to do planned vSphere 5.5 to VCSA 6.5 due to some certificate issue and VMware update manager (no support since 5.5 support ended September 2018). I’ve done some maintenance on cluster and currently at Acropolis: 5.5.0.6, NCC: 3.7.0.2, BiosVersion: G4G5T4.0, BMC Version: 3.63, and Foundation: 4.3.2-c19150a6. I’ll eventually upgrade the windows vSphere 5.5 server to vSphere 6.0 and then do the VCSA 6.5 migration. currently swamped right now migrating 20 users to Windows 10 (7 years ago (2 layoffs and 3 office moves) had migrated 50 users from white-box Windows 7 to HP Windows 7).

 

(kind of annoyed got a response to my original post 10 months later.)

Userlevel 3
Badge +3

@mars_seven Sorry you never had a response to your query when you needed it. We are pretty new with the next community ourselves and trying to provide more input so folks like yourself get faster response to their queries hopefully. Your posting question in here may not have helped you but hopefully somebody else can pick a thing or two from it. Feel free to get back to us if you have questions, we do our best to respond or at least refer you to support if things are more detailed than can be answered by postings.

Reply