Question

Node expansion on a cluster

  • 21 August 2022
  • 3 replies
  • 354 views

hi community,

we want to expand the cluster by adding additional node, the server model is HPE ProLiant DX360 , currently 4 nodes are running and we want to add one node of same hardware model. the hardware is factory AOS imaged. AHV is the hypervisor on current cluster.

we want to know what are the physical network connectivity is required to add the node and image AHV.

on new node IPMI is connected and two 10g are connected , but we are unable to discover the node from prism element. 

is it required to connect the node port 1g as well to the switch for imaging?


3 replies

Userlevel 3
Badge +5

check the below link:

https://portal.nutanix.com/page/documents/details?targetId=Field-Installation-Guide-v5_3:fie-cluster-environment-foundation-network-setup-t.html

We expanding Nutanix cluster by adding 2 node (same model as existing cluster nodes - HP ProLiant DX360), while doing expansion one node is auto discovered and added to our cluster. But another new Nutanix node unable to discover automatically and manually. The IPMI connections of server’s enabled with L2 switch with our network there is IPv6 specifically enabled in our network devices.

If IPv6 requirement for auto discover 1st node should not auto discovered, checking with Nutanix support team.

Userlevel 4
Badge +5

Hi @Sanal, is the new node connected the same way as the other production nodes and are you using LCAP?

If discovery is not working (ipv6 issues) or LACP is configured on the switch ports I always re-foundation the new node with the same versions as the cluster. During foundation make sure you set the correct ip address for AHV and CVM and make sure LACP is configured (as needed). Also make sure the automatic cluster creation is not selected. When foundation is ready you can expand the cluster manually by entering the CVM ip.  

 

Reply