Solved

How to change GPU mode on AHV Cluster

  • 10 August 2020
  • 2 replies
  • 365 views

Badge

I have a Nutanix Node - Dell XC740xd with 4 Tesla T4 GPUs installed.  I am Running AOS 5.15.  

It seems my GPU is in passthrough mode, and I would like to switch this to vGPU mode.  Does anyone know how to do this?

 

             "status": "UNUSED",
              "assignable": true,
              "vendor": "NVIDIA",
              "name": "Tesla T4 compute",
              "index": 0,
              "max_resolution": "None",
              "num_vgpus_allocated": 0,
              "pci_address": "0000:86:00.0",
              "fraction": 0,
              "mode": "PASSTHROUGH_COMPUTE",
              "num_virtual_display_heads": 0,
              "guest_driver_version": "None",
              "frame_buffer_size_mib": 16384,
              "device_id": 7864

icon

Best answer by Alona 11 August 2020, 07:31

Hi GeoB,

Have you seen this guide? It goes over limitations, driver installation and configuration.

Let me know if you need more info.

View original

This topic has been closed for comments

2 replies

Userlevel 5
Badge +5

Hi GeoB,

Have you seen this guide? It goes over limitations, driver installation and configuration.

Let me know if you need more info.

Userlevel 2
Badge +3

Have you used the gpumodeswitch command? 

Although you have T4’s our GPUs needed this as they initially shipped in Compute Mode and the newer ones came in Graphics Mode.

Get the gpumodeswitch package and give it a try and let us know...