Solved

Detected older AHV Version


Badge +1
I'm running 3 node cluster, based on 5.10 version (2019-02-11)
There are some alerts for each node:
  • Detected Incompatible AHV Version
  • Detected older AHV Version
I've checked the Settings-Upgrade menu - there it nothing available to upgrade for AHV and AOS.
icon

Best answer by DenisK 19 March 2019, 16:04

Hi
Did you try this:
https://next.nutanix.com/installation-configuration-23/incompatible-ahv-version-after-upgrade-to-20180501-28193

Thank you for the link.
I've checked it. It tells me "version_id": "el6.nutanix.20170830.185"
Now it seems to me that it is just a minor issue - the version just wasn't updated in file.
Hope it is harmless
View original

11 replies

Hi
Did you try this:
https://next.nutanix.com/installation-configuration-23/incompatible-ahv-version-after-upgrade-to-20180501-28193
Badge +1
Hi
Did you try this:
https://next.nutanix.com/installation-configuration-23/incompatible-ahv-version-after-upgrade-to-20180501-28193

Thank you for the link.
I've checked it. It tells me "version_id": "el6.nutanix.20170830.185"
Now it seems to me that it is just a minor issue - the version just wasn't updated in file.
Hope it is harmless
Badge
I'm running 3 node cluster, based on 5.10 version (2019-02-11)
There are some alerts for each node:
  • Detected Incompatible AHV Version
  • Detected older AHV Version
I've checked the Settings-Upgrade menu - there it nothing available to upgrade for AHV and AOS.



For those of you on CE-2019.02.11-stable this error seems to have come back again.

nope@:xxx.xxx.xxx.6:~$ ncc health_checks hypervisor_checks ahv_version_check
----some results truncated----
Detailed information for ahv_version_check:
Node xxx.xxx.xxx.4:
WARN: AHV host xxx.xxx.xxx.1 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Node xxx.xxx.xxx.5:
WARN: AHV host xxx.xxx.xxx.2 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Node xxx.xxx.xxx.6:
WARN: AHV host xxx.xxx.xxx.3 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Refer to KB 5286 (http://portal.nutanix.com/kb/5286) for details on ahv_version_check or Recheck with: ncc health_checks hypervisor_checks ahv_version_check --cvm_list=xxx.xxx.xxx.4,xxx.xxx.xxx.5,xxx.xxx.xxx.6
I am also getting this with ce-2019.02.11-stable

AHV host 10.1.22.22 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version

Looks like the check is wrong.
Badge +1
I am also getting this with ce-2019.02.11-stable

AHV host 10.1.22.22 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version

Looks like the check is wrong.

Absolutely!
Badge +1
I'm getting these false positive alerts too, is there a way to tweak the check code?
Badge +3
Hi, I have the same issue
WARN: AHV host 172.16.10.99 currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Refer to KB 5286 (http://portal.nutanix.com/kb/5286) for details on ahv_version_check or Recheck with: ncc health_checks hypervisor_checks ahv_version_check --cvm_list=172.16.10.100
Badge +4
Same issue here, new installation of 2019.02.11 CE, ncc_version: 3.7.1.2-f718d84b

Detailed information for ahv_version_check:
Node x.x.x.x:
WARN: AHV host x.x.x.x currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Node x.x.x.x:
WARN: AHV host x.x.x.x currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Node x.x.x.x:
WARN: AHV host x.x.x.x currently is installed with 20190211.279, it should be installed with 20170830.185 or a compatible version
Refer to KB 5286 (http://portal.nutanix.com/kb/5286) for details on ahv_version_check or Recheck with: ncc health_checks hypervisor_checks ahv_version_check --cvm_list= x.x.x.x, x.x.x.x, x.x.x.x

Any ideas how to fix it?
Userlevel 1
Badge +1
Any update?
Badge
Hi, I hate to bump an old thread - but this is still the case with the 20190211 CE version. This check still complains about the version being too old, despite AHV 20190211.279 being installed.

Do i just live with this warning?
Badge +1

Bump, Yes same here. 20190211 CE version running AHV 20190211.279 .  Wonder if there is a cfg file somewhere to edit...

Reply