Question

Attempting to upload AOS binary/json always results in "Server Error"

  • 19 March 2019
  • 8 replies
  • 8088 views

Hi all,

We are attempting to update our AOS offline (all of our clusters do not have internet access) and we have tried uploading via IE, FF and Chrome to no avail.

IE "uploads forever" and Chrome and Firefox say "Server Error" everytime.

We are way past due for an AOS update (5.1.0.3) and we are trying to get this done!

I have a few other side questions as well --

Is the AOS upgrade process non-disruptive?
  • I saw the KB about updating the AOS and it says the CVMs will reboot, but other than that it should be seamless, correct?
We need to update our hypervisor (ESXi 5.5 Patch 10) and need some input there as well if possible here, since we are on a Nutanix node config and posting here seems like the right place. If not, please let me know!

  • We are running a NX-1065-G4
  • ESXi 5.5 Patch 10
  • vCenter 6.0
  • AOS 5.1.0.3
  • NCC 3.1.3
  • Foundation 3.7.2
  • BIOS 2141203
  • BMC 01.92
  • LCM 1.0.e1416e5
  • HBA MPTFW-10.00.07.00-IT
Any input on the order of operations to get "up-to-date" on the above would be greatly appreciated.

We read the upgrade paths documents, but it seems to link a link to another link to another link....

Argh!

8 replies

Userlevel 7
Badge +26
So this is a forum for the Community Edition release which is only AHV. Now the cvm is shared technology so whatever is causing the issue with the upload is probably universal, but don't you have a support contact?

I would check that the satadom isn't full of junk though in case it is just out if space.
Oops, appears I posted in the wrong section!

Thanks for the tip, I'll open a support ticket...

Any chance my topic can be moved by a moderator?
Userlevel 5
Badge +15
@EUSCADA I think @aluciani can move this topic to the correct forum.
Sorry to post again in here being it is in the wrong place, but all 3 of our clusters are experiencing this "Server Error" message when attempting to upload the AOS update files.

Could there be something else to look at?

I can see (via vCenter) the Sata doms appear to have plenty of room to upload the packages.
Userlevel 3
Badge +5
Hi @EUSCADA,

First of all, the files uploaded through the Prism will be stored on CVM, which uses SSD/HDD and not in SATADOM. The SATADOM only host the hypervisor installation and CVM virtual machine configuration files.

About your question regarding upgrades, either the AOS or hypervisor upgrades are non-disruptive, since the Nutanix 1-Click Upgrade feature will make sure only I single CVM and/or host will be upgrade at time and that remaining CVM/hosts will be available to run your VMs.

Regarding the error to upload the AOS binary and json file, can you please let me know which AOS version you are trying yo upload and also the exact size of the JSON file?

Last but not least, if your cluster have active contract support, do not hesitate in open a support ticket and we will be happy to help you.
Hello again,

Turns out the services on the cluster needed to be restarted prior to uploading the AOS files.

All 3 clusters have been updated.

Thanks again for all the input.
Hi,
This answer might be a bit late but might still be helpful to others.
I setup Nutanix few months back, I'm having error message and weird stuff going on.
Solution was to make sure IPMI's interface are all the same on each node, in a Host PC where you upload the files, ensure security settings for Java are allowed to upload such and such, ensure firewall is off if you're using Windows. Once all these basics are covered, Nutanix installation and update should be Sweet n Simple.
To add to my previous post, support people from Nutanix are amazing, they will drill down to OS' backend to find the error, the won't stop until they fix your issue. Reach out to them.

Reply