jMeter On Nutanix

  • 11 December 2015
  • 15 replies
  • 1887 views

Badge +4
Hello friends, I am new here nice to meet you and I hope you can help me.I am working with two Scenarios in my client. One we have Nutanix on its Linux KVM-based hypervisor and the other we have common x86 servers running VMware.The objetive is compare both solutions and decide what's best. (we want Nutanix to the best of course!)The application running on both of them is a jBOSS system, on 3 virtual machines. (application, DB and one apache front end.)I created a recording test using jmeter, where the user makes a lot of steps in the web interface (for instance, search for a specific person, click on the menu, etc). The test runs fine on the x86 server and VMware, but on the Nutanix, after 150 users, I always get: Started: 0 Finished: 0. And also the CPU Usage is higher than the other scenario. Almost the double.I added more CPU and RAM to the virtual machine, but it didn't work. I am also running on non-GUI mode, removed the listeners, added more memory to the "MaxNewSize", but nothing seems to work.Can you tell me if there is anything else I could do to solve this issue?Thanks in advance,

15 replies

Userlevel 7
Badge +30
Are you running this on "paid" Nutanix (Like NX, XC, or HX series platforms)? or Nutanix Community Edition?

If this is a paid platform, please submit a support ticket, and we can get our solutions and performance team engaged for you. That is our center of excellence for apps like these, and they can help debug what's going wrong in detail, so that you dont have to do any guessing. We can run A|B testing with performance tracing, and find out exactly where the bottleneck is. After that, we can happily post the details of that case here for others to follow.

If this is Nutanix community edition, let us know and we can dive in.
Badge +4
Hey Jon, thank you so much for replying.

I am using a paid platform. Running a NX-3050 on my client and trying to compare the two solutions so they buy Nutanix :)

I'll open a case then, thanks!
Userlevel 7
Badge +30
- happy to help.

One thought, and I'm sure you'll get asked this, NX-3050 is a bit older of a model, usually running Sandy Bridge (Intel E5 v1) or Ivy Bridge (Intel E5 v2).

We'll want to make sure we're apples to apples (same) between the commodity servers, similar compute specs, storage hardware specs, and so on.
Badge +4
hey , sorry but I couldn't get the support from the team, could anyone help me here with ideas on the issue?

Thanks,
Userlevel 7
Badge +30
Did you submit a support ticket? If so, what is the ticket number?
Badge +4
The support is still being renewed, so the support team said they can't help me in any way until that is done.

Can you help me here then?
Userlevel 7
Badge +30
Can you post exact specifications of the infrastructure you are using for both tests?

Also, post exact specifications for the guest VM's you are running, including OS and application versions?

The more information the better.

I pinged a few people internally to see how they might be able to help, but we definitely need more information.
Badge +2
Hi Pedro,

If you could please let us know the answers to the questions that Jon asked and also the version of AHV and NOS that you have running on the cluster. In an apples for apples comparison there should not be much difference between them in terms of performance.

Kind regards,

Michael
Badge +3
Pedro, Happy to help.

are the VM's same config on both the platforms, can you share some details on vCPU/Mem/Storage config for each VM (Web, App, DB)

you mentioned the high CPU utilization, what tool are you using and was it a particular VM having high CPU utilization ?

Couple of things to check
1. Check/validate if the VMs are running on different nodes in the Nutanix cluster
2. Verify during the peak load that database didnt run into any out of space issue, deadlocks, blocking sessions
3. If you can run "RVTools" on the Nutanix environment and upload/paste the VM config tab that would be helpful
Userlevel 4
Badge +19
Also Pedro, are you using Linux or Windows Guest Operating system and which versions etc?
Badge +4
Nutanix informationNX3050 - 4 Nodes 1 BlockNOS 4.1.3NCC 2.0.0AHV 20150503Cluster capacity: 166 GHz, 1TB RAM, 15TB diskOn both environments, we have the same configuration of VMs:3 Virtual machinesApplicationDebian Linux 7.8 Wheezy2 vCPU 4 cores each (8 cores total)8GB memory10GB DiskjBOSS 5DatabaseDebian Linux 7.8 Wheezy2 vCPU 4 cores each (8 cores total)4GB memory20GB DiskPostgres 9.2 DatabaseApache Front-end (not crucial)Debian Linux 7.8 Wheezy2 vCPU 2 cores each (4 cores total)4GB memory10GB DiskjBOSS 5I am still getting more information about the other environment, what I know so far:Cisco UCS and Dell poweredge serversVMware 5.5Running tests with jmeter on Nutanix I found out that, after 200 simulated users, the test causes the application to be not available, and stays like this until almost the end of the test. It doesn't generate IOPS too. I suppose it is because the application stops or gets too slow during the test, but I am not sure.

- The VM with high CPU usage was the application VM.- I am using the tool Apache jMeter 2.13 to run the tests (recording test in this case).- The VMs are indeed running on different nodes (Front end and application are in one node and database is in another node)Still trying to get RVtools to work. Will post the info as soon as I can.
Userlevel 7
Badge +30
At minimum, we'll want to upgrade your cluster to both the latest NOS and latest AHV builds, and retest.

We'll also want to get exact specifications on the Cisco/Dell gear you are running comparison tests on.

After you upgrade to the latest NOS and AHV builds, there are some performance tracing scripts that you can run while you do your tests, which will capture everything going on inside the system.
Badge +4
Okay, I will perform the upgrade. Can you tell me the performance tracing scripts I need to run?

Also, any recomendations on the upgrade? From 4.1.3 to 4.5.1.2

Thanks
Userlevel 7
Badge +30
Yes, please upgrade to the latest NOS first (4.5.1.2), then do the AHV upgrade

Also, I'm assuming you've got partner access to the KB, take a look at this article about performance traces

https://portal.nutanix.com/#/page/kbs/details?targetId=kA0600000008hQVCAY
Badge +3
thanks for the details , from the description of the issue and your current setup you indicate the IOPS drops to zero, i suspect you are running out of memory on the JVM for your JBoss instance and your garbage collection is consuming all the cpu on the App tier VM.
Can you check the Jboss logs and the size of JVM when the issue happens.

Reply