Solved

Cluster Check: Powering on VMs failed

  • 4 June 2019
  • 1 reply
  • 375 views

Hi there,

I'm trying to use X-RAY for our purpose and I faced an error without more logs/messages than: "A timeout occurred waiting for VM(s) in VM Group 'Cluster Check' to become responsive within 120 seconds."

I configured both vNIC of the X-RAY VM:
  1. eth0: for communication with the API
  2. eth1: for communication with VMs workload
eth1 is configured with a specific subnet (I didn't find too much documentation for zero configuration).
On my Nutanix cluster, I added this specific network and let it to give addresses to VMs deployed by X-RAY (98 IPs available in this subnet)

During the cluster check, 4 VMs are deployed, powered up and IPs are assigned. The X-RAY VM can communicate with these 4 VMs.

The problem is for the last one, the 5th VM doesn't start and the cluster check fail.



Do you have any idea? Is there some more details in a specific logs?

Thanks for your help
Cheers,

Rémi
icon

Best answer by G3S 5 June 2019, 16:51

After investigation, it seems the DHCP server is not able to deliver an IP address to the last VM.

I deleted the vNIC of the failed VM and after re-created the vNIC on the same network, the DHCP server allocated an IP address and the VM is nos reachable.

I close my ticket as this is not an error of X-RAY
View original

1 reply

After investigation, it seems the DHCP server is not able to deliver an IP address to the last VM.

I deleted the vNIC of the failed VM and after re-created the vNIC on the same network, the DHCP server allocated an IP address and the VM is nos reachable.

I close my ticket as this is not an error of X-RAY

Reply