Question

vServer LACP Issue

  • 10 January 2020
  • 1 reply
  • 2158 views

Hi there,

       I’m a network guy and this is my first time post here. Sorry if I broke any forum rule. We are having some issue with vServer host on Nutanix, and I would like to see if any experts here can tell the solution of the problem from nutanix stand-point. We have nutanix setup as LACP and connects to two nexus switches(5000) by using virtual port-channel. Sometimes mac address of vServer showed incomplete on arp table in one of the switches, not only one vServer. Then we finally realized that if we shutdown one port of the switch, which mac address incomplete in arp table, the vServer started to work immediately. After we executed no shut, the issue was back again. We checked the issue from switch stand-point, but couldn’t find any issue. Is anyone know the issue can be related to Nutanix? Thank you.


1 reply

Userlevel 2
Badge +3

Hello,

Have you tried adjusting any of the LACP parameters (ie timeout)?

We are planning on doing this so anything I say take it with a grain of salt.  It is all from reading and not from doing at this point.  We will be implementing this later this month.

I know there is an option to set auto-fallback to active/backup | active/passive within the Balance-tcp setup should any problems occur ("ovs-vsctl set port br0-up other_config:lacp-fallback-ab=true").  Also you might have to adjust the timing ("ovs-vsctl set port br0-up other_config:lacp-time=fast").  Confirmation of the LACP should be able to be achieved ("ovs-appctl bond/show br0-up" and "ovs-appctl lacp/show br0-up").

A couple of good resources are:

  • AHV Networking Best Practices #2071
  • KB 3263 How to Enable, Disable, and Verify LACP

Other suggestions include those offered by this poster:

https://next.nutanix.com/installation-configuration-23/ahv-lacp-bonding-or-link-aggregation-33536

 

hth

 

Reply