Solved

Install NGT on VM template before Sysprep?


Badge +6
Is it ok to install Nutanix Guest Tools in a guest vm template before the template is Sysprepped?

I need to deploy a bunch of Server 2008 r2 VMs that will need NGT. I'm aware that it's easy to automate NGT install AFTER vm deployment and I do that for most cases; however on Server 2008 r2 builds there's a techinical limitation that prevents this from working.

So I'm wondering if there is anything in NGT that will break if the vm is Sysprepped afterward.

icon

Best answer by Bensation 16 February 2017, 21:46

Hi JBPrado

Yes, you can follow portal documentation https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v50:man-nutanix-guest-tool-enable-multiple-vms-t.html. In this method you add NGT to the base image then confirm you have connectivity from the guest to cluster VIP. Once connectivity is confirmed use that VM as your base image. On each clone of the base VM run the following command to link the new clone to NGT:
ncli> ncli ngt mount vm-id=clone_vm_id
The vm-id can be found in `ncli vm ls`. This will establish the communication link between the cluster VIP to the guest's NGT agent. Also note in AOS 5.0 we added NGT silent installer which lets you enable NGT a lot easier on multiple guests without clicking through the installer. Documentation can be found at https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v50:man-nutanix-guest-tool-windows-silent-install-t.html.

What issue are you seeing on the deploying NGT in Win2k8 R2 VMs post install?

-Ben


View original

4 replies

Userlevel 2
Badge +9
Hi JBPrado

Yes, you can follow portal documentation https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v50:man-nutanix-guest-tool-enable-multiple-vms-t.html. In this method you add NGT to the base image then confirm you have connectivity from the guest to cluster VIP. Once connectivity is confirmed use that VM as your base image. On each clone of the base VM run the following command to link the new clone to NGT:
ncli> ncli ngt mount vm-id=clone_vm_id
The vm-id can be found in `ncli vm ls`. This will establish the communication link between the cluster VIP to the guest's NGT agent. Also note in AOS 5.0 we added NGT silent installer which lets you enable NGT a lot easier on multiple guests without clicking through the installer. Documentation can be found at https://portal.nutanix.com/#/page/docs/details?targetId=Web-Console-Guide-Prism-v50:man-nutanix-guest-tool-windows-silent-install-t.html.

What issue are you seeing on the deploying NGT in Win2k8 R2 VMs post install?

-Ben


Badge +6
Hey, Bensation (Sweet handle)

EDIT: Sorry, I've completely rewritten this post because that procedure you linked me to might solve my problem. At first I thought it was just telling me to mount the CD AFTER cloning and install NGT AFTER cloning but after rereading a couple of times it looks like an install BEFORE cloning and sort of a reinstall after cloning. This might work for me.

My problem, and I've opened a support case for this, is that for Server 2008 r2 VMs the NGT installer looks for KB3033929 as a prerequisite. That KB patch has long been superseded, so any updated servers will refuse to install KB3033929 and NGT will refuse to install.

I was hoping that I could build a new template, patch it with KB3033929 so that NGT will install, then do the rest of the patches and sysprep.


Userlevel 2
Badge +9
JBPrado happy to help. I just edited my post as well to include to use the NGT installed VM as your base image to clone from. Prior it wasn't as too clear.

Also kb 3700 (https://portal.nutanix.com/#/page/kbs/details?targetId=kA032000000TV6ACAW) how to install a modified VMmobility .msi that bypasses the SHA2 check. After if that .msi is installed prior to running NGT you should not receive an error.

-Ben
Badge +6
Perfect, thank you!

Yes, I just received that same link from Support 🙂 I think both my problems are now solved.

BTW I'd done multiple searches using the keywords 'Nutanix guest tools' and 'server 2008' and didn't find that article. But I realize now that if I'd included 'sha-2' i would've found it.

Thanks again for your quick help.

Reply