How do you get your protected vms to power on when you migrate an Asnch DR Protection domain?

  • 1 May 2015
  • 2 replies
  • 3406 views

Badge +10
I have running vms in a consistency group within an asynch DR Protection domain. The snapshots are replicating locally and to a remote sign fine. When I manually migrate the Protection Domain to the remote site the vms are coming online fine at the target site, but they are not automatically powering on? I have to right click on them and manually power them on. Is this normal or should the migrate feature power them on, assuming they were online at the original location?

Regards,
Erik

2 replies

Userlevel 2
Badge +15
Hi Erik, I would recommend opening a support ticket for this issue. I believe that it should be powering that VM on at the remote site. If it is not we should file a bug to get that resolved, which support can do.

Thanks for being a Nutanix customer.

Tony
Userlevel 4
Badge +18
From NOS 4.0.3 and 4.1.1 there is a change of behaviour wherein, for DR workflows and PD operations the VMs will not be automatically powered on.

This was basically done because in a dvSwitch configurations, If you have a protection domain / remote site that contains VM's which are on a distributed switch and perform a migration the VM powers on properly but has no network connectivity. This is due to a vmware limitation with "static" port binding on the port group.The error that gets thrown when you try to reconnect the NIC is:Invalid configuration for device '0'.
Hence the change.


-Navpreet

Reply