Solved

Xtract for VM


Badge +1
Hi all, I am having an issue with Xtract for VM. When I start a migration plan, it stays in "Queued for Migration" and then times out after an hour. No progress at all. This is Xtract 1.1.7 which is the latest. The VM I am testing with are Windows 10 and Windows 7
icon

Best answer by Ankush Gera 16 October 2018, 08:42

Hello Randy,

I would suggest to verify if the xtract VM is part of the AHV Whitelist. If not, add the xtract VM IP in whitelist and retry again.

And also you can follow below xtract troubleshooting guide as an initial step to verify setup and configurations are correct.

https://portal.nutanix.com/#/page/docs/details?targetId=Xtract-for-VMs-v11:v11-xtract-troublehshoot-t.html

Hope this will help you out and if you still face any issues, I would recommend to open support case and someone from SRE team will assist you further.

Regards,
Ankush

View original

3 replies

Hello Randy,

I would suggest to verify if the xtract VM is part of the AHV Whitelist. If not, add the xtract VM IP in whitelist and retry again.

And also you can follow below xtract troubleshooting guide as an initial step to verify setup and configurations are correct.

https://portal.nutanix.com/#/page/docs/details?targetId=Xtract-for-VMs-v11:v11-xtract-troublehshoot-t.html

Hope this will help you out and if you still face any issues, I would recommend to open support case and someone from SRE team will assist you further.

Regards,
Ankush
Same Issue for me. With Xtract < 1.1.7 everything worked as expected.

According to the Logs it seems as if the NFS Mount in the Xtract VM is failing.

Target is an AHV with AOS 5.9. Filesystem Whitelist is correct.

Excerpt from the Logs:

2018-10-22T09:19:52.337126+00:00 E ahvtargetprovider.go:973] Error executing command mount mount -t nfs -o soft 10.100.56.92:/SharedService-VMs /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32 exit status 32 output mount.nfs: Connection timed out
2018-10-22T09:19:52.337512+00:00 E ahvtargetprovider.go:975] Error returned
2018-10-22T09:19:52.337690+00:00 E ahvtargetprovider.go:834] [MigPlan:ae8b680e-f591-4814-9e42-8ad1cb732e32-Task:eeffdede-031a-4269-b4bb-d9a0eadf5af8] Error mounting container SharedService-VMs from 10.100.56.92 ([Container="SharedService-VMs", Err="exit status 32", Location="/home/hudsonb/workspace/workspace/hermes-production-build/go/src/tgtagent/ahvtargetprovider.go:977"] Container mount failed (error=0x4012))
2018-10-22T09:19:52.337924+00:00 I ahvtargetprovider.go:830] [MigPlan:ae8b680e-f591-4814-9e42-8ad1cb732e32-Task:eeffdede-031a-4269-b4bb-d9a0eadf5af8] Mounting 10.100.56.94:SharedService-VMs on /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32
2018-10-22T09:19:52.340450+00:00 I ahvtargetprovider.go:966] Created directory /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32
2018-10-22T09:19:52.340588+00:00 I ahvtargetprovider.go:971] Executing command sudo with args [mount -t nfs -o soft 10.100.56.94:/SharedService-VMs /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32]
2018-10-22T09:24:09.875098+00:00 E ahvtargetprovider.go:973] Error executing command mount mount -t nfs -o soft 10.100.56.94:/SharedService-VMs /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32 exit status 32 output mount.nfs: Connection timed out
2018-10-22T09:24:09.875292+00:00 E ahvtargetprovider.go:975] Error returned
2018-10-22T09:24:09.875447+00:00 E ahvtargetprovider.go:834] [MigPlan:ae8b680e-f591-4814-9e42-8ad1cb732e32-Task:eeffdede-031a-4269-b4bb-d9a0eadf5af8] Error mounting container SharedService-VMs from 10.100.56.94 ([Container="SharedService-VMs", Err="exit status 32", Location="/home/hudsonb/workspace/workspace/hermes-production-build/go/src/tgtagent/ahvtargetprovider.go:977"] Container mount failed (error=0x4012))
2018-10-22T09:24:09.875595+00:00 I ahvtargetprovider.go:830] [MigPlan:ae8b680e-f591-4814-9e42-8ad1cb732e32-Task:eeffdede-031a-4269-b4bb-d9a0eadf5af8] Mounting 10.100.56.98:SharedService-VMs on /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32
2018-10-22T09:24:09.877217+00:00 I ahvtargetprovider.go:966] Created directory /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32
2018-10-22T09:24:09.877389+00:00 I ahvtargetprovider.go:971] Executing command sudo with args [mount -t nfs -o soft 10.100.56.98:/SharedService-VMs /opt/xtract-vm/datamover/ae8b680e-f591-4814-9e42-8ad1cb732e32]
Okay, fixed it myself. Resetting the File System Whitelist seems to have solved my Problem...

Setting the Whitelist to XTRACT-VM-IP/255.255.255.255 solved it.

Reply